Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#226 Le 09/09/2016, à 09:38

LeJediGris

Re : [nVidia Optimus] État des lieux

Salut,

Peut-être une bonne nouvelle (tearing) ici

A+


Matos Asus Zenbook UX32VD
"Home Made" Monstro: core i7 2600+16Go de mémoire+SSD C300 128Go SATAIII+MoBo Asus P8P67 DeLuxe avec Mint 18
+ "Terminator", Pentium 4 avec velociraptor, A la niche, place au Core 2 2660 aussi sous Mint 18 , Freebox Revolution
"->NIL" Quelqu'un a t'il fait du Pascal ?

Hors ligne

#227 Le 21/09/2016, à 18:13

JGuillaumin

Re : [nVidia Optimus] État des lieux

Bonjour à tous,

J'ai un portable MSI-GT60 (~2013), avec une CG GTX 670MX et avec le chipset "Intel® Ivybridge Mobile".
Du coup je suis confronté au problème de la techno Optimus comme vous tous.

Mon objectif est d'installer les drivers Nvidia (>=352.39) , pour faire tourner `nvidia-docker` (https://github.com/NVIDIA/nvidia-docker)
(l'objectif est d'utiliser des images Docker avec des librairies de Machine Learning utilisant la CG, comme `theano`)
Du coup ça ne me dérange pas de ne pas utiliser la technologie Optimus. Ce n'est pas grave si c'est la CG qui fonctionne tout le temps et pour toutes les applications ! !

J'ai parcouru le file de la discussion et essayé les différentes méthodes ...
Depuis les ppa, depuis les fichiers .run téléchargés sur le site de Nvidia, avec ou sans prime .
Mais toujours les mêmes problèmes : écrans noirs au démarrage, système instable, X qui ne se lance plus, ..
Je viens de réinstaller entièrement Ubuntu 14.04 !

Du coup je voulais savoir si des personnes avaient réussi dernièrement à installer correctement des drivers supérieurs à 352.39 ?
Si oui, quelles méthodes ??

Ou bien, pour me faciliter les choses,  est-ce qu'il faut que je passe à Ubuntu 16.04 ? ou même à une autre distribution ?

Dernière petite question .. les ordinateurs actuellement en vente sont équipés de cette technologie ??
(par exemple : ce MSI GS40)


Merci beaucoup par avance pour votre aide !
N'hésitez pas à me demander plus d'informations si ma machine ou mon système!

Julien

Hors ligne

#228 Le 22/09/2016, à 10:42

JGuillaumin

Re : [nVidia Optimus] État des lieux

(ou est-ce que je dois faire mon propre topic ? )

Hors ligne

#229 Le 22/09/2016, à 13:50

obibann

Re : [nVidia Optimus] État des lieux

@JGuillaumin, tu peux suivre le tuto que j'ai réalisé pour un MSI : http://forum.ubuntu-fr.org/viewtopic.php?id=1976971


Ubuntu 16.04
Avec Windows, on fait ce qu'on peut... Avec Linux, on fait ce qu'on veut !! :p

Hors ligne

#230 Le 22/09/2016, à 15:40

JGuillaumin

Re : [nVidia Optimus] État des lieux

Merci beaucoup !

Je me concentre uniquement sur l'installation des drivers ? Ou bien tu me conseilles de faire les modifications sur le GRUB aussi ?

Dernière modification par JGuillaumin (Le 22/09/2016, à 15:41)

Hors ligne

#231 Le 22/09/2016, à 17:34

JGuillaumin

Re : [nVidia Optimus] État des lieux

Black Screen après le redémarrage !
J'ai posté sur la page du tuto

Mais si vous avez des pistes ici, je suis toujours preneur wink

Hors ligne

#232 Le 04/01/2017, à 16:49

Nine Tails Fox

Re : [nVidia Optimus] État des lieux

Bonjour,

Je viens de refaire une installation propre de 16.04.1
Par curiosité, j'ai tenté, avant toute chose, d'installer le driver 367.57 pour ma CG nVidia depuis l'onglet Pilotes additionnels sans m’embarrasser de Prime ni suivre le tuto ici.
Quelle agréable surprise, l'installation se passe sans problème, je reboot, aucun soucis également, je suis bien sur la CG nVidia. Pas de soucis graphique, de black screen ou n'importe quelle autre couleur non plus d'ailleurs.
Je vais dans NVIDIA XServer Settings et là je constate que Prime a été installé également et je peux basculer sur la carte intégrée Intel sans soucis si je le souhaite (testé avec succès) depuis le menu PRIME Profiles.

Ca marche pour moi, je ne peux pas assurer que ça marche pour tout les autres. A vous de faire les essais.
Si ma contribution peut aider du monde.


Linux Ubuntu 16.04.1 (64 bits)
MSI GP60 2PE Léopard  -  Proc : Intel® Core™ i5-4210H CPU @ 2.90GHz × 4  -  CG : NVIDIA GeForce GT840M DDR3 2 Go  -  Ram : 12 Go DDR3 Kingston  -  Stockage : SSD 256 Go Samsung 840 Pro SM84 et HDD 1 To Seagate Barracuda ST1000LM035-1RK1

Hors ligne

#233 Le 04/01/2017, à 18:06

GammaDraconis

Re : [nVidia Optimus] État des lieux

Nine Tails Fox a écrit :

Ca marche pour moi, je ne peux pas assurer que ça marche pour tout les autres. A vous de faire les essais

Bah y'a rien de nouveau, ça fait bien longtemps (plusieurs années) que que les cartes nvidia sont bien géré ainsi que la technologie Optimus. Tu as tout simplement appliqué la méthode recommandé depuis plusieurs années.

Hors ligne

#234 Le 04/01/2017, à 20:03

Nine Tails Fox

Re : [nVidia Optimus] État des lieux

Pardon, mais ce n'était pas l'impression qui ressort de ce présent topic (même les dernières pages plus récentes).
De plus, lors de mes dernières installations, que ce soit en 14.04 ou en 15.10, je devais installer comme indiqué dans le tuto ici si je ne voulais pas d'emmerdes.
D'ailleurs, il n'est écrit nul part dans le tuto que ça fait des années qu'on peut installer direct sans faire les différentes manip du dit tuto.

Ici c'est toujours indiqué qu'il ne faut surtout pas juste installer les pilotes mais qu'il faut utiliser Prime ou Bumblebee et il renvoi sur les pages qui indiquent toutes les manips à effectuer.

Dernière modification par Nine Tails Fox (Le 05/01/2017, à 11:27)


Linux Ubuntu 16.04.1 (64 bits)
MSI GP60 2PE Léopard  -  Proc : Intel® Core™ i5-4210H CPU @ 2.90GHz × 4  -  CG : NVIDIA GeForce GT840M DDR3 2 Go  -  Ram : 12 Go DDR3 Kingston  -  Stockage : SSD 256 Go Samsung 840 Pro SM84 et HDD 1 To Seagate Barracuda ST1000LM035-1RK1

Hors ligne

#235 Le 05/01/2017, à 09:29

Pizz3000

Re : [nVidia Optimus] État des lieux

J'utilise toujours Bumblebee car avec les drivers nVidia seuls, la carte fonctionne toujours même si elle n'est pas utilisée.
Ça chauffe pour rien et l'autonomie est très diminuée.

Sauf si ça a changé récemment et que la carte nVidia se coupe lorsqu'on utilise le driver Intel ?
Lors de l'installation propre de 16.04.1, il y a quelques mois, la carte était constamment allumée avec les drivers seuls même en n'utilisant que la carte Intel.

Dernière modification par Pizz3000 (Le 05/01/2017, à 09:32)


Dell Latitude E6530 / i5-3320M / 8Go RAM / nVidia 5200M / 256Go SSD / Kubuntu 16.04

Hors ligne