Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 26/09/2010, à 18:17

Dhampir

Problème son non reconnu - Asus X7BJ

Bonjour à tous, je bataille depuis un mois (depuis l'aquisition de l'ordinateur) sur un problème de son.
J'ai regardé au niveau de alsamixer, au niveau du matériel, il me trouve bien la carte (enfin je pense tongue ).
La commande :

lspci | grep -i audio

me retourne :

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)

j'ai suivi les infos sur plusieurs liens (dont le plus pertinent) :
http://doc.ubuntu-fr.org/audio_intel_hda

Mais rien n'y fait! en suivant des étapes de ce link, j'ai réussi a faire marcher le son, mais au redémarrage suivant, plus rien.

Je suis sous Unbuntu 10.04.
Si quelqu'un pourrait m'aider ça serait sympa smile

ps : problème de webcam mais ça, je m'en fiche, le son c'est vital quand même big_smile

Hors ligne

#2 Le 26/09/2010, à 22:40

francoise_peace

Re : Problème son non reconnu - Asus X7BJ

Oui, c'est vital big_smile

Pour connaître ton driver du son, c'est cette commande là, car lspci est trop vague:

cat /proc/asound/card0/codec#* | grep Codec

Moi j'utilise la version gratuite de Linuxant car mon codec est Connexant. De plus l'applet du son a été recemment mise à jour:

sudo apt-get update
sudo apt-get upgrade

C'est bien que tu ais installé alsamixer, mais il faut aussi installer mplayer (Ubuntu Software Center).

Hors ligne

#3 Le 27/09/2010, à 08:18

Dhampir

Re : Problème son non reconnu - Asus X7BJ

Bonjour, mercu de ta réponse smile

j'avais biensur fait un update et un upgrade, par contre la commande pour le drver son, la voici :

Codec: Realtek ALC259
Codec: Intel G45 DEVIBX

Donc apparement j'en ai deux? tongue
dans le tuto que j'ai présenté dans le premier post on me dit d'ajouter une ligne pour qu'il charge le bon driver (je pense) au demarrage. Dans le fichier : /etc/modprobe.d/alsa-base.conf :
par défaut, il y a ça :

#options snd-pcsp index=-2

je l'ai commenté pour mettre ça :

options snd-hda-intel model=3stack position_fix=0

J'ai un probleme au niveau du nom du model, je n'arrive pas à le récupérer sad

J'espère avoir donné un peu plus d'infos, merci encore

Hors ligne

#4 Le 27/09/2010, à 13:20

francoise_peace

Re : Problème son non reconnu - Asus X7BJ

Question 1: le fichier : /etc/modprobe.d/alsa-base.conf
J'aurai besoin que quelqu'un d'autre l'aide aussi. sad

Question 2: Installer le bon pilote

J'ai un double boot, sur Windows on a plusieurs pilotes pour le son, il se pourrait que ce soient deux différents. Il doit sûrement y en avoir d'autres mais ils sont moins importants.

Intel Corporation 5 Series/3400 Series Chipset High Definition Audio:
Intel G45 DEVIBX
-> Il doit y en avoir pour Linux
Realtek ALC259
-> Il doit y en avoir pour Linux

http://www.realtek.com.tw/downloads/searchView.aspx?keyword=ALC
    ALC250 (Datasheets)
    ALC250 (Reference Designs)
    ALC260 (Datasheets)
    ALC260 (Reference Designs)

HOME > Downloads > Computer Peripheral ICs > PC Audio Codecs > High Definition Audio Codecs > Software > Accepter les conditions > Unix(Linux)

Linux driver (2.6) 5.15rc15    2010/9/21    5480k    GO    GO    GO

T'as de la chance smile, il est valable pour toutes les versions smile smile. C'est sûrement un fichier zippé à décompresser, poste le README stp.

Point 3: Comment je faisais pour installer Ethernet avec le module du site de Realtek ?

-> Il s'agissait du module r8169, uniquement certaines versions marchaient, mais là j'en ai plus besoin.

Supprimer l'ancien module:
lsmod | grep r8169
sudo rmmod r8169
Aller sur le répertoire avec les fichiers extraits:
cd ./r8169 + TOUCHE TABULATION REPRESENTEE PAR UNE DOUBLE FLECHE

Installer:
sudo make install
sudo depmod -a
sudo modprobe r8169

L'ajouter au démarrage (ceci n'est pas dans le README):
sudo gedit /etc/modules

Rajouter:
r8169

Redémarrer l'ordinateur.
Insister sur son installation:
sudo modprobe r8169

Vérifier qu'il y est:
lsmod | grep r8169

Si besoin, configurer Ethernet:
ifconfig -a
Configurer eth0 (ou ethX):
ifconfig eth0 up
ifconfig eth0 "Votre adresse IP"

A propos des commandes:
modprobe
> modprobe charge et décharge intelligemment un module du Noyau Linux
rmmod
> rmmod est un programme basique qui permet de décharger un module du noyau. La plupart des utilisateurs se serviront plutôt de modprobe(8), avec l'option -r.
(Rem perso: tu l'enlèves quand tu as exactement le même sous la main, mais que celui qui est installé ne marche pas, car parfois c'est juste un problème de version, et la version n'apparaît pas dans le nom du module. De plus les versions compatibles évoluent avec les kernels, tout en dépendant de ton ordinateur, donc quand il y a différentes versions disponibles, ce n'est pas ton cas, il faut toutes les télécharger avant. En cas d'erreur, le sudo apt-get upgrade du kernel qui a lieu tous les 2 à 3 mois, ré-installe les modules si effacés accidentellement.)
depmod
> Examine les modules dans tous les répertoires spécifiés dans le fichier (facultatif) de configuration /etc/modules.conf.
(Rem perso: il vérifie si l'installation du module s'est déroulée sans erreurs = silence.)

Rem perso 3: La procédure d'installation est généralement la suivante -*>
sudo make install
sudo depmod -a
sudo modprobe nom-du-module
L'ajouter au démarrage (ceci n'est pas dans le README)

Et parfois il faut faire sudo make, puis sudo make install. Si tu n'as pas make, il suffit de l'installer:

sudo apt-get install make

make
> install
    Copy the executable file into a directory that users typically search for commands; copy any auxiliary files that the executable uses into the directories where it will look for them.

> clean
    Delete all files that are normally created by running make.

(Rem perso 4: si la compilation fait des erreurs du premier coup et que je veux la re-essayer, en plus du rmmod nom, je fais sudo make clean)

Dernière modification par francoise_peace (Le 27/09/2010, à 14:12)

Hors ligne

#5 Le 27/09/2010, à 13:51

Dhampir

Re : Problème son non reconnu - Asus X7BJ

Ah oui pas mal smile
je cherchais seulement du coté Intel ...
j'ai téléchargé l'archive, ce fut un tar.bz2.
voici le readme :

The source code copy from www.alsa-project.org.      ver:5.15
Linux Source Code for ALC audio codec
Support Codec list:
====AC97 Codec=====
ALC100,100P
ALC200,200P
ALC650D
ALC650E
ALC650F
ALC650
ALC655
ALC653
ALC658
ALC658D
ALC850
ALC101
ALC202
ALC250
ALC203

====HD Audio codec ====
ALC260
ALC262
ALC267
ALC268
ALC259
ALC269
ALC270
ALC272
ALC273
ALC275
ALC660
ALC660VD
ALC661
ALC662
ALC663
ALC665
ALC670
ALC680
ALC861
ALC861VD
ALC880
ALC882
ALC883
ALC885
ALC888
ALC889A
ALC892

Installation:
This Source Code is from www.alsa-project.org.
For OS installation, please remember add the Development tool kit.
For driver installation, please follow below steps.

Automatic install: (Recommend RedHat distribution)
execute

  ./install

Note: Ubuntu OS, please use manual install.
      Run commands need to add sudo at first words.   

Manual install:
Step 1. unzip source code
        tar xfvj alsa-driver-1.0.xx.tar.bz2

Step 2. Complied source code
    a. cd alsa-driver-1.0.xx
    b. ./configure --with-cards=hda-intel
    c. make
    d. make install

Step 3. reboot your machine

Step 4. Use the alsamixer the disable mute (All audio line default is mute)
        Must to compile and to install the ALSA library and utility. (Use automatic install is already install)
        excute alsamixer

Note:     1. The most detail information, can refer the alsa-kernel/Documenttation/ALSA-Configuration.txt in the azx-021705.tar.bz2.
    2. Kernel Version must be 2.6 or later.
    3. All mixer channels are muted by default. You must use a native
        or OSS mixer program to unmute appropriate channels.
    4. If can not compile the source code, try to rename the /usr/src/linux-2.x -> /usr/src/linux.
    5. The driver added to support the SPDIF functoin.    
    6. a. You can download the alsa-lib-1.0.x and alsa-utils-1.0.x form the www.alsa-project.org, then unzip and install them.
       b. Suggest use "alsamixer" to control mixer function.
       c. Used "alsaconf" can autodetect which drive you need to install (step 4).    
        7. SUSE Distribution must install the ncurses package.


Je ne peux m'en occuper pour l'instant, je suis au boulot, je vois ça ce soir, j'ai jeter un bref coup d'œil au README. Apparemment mon codec (ALC259) apparait, donc une bonne chose. Je suis la procédure ce soir et je te tiens au courant.
merci smile

<edit> Pour le fichier : /etc/modprobe.d/alsa-base.conf , je le remet d'origine? c'est à dire, j'enleve la ligne que j'ai mis (qui concerne la carte intel) et je décommente la ligne par défaut? tongue </edit>

Dernière modification par Dhampir (Le 27/09/2010, à 14:08)

Hors ligne

#6 Le 27/09/2010, à 14:20

francoise_peace

Re : Problème son non reconnu - Asus X7BJ

OK
- le dézippage peut se faire avec le Gestionnaire d'archives
note: le ./configure est aussi une sorte de make complémentaire qui sert à compiler et qui donne des résultats, configure est sûrement le nom d'un fichier exécutable.

Je pense que celui que tu as trouvé chez Alsa Project est le même que celui sous Realtek.

J'ai rajouté des commentaires pendant que tu écrivais.

je le remet d'origine?

Oui, tu le remets d'origine, mais comme il faudra ensuite inscrire le pilote au démarrage, je pense que tu pourras le rajouter à :

sudo gedit /etc/modules

Par contre il faudra que quelqu'un te dise, ou que tu trouves par toi-même quelles modification du dois apporter à ce fichier afin qu'il n'y ait pas de conflits entre les modules à défaut et le module que tu va installer. Si l'installation ne marchait pas après plusieurs tentatives, c'est que un des fichiers de configuration bloque quelque chose, et là c'est une histoire de vrai ou faux. Par contre pour les fichiers de configuration, si tu joues avec, il faut que tu les sauvegardes tous comme ils étaient au début.

Dernière modification par francoise_peace (Le 27/09/2010, à 14:26)

Hors ligne

#7 Le 27/09/2010, à 19:00

Dhampir

Re : Problème son non reconnu - Asus X7BJ

bon si tot rentré j'ai desarchivé le fichier que j'ai téléchargé. j'ai suivi les etapes concernant la partie UBUNTU.
a la deuxieme tentative, ça a fonctionnait. au redémarrage j'avais la douce musique d'ubuntu. (je n'ai pas touché au fichier de conf pour le moment, je verrais avec le temps). En espérant que le son ne disparaisse pas au prochain redémarrage big_smile

merci encore.

ps : je mettrais en résolu après deux ou trois redémarrage smile

Hors ligne

#8 Le 28/09/2010, à 10:24

francoise_peace

Re : Problème son non reconnu - Asus X7BJ

je mettrais en résolu après deux ou trois redémarrage

Très sage !!!

Hors ligne

#9 Le 30/09/2010, à 08:27

Dhampir

Re : Problème son non reconnu - Asus X7BJ

bonjour,
Bon ben j'ai parlé un peu vite ...
au bout de plusieurs redémarrage plus de son...
Je pense qu'ubuntu a voulu aller chercher des infos au démaarage et ne les a pas trouvé, comme tu as dit, le fichier /etc/modules.
je viens de l'éditer :
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp

cependant je ne sais pas comment l'écrire, je ferais des recherches ce soir ou demain.
Si jamais tu a une piste big_smile
merci tongue

Hors ligne

#10 Le 03/10/2010, à 13:31

francoise_peace

Re : Problème son non reconnu - Asus X7BJ

lp est le nom d'un module
r8169 est le nom d'un module

lsmod : liste les modules installés
lsmod | grep snd : liste surtout les modules son installés

Pas le bon
Site de Realtek > HOME > Downloads > Computer Peripheral ICs > PC Audio Codecs > AC'97 Audio Codecs > Software
realtek-linux-audiopack-4.06a.tar.bz2 > realtek-linux-audiopack-4.06a
====AC97 Codec=====
ALC200,200P
ALC202
ALC250
ALC203
====HD Audio codec ====
ALC260
ALC262

Le bon
Site de Realtek > HOME > Downloads > Computer Peripheral ICs > PC Audio Codecs > High Definition Audio Codecs > Software
LinuxPkg_5.15rc15.tar.bz2 > realtek-linux-audiopack-5.15
====AC97 Codec=====
ALC202
ALC250
ALC203

====HD Audio codec ====
ALC260
ALC262
ALC267
ALC268
ALC259  xxxxxxxxxxxxx OK smile
ALC269

Il faut dézipper tous les dossiers compressés avant l'installation.

ls
alsa-driver-1.0.23  alsa-plugins-1.0.23  install     test.wav
alsa-lib-1.0.23     alsa-utils-1.0.23    Readme.txt  version

====================
A propos du nom du/des pilotes, mais tu n'en aura pas besoin smile

Doc: [url]http://doc.ubuntu-fr.org/tutoriel/comment_compiler_les_drivers_alsa?s[]=installer&s[]=module&s[]=alsa[/url]

La page sur laquelle vous arrivez contient la commande du ./configure –with-cards=nom du lien –with-sequencer=yes pour votre pilote dans la section quick install. Reprenez y le nom du pilote sans prendre toute la ligne qui peut planter si vous n'êtes pas en mode root et s'il manque des librairies.
D'ailleurs le nom du lien EST le nom du pilote.

Quick install: http://alsa.opensrc.org/index.php/Quick_Install
=======================
I- Partie 1 de l'installation

Quote (Alsa Quick Install):

sudo apt-get install libasound2 alsa-utils alsa-oss

" I recommend you get the drivers, the libraries, the utils and the OSS compat modules to start with. Next, put them into some directory, e.g. /usr/src/alsa "
-> Donc tu dézippes tous tes paquets dans le répertoire de ton choix, ici on te suggère de créer un dossier alsa dans cd /usr/src, mais tu peux aussi avoir ton dossier ./pilotes ou ./drivers dans ton HOME. En tout cas il te faut un dossier qui est présent au démarrage (sur la même partition que Ubuntu), et que tu ne vas pas déplacer.

Puis ils te disent de dézipper TOUS les dossiers.

tar jxvf alsa-driver-xxx.tar.bz2 ou Gestionnaire d'archives

Installation d'après Alsa:

   cd alsa-driver-xxx
   ./configure --with-sequencer=yes && make
   make install
   ./snddevices

Installation d'après la doc:

cd alsa-driver-*
sudo ./configure --with-cards=[votre pilote] --with-sequencer=yes --with-card-options=all
sudo make
sudo make install

En remplaçant "[votre pilote] par le pilote donné sur la page du site ALSA consacrée à votre carte son ou par all pour compiler tous les pilotes. Vous pouvez vous aider de" ... "Pour trouver le bon pilote de votre carte."

cat /proc/asound/cards
./configure --help

II- Après il faut compiler les autres dossiers dézippés:
cd alsa-lib-xxx
./configure && make
make install

cd alsa-utils-xxx
./configure && make
make install
sudo apt-get install libncurses5-dev

cd alsa-oss-xxx
./configure && make
make install

III- Partie 3: Rajouter les modules au démarrage

Chargement des modules dans le kernel (ils se retrouvent dans lsmod temporairement):

modprobe snd-ens1371
modprobe snd-pcm-oss
modprobe snd-mixer-oss
modprobe snd-seq-oss

Le "make install" des pilotes ALSA doit créer un fichier /etc/init.d/alsasound, sinon le fichier (=dossier), également présent dans /alsa-driver-xxx/utils, doit être copié dans /etc/init.d (aidez-vous des permissions chmod -R 755 *)

Leur présence dans ce dossier est importante pour qu'il soit chargé au démarrage:

which takes care of saving and loading the mixer settings etc. on bootup and shutdown

Et donc au cas où vous avez dû copié /alsa-driver-xxx/utils vers /etc/init.d, il faut re-créer les liens symboliques qui n'ont pas été générés parce qu'il n'était pas là:

   % ln -s /etc/init.d/alsasound /etc/rcS.d/S59alsasound
   % ln -s /etc/init.d/alsasound /etc/rc1.d/K15alsasound
   % ln -s /etc/init.d/alsasound /etc/rc6.d/K15alsasound

big_smile Donc ce qui est important pour que tes modules sons soient chargé au démarrage c'est qu'ils soient présents dans /etc/init.d/alsasound avec les liens symboliques. Donc pas besoin de modifier cat /etc/modules. Ce sera pour un autre module plus simple. big_smile

ls /etc/init.d/alsasound

Dernière modification par francoise_peace (Le 03/10/2010, à 14:28)

Hors ligne

#11 Le 03/10/2010, à 20:37

Dhampir

Re : Problème son non reconnu - Asus X7BJ

Bon, je pense que tout ce que tu as pu écrire a fait peur à mon ubuntu, il a redémarré avec le son... apparemment il doit pas toujours trouver les pilotes au démarrage. je resuis les étapes très prochainement (j'ai du dev en cours sad ).
Je pense qu'on pointe le bon bout smile
merci

Hors ligne