Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 22/10/2010, à 12:40

emi_lien

Cinelerra sur Maverick ?

Il semble qu'aucun dépot pour cinellera n'existe sur Maverick...

Hors ligne

#2 Le 22/10/2010, à 14:30

Zococo

Re : Cinelerra sur Maverick ?

Bonjour,

Je suis conduit à la même constatation.

J'ai installé en téléchargeant la version 4.1. 64 bits mais il doit être possible aussi d'essayer le dépôt Akirad :

Voir sur LPROD


Ubuntu 19.10 (64 bits) - Gigabyte B250M-DS3H / Core i5-7600K (Kaby lake)

Hors ligne

#3 Le 23/10/2010, à 15:46

Isaric

Re : Cinelerra sur Maverick ?

Non pas sur Akirad


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.

Hors ligne

#4 Le 27/10/2010, à 09:54

Davjack

Re : Cinelerra sur Maverick ?

Vous avez trouvé un dépôt avec des deb fonctionnels sur Maverick?
J'ai voulu installer la version 4.2 trouvé sur http://heroinewarrior.com/cinelerra.php#download (code source) mais une des dépendances (libx264-85) est obsolète dans les dépôts d'Ubuntu...

Hors ligne

#5 Le 27/10/2010, à 09:56

jeepy

Re : Cinelerra sur Maverick ?

Pareille, impossible à installer... Snif


From Ubuntu 6.06 LTS - Membre attitré de la brigade des J (J suis sur Gnome-Shell et J suis bien)
GNOME 4.0 = GNOME OS == http://linuxfr.org/news/guadec-2012-en- … t-gnome-os
John Mc Cann, avenir GNOME == http://www.generation-linux.fr/index.ph … -de-GNOME3

Hors ligne

#6 Le 27/10/2010, à 16:17

Davjack

Re : Cinelerra sur Maverick ?

Pour le problème de la librairie x264, apparemment il faut la compiler soi-même (trouvé ici). Je n'ai pas encore eu le temps de tester.
En attendant, pour installer la librairie, le code qui devrait fonctionner est le suivant :

git clone git://git.videolan.org/x264.git x264

et enfin

cd x264
./configure --enable-pic --prefix=/usr --enable-shared
make
sudo make install

Dernière modification par Davjack (Le 27/10/2010, à 17:26)

Hors ligne

#7 Le 27/10/2010, à 18:06

Isaric

Re : Cinelerra sur Maverick ?

je suppose que c'est pas la même chose ????? que h264enc.deb ou encore x264.deb que l'on a dans synaptic neutral ou libx264-106 dans les dépôts handbrake ????

...x264$ ./configure --enable-pic --prefix=/usr --enable-shared
Found no assembler
Minimum version is yasm-0.6.2
If you really want to compile without asm, configure with --disable-asm.
...x264$ 

Je rajoute yasm

...x264$ sudo make install
install -d /usr/bin
install -d /usr/include
install -d /usr/lib
install -d /usr/lib/pkgconfig
install -m 644 x264.h /usr/include
install -m 644 libx264.a /usr/lib
install -m 644 x264.pc /usr/lib/pkgconfig
install x264 /usr/bin
ranlib /usr/lib/libx264.a
ln -f -s libx264.so.107 /usr/lib/libx264.so
install -m 755 libx264.so.107 /usr/lib
...x264$

où trouver liblame-dev[ :

$ sudo apt-get install build-essential automake1.7 libtool xorg-dev libasound2-dev libogg-dev libvorbis-dev libtheora-dev libopenexr-dev libdv4-dev libpng3-dev libjpeg62-dev uuid-dev libmjpegtools-dev liba52-dev liblame-dev libsndfile1-dev libfaac-dev libfaad2-dev fftw3-dev libraw1394-dev libavc1394-dev libtiff4-dev subversion checkinstall yasm
[sudo] password for isaric:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note : sélection de « libpng12-dev » au lieu de « libpng3-dev »
Note : sélection de « liba52-0.7.4-dev » au lieu de « liba52-dev »
Note : sélection de « libfftw3-dev » au lieu de « fftw3-dev »
Aucune version du paquet libfaad2-dev n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  libfaad-dev
E: Impossible de trouver le paquet liblame-dev
E: Le paquet « libfaad2-dev » n'a pas de version susceptible d'être installée

où lancer

/hvirtual$ ./configure --prefix=/usr/local/ --enable-mmx --enable-3dnow --enable-opengl

Dernière modification par Isaric (Le 31/10/2010, à 11:56)


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.

Hors ligne

#8 Le 31/10/2010, à 21:17

trhe

Re : Cinelerra sur Maverick ?

Bonjour,

je reviens à la question des dépôts cinelerra:

j'utilise cinelerra 4.1 du dépôt "debian-multimedia.org" version testing, .

Cinelerra 4.1 est ainsi disponible en 64 et 32 bits (contrairement au binaire d'heroinewarrior seulement 64bits), l'acquisition est fonctionnelle, mais le viewer ne fonctionne pas. J'ai besoin de cette version pour les effets en live avec une camera dv en acquisition.

Le dépôt "debian-multimedia.org" peut être activé depuis Maverick, mais je n'installe que le stricte nécessaire et le désactive ensuite (pour éviter les conflits entre les dépôts ubuntu et debian au risque de "casser" le système) , je n'ai eu aucun soucis avec pour l'instant. Le dépôt "debian-multimedia.org" propose aussi cinelerra 2.1 mais je ne l'ai pas testé.
Avec le dépôt "deb http://www.debian-multimedia.org sid main non-free", cinelerra 4.2 est disponible avec ubuntu Maverick, après un test rapide le viewer fonctionne.
(penser aussi à désactiver le dépôt, pour éviter d'endommager le système avec des paquets instables = sid)

Attention cette méthode ne créé pas de lanceur cinelerra dans le menu gnome, à créer soi même ou à lancer en terminal.

Dernière modification par trhe (Le 31/12/2010, à 19:17)

Hors ligne

#9 Le 16/11/2010, à 09:58

Halbox

Re : Cinelerra sur Maverick ?

Une solution qui fonctionne (Maverick 64 bits) :
- installer via Synaptic ce dépôt Debian : deb http://www.debian-multimedia.org sid main non-free
- installer Cinelerra 4.2(**)
- régler dans Settings > Préférences > onglet Playback : Audio driver = ALSA (car OSS, valeur par défaut, ne fonctionne plus avec Maverick*)
On peut aussi installer Cinecutie via Akirad version Lucid, faire le même réglage... et ça marche.

(*) L'émulation OSS d'ALSA a été supprimée pour éviter les conflits empêchant un programme d'accéder à la carte son lorsque qu'un programme utilise OSS vient le bloquer. Les programmes n'utilisant qu'OSS restent donc muets. Pour contourner le problème, utilisez padsp. Malheureusement cette solution ne suffit guère à tous et une solution de remplacement pour l'émulation OSS d'ALSA est en cours d'élaboration - reste à savoir pourquoi les devs ont décidés de mettre la charrue avant les bœufs…

(**) La version 2.1CV est également disponible est s'installe correctement.

VOIR AUSSI ce PPA sur https://launchpad.net/~cinelerra-ppa/+archive/ppa (install impossible chez moi, conflit de bibliothèque semble-t-il ?)

Dernière modification par Halbox (Le 06/12/2010, à 12:28)


Intel core 2 duo E8500 INTEL DG45ID - RAM : 4 Go

Hors ligne

#10 Le 16/11/2010, à 18:19

Zococo

Re : Cinelerra sur Maverick ?

La méthode des dépôts fonctionne bien chez moi aussi. Merci pour l'info.

J'ai finalement rencontré un problème (connu) au lancement.

Si ça devait vous arriver, je vous renvoie sur la page de LPROD qui donne la solution.

Je précise qu'elle a été, pour moi, plus efficace que celle - souvent conseillée sur les forums - consistant à modifier le fichier /proc/sys/kernel/shmmax (commande : sudo echo "0x7fffffff" > /proc/sys/kernel/shmmax) pour laquelle j'ai rencontré des difficultés insolubles (à mon niveau) de droits, même en mode superutilisateur.

Dernière modification par Zococo (Le 16/11/2010, à 18:20)


Ubuntu 19.10 (64 bits) - Gigabyte B250M-DS3H / Core i5-7600K (Kaby lake)

Hors ligne

#11 Le 20/12/2010, à 00:32

marc08160

Re : Cinelerra sur Maverick ?

Bonjour,
a propos de l'install cinelerra sur Maverick,j'ai bétement suivi à la lettre le tuto http://www.g-raffa.eu/Cinelerra/HOWTO/ qui permet de compiler le progamme.Newbie de soixante-huit primtemps,j'ai réussi,donc c'est à la portée de tout un chacun.Seul bémol,la francisation ensuite,est un peu galère.....

Hors ligne

#12 Le 20/12/2010, à 12:17

Halbox

Re : Cinelerra sur Maverick ?

Bravo marc08160 ! J'ai aussi suivi cette voie, mais un plantage à la compil (inexpliqué) a ruiné mes espoirs...

Dernière modification par Halbox (Le 20/12/2010, à 12:17)


Intel core 2 duo E8500 INTEL DG45ID - RAM : 4 Go

Hors ligne

#13 Le 20/12/2010, à 20:54

Petrusmok

Re : Cinelerra sur Maverick ?

Bonsoir,
Je viens faire part de mon expérience a la suite de cette discussion :
Sous ubuntu 10.10 j'active le dépôt Débian comme expliqué ci dessus et installe cinelerra 4.2.
Ensuite, je vérifie que le programme est bien présent en tapant dans un terminal :

cinelerra

Le logiciel s'ouvre sans problème.
J'ai essayer de créer un lanceur en ligne de commande en passant par la doc et en suivant la marche a suivre:
[url]http://doc.ubuntu-fr.org/raccourci-lanceur?s[]=cr%C3%A9er&s[]=un&s[]=lanceur[/url]
Quand j'arrive a l'étape" ouvrir le fichier " /usr/share/applications/cinelerra.desktop
Puis "rajouter les lignes suivantes dans le fichier"   

[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Cinelerra
GenericName=cinelerra
Comment=Montage vidéo
Icon=
Exec=cinelerra
Terminal=false
StartupNotify=false 
Categories= **Application;Son et vidéo;Montage vidéo**

Une fenêtre apparait pour me dire que je n'ai pas l'autorisation de modifier ce fichier.
C'est raté donc, et je ne sais pas pourquoi.
Je sollicite donc quelques conseils.
Ou une autre méthode pour ouvrir ce logiciel depuis un raccourcis dans "applications", comme n'importe quel autre programme.
Merci de votre aide.:)

Dernière modification par Petrusmok (Le 21/12/2010, à 02:10)

Hors ligne

#14 Le 20/12/2010, à 23:03

Petrusmok

Re : Cinelerra sur Maverick ?

Up ?!   smile

Hors ligne

#15 Le 21/12/2010, à 02:01

Petrusmok

Re : Cinelerra sur Maverick ?

Et je voulais rajouter que voulant faire une mise a jour par l'interface graphique, je me retrouve avec le message suivant :
"Certains paquets ne sont pas supportés par ubuntu, ils devront êtres mis a jour depuis une origine inconnue (...)"
Ou une phrase de ce genre...
Qui veut dire, je suppose qu'Ubuntu n'aime pas les dépots Debian installés pour Cinelerra.
Je demande quand même de continuer la mise a jour, et le curseur se met a tourner, tourner, tourner... Sans fin.
J'ai du fermer l'interface de mise a jour de force, trois heures après... Sans qu'aucune mises a jour ne se soient installées.
Ca sent pas bon tout ça, hein ?!   hmm

Hors ligne

#16 Le 22/12/2010, à 16:25

trhe

Re : Cinelerra sur Maverick ?

Bonjour Petrusmok,

il est précisé dans les précédents posts qu'il ne faut activer les dépôts que pour installer cinelerra, après il faut les désactiver, ne fait pas la mise à jour, tu risques de planter ubuntu... (surtout depuis des dépôts sid = instable).
Pour information pour les autres utilisateurs cinelerra 4.2 vient de passe dans les dépôts testing de debian multimédia.org


Pour créer un lanceur dans applications utilise l'éditeur de menu (sous gnome) dans Système/Préférences/menu principal, utilise la fonction créer un lanceur: nom = Cinelerra; commande = cinelerra & cela fonctionne.


Sinon il existe maintenant un dépôt ppa pour ubuntu installant cinelerra 2.1.5 , désinstalle cinelerra 4.2 avant d'installer le nouveau cinelerra, tu pourra laisser ce dépôt activé.
Le lien est sur lprod, pour plus d'information.


La différence entre 2.1.5 & 4.2 est le module d'acquisition qui fonctionne pour les versions 4 seulement. Attention cependant il est difficile sous maverick de donner les bon droits pour l'acquisition firewire.
J'ai réussi à acquérir depuis une caméra dv et des webcams uvc avec cinelerra 4.2, pas encore depuis un périphérique dvb.


Tu peux aussi utiliser les dépots Akirad pour installer cinecutie par exemple,
pour cela edit (gksudo gedit /etc/apt/sources.list dasn un terminal) le fichier sources.list et ajoute ces lignes:

## akirad
deb http://ppa.launchpad.net/akirad/akiradproject/ubuntu lucid main
deb-src http://ppa.launchpad.net/akirad/akiradproject/ubuntu lucid main

Puis télécharge le paquet manquant libx264-85 ici

Bon courage!

Dernière modification par trhe (Le 22/12/2010, à 16:27)

Hors ligne

#17 Le 23/12/2010, à 00:16

Petrusmok

Re : Cinelerra sur Maverick ?

Merci trhe de ta réponse...
Et désolé de pas avoir capté dans les précédents posts qu'il fallait désactiver les dépôts après installation de Cinelerra.
Je l'ai bien lu en fait, mais je pensais que c'était toi qui faisait le ménage, pas que c'était nécessaire au bon fonctionnement des choses...
Pour le coup, la, ça va être clair !  smile
J'aimerais bien être en train de lire cette discussion pour la 1° fois avec cette précision, ça m'éviterai les trois heures de prise de tête de l'autre soir  tongue
En fait, ce n'est pas mon ordi, mais celui d'un club vidéo locale, qui a l'occasion de l'achat d'un ordinateur tout neuf monté pour le club, a voulu un dual boot ubuntu pour se mettre au libre et voir les équivalences des logs de montage vidéo.
Je leur ai mis Kino pour débutant,kdenlive et cinelerra. (Qui ne s'ouvre pour l'instant que par un terminal.)
Des que je peux, j'irais faire ce que tu conseilles et voir selon leurs besoins si je leur met la 2.1.5 ou pas.
Le logiciel Cinelerra avait l'air d'être fonctionnel sinon, j'ai fait la manip pour le mettre en français et ça a marché.
Juste un problème pour ouvrir les menus avec le curseur de la souris :
Le positionner sur Fichiers ou outils comme d'habitude ne donne rien, ça réagit pas.
Mais en déplaçant légèrement le curseur en dessous du titre de la rubrique du menu, ça s'ouvre normalement.

Hors ligne

#18 Le 31/12/2010, à 19:30

trhe

Re : Cinelerra sur Maverick ?

Bonjour Petrusmok,

j'ai modifier mon premier post pour préciser le risque de garder les dépôts actifs, suite à tes remarques...

Le bug dans les menus cinelerra 4.2 vient du compositing (transparence) créer par metacity ou compiz! Par contre cinelerra fonctionne avec les transparences kwin de kde4.
Une astuce pour le corriger le bug est de désactiver le compositing (Système>Préférences>Apparence>Effets visuels>Aucun & dans un terminal taper:
gconf-editor puis naviguer selon ce chemin apps>metacity>general>compositing manager, décocher si la case est cochée).
Par contre on perd les effets compiz et ceux de transparence utiles pour certains docks par exemple.

Dernière modification par trhe (Le 01/01/2011, à 13:59)

Hors ligne

#19 Le 04/02/2011, à 10:39

tomydu77

Re : Cinelerra sur Maverick ?

Bonjour, petit probleme pour moi avec le depot ppa
quand je tape la commande voilà ce qu'il me dis.


sudo add-apt-repository ppa:cinelerra-ppa/ppa
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv 60DB64FA8E893E577651CF3DCBDFA02B432BB368
gpg: requête de la clé 432BB368 du serveur hkp keyserver.ubuntu.com
gpgkeys: HTTP fetch error 7: couldn't connect to host
gpg: aucune donnée OpenPGP valide n'a été trouvée.
gpg: Quantité totale traitée: 0

Comment ce fait-ce?
sinon j'ai pas tout compris pour installer les depot debian
j'ai telecharger le lien de Davjack mais je fais quoi maintenant >_< je de decompresse? et apres?

Hors ligne

#20 Le 04/02/2011, à 10:41

tomydu77

Re : Cinelerra sur Maverick ?

Sinon comment je fais pour installer de dépot?

Hors ligne

#21 Le 04/02/2011, à 11:28

tomydu77

Re : Cinelerra sur Maverick ?

c'est bon je me suis debrouiller smile

Hors ligne

#22 Le 04/02/2011, à 23:37

sergio51

Re : Cinelerra sur Maverick ?

Bonsoir à tous !

Je suis avec beaucoup d'attention votre discussion, car j'utilise Cinelerra depuis plusieurs mois déjà avec satisfaction.
Vos messages sont riches de renseignements et sont très constructifs.

En ce qui me concerne, le seul hic depuis mon passage à lucid 10.04 LTS sur mon pc fixe et maverick 10.10 sur mon portable, c'est qu'après installation du logiciel via le PPA, tous les caractères accentués de l'interface (en français) sont transformés en caractères bizaroïdes...
C'est un peu énervant à force.
Divers forums en parlent, mais je n'ai pas trouvé de solution au problème... J'ai voulu gratter du côté localisation du système, et remplacer UTF8 par FR_fr (8859-1), mais j'ignore où se trouve le fichier de configuration correspondant.

Quelqu'un a-t-il été confronté au problème ? Où est la solution s'il-y-en a une?

Hors ligne

#23 Le 05/02/2011, à 01:20

tomydu77

Re : Cinelerra sur Maverick ?

Oui j'ai le même problème. Pas forcement grave. Mais c'est toujours plus agréable quand tout fonctionne correcttemnt

Hors ligne

#24 Le 01/03/2011, à 13:57

trhe

Re : Cinelerra sur Maverick ?

Pour les caractères accentués, j'ai le même problème sous maverick, du coup je le laisse en anglais en attendant....

Hors ligne

#25 Le 10/08/2011, à 19:25

CocoLasticot

Re : Cinelerra sur Maverick ?

Bonjour a tous

Je me permet de remonter le post pour éviter d'en creer un autre

Quelqu'un a t il reussit a installer cinelerra 4.3 ?

Je débarque tout juste sur ce logiciel et grace a vous j'ai deja pu installer simplement la 4.2 :d

Hors ligne