Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 09/11/2010, à 19:43

Kosy

[Résolu]Problème de son Asus N53J

Bonjour à tous,

Voilà, j'ai un Asus N53J en dual boot Seven/Ubuntu 10.10
Mon problème viens du son en haut-parleur.
Il marche sous Seven (Pas un problème Bios donc d'après ce que j'ai lu dans les divers liens conseillés) mais pas sous Ubuntu.
La prise Jack marche pour les deux OS

La commande lspci me renvoie entre autre:

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)

La commande alsamixer me ramène bien aux différentes "barres" de contrôle du son.

Bref, je sais pas vraiment ce que je dois faire sans tout casser, les tutos ne correspondant pas à mon problème.
Je crois avoir compris qu'il faudrait installer un driver, mais lequel choisir, et n'y aura-t-il pas de problème avec la prise jack à ce moment là?

Merci d'avance pour votre aide

Dernière modification par Kosy (Le 04/12/2010, à 21:35)


Le bonheur n'est réel que lorsqu'il est partagé.

Hors ligne

#2 Le 10/11/2010, à 18:44

Kosy

Re : [Résolu]Problème de son Asus N53J

Je me permet de remonter le sujet, n'ayant toujours pas réussi à résoudre mon problème


Le bonheur n'est réel que lorsqu'il est partagé.

Hors ligne

#3 Le 20/11/2010, à 20:02

bnet22

Re : [Résolu]Problème de son Asus N53J

Bonjour,

J'ai le même problème sur un N53JQ.

Le codec est :

cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC259

Pour ceux que cela intéressent, sur le N53JQ avec Ubuntu 10.10 Out of the box, le driver nvidia fonctionne, la webcam aussi, le micro aussi, le touchpad également, le wifi est ok, bluetooth aussi. Seule les hauts parleurs restent muets pour le moment.

Hors ligne

#4 Le 20/11/2010, à 20:08

Korak

Re : [Résolu]Problème de son Asus N53J

Bonjour,

J'ai eu le problème sur un Compaq nx9010.

C'était les hauts-parleur internes avec le son au minimum.

Une piste peut-être.....


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#5 Le 21/11/2010, à 11:36

bnet22

Re : [Résolu]Problème de son Asus N53J

Pour ma part, j'ai vérifié le volume de chaque sortie avec Alsamixer, et j'ai tout mis à fond...

Hors ligne

#6 Le 21/11/2010, à 20:54

Kosy

Re : [Résolu]Problème de son Asus N53J

Pareil, dans Alsamixer tout est au max, j'ai essayé de vérifier les différents paramètres de la chose, mais au final, toujours pas de son


Le bonheur n'est réel que lorsqu'il est partagé.

Hors ligne

#7 Le 30/11/2010, à 03:27

Zef

Re : [Résolu]Problème de son Asus N53J

Bonjour,

Un petit HS pour profiter de vos retours d'expérience, étant donné qu'il est encore assez difficile de trouver des informations sur ces modèles N53Jf et N53Jq qui me paraissent très intéressants.

Apparemment il existe pour ces deux modèles deux variantes, Full HD ou non. Pouvez-vous confirmer que vous disposez bien des modèles SZ167V qui sont Full HD ? Cette dalle est-elle correcte, notamment en ce qui concerne les angles de vision ?

Outre ce pénible problème de hauts parleurs (Linux ne doit pas être assez cher pour B&O ^^), avez-vous tout testé ? La techno Nvidia optimus ne pose pas de problème par exemple ? La gestion des ventilos est-elle correcte ?

Merci par avance pour vos retours. Et désolé pour le HS.

Hors ligne

#8 Le 30/11/2010, à 11:06

bnet22

Re : [Résolu]Problème de son Asus N53J

Attention, je ne pense pas que les N53Jf fonctionnent avec Ubuntu à cause de la technologie Optimus qui n'est pas supporté pour Linux pour le moment.

C'est pour cela que je me suis orienté vers le N53JQ-SZ156V qui n'a pas Optimus (normalement, tous les JQ n'ont pas optimus, à vérifier).

Pour le moment, tout fonctionne sauf le son des hauts parleur (mais prise casque OK). Depuis mon dernier post, j'ai testé en plus avec succès le lecteur de carte SD. Webcam, touchpad, wifi, micro fonctionne. Un pilote HDMI est installé et semble OK, mais je n'ai pas pu tester la sortie HDMI. Pas testé la prise réseau gigabit. Carte graphique avec pilote proprio Nvdia OK. Dalle full HD OK. L'angle de vision me parait ok, on voit bien, en tout cas cela ne me gêne pas du tout. La brillance me gêne beaucoup plus par contre.

Les points négatifs : Dalle très brillante (attention si il y a une fenêtre dans le dos !), la position des ports USB sur les côtés devant (pas très pratique pour la souris par exemple, ou le port USB gêne en permanence). Autre point négatif, mais c'est relatif, le Disque dur est en SATA 1, et il aurai été mieux d'avoir du SATA 2 dans le cas ou on voudrait remplacer le disque par un SSD.

Tu a une partition de 15Go Recovery, une partition de 150Go pour Win 7, et le reste en une partition DATA. J'ai installé Ubuntu en prenant tout le DATA, et donc en dual-boot, et c'est OK. Pas de tatouage.

Après une semaine d'utilisation, je suis satisfait des performances et de l'utilisation en général, à part le son. J'ai branché des enceintes sur le port casque en attendant quand je suis chez moi.

Pour en revenir au problème des hauts parleur, si quelqu'un trouve la solution, on se tient au courant sur ce post wink Merci !

Dernière modification par bnet22 (Le 30/11/2010, à 11:19)

Hors ligne

#9 Le 30/11/2010, à 20:42

Zef

Re : [Résolu]Problème de son Asus N53J

Merci beaucoup pour ces indications.

La carte graphique nvidia étant la même sur les deux modèles, j'avais bêtement pensé que c'était de l'optimus également sur le i7. En fait j'étais prêt à tenter le coup de prendre une machine en optimus pour disposer du gain d'autonomie sous Windows pour les cas exceptionnels, et désactiver une deux cartes sous Ubuntu. Sachant que de toute façon c'est le même chipset graphique nvidia entre le i7 et i5, je me dis que l'autonomie du i5 ne dois pas plus souffrir que le i7, vu qu'ils ont les mêmes batteries. De plus le jour où des solutions simples de switch manuel entre les cartes (avec redémarrage de X) arriveront (j'imagine), le double chipset graphique peut s'avérer être un avantage en cas de besoin d'autonomie. Mais je n'ai pas de retours pour l'instant sur le N53Jf, donc ça reste un pari risqué.

D'ailleurs Asus s'avance peu sur l'autonomie. Si tu as un retour d'expérience, ça m'intéresse également.

Pour le SATA I, là non plus je n'avais pas fait attention. Déjà le disque 5200 tours sur une machine de ce type je trouvais que ça faisait roues de Clio sur une Mercedes. Cependant il semble tout à fait possible de profiter des bienfaits, même bridés, d'un SSD en SATA I. Donc comme tu dis c'est relatif.

Pour la dalle brillante, la traditionnelle plaie. Déjà que je n'ai pas encore vu que donne une telle résolution sur un écran de cette taille, si en plus c'est le palais des glaces, là ça devient un vrai point bloquant pour moi. Manquerait plus que ça ne fonctionne pas en double écran. sad

Dalle rétroviseur + enceintes + nvidia + optimus + sata I + 5200 tours. Rien de définitivement bloquant mais le bête perd de son aura.

En tout cas encore un très grand merci pour ce précieux retour. Je vais encore réfléchir un peu avant de rejoindre le club des enceintes B&O muettes.

Pour ce problème d'enceintes d'ailleurs, je dirais bien que le responsable soit Sonic Focus. A priori il y a quand même des pilotes Sonic Focus qui tournent sous Linux.
http://www.bioticaindia.com/sonic-focus.html

Hors ligne

#10 Le 01/12/2010, à 09:18

wampas

Re : [Résolu]Problème de son Asus N53J


Asus k42dr amd athlon II P320 2,1G / Ati mobility radeon HD 5470

Hors ligne

#11 Le 01/12/2010, à 09:23

Zef

Re : [Résolu]Problème de son Asus N53J

Avez-vous tenté de bricoler Pulseaudio ? 
http://doc.ubuntu-fr.org/pulseaudio

- Désactiver pulseaudio pour voir si Alsa s'en sort mieux.
- Voir si Pavucontrol ne permettrait pas d'y voir plus clair.
- Tester avec Wine (qui accède directement à Pulseaudio), éventuellement en essayant l'installation de Sonic Focus. Ca peut permettre également de mieux cibler où ça coince.

Hors ligne

#12 Le 01/12/2010, à 21:49

bnet22

Re : [Résolu]Problème de son Asus N53J

@ Zef :
Il me semble qu'avec Optimus, on ne peut utiliser QUE le chipset graphique intégré à la carte mère et qu'on ne puisse pas utiliser la carte dédiée nVidia comme si il n'y avait qu'elle. Donc, ca marcherai je pense, mais uniquement avec la carte graphique la moins bonne. C'est ce qui ressort de mes lectures.

Pour la résolution, on s'y fait, mais il faut que cela soit un choix (d'avoir de la place sur son écran quitte à ce que cela soit un peu petit). Détail amusant toutefois : Win 7 est réglé sur ce portable par défaut pour afficher en +125%. Du coup, les icones, certains textes etc... sont un peu flou et pixelisés d'office. J'ai mis un moment à comprendre pourquoi. Il y a un réglage dans la configuration de l'affichage sous Win7. C'est sans doute parce que la résolution est un peu élevé pour le grand public. C'est vrai que c'est assez petit, mais c'est ce que je voulais (j'ai de bon yeux !).

Je vais essayer vos suggestions pour le son quand j'aurai le temps, et je vous dirai.

Hors ligne

#13 Le 01/12/2010, à 21:53

bnet22

Re : [Résolu]Problème de son Asus N53J

Bon, la solution de wampas ne fonctionne pas sur le N53jq...

Hors ligne

#14 Le 02/12/2010, à 07:55

wampas

Re : [Résolu]Problème de son Asus N53J

mince dommage ........................


Asus k42dr amd athlon II P320 2,1G / Ati mobility radeon HD 5470

Hors ligne

#15 Le 02/12/2010, à 23:24

Zef

Re : [Résolu]Problème de son Asus N53J

Il y a de bonnes chances que ce soit pulseaudio qui fasse des siennes. Voici la solution pour le grand frère 17 pouces :
http://forum.ubuntu-fr.org/viewtopic.php?id=424161

Hors ligne

#16 Le 03/12/2010, à 10:43

bnet22

Re : [Résolu]Problème de son Asus N53J

Alors, j'ai désinstallé PulseAudio -> reboot : Toujours pas de son
J'ai réinstallé PulseAudio -> reboot : Toujours pas de son

Après, il y a peut être une façon de faire que je ne maîtrise pas...

Je pense aussi que le n73j devrait avoir le même soucis, donc, la même solution... Je vais me greffer à son post...

Hors ligne

#17 Le 03/12/2010, à 18:56

Zef

Re : [Résolu]Problème de son Asus N53J

À mon avis c'est surtout qu'il a fait fonctionner sans pulsaudio, donc comme je proposais avec alsa. Et peut-être que la réinstallation ensuite de pulsaudio a profité de la config alsa. Je te propose de vraiment tester avec alsa. Cf page pulsaudio.

Hors ligne

#18 Le 03/12/2010, à 20:41

mayeul75

Re : [Résolu]Problème de son Asus N53J

bonsoir,
J'ai résolu mon problème de son avec mon nouvel ASUS N53JQ-SZ156V sous Maverick 64 bits (10.10) - 6Go de RAM - Core i7-740QM.
Je n'ai pas installé les back-ports (!).

1- modifier le fichier /etc/modprobe.d/alsa-base.conf en ajoutant à la fin :
options snd-hda-intel model=auto position_fix=0

2 - redémarrez le pc ... et ca devrait etre ok
Normalement, ca devrait etre bon, il est toujours malin de vérifier que le niveau des entrées est suffisamment élevé ( commande alsamixer et/ou ).

+ de détails ici : http://doc.ubuntu-fr.org/audio_intel_hda#asus
En espérant que ca vous sera utile !!! smile
a+
Pierre
ps: je viens d'ajouter l'entrée dans le tableau pour ce modèle
ps2:le son est tout de même impressionnant une fois que ca marche, lol ...

Dernière modification par mayeul75 (Le 03/12/2010, à 20:43)

Hors ligne

#19 Le 03/12/2010, à 21:35

bnet22

Re : [Résolu]Problème de son Asus N53J

Bonjour et merci mayeul75,

J'ai 2 ASUS N53JQ-SZ156V sous la main, et j'ai testé ta solution sur les 2 sans succès. Sur le second, je n'ai jamais fait de manipulation particulière et donc, le fait que cela ne fonctionne pas ne vient pas d'une mauvaise manipulation.

Peux tu me dire si tu as fait d'autres manip avant (ou après) avoir ajouté cette ligne ?

Au moins, maintenant, on est sûr de la ligne à ajouter dans la conf.

Merci !!!

Hors ligne

#20 Le 03/12/2010, à 21:56

bnet22

Re : [Résolu]Problème de son Asus N53J

Bon, pour faire suite :

J'ai redésinstaller PulseAudio pour tester avec la nouvelle config de /etc/modprobe.d/alsa-base.conf => Rien
J'ai réinstallé PulseAudio => Rien
J'ai installé Pavucontrol => Tout est nickel et le son réglé à fond.

J'ai une carte qui est quand même apparu avec la nouvelle ligne de conf qui est :
Digital Stereo (IEC958) Output + Analog Stereo Input

mayeul75, si tu y es parvenu, il n'y a pas de raison que je n'y arrive ! N'as tu pas faut d'autres manipulations ?
Peux tu nous donner le contenu de tes configs  et les réglages dans les préférences du son ?

Hors ligne

#21 Le 04/12/2010, à 00:04

mayeul75

Re : [Résolu]Problème de son Asus N53J

bonsoir,
non, je n'ai rien supprimé ni modifié depuis l'installation (que j'ai faites mercredi !).  Donc, pas touche à pulseaudio (!).
Par contre, j'ai fait les dernières mises à jour automatiques du système.
J'utilise mon pc pour du développement web, j'ai donc ajouté apache2+php5, donc rien qui n'ai touché aux pilotes audio ...

As-tu suivi les infos de la page http://doc.ubuntu-fr.org/audio_intel_hda ?


=========================================
Distribution Ubuntu Maverick 10.10 - 64 bits (!) en français.
Le système a détecté automatiquement la présence de la carte graphique Nvidia Geforce GT425M. J'ai donc validé l'installation des pilots Nvidia.
Attention, bien vérifier que le son n'est pas "muet" (voir icône haut-parleur dans la barre de menu en haut) et aller dans les "préférences du son".

J'ai ajouté le module acpi pour surveiller la batterie et les infos thermiques ...

=========================================
ALSA v.1.0.23
Les commandes exécutées en bash sont en gras ... je te conseille doc de vérifier si les infos sont identiques à ton PC.

cat /proc/asound/cards
0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xd9600000 irq 52
1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xd3080000 irq 17

cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel

cat /proc/asound/pcm
00-00: ALC259 Analog : ALC259 Analog : playback 1 : capture 1
00-01: ALC259 Digital : ALC259 Digital : playback 1
01-03: NVIDIA HDMI : NVIDIA HDMI : playback 1
01-07: NVIDIA HDMI : NVIDIA HDMI : playback 1
01-08: NVIDIA HDMI : NVIDIA HDMI : playback 1
01-09: NVIDIA HDMI : NVIDIA HDMI : playback 1


lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
01:00.1 Audio device: nVidia Corporation Device 0bea (rev a1)


contenu du fichier /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

#options snd-hda-intel model=Realtek ALC259 position_fix=0
#options snd-hda-intel model=3stack position_fix=0
options snd-hda-intel model=auto position_fix=0
===========================================================

Dernière modification par mayeul75 (Le 04/12/2010, à 00:09)

Hors ligne

#22 Le 04/12/2010, à 00:06

mayeul75

Re : [Résolu]Problème de son Asus N53J

au fait, mon touchpad n'a pas l'air de fonctionner .. faut-il installer un pilote windows ? compiler une librairie ???  :-(

Hors ligne

#23 Le 04/12/2010, à 00:32

Zef

Re : [Résolu]Problème de son Asus N53J

C'est inquiétant des comportements différents pour une même config. Soit Asus monte ses machines avec ce qu'ils ont en stock, soit votre version de BIOS est différente. Je crois qu'on est à la 209 si je me souviens bien. Peut-être vérifier votre version de BIOS et éventuellement flasher.

Sinon un truc un peu bête qui m'a souvent depanné, installer kde si vous êtes sous gnome. Il y a des chances que kde fasse le boulot.

Hors ligne

#24 Le 04/12/2010, à 10:20

bnet22

Re : [Résolu]Problème de son Asus N53J

Je n'ose pas croire que Asus ait changé la fabrication technique du portable. Je les ai acheté il y a 2 semaines seulement.
Par contre, la question du BIOS est intéressante. Je suis en version 208. Je vais voir pour flasher tout ça...

mayeul75, mon touchpad fonctionnait directement sans aucune manipulation et sur les 2 PC.
Par contre, sur celui de ma compagne, elle s'est retrouvé quelques fois avec une souris folle (qui voulait plus cliquer gauche) : J'ai trouvé d'ou venait ce soucis.
Il s'agissait de l'utilitaire syndaemon qui désactive le touchpad pendant la frappe. Pour désactiver syndaemon, il suffit de faire Système > Préférence > Souris >Onglet Pavé tactile > Décocher "Désactiver le pavé tactile pendant la frappe"

mayeul75, quelle version du bios as tu ?

Je continue mes recherches....

Hors ligne

#25 Le 04/12/2010, à 11:47

bnet22

Re : [Résolu]Problème de son Asus N53J

Bon, résultats de mes derniers tests : Le son fonctionne enfin très bien, mais je ne sais pas exactement pourquoi.

Sur le laptop1, j'ai mis à jour le firmware en 209. J'ai redémarré, pas de son. Au niveau des préférences du son, après une nouvelle vérification, je me suis aperçu que la sortie était configurée sur le HDMI et non sur les HP. Sans doute suite à toute mes manipulations précédentes. J'ai donc mis sur Audio Interne Analog Stereo. Et hop ça marche.

Je me dit, super, je vais mettre à jour le bios sur le laptop2. Je le démarre, et là, le son fonctionne directement. J'avais pourtant testé plusieurs redémarrages hier sans succès et sans rien modifier de plus (ce n'est pas mon portable). Mystère, j'ai fait une fausse manip quelque part.

Donc, pour le N53JQ, je confirme la manipulation de mayeul75 :

1- modifier le fichier /etc/modprobe.d/alsa-base.conf en ajoutant à la fin :
options snd-hda-intel model=auto position_fix=0

2 - redémarrez le pc ... et ca devrait etre ok

J'ajoute que le son fonctionne en BIOS 208 et 209.
Dans les préférences du son, au niveau de l'onglet "Sortie", il faut bien cocher Audio Interne Analog Stereo.

Un grand merci à tous les participants de cette discussion.

Ca serait intéressant pour voir si ça marche chez Kosy aussi.

Hors ligne

Haut de page ↑