Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 24/11/2010, à 04:02

CanadienFr

SSH activer VNC Ubuntu

Bonjour,

J'aimerais activer le VNC de Ubuntu a distance avec le Putty SSH.
J'ai acheter un VPS sous linux mais j'arrive pas a me connecter avec REALVNC.
Je suis un débutant sous linux.

Hors ligne

#2 Le 24/11/2010, à 05:17

CanadienFr

Re : SSH activer VNC Ubuntu

Voila maintenant j'ai lu quelque forum mais , quand je fait la command

sudo apt-get install vnc4server

Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package vnc4server

Hors ligne

#3 Le 24/11/2010, à 07:21

vpoulailleau

Re : SSH activer VNC Ubuntu

Salut,

Je te conseille la lecture de http://doc.ubuntu-fr.org/vnc

Tu es sur quelle version d'Ubuntu ?

À+
Vincent


Guitaristes, pianistes, batteurs, bassistes, venez chercher des partitions sur :
www.tabs.for.free.fr

Hors ligne

#4 Le 24/11/2010, à 10:04

cbloo

Re : SSH activer VNC Ubuntu

Perso je te conseille FREENX , il y a une doc ubuntu-fr bien entendu disponible smile


www.coolbytes.fr
Multigaming et entraide informatique
Tw: @cbloo

Hors ligne

#5 Le 24/11/2010, à 11:54

chopinhauer

Re : SSH activer VNC Ubuntu

CanadienFr a écrit :

J'aimerais activer le VNC de Ubuntu a distance avec le Putty SSH.
J'ai acheter un VPS sous linux mais j'arrive pas a me connecter avec REALVNC.

VNC est un protocole qui affiche en local ce qui est montré sur le serveur distant. Vu que la machine distante est un serveur, son système graphique (serveur X) n'est pas lancé, car cela serait une perte de ressources. En plus je ne sais pas si la technologie de virtualisation utilisée permet de partager la carte graphique, donc toute la charge serait supportée par le processeur de la machine.

Je te déconseille donc de lancer un serveur X sur la machine serveur et de copier son affichage avec VNC.

Cependant dans le monde Unix il y a toujours eu une forte indépendance entre machine qui exécute les applications et périphériques d'entrée/sortie : les deux peuvent très bien être sur des machines différentes. Dans ton cas au lieu de copier ce qui s'affiche sur l'écran du serveur, tu vas demander à ce dernier d'utiliser directement ton écran comme affichage.

Cela est possible sans aucun logiciel additionnel, mais si tu utilises FreeNX tu vas bénéficier de la confidentialité dans la transmission de tes données et une vitesse accrue (car les applications distantes ne vont pas passer par ta machine pour communiquer)[#].

[#] Il faut aussi considérer que à différence de VNC qui transmet des photos (comprimés et optimisées mais toujours des photos), la communication entre une application et le serveur X se fait de manière plus abstraite : par exemple on peut envoyer deux images et dire au serveur d'en faire un échiquier, bien plus pratique.


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#6 Le 02/12/2010, à 12:34

Romain77

Re : SSH activer VNC Ubuntu

je suis tres interressé par la derniere reponse !

Est il possible d' avoir plus d' informations quant a cette manipulation ?

Je dispose egalement d' un serveur Ubuntu 10.04 (64 bits), la j' arrive plus ou moins a afficher correctement une interface graphique via VNC ... mais si j'avais la possibilité d' afficher sur mon ecran directement avec ma carte graphique ce qu il se passe sur le serveur qui lui est distant ... ce serait formidable.

D'avance merci

Hors ligne

#7 Le 02/12/2010, à 14:42

chopinhauer

Re : SSH activer VNC Ubuntu

Il y a une page de documentation sur FreeNX. Aussi l'option -X de ssh permet de lancer des applications graphiques sur le serveur distant et les afficher sur le serveur X local.

La deuxième solution est plus rapide à déployer, mais moins performant, car tout échange entre deux applications X sur le serveur distant va devoir faire un aller-retour par la connexion ssh.

Si tu utilises un client Windows, fait un détour sur le site de NoMachine.


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#8 Le 02/12/2010, à 17:19

LJGIbbs

Re : SSH activer VNC Ubuntu

Bonjour,
Je suis dans le même cas que les personnes précedentes :

ubuntu serveur dédié distant, 10.04
j'arrive à me connecter en SSH
J'ai installé gnome via SSH (avec le terminal MacOs)
Malheureusement impossible d'arriver à prendre la main sur l'interface graphique, ni sur freenx (donc je ne comprends pas le tuto).

Merci à une âme généreuse qui voudra bien me guider...

Nicolas

Hors ligne

#9 Le 02/12/2010, à 21:38

chopinhauer

Re : SSH activer VNC Ubuntu

Sous Mac OS X tu dois d'abord lancer un serveur X (X11.app). Ensuite tu te connectes sur la machine distante :

ssh -X machine_distante

et tu lances ce que tu veux. Par exemple :

dbus-launch --exit-with-session gnome-session

lancera le bureau GNOME au complet.


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#10 Le 02/12/2010, à 22:54

LJGIbbs

Re : SSH activer VNC Ubuntu

Snif'
message d'erreur que j'avais déjà eu ... :

(process:4460): Gtk-WARNING **: Locale not supported by C library.
    Using the fallback 'C' locale.

** (gnome-session:4460): WARNING **: Cannot open display:

Dernière modification par LJGIbbs (Le 02/12/2010, à 22:55)

Hors ligne

#11 Le 02/12/2010, à 22:58

chopinhauer

Re : SSH activer VNC Ubuntu

T'as une section dédiée au débogage de connexion ssh dans la foire aux questions de X11.app.


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#12 Le 03/12/2010, à 13:07

Romain77

Re : SSH activer VNC Ubuntu

Re bonjour a tous !

est ce possible d utiliser la "technique" du ssh -X depuis windows ? tu dis que tu dois installer X11.app sous MAC OS X ! Qu' en est il sous windows ? (si possible of course) !!

Enfin bref je suis preneur de tous vos conseils pour m' aider a administrer graphiquement ce "satané" server wink

Merci

Hors ligne

#13 Le 03/12/2010, à 13:09

chopinhauer

Re : SSH activer VNC Ubuntu

Pour Windows t'as Xming.


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#14 Le 03/12/2010, à 15:31

Romain77

Re : SSH activer VNC Ubuntu

la je suis sous un autre poste avec Linux Ubuntu 10.10 et j essaye tant bien que mal de lancer cette #$$*!ùù d'interface graphique via le SSH ... et quand je tape

dbus-launch --exit-with-session gnome-session

j' obtiens ce message :

X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.

** (gnome-session:14272): WARNING **: Cannot open display:

je ne comprend pas pourquoi j' ai un refus de connexion dans la mesure ou je suis loggé en root sur mon SSH sad

encore un courrageu pour un ptit coup de main ... je sens que je touche au but la wink

Dernière modification par Romain77 (Le 03/12/2010, à 15:31)

Hors ligne

#15 Le 03/12/2010, à 19:44

chopinhauer

Re : SSH activer VNC Ubuntu

Tu peux contrôler ce qui ne marche de manière similaire à ce qui se fait sous Mac OS X :

# Sur le client
echo $DISPLAY
# …doit retourner :0.0 ou similaire
ssh -vX machine
# On doit voir une ligne comme 'Requesting X11 forwarding with authentication spoofing.'
# On est sur le serveur maintenant
echo $DISPLAY
# …doit retourner :10.0 ou similaire
xauth list
# doit contenir une ligne 'nom_de_machine/unix:10'
# Petit test avec de lancer une session complète
gedit

Dernière modification par chopinhauer (Le 03/12/2010, à 19:44)


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#16 Le 03/12/2010, à 20:22

Romain77

Re : SSH activer VNC Ubuntu

Alors ... ça avance ... (mais ça marche pas encore tout a fait)

voici ce que j' obtiens maintenant :

romain@s15425501:~$ dbus-launch --exit-with-session gnome-session
GNOME_KEYRING_CONTROL=/tmp/keyring-j8FEfc
GNOME_KEYRING_PID=2144
GNOME_KEYRING_CONTROL=/tmp/keyring-j8FEfc
SSH_AUTH_SOCK=/tmp/keyring-j8FEfc/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-j8FEfc

** (gnome-settings-daemon:2148): WARNING **: You can only run one xsettings manager at a time; exiting

** (gnome-settings-daemon:2148): WARNING **: Unable to start xsettings manager: Could not initialize xsettings manager.

** (gnome-settings-daemon:2148): WARNING **: Connection failed, reconnecting...

** (gnome-settings-daemon:2148): WARNING **: Failed to connect context: Connection refused

(polkit-gnome-authentication-agent-1:2160): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:2160): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

** (bluetooth-applet:2166): WARNING **: Could not open RFKILL control device, please verify your installation
Initializing nautilus-gdu extension

** (nm-applet:2161): WARNING **: <WARN>  request_name(): Could not acquire the NetworkManagerUserSettings service.
  Error: (9) Connection ":1.34" is not allowed to own the service "org.freedesktop.NetworkManagerUserSettings" due to security policies in the configuration file


(gnome-power-manager:2167): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.24.1/gobject/gsignal.c:2273: signal `proxy-status' is invalid for instance `0x8b8bf18'
Failed to play sound: Not available
Connection failure: Connection refused
pa_context_connect() failed: Connection refused
system-config-printer-applet: failed to start NewPrinterNotification service

** (update-notifier:2337): WARNING **: already running?


(evolution-alarm-notify:2282): GnomeUI-WARNING **: While connecting to session manager:
IO error occured opening connection.
evolution-alarm-notify-Message: Setting timeout for 17148 1291420800 1291403652
evolution-alarm-notify-Message:  Sat Dec  4 01:00:00 2010

evolution-alarm-notify-Message:  Fri Dec  3 20:14:12 2010


** (gnome-settings-daemon:2148): WARNING **: Grab failed for some keys, another application may already have access the them.

** (gnome-settings-daemon:2148): WARNING **: Clipboard manager is already running.

** (gnome-settings-daemon:2148): WARNING **: Connection failed, reconnecting...

** (gnome-settings-daemon:2148): WARNING **: Failed to connect context: Connection refused
The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1262 error_code 8 request_code 3 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

** (gnome-panel:2162): WARNING **: panel-applet-frame.c:1310: failed to get Bonobo/Control interface on applet OAFIID:GNOME_Panel_TrashApplet:
Unknown CORBA exception id: 'IDL:omg.org/CORBA/COMM_FAILURE:1.0'
Write failed: Broken pipe

alors je suis incapable de dechiffrer tout ça mais je sens que ça va venir wink

mais il semble qu il y ai un refus de connexion ... je vois pas pourquoi ni comment ... mais ça semble venir de la !

Dernière modification par Romain77 (Le 03/12/2010, à 20:25)

Hors ligne

#17 Le 03/12/2010, à 20:37

chopinhauer

Re : SSH activer VNC Ubuntu

Normalement cela a marché. Si c'est depuis Ubuntu que t'essaie de le faire, tu vas pas forcement t'apercevoir du résultat, car le nouveau panneau couvrira l'ancien. Tu peux soit créer un deuxième serveur X virtuel à l'intérieur de ton serveur ou lancer un deuxième serveur X sur la machine locale.

Dans le premier cas installe xserver-xephyr et lance :

xinit -- /usr/bin/Xephyr :1

(remarque l'espace entre 'Xephyr' et ':1) dans le deuxième cas lance :

xinit --  :1

T'obtiendra une fenêtre (resp. un serveur sur une autre console virtuel, tu pourra revenir à l'ancien avec CTRL+ALT+FX avec X un nombre, 7 d'habitude) dans laquelle t'aura un terminal pour lancer ton ssh.

PS : au lieu de lancer gnome-session directement, tu peux lancer /etc/X11/Xsession

Dernière modification par chopinhauer (Le 03/12/2010, à 20:39)


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#18 Le 04/12/2010, à 23:03

Romain77

Re : SSH activer VNC Ubuntu

Salut, bon j ai reussis a trouver une solution temporaire mais acceptable ! Mais je dois utiliser VNC ! Mais bon j ai quand meme une jolie interface gnome !

Faudra cependant que je me repenche vers FREENX ... qui me semble de ce que j ai pu lire ... La meilleure solution d administration graphique !

Hors ligne

#19 Le 06/12/2010, à 09:03

Romain77

Re : SSH activer VNC Ubuntu

Salut,

Bon ba voila, j avais enfin reussis a faire fonctionner freenx avec nomachine .. mais j' ai du redemarrer mon server et du coup impossible de relancer une session via nomcahine, j' ai un internal error

voici le detail du log :

NX> 203 NXSSH running with pid: 7948
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 217.160.224.124 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 3.3.0 - GPL
NX> 105 Hello nxclient - version 3.3.0
NX> 134 Accepted protocol: 3.3.0
NX> 105 Set SHELL_MODE: SHELL
NX> 105 Set AUTH_MODE: PASSWORD
NX> 105 Login
NX> 101 User: romain
NX> 102 Password: **********
Could not find ':' in DISPLAY:
NX> 103 Welcome to: s15425501.onlinehome-server.info user: romain
NX> 105 Listsession --user="romain" --status="suspended,running" --geometry="1280x1024x32+render" --type="unix-gnome"
NX> 127 Session list of user 'romain':
Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------
934     unix-gnome       A7D94EBBD1AE8833F6891CB93E3FC02B -RD--PSA    24 1434x832       Running     Root
138     unix-gnome       B50ED9F83BD58DB00B9FA8AA3633C1E1 -RD--PSA    24 1274x956       Running     1%261

NX> 148 Server capacity: not reached for user: romain
NX> 105 Restoresession  --link="adsl" --backingstore="1" --encryption="1" --cache="16m" --images="64m" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --session="1%261" --type="unix-gnome" --geometry="1274x956" --client="winnt" --keyboard="pc102/fr" --id="b50ed9f83bd58db00b9fa8aa3633c1e1" --resize="1"
NX> 500 Internal error
NX> 999 Bye.
NX> 280 Exiting on signal: 15


quelqu un aurait il une idée du pourquoi du comment ?

Merci

Hors ligne

#20 Le 06/12/2010, à 10:56

Romain77

Re : SSH activer VNC Ubuntu

Bon j' ai trouvé !

Il semblerait que l' on ne puisse pas se connecter avec plus de 2 sessions avec le meme user !

Apres recherche, j' ai lu que parfois le server "merdé" et ne fermé pas les sessions correctement !

La solution : virer les sessions manuellement : /var/lib/neatx/sessions et un petit rm -rf *

voila ! Pour moi cela a marché !

Hors ligne