Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 05/06/2006, à 10:11

AddiKT1ve

Marre, marre, marre : drivers ATI Radeon

Hell low hmm

Je suis d'une humeur massacrante... J'ai essayé toutes les solutions pour faire marcher l'accélération 3D de ma carte ATI Radeon 9200, la seule qui a marché, c'est celle des drivers libres ; et comme par hasard, ce driver libre ne fonctionne pas avec l'Unreal Engine, donc exit UT2004, America's Army, etc. (reuh-comme par hasard, les jeux auxquels j'ai envie de jouer...).

Je viens d'installer les drivers propriétaires, c'est fantastique, toujours pas d'accélération 3D, au point que je ne peux même plus lancer xmoto !!

addikt1ve@PC:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

Voilà mon fglrxinfo, on dirait que l'opengl fonctionne hmm ...

J'ai suivi la procédure à la lettre, bordel, je n'en peux plus, ça fait une semaine que je me débats avec ces foutus drivers...

Merci de votre aide, j'en ai vraiment besoin sad


[EDIT] Oulà, je ne peux plus lancer AUCUN jeu...

Dernière modification par AddiKT1ve (Le 05/06/2006, à 10:50)


emacs(){emacs|emacs&};emacs
:: blog | vol organisé

Hors ligne

#2 Le 05/06/2006, à 16:00

AddiKT1ve

Re : Marre, marre, marre : drivers ATI Radeon

Un petit up...

(pour info, je tourne sous Dapper)


emacs(){emacs|emacs&};emacs
:: blog | vol organisé

Hors ligne

#3 Le 05/06/2006, à 16:21

mathieu vilaplana

Re : Marre, marre, marre : drivers ATI Radeon

On dirait que fglrx n'est pas chargé, que renvoi la commande:

sudo modprobe fglrx


===========================================
Ubuntu Lover

Hors ligne

#4 Le 05/06/2006, à 17:04

AddiKT1ve

Re : Marre, marre, marre : drivers ATI Radeon

addikt1ve@PC:~$ sudo modprobe fglrx
Password:
FATAL: Module fglrx not found.

Forcément, maintenant j'ai tout supprimé... le fichier xorg.conf est out, je l'ai tellement modifié...

Je vais essayer de faire quelque chose de propre et installer fgl.

Mon xorg.conf -section Device-

Section "Device"
	Identifier	"ATI Technologies, Inc. RV280 [Radeon 9200]"
	Driver		"ati"
	BusID		"PCI:1:0:0"

Normalement là, c'est à neuf où il faut encore que je modifie quelque chose pour que ce soit compatible xgl ? hmm

Mon etc/modules

fglrx
lp
mousedev
psmouse
sbp2
sr_mod

Ca le fait ?

Maintenant je vais installer les packages fgl...

xorgdriverfglrx1tp.th.png

Et merde, fallait que ça m'arrive !

Je n'arrive pas à déslectionner ce paquet, et je ne connais pas la commande en mode console pour ce faire... :x

Dernière modification par AddiKT1ve (Le 05/06/2006, à 17:27)


emacs(){emacs|emacs&};emacs
:: blog | vol organisé

Hors ligne

#5 Le 05/06/2006, à 17:52

jorkar

Re : Marre, marre, marre : drivers ATI Radeon

tu veux le virer?
apt-get remove xorg-driver-fglrx

En fait moi j'ai fait le con sur xorg.conf l'autre jour quand j'ai voulu installer xgl je crois. Depuis plus d'accélération graphique non plus. j'ai resuivi plusieurs tutos dont celui du wiki.
fglrxinfo me donne la même chose que toi.


La géologie pétrolière se contrefout de votre envie ou besoin de conduire une automobile.
Jabber ID: jorkar@fritalk.com : http://presence.jabberfr.org/f63814f96538116bb64ff88adc81e548/text-fr.txt

Hors ligne

#6 Le 05/06/2006, à 17:57

AddiKT1ve

Re : Marre, marre, marre : drivers ATI Radeon

root@PC:/home/addikt1ve# apt-get remove xorg-driver-fglrx
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Les paquets suivants seront ENLEVÉS :
  xorg-driver-fglrx
0 mis à jour, 0 nouvellement installés, 1 à enlever et 1 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o dans les archives.
Après dépaquetage, 26,3Mo d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 97993 fichiers et répertoires déjà installés.)Suppression de xorg-driver-fglrx ...
dpkg-divert: rename involves overwriting `/usr/lib/libGL.so.1' with
  different file `/usr/lib/fglrx/libGL.so.1.xlibmesa', not allowed
dpkg : erreur de traitement de xorg-driver-fglrx (--remove) :
le sous-processus post-removal script a retourné une erreur de sortie d'état 2
Des erreurs ont été rencontrées pendant l'exécution :
xorg-driver-fglrx
E: Sub-process /usr/bin/dpkg returned an error code (1)

Et merde...

Dernière modification par AddiKT1ve (Le 05/06/2006, à 17:57)


emacs(){emacs|emacs&};emacs
:: blog | vol organisé

Hors ligne

#7 Le 05/06/2006, à 17:59

Shyne

Re : Marre, marre, marre : drivers ATI Radeon

dpkg-divert: rename involves overwriting `/usr/lib/libGL.so.1' with
  different file `/usr/lib/fglrx/libGL.so.1.xlibmesa', not allowed

Et le sudo il est ou tongue

edit: j'avais pas vu que t'etait root j'ai rien dit...

Dernière modification par Shyne (Le 05/06/2006, à 18:06)

Hors ligne

#8 Le 05/06/2006, à 18:02

did

Re : Marre, marre, marre : drivers ATI Radeon

Je vous fait par à tout hasard de mon experience.

Il m'est arrivé moi aussi de galérer de manière inexpliqué pour installer les drivers suivant la procédure de la doc, pour dapper.

En fait ce qui m'a finalement tiré d'affaire après le  "sudo aticonfig --initial" c'est cette ligne.

sudo ln -s /usr/lib/dri /usr/lib/xorg/modules/dri

Je sais qu'elle est déjà dans la doc, mais comme je n'ai jamais eu à l'utiliser dans mes installation précedentes, je n'ai pas pensé à m'en servir tout de suite, c'est peut-être aussi votre cas...

Hors ligne

#9 Le 05/06/2006, à 19:25

AddiKT1ve

Re : Marre, marre, marre : drivers ATI Radeon

Shyne a écrit :

dpkg-divert: rename involves overwriting `/usr/lib/libGL.so.1' with
  different file `/usr/lib/fglrx/libGL.so.1.xlibmesa', not allowed

Et le sudo il est ou tongue

edit: j'avais pas vu que t'etait root j'ai rien dit...

Je viens de voir ton edit, le pire c'est que tu m'as fait douter et que j'ai réessayé après un énième sudo su ^^


emacs(){emacs|emacs&};emacs
:: blog | vol organisé

Hors ligne

#10 Le 06/06/2006, à 16:51

AddiKT1ve

Re : Marre, marre, marre : drivers ATI Radeon

Up... toujours impossible sad


emacs(){emacs|emacs&};emacs
:: blog | vol organisé

Hors ligne

#11 Le 06/06/2006, à 16:58

mazesloup

Re : Marre, marre, marre : drivers ATI Radeon

Pour ça,

dpkg-divert: rename involves overwriting `/usr/lib/libGL.so.1' with
  different file `/usr/lib/fglrx/libGL.so.1.xlibmesa', not allowed

j'ai une solution pas propre :

tu édites le fichier /var/lib/dpkg/info/xorg-driver-fglrx.postrm

et tu remplace ça :

        dpkg-divert --remove --rename --package $PKGNAME --divert /usr/lib/fglrx/libGL.so.1.xlibmesa /usr/lib/libGL.so.1 > /dev/null
        dpkg-divert --remove --rename --package $PKGNAME --divert /usr/lib/fglrx/libGL.so.1.2.xlibmesa /usr/lib/libGL.so.1.2 > /dev/null

par

        #dpkg-divert --remove --rename --package $PKGNAME --divert /usr/lib/fglrx/libGL.so.1.xlibmesa /usr/lib/libGL.so.1 > /dev/null
        #dpkg-divert --remove --rename --package $PKGNAME --divert /usr/lib/fglrx/libGL.so.1.2.xlibmesa /usr/lib/libGL.so.1.2 > /dev/null

C'est pas propre, mais comme cela tu peux enlever le paquet...

sinon je suis dans ton cas, toujours pas de fglrx en dapper


Mes applis Android - Jabber mazesloup[AT]gmail point com
DADVSI Passé, je suis en berne, je n'achète plus de CD, DVD ni de choses DRMisées
N'oubliez pas : Une petite recherche avant de poster

Hors ligne

#12 Le 06/06/2006, à 17:32

AddiKT1ve

Re : Marre, marre, marre : drivers ATI Radeon

Donc ça ne vient pas de moi ? Il est toujours impossible d'utiliser fglrx sous Dapper ? big_smile

*soulagé*


emacs(){emacs|emacs&};emacs
:: blog | vol organisé

Hors ligne

#13 Le 06/06/2006, à 17:48

pohiohio

Re : Marre, marre, marre : drivers ATI Radeon

salut.
desolé mais si les pilotes proprio du dépot marchent très bien et au moins depuis la beta de dapper. continuez de chercher ça devrait marcher, perso j'ai suivi le tuto pour la breezy et pas de probleme.
courage.

Hors ligne

#14 Le 06/06/2006, à 17:50

AddiKT1ve

Re : Marre, marre, marre : drivers ATI Radeon

Pff, de toute façon c'est le gros bordel sur mon pc...

Va falloir que je fasse un aticonfig --initial et que je réinstalle tout...


[EDIT] J'ai réinstallé avec le tuto pour Breezy, tu es marrant toi, pour avoir mon écran rien qu'en 75Hz il faut que je me mette en 1024*768, ce qui encore serait acceptable si j'avais l'accélération 3D, ce qui n'est absolument pas le cas :x ...

Dernière modification par AddiKT1ve (Le 06/06/2006, à 17:58)


emacs(){emacs|emacs&};emacs
:: blog | vol organisé

Hors ligne

#15 Le 06/06/2006, à 18:37

did

Re : Marre, marre, marre : drivers ATI Radeon

Peut-etre devrait tu faire un sudo dpkg-reconfigure xserver-xorg pour remettre ton xorg.conf à plat et réessayer la methode pour Dapper dans la doc.
Les drivers proprios du dépot marchent aussi très bien chez moi.

Hors ligne

#16 Le 06/06/2006, à 18:49

AddiKT1ve

Re : Marre, marre, marre : drivers ATI Radeon

J'ai suivi les instructions ici et maintenant, fgl_glxgears fonctionne parfaitement.

À côté de ça, je ne peux plus accéder aux résolutions supérieures à 1024*768 au-dessus de 60Hz (et pourtant, avant, je tournais en 1152*864 en 75Hz, et ce parfaitement).

Je ne peux plus non plus lancer un jeu exploitant l'OpenGL ou Direct3D (xMoto et America's Army en sont deux bons exemples).

Merci de m'aider, je sens que la fin est proche, mais y'a encore du boulot sad ...

[EDIT] J'ai réussi à obtenir mes 75Hz, en faisant la configuration "Simple" de l'écran lors d'un dpkg-reconfigure xserver-xorg, mais toujours rien pour les jeux sad

Dernière modification par AddiKT1ve (Le 06/06/2006, à 18:53)


emacs(){emacs|emacs&};emacs
:: blog | vol organisé

Hors ligne

#17 Le 06/06/2006, à 19:26

did

Re : Marre, marre, marre : drivers ATI Radeon

Essayes peut-être de rajouter les résolutions qui t'interressent directement dans ton xorg.conf :
http://doc.ubuntu-fr.org/materiel/fix_p … resolution

Hors ligne

#18 Le 06/06/2006, à 19:28

AddiKT1ve

Re : Marre, marre, marre : drivers ATI Radeon

Tu aurais pu lire mon edit avant de poster...

De plus, ces résolutions étaient déjà présentes, même quand le problème était effectif...

[EDIT] J'ai réussi à obtenir mes 75Hz, en faisant la configuration "Simple" de l'écran lors d'un dpkg-reconfigure xserver-xorg, mais toujours rien pour les jeux sad


emacs(){emacs|emacs&};emacs
:: blog | vol organisé

Hors ligne

#19 Le 06/06/2006, à 23:32

pohiohio

Re : Marre, marre, marre : drivers ATI Radeon

si ça peux t'aider perso je peux jouer à ureal tournament 2003 sans probleme.

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "aticonfig Screen 0" 0 0
	InputDevice    "Generic Keyboard"
	InputDevice    "Configured Mouse"
	InputDevice    "stylus" "SendCoreEvents"
	InputDevice    "cursor" "SendCoreEvents"
	InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

	# path to defoma fonts
	FontPath     "/usr/share/X11/fonts/misc"
	FontPath     "/usr/share/X11/fonts/cyrillic"
	FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath     "/usr/share/X11/fonts/Type1"
	FontPath     "/usr/share/X11/fonts/100dpi"
	FontPath     "/usr/share/X11/fonts/75dpi"
	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load  "i2c"
	Load  "bitmap"
	Load  "ddc"
	Load  "dri"
	Load  "extmod"
	Load  "freetype"
	Load  "glx"
	Load  "int10"
	Load  "type1"
	Load  "vbe"
EndSection

Section "InputDevice"
	Identifier  "Generic Keyboard"
	Driver      "kbd"
	Option	    "CoreKeyboard"
	Option	    "XkbRules" "xorg"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "fr"
	Option	    "XkbVariant" "latin9"
EndSection

Section "InputDevice"
	Identifier  "Configured Mouse"
	Driver      "mouse"
	Option	    "CorePointer"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "ExplorerPS/2"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
	Identifier  "stylus"
	Driver      "wacom"
	Option	    "Device" "/dev/wacom"          # Change to 
	Option	    "Type" "stylus"
	Option	    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
	Identifier  "eraser"
	Driver      "wacom"
	Option	    "Device" "/dev/wacom"          # Change to 
	Option	    "Type" "eraser"
	Option	    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
	Identifier  "cursor"
	Driver      "wacom"
	Option	    "Device" "/dev/wacom"          # Change to 
	Option	    "Type" "cursor"
	Option	    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
	Identifier   "C1786PNST"
	Option	    "DPMS"
EndSection

Section "Monitor"
	Identifier   "aticonfig Monitor 0"
EndSection

Section "Device"
	Identifier  "ATI Technologies, Inc. RV350 AP [Radeon 9600]"
	Driver      "ati"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
	Identifier  "ATI Graphics Adapter 0"
	Driver      "fglrx"
	Option	    "(null)"
	Option	    "FSAAEnable" "on"
	BusID       "PCI:1:0:0"
	  Option      "VideoOverlay" "on"
          Option      "OpenGLOverlay" "off"

EndSection

Section "Screen"
	Identifier "Default Screen"
	Device     "ATI Technologies, Inc. RV350 AP [Radeon 9600]"
	Monitor    "C1786PNST"
	DefaultDepth     24
	SubSection "Display"
		Depth     1
		Modes    "1280x1024" "1280x960" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     4
		Modes    "1280x1024" "1280x960" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     8
		Modes    "1280x1024" "1280x960" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     15
		Modes    "1280x1024" "1280x960" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     16
		Modes    "1280x1024" "1280x960" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     24
		Modes    "1280x1024" "1280x960" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
EndSection

Section "Screen"
	Identifier "aticonfig Screen 0"
	Device     "ATI Graphics Adapter 0"
	Monitor    "aticonfig Monitor 0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "DRI"
	Mode         0666
EndSection

Hors ligne

#20 Le 07/06/2006, à 12:27

AddiKT1ve

Re : Marre, marre, marre : drivers ATI Radeon

Hmm merci, je vais essayer ça...

Mais je prévois une installation clean de Dapper dès que je reçois mes nouveaux CD, donc je verrai plus tard...

@ peluche, merci wink


emacs(){emacs|emacs&};emacs
:: blog | vol organisé

Hors ligne

Haut de page ↑