Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 06/06/2006, à 15:18

lordjem

Apt-build impossible d'installer ou de recompiller des paquets !

Bonjour,

J'ai découvert depuis 1 semaine apt-build ! Pris par l'envie de recompiller des paquets pour les optimiser pour mon architecture je me décide à essayer !

Il n'y a pas beaucoup de doc française et anglaise, les 3/4 sont tirés du même tuto en anglais. Cependant ils expliquent comment installé apt-build mais rien sur les problèmes que l'on peut rencontrer >_<

Je m'explique donc, j'ai installé apt-build avec la commande :

sudo apt-get install apt-build

Aucun problème jusqu'ici.

à l'installe je renseigne mon architecture proc, qui est athlon-xp soit k7. Toujours pas de problème.

Une fois le tout configurer, les dépots de source activé et un joli

sudo apt-build update

Tous les paquets sont bien listés big_smile

C'est là que sa se complique, pour tout paquet que je veut installer, apt-build télécharge bien les sources, les compilent (visiblement) mais ne les installe pas et me sort parfois en dernier message "erreur de segmentation".

J'essaye avec --force-yes pour installer les dépendances etc... rien n'y fait toujours la même erreur !

voici le déroulement raccourcis de la vu dans le terminal pour un programme léger : gmail-notify

$ sudo apt-build install gmail-notify
-----> Installing build dependencies (for gmail-notify) <-----
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
-----> Updating package lists <-----
Ign file: apt-build Release.gpg
Réception de : 1 file: apt-build Release [89B]
Ign file: apt-build/main Packages
Réception de : 2 http://ftp.u-picardie.fr dapper Release.gpg [189B]
Réception de : 3 http://ftp.u-picardie.fr dapper-updates Release.gpg [189B]
Réception de : 4 http://ftp.u-picardie.fr dapper-backports Release.gpg [189B]

.
.
.

-----> Building gmail-notify <-----
dpkg-buildpackage: source package is gmail-notify
dpkg-buildpackage: source version is 1.6.1-0ubuntu2
dpkg-buildpackage: source changed by root <root@localhost>
dpkg-buildpackage: host architecture i386
 debian/rules clean
test -x debian/rules
test "`id -u`" = 0
if test -n "" && test "" != "."; then rmdir ""; fi

.
.
.

71:6:E: element "PARA" undefined
Can't call method "value" on an undefined value at /usr/share/perl5/sgmlspl-specs/docbook2man-spec.pl line 249, <STDIN> line 1.
make: *** [install/gmail-notify] Erreur 8
----> Cleaning up object files <-----
Cleaning in directory .
test -x debian/rules
test "`id -u`" = 0
if test -n "" && test "" != "."; then rmdir ""; fi
if test "." != "."; then rmdir .; fi
dh_clean

.
.
.

rm -f debian/gmail-notify.1
rm -f debian/manpage.*
Error while building gmail-notify!
Sorry, no package to install.

Voilà si qqn sait comment résoudre ça ! big_smile

Merci d'avance !!

@+
Lordjem

Hors ligne

Haut de page ↑