Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 10/03/2011, à 00:33

James06

Mediatomb config.xml pour freebox v5 : video, youtube, musique, images

Ce qui suit permet de lire sur Freebox V5 touts formats video, tous formats image (dont mp4 et flv), format musique mp3, youtube en mp4  depuis une freebox V5.

Le UPNP de la V6 semble un peu moins bete, il conviendra donc de supprimer les transcodages en trop. J'ai pas de V6, donc pas de details.

Sous titres non implémentés,

mode d'emploi en version hack rapide et sale.

1: installer mediatomb
2 recuperer le tar 0.12.1 http://downloads.sourceforge.net/mediat … 2.1.tar.gz
3 tar xvf mediatomb-0.12.1.tar.gz
4 recuperer dernier patch http://sourceforge.net/tracker/download … id=3064910
5 patch -p0 < youtube.diff
6 cd mediatomb-0.12.1
7 ./configure          (verifier dependances de libs -- installer ce ui manque)
8 make
9 cp build/mediatomb /usr/bin/mediatomb
10 installer ffmpeg
11 remplacer /etc/mediatomb/config.xml par:

<?xml version="1.0" encoding="UTF-8"?>
<config version="2" xmlns="http://mediatomb.cc/config/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/2 http://mediatomb.cc/config/2.xsd">
  <server>
    <ui enabled="yes" show-tooltips="yes">
      <accounts enabled="no" session-timeout="30">
        <account user="mediatomb" password="mediatomb"/>
      </accounts>
    </ui>
    <name>MediaTomb</name>
    <udn>uuid:51be527a-ec2c-4443-b0c6-0db7d1839b3b</udn>
    <home>/etc/mediatomb</home>
    <webroot>/usr/share/mediatomb/web</webroot>
    <storage caching="no">
      <sqlite3 enabled="yes">
        <database-file>mediatomb.db</database-file>
    <on-error>restore</on-error>
    <backup enabled="no" interval="6000"/>
      </sqlite3>
    </storage>
    <protocolInfo extend="no"/><!-- For PS3 support change to "yes" --><!--
       Uncomment the lines below to get rid of jerky avi playback on the
       DSM320 or to enable subtitles support on the DSM units
    --><!--
    <custom-http-headers>
      <add header="X-User-Agent: redsonic"/>
    </custom-http-headers>

    <manufacturerURL>redsonic.com</manufacturerURL>
    <modelNumber>105</modelNumber>
    --><!-- Uncomment the line below if you have a Telegent TG100 --><!--
       <upnp-string-limit>101</upnp-string-limit>
    -->
    <extended-runtime-options>
      <ffmpegthumbnailer enabled="no"/>
      <thumbnail-size>128</thumbnail-size>
      <mark-played-items enabled="yes" suppress-cds-updates="yes">
        <string mode="prepend">* </string>
        <mark>
          <content>video</content>
        </mark>
      </mark-played-items>
      <seek-percentage>5</seek-percentage>
      <filmstrip-overlay>yes</filmstrip-overlay>
      <workaround-bugs>yes</workaround-bugs>
    </extended-runtime-options>
  </server>
<!--  <filesystem-charset>iso-8859-1</filesystem-charset>-->
  <filesystem-charset>UTF-8</filesystem-charset>
  <metadata-charset>UTF-8</metadata-charset>
  <playlist-charset>UTF-8</playlist-charset>
  <import hidden-files="no">
    <filesystem-charset>iso-8859-1</filesystem-charset>
    <metadata-charset>UTF-8</metadata-charset>
    <playlist-charset>UTF-8</playlist-charset>
    <scripting script-charset="UTF-8">
      <common-script>/usr/share/mediatomb/js/common.js</common-script>
      <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
      <virtual-layout type="builtin">
        <import-script>/usr/share/mediatomb/js/import.js</import-script>
      </virtual-layout>
    </scripting>
    <autoscan use-inotify="auto">
<!--      <directory location="/home/images" mode="inotify" interval="36000"
        level="basic" recursive="yes" hidden-files="no"/>
      <directory location="/home/video" mode="inotify" interval="36000"
        level="basic" recursive="yes" hidden-files="no"/>
      <directory location="/home/music" mode="inotify" interval="36000"
        level="basic" recursive="yes" hidden-files="no"/>
-->    </autoscan>
    <mappings>
      <extension-mimetype ignore-unknown="no">
        <map from="mp3" to="audio/mpsp"/>
        <map from="ogg" to="application/ogg"/>
        <map from="asf" to="video/x-ms-asf"/>
        <map from="asx" to="video/x-ms-asf"/>
        <map from="wma" to="audio/x-ms-wma"/>
        <map from="wax" to="audio/x-ms-wax"/>
        <map from="wmv" to="video/x-ms-wmv"/>
        <map from="wvx" to="video/x-ms-wvx"/>
        <map from="wm" to="video/x-ms-wm"/>
        <map from="wmx" to="video/x-ms-wmx"/>
        <map from="m3u" to="audio/x-mpegurl"/>
        <map from="pls" to="audio/x-scpls"/>
        <map from="flv" to="video/x-flv"/>
        <map from="mkv" to="video/x-matroska"/>
        <map from="mka" to="audio/x-matroska"/>
        <map from="ts" to="video/mp2t"/>
        <map from="m2ts" to="video/mp2t"/>
        <map from="mp2t" to="video/mp2t"/>
        <map from="mts" to="video/avchd"/>
        <map from="flac" to="audio/x-flac"/>
        <map from="mov" to="video/x-quicktime"/>
        <map from="vob" to="video/mpeg"/>
        <map from="mpg" to="video/mpeg"/>
        <map from="mp4" to="video/mp4"/>
        <map from="m4v" to="video/mp4"/>
        <map from="avi" to="video/divx"/>
        <map from="avi" to="video/avi"/>
        <map from="srt" to="video/subtitle"/>
      </extension-mimetype>
      <mimetype-upnpclass>
        <map from="audio/*" to="object.item.audioItem.musicTrack"/>
        <map from="video/*" to="object.item.videoItem"/>
        <map from="image/*" to="object.item.imageItem"/>
      </mimetype-upnpclass>
      <mimetype-contenttype>
        <treat mimetype="audio/mpsp" as="mp3"/>
        <treat mimetype="video/mp2t" as="ts"/>
        <treat mimetype="video/avchd" as="mts"/>
        <treat mimetype="video/mp3" as="mp3"/>
        <treat mimetype="application/ogg" as="ogg"/>
        <treat mimetype="audio/x-flac" as="flac"/>
        <treat mimetype="image/jpeg" as="jpg"/>
        <treat mimetype="audio/x-mpegurl" as="playlist"/>
        <treat mimetype="audio/x-scpls" as="playlist"/>
        <treat mimetype="audio/x-wav" as="pcm"/>
        <treat mimetype="audio/L16" as="pcm"/>
        <treat mimetype="video/x-msvideo" as="avi"/>
        <treat mimetype="video/mp4" as="mp4"/>
        <treat mimetype="audio/mp4" as="mp4"/>
        <treat mimetype="video/quicktime" as="mov"/>
        <treat mimetype="video/x-quicktime" as="mov"/>
      </mimetype-contenttype>
    </mappings>
    <online-content><!-- Make sure to setup a transcoding profile for flv -->
      <YouTube enabled="yes" refresh="28800" update-at-start="yes"
           format="mp4" hd="yes" purge-after="604800" racy-content="exclude">
        <favorites user="bbb"/>
        <subscriptions user="bbb"/>
        <playlists user="bbb"/>
        <uploads user="bbb" start-index="1" amount="all"/>        
        <uploads user="xxx" start-index="1" amount="all"/>
        <standardfeed feed="top_rated" region_id="fr" time-range="today"/>
        <standardfeed feed="top_favorites" region_id="fr" time-range="today"/>
        <standardfeed feed="most_recent" region_id="fr" time-range="today"/>
        <standardfeed feed="most_viewed" region_id="fr" time-range="today"/>
        <standardfeed feed="most_discussed" region_id="fr" time-range="today"/>
        <standardfeed feed="most_linked" region_id="fr" time-range="today"/>
        <standardfeed feed="most_responded" region_id="fr" time-range="today"/>
        <standardfeed feed="recently_featured" region_id="fr" time-range="today"/>
      </YouTube>
    </online-content>
  </import>
  <transcoding enabled="yes">
    <mimetype-profile-mappings>
      <transcode mimetype="audio/mpsp" using="mp3mpeg"/>
      <transcode mimetype="video/x-flv" using="flvmpeg"/>
      <transcode mimetype="video/avchd" using="anympeg"/>
      <transcode mimetype="video/mp4" using="anympeg"/>
      <transcode mimetype="video/quicktime" using="anympeg"/>
      <transcode mimetype="video/x-quicktime" using="anympeg"/>
      <transcode mimetype="video/x-matroska" using="anympeg"/>
      <transcode mimetype="video/bidon" using="vlcmpeg"/>
      <transcode mimetype="application/ogg" using="oggflac2raw"/>
      <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
    </mimetype-profile-mappings>
    <profiles>
      <profile name="mp3mpeg" enabled="yes" type="external">
        <hide-original-resource>yes</hide-original-resource>
        <mimetype>video/mp2t</mimetype>
        <accept-url>yes</accept-url>
        <first-resource>no</first-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <agent command="ffmpeg" arguments="-y -i %in -acodec copy -f mpegts %out"/>
        <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
      </profile>
      <profile name="flvmpeg" enabled="yes" type="external">
        <hide-original-resource>yes</hide-original-resource>
        <mimetype>video/mp2t</mimetype>
        <accept-url>yes</accept-url>
        <first-resource>no</first-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <agent command="ffmpeg" arguments="-y -i %in -sameq -sws_flags lanczos -f mpegts  -acodec ac3 -ar 44100 -ac 2 %out"/>
        <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
      </profile>
      <profile name="anympeg" enabled="yes" type="external">
        <hide-original-resource>yes</hide-original-resource>
        <mimetype>video/mp2t</mimetype>
    <use-chunked-encoding>no</use-chunked-encoding>
        <accept-url>yes</accept-url>
        <first-resource>no</first-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <agent command="ffmpeg" arguments="-y -i %in -sameq -f mpegts -acodec ac3 -ar 44100 -ac 2 %out"/>
        <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
      </profile>
      <profile name="oggflac2raw" enabled="yes" type="external">
        <mimetype>audio/L16</mimetype>
        <accept-url>no</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <agent command="ogg123" arguments="-d raw -f %out %in"/>
        <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
      </profile>
      <profile name="vlcmpeg" enabled="no" type="external">
        <mimetype>video/mpeg</mimetype>
        <accept-url>yes</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>yes</accept-ogg-theora>
        <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
        <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
      </profile>
    </profiles>
  </transcoding>
</config>

(changer les 2-3 parametres specifiques a ma config en debut de fichier.)

Pour youtube et FB V5, le parametre transcodage first-resource a "no" est d'importance essentielle, car la FB prend la derniere ressource, de la reponse, qui se trouve etre un thumbnail jpg si on utilise les exemples ou il est toujours a "yes".

Mes excuses si c'est pas du pur Ubuntu, j'ai fait cela sur une Mandriva, mais pour que cela serve au plus grand nombre et que peu importe la distrib, je poste ici.

Les puristes rectifieront, et eventuellement genereront un vrai package.

Amusez vous bien !

Hors ligne

#2 Le 10/03/2011, à 06:18

starsailorz

Re : Mediatomb config.xml pour freebox v5 : video, youtube, musique, images

Rhôo ça m'a l'air ENORME tout ça ! je me suis juste inscrit pour te remercier même si je ne peux pas encore tester tout ça .... Depuis le temps que je cherche un config.xml pour FBv5 !
MERCI James06 !

Tu as quoi comme NAS ?

Tu pourrais détailler un poil plus les commandes ... Je sais je suis chiant, mais rien que le 11 par exemple,je suis même pas sur d'y arriver ... Faut créer un fichier config1.xml, coller ton code et faire un mv config.xml ?

Merci d'avance !!

Hors ligne

#3 Le 10/03/2011, à 11:21

James06

Re : Mediatomb config.xml pour freebox v5 : video, youtube, musique, images

Salut. pas de pb.

Quelques precisions:

La recompilation de mediatomb  0.12.1 n'est necessaire que si l'on veut un acces a Youtube. sinon, commencer a 10.

j'ai pas trop détaillé, j'ai pas d'ubuntu sous la main, donc je suis pas 100% sur que les fichiers du package mediatomb partent tous aux memes endroits.
mais sur ubuntu, installer xxx, c'est "sudo apt-get xxx"
recuperer le fichier xxx c'est "wget xxx"

Pour les commandes 2 a 8, faire cela dans une directory de travail, ne pas faire de "cd" sauf mention.

sudo apt-get install mediatomb
mkdir compile
cd compile
wget http://downloads.sourceforge.net/mediatomb/mediatomb-0.12.1.tar.gz
tar xvf mediatomb-0.12.1.tar.gz
wget http://sourceforge.net/tracker/download.php?group_id=129766&atid=715780&file_id=401824&aid=3064910
patch -p0 < youtube.diff
cd mediatomb-0.12.1
./configure          (verifier dependances de libs (message a la fin)-- installer ce qui manque, recommencer)
make
./build/mediatomb 
sudo cp /usr/bin/mediatomb /usr/bin/mediatomb.sav
sudo cp build/mediatomb /usr/bin/mediatomb
sudo apt-get install ffmpeg

pour le 11:

sudo cp /etc/mediatomb/config.xml  /etc/mediatomb/config.xml.sav

puis editer  /etc/mediatomb/config.xml, replacer le contenu par un paste du mien remplacer les utilisateurs Youtube "bbb" et "xxx" par ce qui va bien pour vous.

Bon, quelques points:

- Le mp3 se joue en transcodant les fichiers mp3 en video mpegts, donc morceau par morceau, pas de playlist (faut que je verifie sui je peux arriver a faire jouer des playlist, mais il me semble que la freebox v5 ne joue que le dernier morceau video des playlist .m3u)

- Pas de sous-titres. pour les sous titres, il faut implementer le transcodage dans un script, j'ai vu des exemples dans ces forums.
Attention a la vitesse de transcodage en format HD, elle peut etre bloquante, donc commande simple avec un minimum de manipulations video et audio.

- Dans cette config, on peut tranferer les fichiers video enregistres de la FB (les .TS) sur le PC et encore pouvoir les jouer par mediatomb.

Suis pas sur de comprendre la question sur le NAS. Ma FB est configurée en routeur, j'ai donc pas de NAS. le PC qui tourne mediatomb est un quadri athlon 64 a 2300Mhz/core, et je tourne linux en 64 bits natif. Le transcodage ffmpeg ne prend qu'un cpu.

Dernière modification par James06 (Le 10/03/2011, à 11:29)

Hors ligne

#4 Le 03/04/2011, à 09:33

Microphage71

Re : Mediatomb config.xml pour freebox v5 : video, youtube, musique, images

Voila après des heures de galère et un mix de tout ce que j'ai pu trouver sur le net, voici le config.xml MediaTomb qui fonctionne au moins pour moi sur la FBv5 (v6 je ne sais pas). Elle lit desormais, les mp3, flac, divx, matroska et flv!

Ouvrir le fichier de config:

~$ sudo gedit /etc/mediatomb/config.xml

Puis editez le comme suit:

<?xml version="1.0" encoding="UTF-8"?>
<config version="2" xmlns="http://mediatomb.cc/config/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/2 http://mediatomb.cc/config/2.xsd"><!--
     Read /usr/share/doc/mediatomb-common/README.gz section 6 for more
     information on creating and using config.xml configration files.
    -->
  <server>
    <ui enabled="yes" show-tooltips="yes">
      <accounts enabled="no" session-timeout="30">
        <account user="mediatomb" password="mediatomb"/>
      </accounts>
    </ui>
    <name>MediaTomb</name>
    <udn>uuid:b7345196-4269-42d5-a3ec-c99f9c36b242</udn>
    <home>/var/lib/mediatomb</home>
    <webroot>/usr/share/mediatomb/web</webroot>
    <storage caching="yes">
      <sqlite3 enabled="yes">
        <database-file>mediatomb.db</database-file>
      </sqlite3>
      <mysql enabled="no">
        <host>localhost</host>
        <username>mediatomb</username>
        <database>mediatomb</database>
      </mysql>
    </storage>
    <protocolInfo extend="no"/><!-- For PS3 support change to "yes" --><!--
       Uncomment the lines below to get rid of jerky avi playback on the
       DSM320 or to enable subtitles support on the DSM units
    --><!--
    <custom-http-headers>
      <add header="X-User-Agent: redsonic"/>
    </custom-http-headers>

    <manufacturerURL>redsonic.com</manufacturerURL>
    <modelNumber>105</modelNumber>
    --><!-- Uncomment the line below if you have a Telegent TG100 --><!--
       <upnp-string-limit>101</upnp-string-limit>
    -->
    <extended-runtime-options>
      <ffmpegthumbnailer enabled="no">
        <thumbnail-size>128</thumbnail-size>
        <seek-percentage>5</seek-percentage>
        <filmstrip-overlay>yes</filmstrip-overlay>
        <workaround-bugs>no</workaround-bugs>
      </ffmpegthumbnailer>
      <mark-played-items enabled="no" suppress-cds-updates="yes">
        <string mode="prepend">*</string>
      </mark-played-items>
    </extended-runtime-options>
  </server>
  <filesystem-charset>UTF-8</filesystem-charset>
  <metadata-charset>UTF-8</metadata-charset>
  <playlist-charset>UTF-8</playlist-charset>
  <import hidden-files="no">
  <filesystem-charset>UTF-8</filesystem-charset>
<metadata-charset>UTF-8</metadata-charset>
<playlist-charset>UTF-8</playlist-charset>
    <scripting script-charset="UTF-8">
      <common-script>/usr/share/mediatomb/js/common.js</common-script>
      <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
      <virtual-layout type="builtin">
        <import-script>/usr/share/mediatomb/js/import.js</import-script>
        <dvd-script>/usr/share/mediatomb/js/import-dvd.js</dvd-script>
      </virtual-layout>
    </scripting>
    <mappings>
      <extension-mimetype ignore-unknown="no">
        <map from="mp3" to="audio/mpsp"/>
        <map from="ogg" to="application/ogg"/>
        <map from="asf" to="video/x-ms-asf"/>
        <map from="asx" to="video/x-ms-asf"/>
        <map from="wma" to="audio/x-ms-wma"/>
        <map from="wax" to="audio/x-ms-wax"/>
        <map from="wmv" to="video/x-ms-wmv"/>
        <map from="wvx" to="video/x-ms-wvx"/>
        <map from="wm"    to="video/x-ms-wm"/>
        <map from="wmx" to="video/x-ms-wmx"/>
        <map from="m3u" to="audio/x-mpegurl"/>
        <map from="pls" to="audio/x-scpls"/>
        <map from="flv" to="video/x-flv"/>
        <map from="mkv" to="video/x-matroska"/>
        <map from="mka" to="audio/x-matroska"/><!-- Uncomment the line below for PS3 divx support --><!-- <map from="avi" to="video/divx"/> --><!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 --><!-- <map from="avi" to="video/avi"/> -->
        <map from="mkv"    to="video/x-matroska"/>
    <map from="ts"    to="video/mp2t"/>
    <map from="avi" to="video/divx"/>
        <map from="avi" to="video/avi"/>
    <map from="avi"    to="video/x-msvideo"/>
    <map from="m2ts" to="video/mp2t"/>
        <map from="mp2t" to="video/mp2t"/>
        <map from="mts" to="video/avchd"/>
        <map from="flac" to="audio/x-flac"/>
        <map from="mov" to="video/x-quicktime"/>
        <map from="vob" to="video/mpeg"/>
        <map from="mpg" to="video/mpeg"/>
        <map from="mp4" to="video/mp4"/>
        <map from="m4v" to="video/mp4"/>
    <map from="srt" to="video/subtitle"/>
      </extension-mimetype>
      <mimetype-upnpclass>
        <map from="audio/*" to="object.item.audioItem.musicTrack"/>
        <map from="video/*" to="object.item.videoItem"/>
        <map from="image/*" to="object.item.imageItem"/>
        <map from="application/ogg" to="object.item.audioItem.musicTrack"/>
      </mimetype-upnpclass>
      <mimetype-contenttype>
          <treat mimetype="audio/mpsp" as="mp3"/>
        <treat mimetype="video/mp2t" as="ts"/>
        <treat mimetype="video/avchd" as="mts"/>
        <treat mimetype="video/mp3" as="mp3"/>
        <treat mimetype="application/ogg" as="ogg"/>
        <treat mimetype="audio/x-flac" as="flac"/>
        <treat mimetype="image/jpeg" as="jpg"/>
        <treat mimetype="audio/x-mpegurl" as="playlist"/>
        <treat mimetype="audio/x-scpls" as="playlist"/>
        <treat mimetype="audio/x-wav" as="pcm"/>
        <treat mimetype="audio/L16" as="pcm"/>
        <treat mimetype="video/x-msvideo" as="avi"/>
        <treat mimetype="video/mp4" as="mp4"/>
        <treat mimetype="audio/mp4" as="mp4"/>
        <treat mimetype="application/x-iso9660" as="dvd"/>
        <treat mimetype="application/x-iso9660-image" as="dvd"/>
        <treat mimetype="video/x-matroska" as="mkv"/>
        <treat mimetype="audio/x-matroska" as="mka"/>
        <treat mimetype="video/quicktime" as="mov"/>
        <treat mimetype="video/x-quicktime" as="mov"/>
      </mimetype-contenttype>
    </mappings>
    <online-content><!-- Make sure to setup a transcoding profile for flv -->
      <YouTube enabled="no" refresh="28800" update-at-start="no" purge-after="604800" racy-content="exclude" format="flv" hd="no">
        <favorites user="mediatomb"/>
        <standardfeed feed="most_viewed" time-range="today"/>
        <playlists user="mediatomb"/>
        <uploads user="mediatomb"/>
        <standardfeed feed="recently_featured" time-range="today"/>
      </YouTube>
      <Weborama enabled="no" refresh="28800" update-at-start="no">
        <playlist name="Active" type="playlist" mood="active"/>
        <playlist name="Metal" type="playlist">
          <filter>
            <genres>metal</genres>
          </filter>
        </playlist>
      </Weborama>
      <AppleTrailers enabled="no" refresh="43200" update-at-start="no" resolution="640"/>
    </online-content>
  </import>
  <transcoding enabled="yes">
    <mimetype-profile-mappings>
          <transcode mimetype="video/x-flv" using="freebox-ts"/>
          <transcode mimetype="video/mp3" using="mp3mpeg"/>
          <transcode mimetype="audio/mpsp" using="mp3mpeg"/>
        <transcode mimetype="application/ogg" using="vlcmpeg"/>
        <transcode mimetype="application/ogg" using="oggflac2raw"/>
        <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
    </mimetype-profile-mappings>
    <profiles>
        <profile name="oggflac2raw" enabled="no" type="external">
            <mimetype>audio/L16</mimetype>
            <accept-url>no</accept-url>
               <first-resource>yes</first-resource>
            <accept-ogg-theora>no</accept-ogg-theora>
            <agent command="ogg123" arguments="-d raw -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
        </profile>
        <profile name="vlcmpeg" enabled="no" type="external">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
               <accept-ogg-theora>yes</accept-ogg-theora>
            <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
        </profile>
    <profile name="mp3mpeg" enabled="yes" type="external">
        <hide-original-resource>yes</hide-original-resource>
        <mimetype>video/mp2t</mimetype>
        <accept-url>no</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <agent command="ffmpeg" arguments="-y -i %in -acodec copy -f mpegts %out"/>
        <buffer size="1048576" chunk-size="131072" fill-size="4096"/>
    </profile>
        <profile name="freebox-ts" enabled="yes" type="external">
         <mimetype>video/mp2t</mimetype>
        <accept-url>yes</accept-url>
         <first-resource>no</first-resource>                            
        <hide-original-resource>yes</hide-original-resource>        
        <agent command="/usr/bin/mediatomb.transcode.bash" arguments="%in %out"/>
        <buffer size="1000000" chunk-size="10000" fill-size="200000"/>
        </profile>
    </profiles>
  </transcoding>
</config>

Les prérequis:

installer ogg123, ffmpeg et vlc.

~$ sudo apt-get install vorbis-tools
~$ sudo apt-get install ffmpeg
~$ sudo apt-get install vlc

Ensuite ouvrez un nouveau fichier:

~$ sudo gedit /usr/bin/mediatomb.transcode.bash

et copiez le contenu ci-dessous:

#!/bin/bash
 
INPUT="$1"
MEDIATOMB_FIFO="$2"
TS_TRANSCODED_FILE="dummy.ts"
 
function transcode_video_ffmpeg_mpeg2_ac3_ts
{
    # Create the ts buffer file
    # Note : Emptying the ts buffer file maybe make unuseful the use of the ffmpeg -y option.
    rm    -f "${TS_TRANSCODED_FILE}"
    touch    "${TS_TRANSCODED_FILE}"
 
    # Start to stream the ts buffer file to the mediatomb fifo pipe in background
    tail     -q -c 1024 -f "${TS_TRANSCODED_FILE}" > "${MEDIATOMB_FIFO}" &
 
    # Start to transcode, ouputing to the ts buffer file
    # Note : I know I can replace this bash process by the ffmpeg process using 'exec ffmpeg -y ...'
    ffmpeg -y -i "${INPUT}" -vcodec mpeg2video -sameq -r 25 -s ega -acodec ac3 -ar 44100 -ac 2 "${TS_TRANSCODED_FILE}"
}
 
transcode_video_ffmpeg_mpeg2_ac3_ts

enregistrez le, puis:

~$ sudo chmod 0777 /usr/bin/mediatomb.transcode.bash
~$ sudo chmod +x /usr/bin/mediatomb.transcode.bash
~$ sudo /etc/init.d/mediatomb restart

pour finir, supprimez tous les dossiers que vous avez ajoutez avant dans l'interface MediaTomb puis réajoutez les!

Pour moi tout est nickel, après à voir suivant configs et versions.

Hors ligne

#5 Le 08/04/2011, à 17:54

bdelepine

Re : Mediatomb config.xml pour freebox v5 : video, youtube, musique, images

Bonjour,

Merci pour le config.xml, très complet.

J'utilise mediatomb (sur debian stable) avec une freebox v5 depuis 2 ans, et depuis 3 mois, les nouveaux contenus n'étaient pas vu par la freebox.
Je stocke les données de mediatomb dans une base mysql, j'ai vérifié de ce côté, tout va bien.
J'ai également vérifié avec un autre périphérique upnp (téléphone ou pc), les nouveaux contenus sont bien vus.

Le week-end dernier, j'ai upgradé ma debian stable en 6.0.1, et j'ai remarqué que mediatomb s'est mis à jour.
Après le redémarrage, la freebox voit bien les nouveaux contenus (houra), mais lance une espèce de mode diaporama, qui demande à mediatomb de générer des miniatures (thumbnails).
Or, mon mediatomb, pour je ne sais pas quelle raison, ne génère pas (j'ai un ERROR dans mediatomb.log à chaque demande de la freebox).

Le pb, c'est que dès que je désactive le thumbnails dans mon config.xml, la freebox ne voit plus le fameux nouveau contenu.
A n'y rien comprendre !

Quelqu'un a-t-il réussi à faire fonctionner les thumbnails avec un coupmle mediatomb/freebox ?

Autre chose, j'utilise le paquet debian de mediatomb, version 0.12.0, mais je peux éventuellement le compiler avec la 0.12.1, est-ce que ça vaut le coup ?

mon config.xml : http://paste.geeknode.org/f1bc8e46

Merci

Hors ligne

#6 Le 01/05/2011, à 20:31

bdelepine

Re : Mediatomb config.xml pour freebox v5 : video, youtube, musique, images

Bonjour,

J'ai finalement trouvé le problème. Ca venait tout simplement d'une erreur dans la base de donnée mysql. J'ai supprimé les tables, ré importé les medias et c'est reparti.
(Entre temps, j'ai tout de même supprimé le paquet debian, compilé mediatomb, et pommé mon super import.js sad )

Hors ligne

#7 Le 19/06/2011, à 20:50

versatis

Re : Mediatomb config.xml pour freebox v5 : video, youtube, musique, images

bonsoir je me présente je m appelle versatis jai une freebox v5 freebox hd  et un nas dns 323 jai installer mediaplond j arrive a lire les videau par contre j arrive pas a lire des fichier audiau que sa soit mp3 ect

Je vous donne ma config config.xxlm


<?xml version="1.0" encoding="UTF-8"?>
<config version="1" xmlns="http://mediatomb.cc/config/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/1 http://mediatomb.cc/config/1.xsd">
  <server>
    <ui enabled="yes">
      <accounts enabled="no" session-timeout="30">
        <account user="mediatomb" password="mediatomb"/>
      </accounts>
    </ui>
    <name>NAS</name>
    <udn>uuid:f3bbf993-7302-47a4-9940-81d7bc902956</udn>
    <home>/ffp/var/mediatomb</home>
    <webroot>/ffp/share/mediatomb/web</webroot>
    <storage>
      <sqlite3 enabled="yes">
        <database-file>mediatomb.db</database-file>
      </sqlite3>
    </storage>
    <protocolInfo extend="no"/><!-- For PS3 support change to "yes" -->
    <!--
       Uncomment the lines below to get rid of jerky avi playback on the
       DSM320 or to enable subtitles support on the DSM units
    -->
    <!--
    <custom-http-headers>
      <add header="X-User-Agent: redsonic"/>
    </custom-http-headers>

    <manufacturerURL>redsonic.com</manufacturerURL>
    <modelNumber>105</modelNumber>
    -->
    <!-- Uncomment the line below if you have a Telegent TG100 -->
    <!--
       <upnp-string-limit>101</upnp-string-limit>
    -->
<extended-runtime-options>
      <ffmpegthumbnailer enabled="yes"/>
      <thumbnail-size>128</thumbnail-size>
      <mark-played-items enabled="yes" suppress-cds-updates="yes">
        <string mode="prepend">* </string>
        <mark>
          <content>video</content>
        </mark>
      </mark-played-items>
      <seek-percentage>5</seek-percentage>
      <filmstrip-overlay>yes</filmstrip-overlay>
      <workaround-bugs>yes</workaround-bugs>
    </extended-runtime-options>

  </server>
  <import hidden-files="no">
  <filesystem-charset>UTF-8</filesystem-charset>
    <metadata-charset>UTF-8</metadata-charset>
    <playlist-charset>UTF-8</playlist-charset>
    <scripting script-charset="UTF-8">
      <!--<virtual-layout type="builtin"/> -->
    </scripting>
    <mappings>
      <extension-mimetype ignore-unknown="no">
        <map from="mp3" to="audio/mpeg"/>
        <map from="ogg" to="application/ogg"/>
        <map from="asf" to="video/x-ms-asf"/>
        <map from="asx" to="video/x-ms-asf"/>
        <map from="wma" to="audio/x-ms-wma"/>
        <map from="wax" to="audio/x-ms-wax"/>
        <map from="wmv" to="video/x-ms-wmv"/>
        <map from="wvx" to="video/x-ms-wvx"/>
        <map from="wm" to="video/x-ms-wm"/>
        <map from="wmx" to="video/x-ms-wmx"/>
        <map from="m3u" to="audio/x-mpegurl"/>
        <map from="pls" to="audio/x-scpls"/>
        <map from="flv" to="video/x-flv"/>
        <map from="mkv" to="video/x-matroska"/>
        <map from="ts" to="video/mp2t"/> 
        <!-- Uncomment the line below for PS3 divx support -->
        <!-- <map from="avi" to="video/divx"/> -->
        <!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
        <!-- <map from="avi" to="video/avi"/> -->
      </extension-mimetype>
      <mimetype-upnpclass>
        <map from="audio/*" to="object.item.audioItem.musicTrack"/>
        <map from="video/*" to="object.item.videoItem"/>
        <map from="image/*" to="object.item.imageItem"/>
      </mimetype-upnpclass>
      <mimetype-contenttype>
        <treat mimetype="audio/mpeg" as="mp3"/>
        <treat mimetype="application/ogg" as="ogg"/>
        <treat mimetype="audio/x-flac" as="flac"/>
        <treat mimetype="image/jpeg" as="jpg"/>
        <treat mimetype="audio/x-mpegurl" as="playlist"/>
        <treat mimetype="audio/x-scpls" as="playlist"/>
        <treat mimetype="audio/x-wav" as="pcm"/>
        <treat mimetype="audio/L16" as="pcm"/>
        <treat mimetype="video/x-msvideo" as="avi"/>
      </mimetype-contenttype>
    </mappings>
  </import>
</config>


Voila ma config

Je recherche un fichier de config pour pouvoir lire les mp3 ect ect et aussi d autre format de videau que j arrive pas a lire

mercis a bientôt.

Hors ligne

#8 Le 11/04/2012, à 00:42

dadour13

Re : Mediatomb config.xml pour freebox v5 : video, youtube, musique, images

voici un autre exemple
je vous propose ma config utiliser XML COPY EDITOR.
si vous avez des remarques faite moi les savoir.

<?xml version="1.0" encoding="UTF-8"?>
<config version="2" xmlns="http://mediatomb.cc/config/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/2 [url=http://mediatomb.cc/config/2.xsd\><]http://mediatomb.cc/config/2.xsd\"><[/url]!--
     Read /usr/share/doc/mediatomb-common/README.gz section 6 for more
     information on creating and using config.xml configration files.
    -->
  <server>
    <ui enabled="yes" show-tooltips="yes">
      <accounts enabled="yes" session-timeout="30">
        <account user="mediatomb" password="mediatomb"/>
      </accounts>
    </ui>
    <name>MediaTomb</name>
    <udn>uuid:3c57b468-cf5a-4f42-995d-e3c2ae53b205</udn>
    <home>/var/lib/mediatomb</home>
    <webroot>/usr/share/mediatomb/web</webroot>
    <storage caching="yes">
      <sqlite3 enabled="yes">
        <database-file>mediatomb.db</database-file>
      </sqlite3>
      <mysql enabled="no">
        <host>localhost</host>
        <username>mediatomb</username>
        <database>mediatomb</database>
      </mysql>
    </storage>
    <protocolInfo extend="yes"/><!-- For PS3 support change to "yes" --><!--
       Uncomment the lines below to get rid of jerky avi playback on the
       DSM320 or to enable subtitles support on the DSM units
    --><!--
    <custom-http-headers>
      <add header="X-User-Agent: redsonic"/>
    </custom-http-headers>

    <manufacturerURL>redsonic.com</manufacturerURL>
    <modelNumber>105</modelNumber>
    --><!-- Uncomment the line below if you have a Telegent TG100 --><!--
       <upnp-string-limit>101</upnp-string-limit>
    -->
    <extended-runtime-options>
      <ffmpegthumbnailer enabled="yes">
        <thumbnail-size>128</thumbnail-size>
        <seek-percentage>5</seek-percentage>
        <filmstrip-overlay>yes</filmstrip-overlay>
        <workaround-bugs>no</workaround-bugs>
      </ffmpegthumbnailer>
      <mark-played-items enabled="no" suppress-cds-updates="yes">
        <string mode="prepend">*</string>
      </mark-played-items>
    </extended-runtime-options>
  </server>
  <import hidden-files="yes">
    <scripting script-charset="UTF-8">
    <metadata-charset>ISO-8859-15</metadata-charset> 
    <scripting script-charset="UTF-8">
      <common-script>/usr/share/mediatomb/js/common.js</common-script>
      <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
      <virtual-layout type="builtin">
        <import-script>/usr/share/mediatomb/js/import.js</import-script>
        <dvd-script>/usr/share/mediatomb/js/import-dvd.js</dvd-script>
      </virtual-layout>
    </scripting>
    <mappings>
      <extension-mimetype ignore-unknown="no">
        <map from="mp3" to="audio/mpeg"/>
        <map from="ogg" to="application/ogg"/>
        <map from="ogx" to="application/ogg"/>
        <map from="ogv" to="video/ogg"/>
        <map from="oga" to="audio/ogg"/>
        <map from="ogg" to="audio/ogg"/>
        <map from="ogm" to="video/ogg"/>
        <map from="asf" to="video/x-ms-asf"/>
        <map from="asx" to="video/x-ms-asf"/>
        <map from="wma" to="audio/x-ms-wma"/>
        <map from="wax" to="audio/x-ms-wax"/>
        <map from="wmv" to="video/x-ms-wmv"/>
        <map from="wvx" to="video/x-ms-wvx"/>
        <map from="wm" to="video/x-ms-wm"/>
        <map from="wmx" to="video/x-ms-wmx"/>
        <map from="m3u" to="audio/x-mpegurl"/>
        <map from="pls" to="audio/x-scpls"/>
        <map from="avi" to="video/avi"/> 
        <map from="rm" to="video/realmedia"/> 
        <map from="srt" to="video/subtitle"/> 
        <map from="sub" to="video/subtitle"/> 
        <map from="mpg" to="video/mpeg"/>
        <map from="flv" to="video/x-flv"/>
        <map from="iso" to="video/dvdiso"/>
        <map from="mkv" to="video/x-matroska"/>
        <map from="mka" to="audio/x-matroska"/>
        <map from="mp4" to="video/mp4"/>
        <!-- Uncomment the line below for PS3 divx support --> 
          <map from="avi" to="video/divx"/> 
        <!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 --><!-- <map from="avi" to="video/avi"/> -->
      </extension-mimetype>
      <mimetype-upnpclass>
        <map from="audio/*" to="object.item.audioItem.musicTrack"/>
        <map from="video/*" to="object.item.videoItem"/>
        <map from="image/*" to="object.item.imageItem"/>
        <map from="application/ogg" to="object.item.audioItem.musicTrack"/>
      </mimetype-upnpclass>
      <mimetype-contenttype>
        <treat mimetype="audio/mpeg" as="mp3"/>
        <treat mimetype="application/ogg" as="ogg"/>
        <treat mimetype="audio/ogg" as="ogg"/>
        <treat mimetype="audio/x-flac" as="flac"/>
        <treat mimetype="image/jpeg" as="jpg"/>
        <treat mimetype="audio/x-mpegurl" as="playlist"/>
        <treat mimetype="audio/x-scpls" as="playlist"/>
        <treat mimetype="audio/x-wav" as="pcm"/>
        <treat mimetype="audio/L16" as="pcm"/>
        <treat mimetype="video/x-msvideo" as="mkv"/>
        <treat mimetype="video/mp4" as="mp4"/>
        <treat mimetype="audio/mp4" as="mp4"/>
        <treat mimetype="video/divx" as="avi"/>
        <treat mimetype="application/x-iso9660" as="dvd"/>
        <treat mimetype="application/x-iso9660-image" as="dvd"/>
        <treat mimetype="video/x-matroska" as="mkv"/>
        <treat mimetype="audio/x-matroska" as="mka"/>
        <treat mimetype="video/avi" as="avi"/>
        <treat mimetype="video/mp2t" as="ts"/>
      </mimetype-contenttype>
    </mappings>
    <online-content><!-- Make sure to setup a transcoding profile for flv -->
      <YouTube enabled="yes" refresh="28800" update-at-start="yes" purge-after="604800" racy-content="exclude" format="flv" hd="yes">
        <favorites user="mediatomb"/>
        <standardfeed feed="most_viewed" time-range="today"/>
        <playlists user="mediatomb"/>
        <uploads user="mediatomb"/>
         <standardfeed feed="most_viewed" time-range="today"/>       
         <standardfeed feed="recently_featured" time-range="today"/>
      </YouTube>
      <Weborama enabled="yes" refresh="28800" update-at-start="no">
        <playlist name="Active" type="playlist" mood="active"/>
        <playlist name="Metal" type="playlist">
          <filter>
            <genres>metal</genres>
          </filter>
        </playlist>
      </Weborama>
      <AppleTrailers enabled="no" refresh="43200" update-at-start="no" resolution="640"/>
    </online-content>
  </import>
  <transcoding enabled="yes">
    <mimetype-profile-mappings>
      <transcode mimetype="video/x-flv"      using="vlcmpeg"/>
      <transcode mimetype="application/ogg"  using="vlcmpeg"/>
      <transcode mimetype="application/ogg"  using="oggflac2raw"/>
      <transcode mimetype="audio/x-flac"     using="oggflac2raw"/>
      <transcode mimetype="audio/ogg"        using="audio2pcm"/>
      <transcode mimetype="video/ogg"        using="video2mpeg"/>
      <transcode mimetype="vi"               using="video2mpeg"/>
      <!--<transcode mimetype="audio/x-flac" using="flac2pcm"/>-->
      <transcode mimetype="video/quicktime" using="video2mpeg"/>
      <transcode mimetype="audio/mpeg"       using="mpeg2pcm"/> 
      <transcode mimetype="video/avi"        using="video2mpeg"/> 
      <transcode mimetype="video/x-msvideo"  using="video2mpeg"/> 
      <transcode mimetype="video/mp4"        using="anympeg"/> 
      <!--<transcode mimetype="video/x-matroska" using="video2mpeg"/>-->
      <transcode mimetype="video/x-msvideo"  using="video2mpeg"/>
      <transcode mimetype="image/jpeg"       using="resizejpeg"/>
      <transcode mimetype="image/raw"        using="raw2jpeg"/>
      <transcode mimetype="video/transcode" using="mencoder-int"/> 
      <transcode mimetype="video/realmedia" using="mencoder-int"/> 
      <transcode mimetype="video/oggmedia" using="mencoder-720"/> 
      <transcode mimetype="video/matroska" using="mencoder-720"/> 
      <transcode mimetype="video/dvdiso" using="mencoder-iso"/> 
      <transcode mimetype="video/subtitle" using="mencoder-sub"/>
    </mimetype-profile-mappings><!--ru-->
    <profiles>
      <profile name="mencoder-sub" enabled="yes" type="external">
        <mimetype>video/mpeg</mimetype> 
        <accept-url>yes</accept-url> 
        <first-resource>yes</first-resource> 
        <accept-ogg-theora>yes</accept-ogg-theora> 
        <agent command="/usr/bin/mediatomb-mencoder-sub" arguments="%in %out"/> 
        <buffer size="1000000" chunk-size="512000" fill-size="20480"/> 
      </profile> 
      <profile name="mencoder-int" enabled="yes" type="external"> 
      <mimetype>video/mpeg</mimetype> 
      <accept-url>yes</accept-url> <first-resource>yes</first-resource> 
      <accept-ogg-theora>yes</accept-ogg-theora> 
       <agent command="mencoder" arguments="%in -oac lavc -ovc lavc -of mpeg -lavcopts vcodec=mpeg2video:keyint=1:vbitrate=200000:vrc_maxrate=9000:vrc_buf_size=1835 -ofps 25 -mpegopts muxrate=12000 -af lavcresample=44100 -vf harddup -o %out"/> <buffer size="1000000" chunk-size="512000" fill-size="20480"/> 
      </profile> 
      <profile name="mencoder-720" enabled="yes" type="external"> 
        <mimetype>video/mpeg</mimetype> 
        <accept-url>yes</accept-url> 
        <first-resource>yes</first-resource> 
        <accept-ogg-theora>yes</accept-ogg-theora> 
        <agent command="mencoder" arguments="%in -aid 0 -sid 0 -oac lavc -ovc lavc -of mpeg -lavcopts
vcodec=mpeg2video:keyint=1:vbitrate=200000:vrc_maxrate=12000:vrc_buf_size=1835 -mpegopts muxrate=12000 -vf harddup,scale -zoom -xy 720 -font /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf -subfont-autoscale 0 -subfont-text-scale 20 -slang nl,en -noautosub -ofps 24000/1001 -o %out"/> 
      <buffer size="1000000" chunk-size="512000" fill-size="20480"/> 
      </profile>
      <profile name="anympeg" enabled="yes" type="external">
        <hide-original-resource>yes</hide-original-resource>
        <mimetype>video/mp2t</mimetype>
        <use-chunked-encoding>no</use-chunked-encoding>
        <accept-url>yes</accept-url>
        <first-resource>no</first-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <agent command="ffmpeg" arguments="-y -i %in -sameq -f mpegts -acodec ac3 -ar 44100 -ac 2 %out"/>
        <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
      </profile> 
      <profile name="mencoder-iso" enabled="yes" type="external"> 
       <mimetype>video/mpeg</mimetype> 
       <accept-url>yes</accept-url> 
       <first-resource>yes</first-resource> 
       <accept-ogg-theora>yes</accept-ogg-theora> 
       <agent command="/usr/bin/mediatomb-mencoder-iso" arguments="%in %out"/> 
       <buffer size="1000000" chunk-size="512000" fill-size="20480"/> 
      </profile>
      <profile name="oggflac2raw" enabled="yes" type="external">
        <mimetype>audio/L16</mimetype>
        <accept-url>no</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
        <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
      </profile>
      <profile name="vlcmpeg" enabled="yes" type="external">
        <mimetype>video/mpeg</mimetype>
        <accept-url>yes</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>yes</accept-ogg-theora>
        <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
        <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
      </profile> 
      <profile name="audio2pcm" enabled="yes" type="external">
        <mimetype>audio/L16</mimetype>
        <accept-url>yes</accept-url>
        <first-resource>yes</first-resource>
        <hide-original-resource>yes</hide-original-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <sample-frequency>44100</sample-frequency>
        <audio-channels>2</audio-channels>
        <agent command="vlc" arguments="%in -I dummy --sout=#transcode{acodec=s16b,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=raw,dst=%out} vlc://quit"/>
        <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
      </profile>
      <profile name="video2mpeg" enabled="yes" type="external">
        <mimetype>video/mpeg</mimetype>
        <accept-url>yes</accept-url>
        <first-resource>yes</first-resource>
        <hide-original-resource>yes</hide-original-resource>
        <accept-ogg-theora>yes</accept-ogg-theora>
        <sample-frequency>48000</sample-frequency>
        <audio-channels>2</audio-channels>
        <agent command="vlc" arguments="%in -I dummy --sout=#transcode{vcodec=mp2v,vb=4096,fps=25,acodec=mpga,ab=192,samplerate=48000,channels=2,audio-sync}:standard{access=file,mux=ps,dst=%out} vlc://quit"/>
        <buffer size="10485760" chunk-size="262144" fill-size="524288"/>
        </profile>
      <profile name="video2mpeg" enabled="yes" type="external">
        <mimetype>video/mp4</mimetype>
        <accept-url>no</accept-url>
        <first-resource>yes</first-resource>
        <hide-original-resource>yes</hide-original-resource>
        <accept-ogg-theora>yes</accept-ogg-theora>
        <sample-frequency>48000</sample-frequency>
        <audio-channels>2</audio-channels>
        <agent command="vlc" arguments="%in -I dummy --sout=#transcode{vcodec=mp2v,vb=4096,fps=25,acodec=mpga,ab=192,samplerate=48000,channels=2,audio-sync}:standard{access=file,mux=ps,dst=%out} vlc://quit"/>
        <buffer size="10485760" chunk-size="262144" fill-size="524288"/>
      </profile>
      <profile name="raw2jpeg" enabled="yes" type="external">
        <mimetype>image/jpeg</mimetype>
        <accept-url>no</accept-url>
        <first-resource>yes</first-resource>
        <hide-original-resource>yes</hide-original-resource>
        <use-chunked-encoding>no</use-chunked-encoding>
        <agent command="/usr/local/bin/mediatomb-raw2jpeg" arguments="%in %out"/>
        <buffer size="524288" chunk-size="512" fill-size="1024"/>
      </profile>
    </profiles>
  </transcoding>
</config>

Dernière modification par dadour13 (Le 11/04/2012, à 00:45)

Hors ligne

#9 Le 19/06/2012, à 20:29

m@rco123

Re : Mediatomb config.xml pour freebox v5 : video, youtube, musique, images

Salut,
Je reviens sur ce sujet ...
J'ai 1 video flv qui ne passe pas ! le son ok mais la video nok !
Bon, le codec est vp6.2 on2s ....
Donc, ca me semble normal !
Une fois transformer avec ffmpeg ou mencoder ca roule mais la qualité est pas au rendez-vous !

voici les données exact :
codec video :
on2s vp6.2 video flash vp6f

codec son :
mpeg 1/2/3 mpga
stereo / 44100

Donc, le son ok video nok
avec mediatomb sur mon galaxy ace avec Upnplayer et vplayer ok
avec mediatomb sur fb v6 son ok pas de video !

Vlc 1.1.11 ...

Dernière modification par m@rco123 (Le 19/06/2012, à 20:33)

Hors ligne

#10 Le 18/10/2014, à 20:36

speedsterharry

Re : Mediatomb config.xml pour freebox v5 : video, youtube, musique, images

Bonjour,

J'essaie d'installer Mediatomb pour utiliser la freebox en mediacenter, et les fichiers de config fournis précédemment ne fonctionnent plus, notamment leconfig.xml (j'ai fait un copier-coller de celui de microphage71, mediatomb n'est plus vu par la freebox, alors qu'avec l'install par défaut, la freebox détectait mediatomb). De meme, le transcodage se fait avec ffmpeg alors que dans ubuntu 14.04, ffmpeg n'est plus installable (remplacé par avcodec). Qqun aurait-il une config actualisée de Mediatomb pour transcoder les MP3 sur ma freebox ? Merci bien !

EDIT: J'ai laissé tomber Mediatomb, n'ayant pas réussi à ajouter la config de transcodage des MP3, je passe par FreeMi, ca passe tout seul !

Dernière modification par speedsterharry (Le 19/10/2014, à 08:35)

Hors ligne

#11 Le 27/12/2014, à 14:31

Opiwa

Re : Mediatomb config.xml pour freebox v5 : video, youtube, musique, images

J'ai aussi installé FreeMi, faute de pouvoir lire les MP3 sur la freebox.
Tout comme speedsterharry, ce n'est pas faute d'avoir cherché et essayé nombres de réglages, conversion à la volée, ...

Dommage.

Hors ligne