Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 10/05/2005, à 19:12

gilles27

[résolu(contourné)]installation wesnoth.deb ?

Bonjour à tous,

J'ai trouvé des paquets debian pour wesnoth0.9.1 dans unstable, mais je suis un débutant total avec apt , dpkg etc...
Naïvement j'ai essayé cette commande :

sudo dpkg -i wesnoth_0.9.1-1_i386.deb wesnoth-data_0.9.1-1_all.deb wesnoth-httt_0.9.1-1_all.deb

Mais cela ne marche pas vraiment hmm

Sélection du paquet wesnoth précédemment désélectionné.
(Lecture de la base de données... 67174 fichiers et répertoires déjà installés.)
Dépaquetage de wesnoth (à partir de wesnoth_0.9.1-1_i386.deb) ...
Sélection du paquet wesnoth-data précédemment désélectionné.
Dépaquetage de wesnoth-data (à partir de wesnoth-data_0.9.1-1_all.deb) ...
Sélection du paquet wesnoth-httt précédemment désélectionné.
Dépaquetage de wesnoth-httt (à partir de wesnoth-httt_0.9.1-1_all.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de wesnoth :
wesnoth dépend de libc6 (>= 2.3.2.ds1-21) ; cependant :
  La version de libc6 sur le système est 2.3.2.ds1-20ubuntu13.
wesnoth dépend de libsdl-mixer1.2 (>= 1.2.6) ; cependant :
  La version de libsdl-mixer1.2 sur le système est 1.2.5-9.
dpkg : erreur de traitement de wesnoth (--install) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de wesnoth-httt :
wesnoth-httt dépend de wesnoth ; cependant :
  Paquet wesnoth n'est pas encore configuré.
dpkg : erreur de traitement de wesnoth-httt (--install) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de wesnoth-data :
wesnoth-data dépend de wesnoth-campaign-0.9.1 ; cependant :
  Paquet wesnoth-campaign-0.9.1 n'est pas installé.
  Paquet wesnoth-httt qui fournit wesnoth-campaign-0.9.1 n'est pas encore config uré.
dpkg : erreur de traitement de wesnoth-data (--install) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
wesnoth
wesnoth-httt
wesnoth-data

Je précise que wesnoth-campain-0.9.1 est un paquet virtuel ( sic !) qui "contient" (?) wesnoth-httt (entres autres)

Bref, j'aimerais un peu d'aide pour m'expliquer comment installer plusieurs paquets simultanément, cela doit être la solution (n'est-ce pas ?)

Merci.
Je précise que je n'est pas rajouté instable dans les sources et que je ne compte pas le faire (ce qui devrait être une très mauvaise idée d'après ce que j'ai glané sur le net)

Dernière modification par gilles27 (Le 10/05/2005, à 23:07)

Hors ligne

#2 Le 10/05/2005, à 19:29

laurent

Re : [résolu(contourné)]installation wesnoth.deb ?

Salut,

le plus simple pour toi serait d'utiliser les dépots backports pour hoary. Wesnoth .09.1 est dedans. Je te conseille donc une petite recherche avec "backports" pour en apprendre plus wink


Laurent, petit belge explorant la banquise

Hors ligne

#3 Le 10/05/2005, à 20:18

sbrunner

Re : [résolu(contourné)]installation wesnoth.deb ?

+1

Au passage ta commande pour installer plusieurs paquets simultanément étais correcte, mais il manquai les paquets dépendants...

CU
Stéph

Hors ligne

#4 Le 10/05/2005, à 23:05

gilles27

Re : [résolu(contourné)]installation wesnoth.deb ?

Merci laurent,

Sympas le système des backports repompé de debian, voici ce que j'ai glané :

C'est quoi des backports en quelques mots : Ce sont des paquets d'applications de la branche de développement qui sont packagés pour fonctionner sur la branche stable. Ca sert principalement à bénéficier de logiciels récents sans passer toute sa distribution dans une version "testing" .

Ca reste bien entendu à vos risques et périls puisque la compatibilté avec les versions "officielles" n'est pas garantie. Enfin c'est quand même bien pratique pour installer des logiciels récents sans attendre la prochaine version stable de Ubuntu

Tous les détails sur http://backports.ubuntuforums.org/

J'ai donc rajouté ceci à mes dépots :
deb http://backports.ubuntuforums.org/backports hoary-backports main universe multiverse restricted

Et .... MIRACLE ! wesnoth 9.1 est là cool
Mais par contre le téléchargement est long hmm  (victime de son succès ?)

Encore merci smile

Par contre, je suis un peu déçu, cela veut dire que l'ubuntu n'est pas compatible avec débian ?
Les gars de canonical se tapent donc tout le boulot de "clonage" de débian ? Ils sont courageux smile

Hors ligne

#5 Le 10/05/2005, à 23:22

laurent

Re : [résolu(contourné)]installation wesnoth.deb ?

si, au départ ubuntu est compatible debian unstable

mais bon, au fur et à mesure, les 2 distib vont s'éloigner, c'est clair... Et de toutes façons, oui, tous les paquets de base sont retravaillé spécifiquement.

Maintenant pour t'expliquer ton prob, tu aurais du t'amuser à télécharger tous les paquets demandés dans le messages d'erreur et les installer un à un (ou les installer par synaptic), et après tu aurais pu installer wesnoth. C'est le principe des dépendances (bien que ton prob aie l'air un chouia plus complexe, je pense que ça doit être par là qu'il fallait chercher la soluce)

L'avantage d'apt dans l'affaire est qu'il gère les dépendances tout seul et installes ces paquets là pour toi, avant d'installer wesnoth. cool, non? cool


Laurent, petit belge explorant la banquise

Hors ligne

  • Accueil
  • » Forum
  • » Jeux
  • » [résolu(contourné)]installation wesnoth.deb ?

Haut de page ↑