Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 06/05/2011, à 12:20

dexlo5791

Wifi désactivé "physiquement" (par commutateur matériel)

Bonjour à tous,
J'ai ma carte Wifi qui est désactiver "physiquement" :
rfkill list me renvoi :

phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Le problème étant que le bouton pour activer le wifi est cassé donc impossible de le replacer sur ON (même en démontant le PC)
Pour le moment je me connecte avec un dongle mais je souhaiterais si possible récupérer la carte intégré.

Existe-t-il une manipulation sous Ubuntu pour réactiver la carte ?
La mise à jour du BIOS peut elle aider à résoudre le problème ?

Informations complémentaires :
Acer Aspire 5600
Ubuntu 11.04

Merci

Commandes demandées :
cat /etc/lsb-release

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"

lsusb

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lspci

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc M52 [Mobility Radeon X1300]
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
0a:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0a:09.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
0a:09.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
0a:09.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller

lspci -nn | grep -i net

02:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
0a:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)

sudo lshw -C network

  *-network DISABLED      
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 02
       serial: 00:13:02:6e:79:dd
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 driverversion=2.6.38-8-generic firmware=15.32.2.9 latency=0 link=no multicast=yes wireless=IEEE 802.11abg
       resources: irq:46 memory:84000000-84000fff
  *-network
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:0a:00.0
       logical name: eth0
       version: 10
       serial: 00:16:36:57:d1:9e
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=192.168.1.53 latency=32 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
       resources: irq:17 ioport:3000(size=256) memory:c8300000-c83000ff

lsmod

Module                  Size  Used by
binfmt_misc            13213  1 
parport_pc             32111  0 
ppdev                  12849  0 
vboxnetadp             13348  0 
vboxnetflt             27855  0 
snd_hda_codec_si3054    12924  1 
snd_hda_codec_realtek   255820  1 
vboxdrv               238410  2 vboxnetadp,vboxnetflt
snd_hda_intel          24140  2 
snd_hda_codec          90901  3 snd_hda_codec_si3054,snd_hda_codec_realtek,snd_hda_intel
pcmcia                 39671  0 
snd_hwdep              13274  1 snd_hda_codec
arc4                   12473  2 
snd_pcm                80244  3 snd_hda_codec_si3054,snd_hda_intel,snd_hda_codec
snd_seq_midi           13132  0 
snd_rawmidi            25269  1 snd_seq_midi
radeon                896428  3 
iwl3945               130113  0 
iwlcore               148965  1 iwl3945
snd_seq_midi_event     14475  1 snd_seq_midi
mac80211              257001  2 iwl3945,iwlcore
snd_seq                51291  2 snd_seq_midi,snd_seq_midi_event
ttm                    65184  1 radeon
snd_timer              28659  2 snd_pcm,snd_seq
joydev                 17322  0 
drm_kms_helper         40745  1 radeon
snd_seq_device         14110  3 snd_seq_midi,snd_rawmidi,snd_seq
tifm_7xx1              12898  0 
yenta_socket           27230  0 
snd                    55295  14 snd_hda_codec_si3054,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
tifm_core              15040  1 tifm_7xx1
cfg80211              156212  3 iwl3945,iwlcore,mac80211
pcmcia_rsrc            18292  1 yenta_socket
drm                   180037  5 radeon,ttm,drm_kms_helper
pcmcia_core            21505  3 pcmcia,yenta_socket,pcmcia_rsrc
soundcore              12600  1 snd
psmouse                73312  0 
i2c_algo_bit           13184  1 radeon
snd_page_alloc         14073  2 snd_hda_intel,snd_pcm
serio_raw              12990  0 
lp                     13349  0 
parport                36746  3 parport_pc,ppdev,lp
sdhci_pci              13623  0 
8139too                23208  0 
8139cp                 22497  0 
sdhci                  22720  1 sdhci_pci
btrfs                 527341  0 
zlib_deflate           26594  1 btrfs
libcrc32c              12543  1 btrfs

iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          
vboxnet0  no wireless extensions.

ifconfig

eth0      Link encap:Ethernet  HWaddr 00:16:36:57:d1:9e  
          inet adr:192.168.1.53  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::216:36ff:fe57:d19e/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:806 erreurs:0 :0 overruns:0 frame:0
          TX packets:730 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:499064 (499.0 KB) Octets transmis:106573 (106.5 KB)
          Interruption:17 Adresse de base:0x3000 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:8 erreurs:0 :0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:480 (480.0 B) Octets transmis:480 (480.0 B)

sudo iwlist scan

lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wlan0     Interface doesn't support scanning : Network is down

vboxnet0  Interface doesn't support scanning.

uname -r -m

2.6.38-8-generic i686

cat  /etc/network/interfaces

auto lo
iface lo inet loopback

nm-tool

NetworkManager Tool

State: connected

- Device: eth0  [Auto eth0] ----------------------------------------------------
  Type:              Wired
  Driver:            8139too
  State:             connected
  Default:           yes
  HW Address:        00:16:36:57:D1:9E

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.1.53
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.1.1


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwl3945
  State:             unavailable
  Default:           no
  HW Address:        00:13:02:6E:79:DD

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 

Dernière modification par dexlo5791 (Le 06/05/2011, à 14:56)


4|_| 23\/012  m|cr0$0f7
\/1\/3 11[]|_|)( !
1337

Hors ligne

#2 Le 06/05/2011, à 13:33

sauthess

Re : Wifi désactivé "physiquement" (par commutateur matériel)

Bonjour,

J'ai eu un problème sur le portable d'une connaissance (le bouton était sur on mais aléatoirement, la carte était physiquement éteinte). aucune possibilité via le bios/windows mais cette solution a marché (et depuis son pc marche toujours).

sudo rm /dev/rfkill
sudo shutdown -r now (on ferme les applications avant hein ... c'est un redémarrage)

source :
http://pkadetiloye.blogspot.com/2010/11 … flags.html

Si ça peut aider...


Serveur : Debian squeeze openvz, Portable 1 : Arch linux Enlightenment/Cinnamon, Portable 2 : Ubuntu 12.04 unity
(aucun Windows depuis 2006 mais je continue à payer les licences OEM à chaque achat par manque de possibilités...)

Hors ligne

#3 Le 06/05/2011, à 15:00

dexlo5791

Re : Wifi désactivé "physiquement" (par commutateur matériel)

Bonjour sauthess, j'ai testé ta méthode maintenant il m'affiche "périphérique non prêt".

J'ai rajouter les commandes dans mon premier poste (petit oubli de ma part)

Le wifi fonctionnait sous Windows XP puis du jour au lendemain plus rien, que se soit sous Linux ou Windows (peu importe la version)

Est il possible d'envisager une panne matériel ? La carte est quand même détectée pas Ubuntu et Windows.

Edit : Le message est variable des fois j'ai "périphérique non prêt" et d'autre fois "réseau sans fil d'activé par commutateur matériel" et "Activé le réseau sans fil" est grisé

Dernière modification par dexlo5791 (Le 06/05/2011, à 15:15)


4|_| 23\/012  m|cr0$0f7
\/1\/3 11[]|_|)( !
1337

Hors ligne

#4 Le 06/05/2011, à 16:45

sauthess

Re : Wifi désactivé "physiquement" (par commutateur matériel)

Bonjour,

Non pret ? où cela ?

Que donne les commandes :

sudo iwconfig
sudo ifconfig -a
sudo rfkill

Quand je regarde ton post modifé, j'ai l'impression que ta carte wifi est simplement éteinte.

essaye :

sudo ifconfig wlan0 up

Serveur : Debian squeeze openvz, Portable 1 : Arch linux Enlightenment/Cinnamon, Portable 2 : Ubuntu 12.04 unity
(aucun Windows depuis 2006 mais je continue à payer les licences OEM à chaque achat par manque de possibilités...)

Hors ligne

#5 Le 08/05/2011, à 10:26

boblouis

Re : Wifi désactivé "physiquement" (par commutateur matériel)

sudo rfkill unblock all

Hors ligne

#6 Le 19/10/2011, à 12:53

cyril34

Re : Wifi désactivé "physiquement" (par commutateur matériel)

Cette solution a très bien fonctionné pour moi, merci beaucoup! J'étais bloqué après une migration, mon commutateur pour le wifi ne répondait plus!

sauthess a écrit :

Bonjour,

J'ai eu un problème sur le portable d'une connaissance (le bouton était sur on mais aléatoirement, la carte était physiquement éteinte). aucune possibilité via le bios/windows mais cette solution a marché (et depuis son pc marche toujours).

sudo rm /dev/rfkill
sudo shutdown -r now (on ferme les applications avant hein ... c'est un redémarrage)

source :
http://pkadetiloye.blogspot.com/2010/11 … flags.html

Si ça peut aider...

Hors ligne

#7 Le 23/10/2011, à 20:53

andreu59

Re : Wifi désactivé "physiquement" (par commutateur matériel)

sudo rm /dev/rfkill
sudo shutdown -r now

J'avais aussi ma carte wifi désactivé par commutateur matériel et
je confirme; ça marche !
Merci Sauthess


Lubuntu 14.04 32bit sur un Dell Optiplex GX260 Intel Pentium 4 @2.00GHz RAM: 505MB

Hors ligne

#8 Le 24/10/2011, à 09:18

sauthess

Re : Wifi désactivé "physiquement" (par commutateur matériel)

de rien wink


Serveur : Debian squeeze openvz, Portable 1 : Arch linux Enlightenment/Cinnamon, Portable 2 : Ubuntu 12.04 unity
(aucun Windows depuis 2006 mais je continue à payer les licences OEM à chaque achat par manque de possibilités...)

Hors ligne

#9 Le 06/11/2011, à 21:48

gregoflex

Re : Wifi désactivé "physiquement" (par commutateur matériel)

j ai éssayer de faire comme sa mais sa me dit " imposible de suprimé «/dev/rfkill»: Aucun fichier ou dossier de ce type
répondé au plus vite slvp!!

Hors ligne

#10 Le 10/11/2011, à 12:45

assongmi

Re : Wifi désactivé "physiquement" (par commutateur matériel)

SALUT il se peut que mon wifi se soit désactivé car,je n"arrive plus à voir le signal sans fil; j'ai mème instalé wicd ;il ne voie rien il m"affiche: non connecté! ma version est la 10.04 et voici le lsmod
Module                  Size  Used by
binfmt_misc             6599  1
snd_intel8x0           25664  2
snd_ac97_codec         99227  1 snd_intel8x0
ac97_bus                1014  1 snd_ac97_codec
snd_pcm                71475  2 snd_intel8x0,snd_ac97_codec
snd_seq_midi            4588  0
snd_rawmidi            17783  1 snd_seq_midi
snd_seq_midi_event      6047  1 snd_seq_midi
snd_seq                47174  2 snd_seq_midi,snd_seq_midi_event
joydev                  8767  0
i915                  295819  4
snd_timer              19067  2 snd_pcm,snd_seq
pcmcia                 35973  0
snd_seq_device          5744  3 snd_seq_midi,snd_rawmidi,snd_seq
drm_kms_helper         30136  1 i915
drm                   168092  4 i915,drm_kms_helper
snd                    49102  11 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
yenta_socket           21518  0
tifm_7xx1               3766  0
intel_agp              26566  2 i915
pcmcia_rsrc            10566  1 yenta_socket
soundcore                880  1 snd
ppdev                   5556  0
i2c_algo_bit            5168  1 i915
irda                  179179  0
tifm_core               6089  1 tifm_7xx1
pcmcia_core            14657  3 pcmcia,yenta_socket,pcmcia_rsrc
snd_page_alloc          7120  2 snd_intel8x0,snd_pcm
agpgart                32011  2 drm,intel_agp
parport_pc             26058  1
video                  18712  1 i915
psmouse                59033  0
output                  1883  1 video
serio_raw               4022  0
crc_ccitt               1351  1 irda
lp                      7342  0
hp_wmi                  5223  0
parport                31492  3 ppdev,parport_pc,lp
btrfs                 489658  0
firewire_ohci          21234  0
zlib_deflate           19266  1 btrfs
sdhci_pci               6633  0
tg3                   123310  0
sdhci                  15922  1 sdhci_pci
firewire_core          46643  1 firewire_ohci
crc_itu_t               1383  1 firewire_core
led_class               2633  1 sdhci
crc32c                  2531  1
libcrc32c                887  1 btrfs


aidez moi je vous en prie merci

Hors ligne

#11 Le 10/11/2011, à 13:11

chibbata

Re : Wifi désactivé "physiquement" (par commutateur matériel)

salut assongmi
il n ya aucuns drivers wifi de chargés §
post le resultat de

 lspci

Hors ligne

#12 Le 11/11/2011, à 20:13

sauthess

Re : Wifi désactivé "physiquement" (par commutateur matériel)

@gregoflex : as tu installé rfkill : "sudo apt-get install rfkill" ?

sinon fais le + redémarrage.

normalement la commande rfkill list renvoie quelque chose comme :

rfkill list
1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
14: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

une fois que ça marche, tu devrais avoir un fichier /dev/rfkill


Serveur : Debian squeeze openvz, Portable 1 : Arch linux Enlightenment/Cinnamon, Portable 2 : Ubuntu 12.04 unity
(aucun Windows depuis 2006 mais je continue à payer les licences OEM à chaque achat par manque de possibilités...)

Hors ligne

#13 Le 11/11/2011, à 20:16

sauthess

Re : Wifi désactivé "physiquement" (par commutateur matériel)

précision : dans le bug dont il est question, tu as un hard block a yes (le pc sur lequel je suis n'a pas ce problème...)

la commande rfkil est justement là pour identifier ce genre de pb....


Serveur : Debian squeeze openvz, Portable 1 : Arch linux Enlightenment/Cinnamon, Portable 2 : Ubuntu 12.04 unity
(aucun Windows depuis 2006 mais je continue à payer les licences OEM à chaque achat par manque de possibilités...)

Hors ligne

#14 Le 20/12/2012, à 16:09

KoZzY

Re : Wifi désactivé "physiquement" (par commutateur matériel)

Hello tout le monde,

Je me permets de déterrer ce topic car je fais face à un problème similaire mais frustrant au possible... Voilà deux jours que je m'arrache les cheveux là dessus (et deux ré-installations système plus tard car j'ai fait le c..) et vraiment, je manque d'idée !

J'espère que vous pourrez m'aider.

En gros j'ai également ce problème de commutateur matériel. Je possède un Pc portable Lenovo 0769 (oui, je sais, c'est pas génial) et la carte réseau intégrée était une Broadcom bmc5906M que j'ai retiré pour la remplacer par une bcm4312 (Ubuntu semble avoir moins de soucis à reconnaître cette dernière).

Je crois que le problème persiste car mon système garde un "souvenir" de mon ancienne carte réseau, l'illustration avec un petit lspci:

lspci a écrit :

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
04:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
06:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express (rev 02)
08:06.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
08:06.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
08:06.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
08:06.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)

Vous voyez, les deux sont là alors que je tiens la carte bcm5906m dans ma main en ce moment (elle n'est donc méchamment pas connectée ^^). Je ne sais pas comment virer ça pour ne laisser que la bcm4312 hmm

Par ailleurs, rfkill me retourne un bug intéressant mais énervant au possible:

rfkill a écrit :

/dev# rfkill list
0: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Maintenant regardez bien:

rfkill a écrit :

/dev# rfkill unblock all

Et boum, toujours la même chose:

rfkill a écrit :

/dev# rfkill list
0: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Quand je testais rfkill avec l'ancienne carte (bcm5906m) il avait au moins le mérite de fonctionner, le wifi ne fonctionnait toujours pas car Ubuntu ne parvenait pas à trouver les pilotes mais au moins le Hard était débloqué.
Depuis que j'ai interverti les cartes réseaux, Ubuntu reconnaît les pilotes additionnels mais rfkill n'a plus aucun impact sur le Hard (je peux cependant activer ou désactiver le Soft avec rfkill sans problème).

Si vous avez une idée de génie c'est le moment car il ne me reste plus beaucoup de cheveux big_smile

Merci d'avance pour votre aide =]

Dernière modification par KoZzY (Le 20/12/2012, à 16:10)

Hors ligne

#15 Le 20/12/2012, à 16:58

chibbata

Re : Wifi désactivé "physiquement" (par commutateur matériel)

salut
deja vas voir dans le bios que le wifi est actif,si pas d'option wifi dans le bios,execute l'option du bios load default settings
l'autre carte reseau,la bcm5906m est une carte reseau filaire,tu peux la desactiver par le bios


tu as essayé l'autre driver,b43 ?
il faut etre connecté au net par le cable reseau pour faire la manip ci dessous

sudo apt-get update
sudo apt-get install firmware-b43-lpphy-installer
sudo apt-get remove --purge bcmwl-kernel-source

redemarres le pc

si pas de connexion au net
telecharges le paquet ci dessous avec un autre pc,puis copie le dans le dossier Documents de ubuntu
http://nl.archive.ubuntu.com/ubuntu/poo … 14_all.deb
ouvres un terminal

cd Documents
sudo dpkg -i linux-firmware-nonfree_1.14_all.deb

redemarres le pc

Hors ligne

#16 Le 20/12/2012, à 21:03

KoZzY

Re : Wifi désactivé "physiquement" (par commutateur matériel)

rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

J'ai essayé tout ce que tu m'as conseillé et rien ne va.
En tout cas je te remercie pour tes idées nouvelles, je n'avais pas encore testé tout ça jusqu'ici. J'ai désactivé le "modem intégré" dans le bios (et restauré les paramètres par défaut), j'ai ré-installé le broadcom via terminal (je l'avais déjà fait avec l'utilitaire "pilotes additionnels" de Ubuntu 12.04 mais on ne sait jamais), j'ai installé le .deb que tu m'as donné...
D'un côté je suis content d'avoir ce problème à régler car j'apprends plein de nouveaux trucs tout autour mais d'un autre côté j'aimerais tellement que ce foutu wifi fonctionne xD

J'ai vu sur un autre forum des idées concernant un fichier "rules.d" où un utilisateur à changé le nom / la valeur eth0(ou eth2) par wlan0 et que ça a réglé son problème... Malheureusement je ne mets plus la main dessus.

edit: Au fait, malgré tout ça, lspci me retourne toujours la même chose (les deux cartes sont toujours là, rien n'a changé depuis la dernière fois).

Dernière modification par KoZzY (Le 09/01/2013, à 15:58)

Hors ligne

#17 Le 09/01/2013, à 15:54

KoZzY

Re : Wifi désactivé "physiquement" (par commutateur matériel)

Ok problème résolu !

Apparemment les PC Lenovo possèdent un commutateur "Switch" à l'avant du clavier, il faut le pousser vers la droite pour l'activer (c'est franchement pas voyant). Le truc c'est que quand on a une carte réseau BCM43xx ou autre du genre "qui ne s'installe pas de suite avec Ubuntu"", la première fois qu'on active physiquement ce switch on active que le Bluetooth en fait. Du coup on n'y fait plus attention et on se dit que le problème est ailleurs...

En fait il faut:

- S'assurer dans le bios que le "modem" est activé (Enabled).
- Pousser le switch physique vers la droite pour allumer, dans un premier temps, le Bluetooth uniquement.
- Installer la carte réseau avec l'outil des pilotes additionnels de Ubuntu (ou, si on n'a pas de connexion filière, avec fw-cutter après avoir téléchargé le firmware adéquat (voir le post de Chibbata un peu plus haut)).
- Maintenir Fn+F5 et si ça ne fonctionne pas, Fn+F12 (ne me demandez pas pourquoi... Le Pc va se mettre en veille et quand vous le rallumerez il y a de fortes chances pour que le wifi soit activé) et si ça ne marche toujours pas, essayez toutes les combinaisons Fn+Fx possibles (bizarrement j'ai l'impression que les fonctions des touches sont mal assignées sous Ubuntu).
- Ouvrir un terminal et taper: rfkill block bluetooth puis rfkill list pour s'assurer que le bluetooth est éteint.

Oui car je n'ai pas trouvé le moyen d'activer uniquement le wifi sans le bluetooth ... Sorry pour ceux qui ont le même problème, mais au moins, la connexion fonctionne =]

C'était tout con mais si vous ne faites pas les choses dans cet ordre précis avec un Pc Lenovo comme le mien, ça ne fonctionnera pas, je vous le garantis ^^

Dernière modification par KoZzY (Le 10/01/2013, à 01:04)

Hors ligne

#18 Le 24/10/2013, à 21:14

CH4NCE

Re : Wifi désactivé "physiquement" (par commutateur matériel)

sauthess a écrit :

Bonjour,

J'ai eu un problème sur le portable d'une connaissance (le bouton était sur on mais aléatoirement, la carte était physiquement éteinte). aucune possibilité via le bios/windows mais cette solution a marché (et depuis son pc marche toujours).

sudo rm /dev/rfkill
sudo shutdown -r now (on ferme les applications avant hein ... c'est un redémarrage)

source :
http://pkadetiloye.blogspot.com/2010/11 … flags.html

Si ça peut aider...

Cela a résolu le problème sur un emachine e510. Génial, merci beaucoup.

Hors ligne

#19 Le 04/07/2014, à 19:50

belo71

Re : Wifi désactivé "physiquement" (par commutateur matériel)

Pfff : j'ai cherché et cherché...

Il y a effectivement un interrupteur physique sur le champ droit de la machine...

Merci pour votre aide précieuse.

JS

Hors ligne

  • Accueil
  • » Forum
  • » WiFi
  • » Wifi désactivé "physiquement" (par commutateur matériel)

Haut de page ↑