Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 02/07/2006, à 19:44

Fugate

[Résolu] Problème MAJ avec le paquet libcairo2

Bonjour à tous smile

Depuis une ptite mise à jour effectuée hier, un problème causé par le paquet libcairo2 est apparu...
Voiçi le message d'erreur:

maj5vt.th.png

Evidemment un apt-get dist-upgrade ne donne rien sad il parle de suppression mais je n'ose pas trop m'aventuré...
Alors que se passe t-il?

Hors ligne

#2 Le 02/07/2006, à 19:46

coubi64

Re : [Résolu] Problème MAJ avec le paquet libcairo2

J'ai eu le même souci. J'attend, je me dis que ça va peut etre se résoudre tout seul comme souvent wink

Hors ligne

#3 Le 02/07/2006, à 20:05

mr_pouit

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Vous avez des sources exotiques dans votre /etc/apt/sources.list, ou seulement les dépôts officiels ?

Dernière modification par mr_pouit (Le 02/07/2006, à 20:12)


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#4 Le 02/07/2006, à 20:19

Fugate

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Voila mon sources.list

deb http://wine.sourceforge.net/apt/ binary/
deb http://deb.opera.com/opera etch non-free
# The above lines were generated automatically by EasyUbuntu 3.0 Beta Release
# The rest of your sources.list follows

deb http://archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse

## Major bug fix updates produced after the final release of the
## distribution.

deb http://archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu/ dapper-updates main restricted


## Uncomment the following two lines to add software from the 'backports'
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

deb http://archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted

deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe



#XGL
deb http://www.beerorkid.com/compiz/ dapper main
deb http://xgl.compiz.info dapper main

#Listen
deb http://theli.free.fr/packages/dapper/ ./

#Bonfire
#deb http://ketsugi.com/ubuntu/ dapper main

edit: edit je vais dailleurs ajouter ton dépot wink pour bonfire entre autres, merci smile

Dernière modification par Fugate (Le 02/07/2006, à 20:24)

Hors ligne

#5 Le 02/07/2006, à 20:21

mr_pouit

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Ah tu as XGL lol : le bug sera probablement corrigé dans la prochaine mise à jour du dépôt beerorkid je suppose wink


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#6 Le 02/07/2006, à 20:24

coubi64

Re : [Résolu] Problème MAJ avec le paquet libcairo2

mr_pouit a écrit :

Ah tu as XGL lol : le bug sera probablement corrigé dans la prochaine mise à jour du dépôt beerorkid je suppose wink

Idem pour moi pour XGL..... smile

Et je pense comme toi pour la prochaine MAJ wink

Hors ligne

#7 Le 02/07/2006, à 20:25

Fugate

Re : [Résolu] Problème MAJ avec le paquet libcairo2

ah ok, ptit problème passager alors tongue

edit: XGL c'est juste pour tester de temps en temps, je sais pas si libcairo2 peut gêner sur une session normal?

Dernière modification par Fugate (Le 02/07/2006, à 20:38)

Hors ligne

#8 Le 02/07/2006, à 21:03

mr_pouit

Re : [Résolu] Problème MAJ avec le paquet libcairo2

D'ailleurs ce problème est signalé sur le forum de compiz, donc une mise à jour ne devrait pas tarder : http://www.compiz.net/viewtopic.php?pid=11283#p11283

C'est juste que la version de libcairo2 incluse dans dapper (1.0.4) n'est pas compatible avec compiz/xgl ; c'est pour ça qu'il met une version plus récente (1.10 si je me souviens bien). Je crois que cette bibliothèque gère plusieurs choses relatives à l'affichage sous gnome... Au pire, ça te pourrit tout l'affichage des polices, rien de grave lol

Fugate : attention, mon dépôt possède justement une version spéciale de la libcairo2 (et de libxft) : c'est la version de dapper (1.0.4) patchée pour améliorer l'affichage des polices sur les écrans LCD smile

Dernière modification par mr_pouit (Le 02/07/2006, à 21:10)


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#9 Le 03/07/2006, à 11:08

Fugate

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Ah merci pour le forum de compiz wink

Pour ton dépot, il me semble bien qu'il à mit à jour libfxt mais pas libcairo2, je fait quoi à ton avis? Je désactive ton dépot?

edit: sinon, tu veut dire que avec la version de libcairo2 que les gars de compiz vont publié, sa risque de pourir mes polices sous gnome? neutral

Dernière modification par Fugate (Le 03/07/2006, à 11:10)

Hors ligne

#10 Le 03/07/2006, à 17:15

mr_pouit

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Fugate a écrit :

edit: sinon, tu veut dire que avec la version de libcairo2 que les gars de compiz vont publié, sa risque de pourir mes polices sous gnome? neutral

Non, c'est exagéré : il y a peu de risques, car le gars teste ses paquets (enfin j'espère lol)

Pour libxft, tu peux remettre la version de dapper (paquet > forcer la version), puis tu peux ensuite bloquer la version pour que ce paquet ne soit plus mis à jour (paquet > bloquer la version). Sinon le plus simple c'est de désactiver mon dépôt wink


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#11 Le 03/07/2006, à 18:02

juju_teamp2p

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Bon bah je croit que je ne suit pas le seul à avoir ce pb, ouf.... ça me rassure! pour moi idem, ça plante pour la MAJ de compiz!


www.p2p-area.com: telecharger des logiciels libres!
www.linux-inside.fr: Partagez vos experiences dans le domaine du monde libre de Linux

Hors ligne

#12 Le 03/07/2006, à 18:37

Fugate

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Merci mr_pouit wink

Hors ligne

#13 Le 03/07/2006, à 21:48

florian

Re : [Résolu] Problème MAJ avec le paquet libcairo2

+1
même probleme: log apt:

réconfiguration des paquets...
Sélection du paquet libclamav1 précédemment désélectionné.
(Lecture de la base de données... 134317 fichiers et répertoires déjà installés.)
Dépaquetage de libclamav1 (à partir de .../libclamav1_0.88.2-1ubuntu1_i386.deb) ...
Sélection du paquet clamav-base précédemment désélectionné.
Dépaquetage de clamav-base (à partir de .../clamav-base_0.88.2-1ubuntu1_all.deb) ...
Sélection du paquet clamav-freshclam précédemment désélectionné.
Dépaquetage de clamav-freshclam (à partir de .../clamav-freshclam_0.88.2-1ubuntu1_i386.deb) ...
Sélection du paquet clamav précédemment désélectionné.
Dépaquetage de clamav (à partir de .../clamav_0.88.2-1ubuntu1_i386.deb) ...
Sélection du paquet libtext-glob-perl précédemment désélectionné.
Dépaquetage de libtext-glob-perl (à partir de .../libtext-glob-perl_0.06-1_all.deb) ...
Sélection du paquet libnumber-compare-perl précédemment désélectionné.
Dépaquetage de libnumber-compare-perl (à partir de .../libnumber-compare-perl_0.01-1_all.deb) ...
Sélection du paquet libfile-find-rule-perl précédemment désélectionné.
Dépaquetage de libfile-find-rule-perl (à partir de .../libfile-find-rule-perl_0.28-1_all.deb) ...
Sélection du paquet libcarp-clan-perl précédemment désélectionné.
Dépaquetage de libcarp-clan-perl (à partir de .../libcarp-clan-perl_5.3-3_i386.deb) ...
Sélection du paquet libbit-vector-perl précédemment désélectionné.
Dépaquetage de libbit-vector-perl (à partir de .../libbit-vector-perl_6.4-4_i386.deb) ...
Sélection du paquet libdate-calc-perl précédemment désélectionné.
Dépaquetage de libdate-calc-perl (à partir de .../libdate-calc-perl_5.4-4_i386.deb) ...
Sélection du paquet clamtk précédemment désélectionné.
Dépaquetage de clamtk (à partir de .../clamtk_2.17-0ubuntu1_all.deb) ...
Paramétrage de libclamav1 (0.88.2-1ubuntu1) ...

Paramétrage de clamav-base (0.88.2-1ubuntu1) ...
Ajout de l'utilisateur système clamav...
Ajout du nouveau groupe « clamav » (114).
Ajout du nouvel utilisateur « clamav » (114) avec le groupe « clamav ».
Ne crée pas le dossier personnel '/var/lib/clamav'.
dpkg : erreur de traitement de clamav-base (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de clamav-freshclam :
 clamav-freshclam dépend de clamav-base (= 0.88.2-1ubuntu1) ; cependant :
  Paquet clamav-base n'est pas encore configuré.
dpkg : erreur de traitement de clamav-freshclam (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de clamav :
 clamav dépend de clamav-freshclam | clamav-data ; cependant :
  Paquet clamav-freshclam n'est pas encore configuré.
  Paquet clamav-data n'est pas installé.
  Paquet clamav-freshclam qui fournit clamav-data n'est pas encore configuré.
dpkg : erreur de traitement de clamav (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de libtext-glob-perl (0.06-1) ...
Paramétrage de libnumber-compare-perl (0.01-1) ...
Paramétrage de libfile-find-rule-perl (0.28-1) ...
Paramétrage de libcarp-clan-perl (5.3-3) ...
Paramétrage de libbit-vector-perl (6.4-4) ...
Paramétrage de libdate-calc-perl (5.4-4) ...
dpkg : des problèmes de dépendances empêchent la configuration de clamtk :
 clamtk dépend de clamav (>= 0.83) ; cependant :
  Paquet clamav n'est pas encore configuré.
 clamtk dépend de clamav-freshclam (>= 0.83) ; cependant :
  Paquet clamav-freshclam n'est pas encore configuré.
dpkg : erreur de traitement de clamtk (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 clamav-base
 clamav-freshclam
 clamav
 clamtk
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#14 Le 04/07/2006, à 00:46

Fugate

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Sa a l'air plus sérieux ton problème; tu as le même message d'erreur que moi?

Hors ligne

#15 Le 04/07/2006, à 09:41

BlackSmileFR

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Salut j'ai le même problème sauf que par synaptic on a un retour qui dit quoi installer le paquet qui me pose problème est libfreetype6. En fait il ,me dit d'installer une version qui est déjà installé. le problème c'est qu'il y a déjà eu plein de mise a jour compiz sans correction de ce bug apparement connu (si c'est le même)!
Voici mon post sur le sujet :
http://forum.ubuntu-fr.org/viewtopic.php?id=48530

wait and see roll


BlackSmile[FR] <--
Source.list
http://www.giroll.org
http://doc.ubuntu-fr.org/depots

Hors ligne

#16 Le 04/07/2006, à 15:06

gooopy007

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Bonjour,
jai moi aussi le problème avec libcairo2 mais je sais pas pour vous mais je ne peut plus installer ou updater aucun paquet:
voila ce que me renvoi un apt-get dist-upgrade:

sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  xserver-xorg-input-mouse
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o/21,3ko dans les archives.
Après dépaquetage, 0o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... dpkg : erreur de traitement de /var/cache/apt/archives/xserver-xorg-input-mouse_1%3a1.0.3.1+cvs.20060109-0ubuntu1.1_i386.deb (--unpack) :
 impossible d'ouvrir le fichier contenant la liste des fichiers du paquet « libcairo2 »: Aucun périphérique ou adresse
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/xserver-xorg-input-mouse_1%3a1.0.3.1+cvs.20060109-0ubuntu1.1_i386.deb
L'exécution a été arrêtée car il y avait trop d'erreurs.
E: Sub-process /usr/bin/dpkg returned an error code (1)

si quelqun a une solution, elle est la bienvenue...

#17 Le 04/07/2006, à 15:38

Fugate

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Moi les maj fonctionnent, y comprit celle du paquet xserver-xorg-input-mouse

Hors ligne

#18 Le 04/07/2006, à 19:33

wolux

Re : [Résolu] Problème MAJ avec le paquet libcairo2

MMHHHHhhh.....  hmm

c'est bizarre tout ça... J'ai également cette erreur, mais je peux encore installer des paquets, pas de problème avec libfreetype6....
En fait, si ça a effectivement un rapport avec l'affichage, cela expliquerait le bug que j'expérimente dans listen hier (des boutons disparraisse et il y a des aplats noirs à la place, il faut passer la souris dessus pour que ça revienne)... C'est un peu le même bug que sur les infos bulles, sauf qu'il avait disparu, et bien le revoilou !!!!  lol


Si rien n'est moins sûr que l'incertain, rien n'est plus certain que ce qui est aussi sûr

Hors ligne

#19 Le 05/07/2006, à 09:29

coubi64

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Toujours pas résolu chez moi.

C'est pareil chez vous?

Hors ligne

#20 Le 05/07/2006, à 11:37

Fugate

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Toujours pas, il y a plein de maj de compiz et compiz-gnome mais pas de libcairo2

Hors ligne

#21 Le 05/07/2006, à 13:50

dawar

Re : [Résolu] Problème MAJ avec le paquet libcairo2

pareil, c'est un peu embettant...


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#22 Le 06/07/2006, à 06:01

juju_teamp2p

Re : [Résolu] Problème MAJ avec le paquet libcairo2

pour moi c'est bon, mon pb est résolu j'ai eu la mise à jour de libcairo2 big_smile


www.p2p-area.com: telecharger des logiciels libres!
www.linux-inside.fr: Partagez vos experiences dans le domaine du monde libre de Linux

Hors ligne

#23 Le 06/07/2006, à 08:02

BnouK

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Pareil pour moi, j'ai enfin la maj de libcairo2

Hors ligne

#24 Le 06/07/2006, à 08:07

mmaze

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Je viens de me faire grillé lol
Même chose maj effectuée ;-)

Hors ligne

#25 Le 06/07/2006, à 09:47

dawar

Re : [Résolu] Problème MAJ avec le paquet libcairo2

Alors on passe ça en Résolu


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

Haut de page ↑