Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 15/07/2006, à 14:34

Dionysos

[Résolu] Probleme de paquet cassé.

Donc voila... J'ai voulu installer samba pour partager des fichiers avec un ordinateur windows de mon reseau...

Sauf que... ça à merder... je ne sais pas pourquoi... Enfin, samba je m'en fou un peu mais maintenant, je ne peux plus rien installer...

root@ubuntu:/home/dionysos# apt-get install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
  samba: Dépend: samba-common (= 3.0.22-1ubuntu3) mais 3.0.22-1ubuntu3.1 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
root@ubuntu:/home/dionysos#

Donc... je tape ce "apt-get -f install"

root@ubuntu:/home/dionysos# apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  samba
Paquets suggérés :
  samba-doc
Paquets recommandés :
  smbldap-tools
Les paquets suivants seront mis à jour :
  samba
1 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
Il est nécessaire de prendre 0o/2845ko dans les archives.
Après dépaquetage, 0o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Préconfiguration des paquets...
(Lecture de la base de données... 90655 fichiers et répertoires déjà installés.)Préparation du remplacement de samba 3.0.22-1ubuntu3 (en utilisant .../samba_3.0.22-1ubuntu3.1_i386.deb) ...
invoke-rc.d: dangling symlink: /etc/rc2.d/S91samba
dpkg : avertissement - ancien script pre-removal a retourné un code d'erreur de sortie 102
dpkg - tentative d'exécution du script du nouveau paquet à la place ...
invoke-rc.d: dangling symlink: /etc/rc2.d/S91samba
dpkg : erreur de traitement de /var/cache/apt/archives/samba_3.0.22-1ubuntu3.1_i386.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 102
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/samba_3.0.22-1ubuntu3.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@ubuntu:/home/dionysos#

Voilà.... Donc là je ne sais plus quoi faire... si quelqu'un peux m'aider...

#2 Le 15/07/2006, à 17:41

foch

Re : [Résolu] Probleme de paquet cassé.

essaye de supprimer samba-common avant de relancer un apt-get -f install


De retour sous Ubuntu après quelques années sous ArchLinux.

Programme de téléchargement de musique qui ne marche plus vraiment.

Hors ligne

#3 Le 15/07/2006, à 18:26

Dionysos

Re : [Résolu] Probleme de paquet cassé.

root@ubuntu:/home/dionysos# apt-get remove samba-common
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
  samba: Dépend: samba-common (= 3.0.22-1ubuntu3) mais ne sera pas installé
  smbclient: Dépend: samba-common (= 3.0.22-1ubuntu3.1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
root@ubuntu:/home/dionysos#

hmm

#4 Le 15/07/2006, à 18:43

Gilles.L

Re : [Résolu] Probleme de paquet cassé.

Je rencontre exactement le même problème. L'erreur est survenue lors ma dernière upgrade via apt-get. Si quelqu'un a trouvé une solution, je suis intéressé.

#5 Le 15/07/2006, à 18:48

bapoumba

Re : [Résolu] Probleme de paquet cassé.

Faudrait poster vos sources.list. Avez-vous utilisé des dépôts «exotiques» ?


| Ubuntu Forums |
J'aime les fraises.

Hors ligne

#6 Le 15/07/2006, à 18:51

Gilles.L

Re : [Résolu] Probleme de paquet cassé.

Au temps pour moi... en cherchant un peu plus loin, j'ai trouvé la réponse à mon problème :

http://forum.ubuntu-fr.org/viewtopic.php?id=47227

#7 Le 15/07/2006, à 19:02

Dionysos

Re : [Résolu] Probleme de paquet cassé.

Honte à moi.... Encore une fois... je pose une question auquel on a deja repondu 15 fois.... Désolé... Faudra que j'apprenne à rechercher dans un forum un jour...

#8 Le 15/07/2006, à 19:50

bapoumba

Re : [Résolu] Probleme de paquet cassé.

@ Dionysos : j'ai passé ton sujet en [Résolu]. Tu es invité donc tu ne peux pas le faire toi même (en > modifiant ton premier post) ==> inscrits-toi wink


| Ubuntu Forums |
J'aime les fraises.

Hors ligne

Haut de page ↑