Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 17/07/2006, à 19:20

Akewea

Installer FreeBoB

Salut à tous !

NewB' dans le coin, je cherche à installer FreeBoB pour ma carte son FireWire... sans succès ! Je galère car il faut construire et configurer des trucs dont je ne soupçonnais même pas l'existence !

Bref, si quelqu'un a déjà fait et qu'il veut bien m'expliquer (façon "pour les Nuls" !) ou un lien vers un tuto (en french c'est mieux wink ) ...

Merci d'avance !


Akewea - Mon Blog !
Ubuntu Edgy Eft sur Dell Dimension 9100... Et qui galère avec sa M-Audio FireWire 410 !

Hors ligne

#2 Le 17/07/2006, à 19:34

xabilon

Re : Installer FreeBoB

Salut

Je suis également musicien, et je dois garder Windows pour faire de la zik. Je n'ai pas de carte Firewire, je ne peux t'aider à résoudre ton problème, mais tu pourrais peut-être t'orienter vers une distribution plus axée sur la MAO, comme Agnula Demudi (assez similaire à Ubuntu).

Tout ce que j'ai trouvé (mais je suppose que tu es déjà passé par là):
http://www.linuxmao.org/tikiwiki/tiki-i … ge=FreeBob
où l'on apprend que FreeBob ne peux passer que par Jack, et non ALSA.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 17/07/2006, à 19:42

Akewea

Re : Installer FreeBoB

Merci pour ta réponse !

oui, j'ai vu cette page, mais ca va un peu vite pour moi... wink

Enfin, je vais quand même essayer, à défaut... roll


Akewea - Mon Blog !
Ubuntu Edgy Eft sur Dell Dimension 9100... Et qui galère avec sa M-Audio FireWire 410 !

Hors ligne

#4 Le 17/07/2006, à 20:09

xabilon

Re : Installer FreeBoB

Il faut que t'apprennes à compiler des sources.

Tu trouveras comment réussir une compilation dans la doc d'Ubuntu.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#5 Le 23/07/2006, à 17:08

Akewea

Re : Installer FreeBoB

Salut again...

Bon, j'ai (un peu) progressé, je sais maintenant compilé des sources etc.

Mais je n'arrive toujours pas installer FreeBoB ! sad

J'ai suivi ce "tuto" et ca bloque sur le ./configure du libiec61883 :

checking for LIBRAW1394... configure: error: Package requirements (libraw1394 >= 1.2.0) were not met:

Requested 'libraw1394 >= 1.2.0' but version of libraw1394 is

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBRAW1394_CFLAGS
and LIBRAW1394_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Ce qui est bizarre, car je n'est pas (plus) d'erreur sur le raw1394. En plus je dois utiliser cette lib avec kino pour mon camescope DV en FireWire. Et ca, ca marche. Bref, je pédale dans la semoule... hmm

Si quelqu'un a une idée sur cette erreur ? Je ne suis pas encore assez bon... roll

Et y a-t-il un moyen de passer outre et d'installer quand même ?


Akewea - Mon Blog !
Ubuntu Edgy Eft sur Dell Dimension 9100... Et qui galère avec sa M-Audio FireWire 410 !

Hors ligne

#6 Le 01/08/2006, à 08:34

sx64

Re : Installer FreeBoB

Avec Synaptic il faut vérifier si libraw est bien installé
le Menu Raccourcis->Rechercher des fichiers il faut recherche l'emplacement de libraw (Comme type de fichier : une librairie partagée)
Dans le répétoire de libex61883 : essaye ces commandes :
sudo ln -s -f /usr/lib/libraw1394.so.5 /le répétoire de libex61883
sudo ln -s -f /usr/lib/libraw1394.so.5.2.0 /le répétoire de libex61883
Je ne sais pas si ça fontionne, apparament la libex61883 que tu souhaite installer à besion d'un paquet libraw plus récent. Dans ce cas il faut essayer avec une version plus ancienne de FreeBob.

Hors ligne

#7 Le 01/08/2006, à 08:42

sx64

Re : Installer FreeBoB

http://sourceforge.net/project/showfiles.php?group_id=117802
Apparament il y a deux paquet 1.0.0 et 0.9.0 : il faut essayer avec le 0.9.0 peut-être les 'librairies' (paquets .lib d'Ubuntu) seront pas trop anciens

Hors ligne

#8 Le 01/08/2006, à 09:17

Akewea

Re : Installer FreeBoB

Merci de te pencher sur mon problème.

Avec Synaptic il faut vérifier si libraw est bien installé

Il est bien installé. De plus, cette lib est utilisé par kino pour piloter un camescope DV en FireWire, et ca marche sans pb.

Je ne sais pas si ça fontionne, apparament la libex61883 que tu souhaite installer à besion d'un paquet libraw plus récent. Dans ce cas il faut essayer avec une version plus ancienne de FreeBob.

Je pense qu'il ne trouve pas libraw1394, en fait, car il n'affiche pas le numéro de version (NB : j'ai installé la dernière version disponible via svn... Donc ca n'est surement pas un pb de version). Pour FreeBoB, je n'en suis pas encore à l'installation ! J'essaie pour l'instant de mettre les lib nécessaires à l'installation...

Je vais essayer tes lignes de commande ce soir (quand je serais chez moi...).

Merci de ton aide !


Akewea - Mon Blog !
Ubuntu Edgy Eft sur Dell Dimension 9100... Et qui galère avec sa M-Audio FireWire 410 !

Hors ligne

#9 Le 01/08/2006, à 12:13

Akewea

Re : Installer FreeBoB

Rhaaaggh... yikes

Il semblerai, d'après cette page, que le problème vienne juste d'Ubuntu et de l'absence de numéro de version dans le libraw1394.pc après installation...

Je teste ça ce soir et passe (peut-être) le topic en résolu... smile

En tous cas, c'est tout à fait cohérent avec le message d'erreur !


Akewea - Mon Blog !
Ubuntu Edgy Eft sur Dell Dimension 9100... Et qui galère avec sa M-Audio FireWire 410 !

Hors ligne

#10 Le 02/08/2006, à 07:52

Akewea

Re : Installer FreeBoB

J'ai une bonne et une mauvaise nouvelle...

La bonne : en ajoutant le numéro de version, le ./configure passe sans soucis !

La mauvaise : maintenant c'est le make qui merde... sad Il me dit qu'il ne trouve pas le fichier libraw1394/raw1394.h ... J'ai regardé et il en existe un dans /usr/include/check-news . Je sais vraiment pas quoi faire...


Akewea - Mon Blog !
Ubuntu Edgy Eft sur Dell Dimension 9100... Et qui galère avec sa M-Audio FireWire 410 !

Hors ligne

#11 Le 02/08/2006, à 12:47

michel2652

Re : Installer FreeBoB

smile

sad

#12 Le 02/08/2006, à 22:11

sx64

Re : Installer FreeBoB

Akewea a écrit :

J'ai une bonne et une mauvaise nouvelle...

La bonne : en ajoutant le numéro de version, le ./configure passe sans soucis !

La mauvaise : maintenant c'est le make qui merde... sad Il me dit qu'il ne trouve pas le fichier libraw1394/raw1394.h ... J'ai regardé et il en existe un dans /usr/include/check-news . Je sais vraiment pas quoi faire...

Peut-être faire un lien symbolique avec la commande ln -s -f
ln -s -f /usr/include/check-news /le_répétoire_d'installation_de_libraw1394

Hors ligne

#13 Le 02/08/2006, à 22:12

sx64

Re : Installer FreeBoB

Pardon, il faut ajouter sudo avant la commande ln -s -f ...

Hors ligne

#14 Le 02/11/2006, à 17:02

siebe4

Re : Installer FreeBoB

Salut j'ai un problème similaire.

J'avais commencé par jeter un oeil au sympathique gestionnaire de paquet synaptic pour m'apercevoir que toutes les libs demandées par l'install de freebob étaient présente (versions ok).

J'ai alors tenté l'install de freebob.
./configure (normal...)
plantage (voir le code ci-dessous), "il" me dit qu'il ne trouve pas le paquet libraw1394.
Je l'installe à partir des sources (./configure make make install... le tout en root)
Je retente un ./configure de libfreebob.
Re-plantage, cette fois c'est le paquet libiec61883 qu' "il" ne trouve pas...
J'installe donc toutes les lib recommandées par tous les tuto sur freebob.

Je relance donc le ./configure.
Et là (c'est le drame) : c'est le paquet alsa qui n'est pas au rendez-vous :

checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for LIBRAW1394... yes
checking for LIBIEC61883... yes
checking for LIBAVC1394... yes
checking for ALSA... configure: error: Package requirements (alsa >= 1.0.0) were not met:

No package 'alsa' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables ALSA_CFLAGS
and ALSA_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

En fouinant un petit peu (less config.log), je me suis aperçu qu'effectivement, les variables d'environnement ALSA_CFLAGS et ALSA_LIBS n'étaient pas fixées contrairement au suivantes :

LIBAVC1394_CFLAGS='-I/usr/local/include  '
LIBAVC1394_LIBS='-L/usr/local/lib -lavc1394 -lrom1394 -lraw1394  '
LIBIEC61883_CFLAGS='-I/usr/local/include  '
LIBIEC61883_LIBS='-L/usr/local/lib -liec61883 -lraw1394  '
LIBRAW1394_CFLAGS='-I/usr/local/include  '
LIBRAW1394_LIBS='-L/usr/local/lib -lraw1394  '

Je ne connais pas grand chose aux variables d'environnement. Si quelqu'un (ou quelque chose) peut m'éclairer : à savoir est ce que je télécharge les sources d'alsa et je le recompile (à mon avis très mauvaise idée...)
OU
Je fixe les variables d'env. qui vont bien comme cela me l'est gentillement proposé par la sortie du ./configure...?

Merci d'avance.

--------------------
Pour info : tout ceci se passe sur un portable dell inspirion 640m, sous dapper
kernel 2.6.17-10-generic (le tout délesté de cet immonde autocollant vista-(in)capable...)

#15 Le 02/11/2006, à 17:20

siebe4

Re : Installer FreeBoB

j'oubliais

en faisant un ./configure --help
on obtient une liste des principales variables d'environnement (et la méthode pour les fixées)

Maintenant yapluka trouver quelle valeur fixer...

... si quelqu'un a une idée...

merci

#16 Le 27/03/2007, à 11:07

mr normal

Re : Installer FreeBoB

Bonjour tout le monde,
ravi de pas être seul dans la mewde !
super pas-à-pas ici :
http://dogbreath.free.fr/trucs.html
mais effetivement, les librairies semblent un peut récalcitrante.
Voilà ce que j'ai :

checking for LIBIEC61883... configure: error: Package requirements (libiec61883 >= 1.1.0) were not met:

Requested 'libiec61883 >= 1.1.0' but version of libiec61883 is 1.0.0

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBIEC61883_CFLAGS
and LIBIEC61883_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

il me faut donc installer à la main une nouvelle version de libiec61883 ?
Qqu'un a un chti pas à pas ?
Allez !

Pour moi Ubuntu (que j'adore !) ça serait plus pour faire du son que pour gérer le C++ !
On peut pas être partout !
Merci.

#17 Le 27/03/2007, à 16:58

mrnormal

Re : Installer FreeBoB

Bon, j'ai résolu mon changement de version de libiec61883 là :
http://packages.ubuntulinux.org/feisty/libdevel/libiec61883-dev.html
Mais j'ai du installer des paquets de feisty syr une version inférieure (6.10)
Est-ce mal ?
Voyons voir ce qu'en dit freebob ?