Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#51 Le 22/06/2011, à 20:28

Zuran67

Re : Virtual box ne marche pas...

Ok... problème maintenant que j'ai fais la manip à faire... ce truc me remarque ça...

"Please install the virtualbox-ose-dkms package and execute 'modprobe vboxdrv' as root."

Pfff... un coup ça marche mais c'est pas la bonne version, un autre coup ça marche mais on peut pas aller dans les fichiers communs... et ça maintenant... c'est quoi cette "chose"?!

On pouvait pas tou mettre dans un deb et hop on l'installe avec la logithèque et puis basta que ça aurait été plus simple?! Perte de temps inutile à se faire chier pour tout!

Hors ligne

#52 Le 22/06/2011, à 20:34

RegisBurin

Re : Virtual box ne marche pas...

Zuran67 a écrit :

Mais quand je met ça....


"sudo apt-get install virtualbox-guest-additions"

y me fout en l'air la VB 4 et met la VB OSE...

C'est normal?

Si j'ai bien compris il faut la 4 pas la OSE?

...

Dans la doc dont je donne le lien plus haut, il est bien marqué (dans la 2ème note importante):

http://doc.ubuntu-fr.org/virtualbox a écrit :

5.1 Améliorer l'émulation : les additions invité

[...]

Ce jeu de pilotes s'appelle les additions invité (en anglais : guest additions). Comme leur nom l'indique, c'est uniquement dans le système invité que les additions invité doivent être installés ; le système hôte n'en a pas besoin.

Après installation des additions invité, vous devez arrêter puis réamorcer votre système invité. Tant que le réamorçage de votre système invité n'est pas effectué, les additions invité demeurent inactifs.

L'installation se fait sur une machine en cours de fonctionnement :

    Dans le menu Périphériques → Installer les additions invité…
    Avec le raccourci touche hôte + D

VirtualBox va monter automatiquement une image ISO fournie avec l'émulateur. Si un message indique que les additions ne sont pas disponibles vous pouvez au choix :

    Accepter le téléchargement proposé
    Installer le paquet virtualbox-guest-additions Uniquement pour Virtualbox 3.1.6 !!

RTFM quoi !

Zuran67 a écrit :

Y a un gros bug quelque part là!

C'toi l'bug !! lol

@+

Edit: "...tout mettre dans un paquet deb et hop..." P'TAIN, C'EST DÉJÀ LE CAS !!!!

Dernière modification par RegisBurin (Le 22/06/2011, à 20:36)


Ma config (M-AUDIO Delta44/Wacom CTH661) | BabyBox[WIP]
Moi sur le web ("Régis est un cool") / Moi, IRL mais sur le web / Ma maison sur le web

Hors ligne

#53 Le 23/06/2011, à 10:03

Zuran67

Re : Virtual box ne marche pas...

Je suis paumé... faut tout reprende de A à Z...

IL faut quelle version de virtual box et faire quoi pour l'avoir? Là j'ai VB OSE...

On l'installe avec quelles commandes?

On fait quoi?

Puis après pour avoir des fichiers partagés on procède comment? Parce que là j'ai pas compris... et suivant la version que c'est de VB j'ai pas les même boutons... c'est quoi la touche ôte?

Génial... ça c'est de l'originalité!

"zuran@zuran-K70IJ:~$ deb http://download.virtualbox.org/virtualbox/debian natty contrib
Commande « deb » non trouvée, vouliez-vous dire :
La commande « debc » issue du paquet « devscripts » (main)
La commande « derb » issue du paquet « libicu-dev » (main)
La commande « dab » issue du paquet « bsdgames » (universe)
La commande « debi » issue du paquet « devscripts » (main)
La commande « xdeb » issue du paquet « xdeb » (universe)
deb : commande introuvable
zuran@zuran-K70IJ:~$ "

Et ça c'est en suivant la doc...

Dernière modification par Zuran67 (Le 23/06/2011, à 10:11)

Hors ligne

#54 Le 23/06/2011, à 10:24

Zuran67

Re : Virtual box ne marche pas...

Toujours en suivant la doc du site...


"zuran@zuran-K70IJ:~$ sudo apt-get install virtualbox-4.0
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Il est possible qu'un autre processus l'utilise.
zuran@zuran-K70IJ:~$ "

no comment...

Hors ligne

#55 Le 23/06/2011, à 11:06

RegisBurin

Re : Virtual box ne marche pas...

Bon... Là, c'est trop de boulot. Ton problème c'est que tu n'as même pas lu de doc concernant le fonctionnement de base de l'OS... Et là, je vais juste te ré-écrire la doc...

Zuran67 a écrit :

Je suis paumé... faut tout reprende de A à Z...

C'est le mieux.
Donc, on recommence une énième (et dernière) fois: Désinstalle tout ce qui concerne virtualbox (via Synaptic, recherche "virtualbox" et vire tout)

Zuran67 a écrit :

IL faut quelle version de virtual box et faire quoi pour l'avoir? Là j'ai VB OSE...

On l'installe avec quelles commandes?

On fait quoi?

Il faut le paquet virtualbox-4.0 (comme indiqué dans la doc)
Pour l'installer il faut ajouter dans les sources le PPA stipulé dans la doc et sa clé, en faisant strictement ce que dit la doc:

sudo echo "deb http://download.virtualbox.org/virtualbox/debian `lsb_release -sc` contrib" | sudo tee -a /etc/apt/sources.list
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 98AB5139
sudo apt-get update
sudo apt-get install virtualbox-4.0

Normalement, via cette procédure, ça te demande (je crois) si tu veux créer/ajouter un utilisateur/groupe vboxuser. Et ça dois aussi te demander si tu veux rajouter ton compte à ce groupe. C'est essentiel si tu veux pouvoir utiliser les ports USB, le partage, etc...

Si ça ne te demande pas, ou si tu ne sais pas, voit la doc, ou reposte ici.

Zuran67 a écrit :

c'est quoi la touche ôte?

C'est pas marqué assez gros dans la doc?

la doc de virtualbox a écrit :

Description des principales commandes
La Touche Hôte est par défaut la touche Ctrl droite (votre clavier a 2 touches Ctrl, il faut utiliser la touche Ctrl de droite!).

Mais c'est modifiable dans les préférence de l'application.

Zuran67 a écrit :

zuran@zuran-K70IJ:~$ deb http://download.virtualbox.org/virtualbox/debian natty contrib
[...]
Et ça c'est en suivant la doc...

NON! ça c'est en extrapolant la doc, quand on ne comprend pas ce qu'est un dépôt logiciel, et comment le rajouter... (alors que la doc donne un moyen de ne même pas s'en soucier, c'est fait dans la première commande que je donne au dessus "echo deb...")

Zuran67 a écrit :

Toujours en suivant la doc du site...

"zuran@zuran-K70IJ:~$ sudo apt-get install virtualbox-4.0
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Il est possible qu'un autre processus l'utilise.

Ca c'était presque bon (à part que tu suivais les 2 tutos, pour les 2 versions à la fois, forcément, ça pouvait pas marcher au bout du compte...)
Après, le message d'erreur indique juste que tu as déjà un utilitaire de gestion de paquets en cours d'utilisation (synaptic ouvert, apt-get en cours dans un autre terminal, etc...). On ne peut lancer qu'un outil de gestion de paquet à la fois (une rapide recherche avec le message d'erreur t'aurais tout de suite dit de quoi il en retournait).

Pour les "additions invités" (qui permettent la prise en charge de la résolution de l'écran virtuel, les ports USB, le partage, etc...), je te renvoie (une nouvelle fois) à mon post #52 et à la doc:

la doc, §5.1 a écrit :

L'installation se fait sur une machine en cours de fonctionnement :

    Dans le menu Périphériques → Installer les additions invité

VirtualBox va monter automatiquement une image ISO fournie avec l'émulateur. Si un message indique que les additions ne sont pas disponibles vous pouvez...

    Accepter le téléchargement proposé

Zuran67 a écrit :

Puis après pour avoir des fichiers partagés on procède comment? Parce que là j'ai pas compris...

La doc:

La doc §Utilisation a écrit :

Partage de dossiers entre Windows et Linux (version ex-PUEL)
Lancer Virtualbox ex-PUEL
Sélectionner la machine virtuelle Windows. Dans la fenêtre de droite, cliquez sur Dossiers partagés. Cliquer sur le dossier à droite avec la croix verte. Dans la nouvelle fenêtre, cliquer sur la flèche et autres. Sélectionner votre dossier.
Lancer Windows
Aller dans Démarrer, et cliquer droit sur Poste de travail, puis se connecter à un lecteur réseau. Sélectionner Parcourir, puis virtualbox Shared Folders, ensuite cliquer sur les + jusqu'à retrouver le nom du dossier que vous voulez partager. Cliquer sur ok.

(Je vois difficillement comment faire plus compréhensible...)

Zuran67 a écrit :

no comment...

Effectivement, no comment...

@+

Dernière modification par RegisBurin (Le 23/06/2011, à 11:10)


Ma config (M-AUDIO Delta44/Wacom CTH661) | BabyBox[WIP]
Moi sur le web ("Régis est un cool") / Moi, IRL mais sur le web / Ma maison sur le web

Hors ligne

#56 Le 23/06/2011, à 11:54

Zuran67

Re : Virtual box ne marche pas...

Alors j'ai tout supprimé comme dit...

J'ai lancé les commandes, ça passe pour les deux premières (j'ai bien un seul terminal d'ouvert).

Voici la troisième à la fin.

"W: Impossible de récupérer cdrom://Ubuntu 11.04 _Natty Narwhal_ - Release i386 (20110427.1)/dists/natty/restricted/binary-i386/Packages  Veuillez utiliser apt-cdrom afin de faire reconnaître ce cédérom par votre APT. apt-get update ne peut être employé pour ajouter de nouveaux cédéroms

W: Impossible de récupérer http://download.virtualbox.org/virtualb … ty/Release  Impossible de trouver l'entrée « contrib/source/Sources » attendue dans le fichier « Release » :  ligne non valable dans sources.list ou fichier corrompu

W: Impossible de récupérer http://download.virtualbox.org/virtualb … ck/Release  Impossible de trouver l'entrée « contrib/source/Sources » attendue dans le fichier « Release » :  ligne non valable dans sources.list ou fichier corrompu

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
zuran@zuran-K70IJ:~$ "

Hors ligne

#57 Le 23/06/2011, à 12:20

RegisBurin

Re : Virtual box ne marche pas...

La première ligne, c'est un autre problème (bizarre en plus, et qui doit être lié à une bidouille récente, sinon, il te mettrait ça depuis le premier jour)... qui n'a rien à voir avec l'install de virtualbox. Il cherche à explorer le cd-rom d'installation d'Ubuntu...

Va dans Synaptic Configuration>Dépôts (ou depuis le menu utilisateur d'Ubuntu Administration>sources de logiciels, ou encore par la logithèque... c'est aussi expliqué dans la doc big_smile ) décoche la ligne "CDROM" qui doit être dans le premier onglet.

Pour les 2 autres messages, déjà il t'indique que tu essaies de choper le paquet sur 2 versions différentes d'Ubuntu (Maverick!!? et Natty). Je ne sais pas ce que tu as fait pour avoir une ligne de dépôt vers Ubuntu10.10, mais c'est pas grave. On va le faire à la main.

Va dans Synaptic Configuration>Dépôts>onglet "logiciels de tierces parties" (ou via le menu utilisateur, ou la logithèque), puis supprimes toutes les lignes concernant virtualbox, et ajoute en une avec dans la "Ligne APT":

deb http://download.virtualbox.org/virtualbox/debian natty contrib

Ferme Synaptic, relance la mise à jour et installe VB:

sudo apt-get update
sudo apt-get install virtualbox-4.0

Puis suis le reste du tuto.

@+

Edit: Sur le fourm, les messages systèmes ou ligne de terminal peuvent être mis entre balises code (le bouton <> au dessus de la fenêtre d'édition des messages). C'est vraiment plus lisible. Merci.

Dernière modification par RegisBurin (Le 23/06/2011, à 12:24)


Ma config (M-AUDIO Delta44/Wacom CTH661) | BabyBox[WIP]
Moi sur le web ("Régis est un cool") / Moi, IRL mais sur le web / Ma maison sur le web

Hors ligne

#58 Le 23/06/2011, à 12:50

Zuran67

Re : Virtual box ne marche pas...

Je n'ai pas "logiciels de tiers partie." (interface gnome.)

Qu'est-ce que la "Ligne APT"?

Hors ligne

#59 Le 23/06/2011, à 12:56

RegisBurin

Re : Virtual box ne marche pas...

Désolé, mais là (pour le moment) je peux plus... hmm

Je t'ai donné trois façons de faire différentes pour modifier les sources (approximatives parce que je te dépanne de mémoire là, et sur un OS que je n'ai pas, mais quand même), et surtout un lien vers la doc (que je remets là:  http://doc.ubuntu-fr.org/tutoriel/comme … ources_maj , je suis plus à ça prêt...)

Non, sérieux, je suis blasé là, j'abandonne (pour aujourd'hui)...

@+

Edit: Sans dec' si on renvoie à la doc pour aider, c'est parce qu'elle existe, qu'elle pas si mal écrite, et pour éviter d'avoir à la ré-écrire dans le forum à chaque question "banale" de chaque topic sur le même problème, si tu ne fais pas l'effort de lire ce qu'on te donne comme aide (déjà rien que par curiosité), on ne peut pas t'aider plus...

Ha tu peux te fout' des blondes en signature, hein...!

Sans dec'...

Dernière modification par RegisBurin (Le 23/06/2011, à 13:03)


Ma config (M-AUDIO Delta44/Wacom CTH661) | BabyBox[WIP]
Moi sur le web ("Régis est un cool") / Moi, IRL mais sur le web / Ma maison sur le web

Hors ligne

#60 Le 23/06/2011, à 13:41

Zuran67

Re : Virtual box ne marche pas...

Je vais laisser tomber... c'est vraiment la merde ce truc! On peut pas l'installer tranquillement, obligé d'être aidé...

Je prendrai une tour sous seven, au moins comme ça je pourrai jouer, mais au prix fort! (quoi que cette grosse merde codée par des connards qui pensent qu'à passer sous le bureau des patrons qui sont à la botte des système tout sécuritaires totalitaires ont fait en sorte de pas pouvoir utiliser un crack sur un jeu... bien, pour un gamer qui veut pas perdre de temps dans ses piles de jeux c'est super... surtout s'il perd un jeux ou s'il a un problème etc...)<= je dis ça parce que... deux fois j'ai vu une telle aberration... ce genre de truc je considère ça comme une forme de fascisme dirigé contre la liberté de choisir entre deux trucs simples... de l'espionnage et de du harcèlement qui oblige à racheter un truc si on le perd (la loi autorise une copie personnelle mais sans un crack un jeu dl est inutile.(qui a été acheté bien sûr!<=application des droits.)<=donc faut acheter à nouveau en cas de perte car le crack est inutile<=donc consommer etc... notre cher nabo facho avec ses copains microsoft (il leur passe sous le bureau comme avec les chinois) ont faits fort!

Ça mériterait des pétitions avec plaintes en masse au cul ça! Des millions de gamers, plus des gens autours... mais bon, même là c'est eux qui gagneraient...

Dernière modification par Zuran67 (Le 23/06/2011, à 13:43)

Hors ligne

#61 Le 23/06/2011, à 14:05

RegisBurin

Re : Virtual box ne marche pas...

Attends... tout ça c'était pour pouvoir jouer ?

T'es conscient que sur une machine virtuelle tu ne "peux" pas jouer... La machine virtuelle utilise des périphériques virtuels (elle émule des chipset "classiques", déjà pas assez puissants sur une machine réelle pour faire tourner le moindre FPS de moins de 5 ans), et tourne avec la RAM maximum déclarée à la création de la machine (et la ram virtuelle dédiée à la vidéo n'excède pas 64Mo, je crois), et ne permet pas de faire tourner des jeux récents... A part si tu voulais faire tourner des baldur's gate ou autre Diablo II (grand max), il fallait le dire dès le début, on t'aurait dissuadé tout de suite (et on t'aurait conseillé Wine ou un dual-boot), et, surtout, on aurait pas passé 3 pages à tenter de t'expliquer les choses...

Quant au reste de ton message (si je n'en pense pas moins) il n'a rien à faire dans ce fil. Les coups de gueule, c'est dans "le café" ou "l'éphémère".

@+

Dernière modification par RegisBurin (Le 23/06/2011, à 14:07)


Ma config (M-AUDIO Delta44/Wacom CTH661) | BabyBox[WIP]
Moi sur le web ("Régis est un cool") / Moi, IRL mais sur le web / Ma maison sur le web

Hors ligne

#62 Le 23/06/2011, à 18:07

L_d_v_c@

Re : Virtual box ne marche pas...

Zuran67 a écrit :

Je vais laisser tomber... c'est vraiment la merde ce truc! On peut pas l'installer tranquillement, obligé d'être aidé...
...

Alt F2 ouvre une fenêtre où tu tapes gksudo synaptic + touche Entrée
mets le mot de passe administrateur + touche Entrée
tape directement virtualb (qui fait apparaître virtualbox-ose en première ligne que tu valides par touche Entrée puis clic bouton Ajouter à la sélection pour les dépendances)
puis un clic sur bouton Appliquer puis un nouveau clic sur le nouveau Appliquer

Ça fait 3 clic et 3 touche Entrée, je ne trouve pas cela trop compliqué ou fastidieux... wink

Je te recommande de relire le PDF de simple comme Ubuntu.


Plus rien sur 1001HA ni sur K50IE ; Ubuntu Studio 12.04 MAO. sur E6600
CentOS 6.5 sur Tyan S2915E RAID 5
Pourquoi Linux
Bug -1 : Derrière chaque bogue se cache constamment la faille humaine !

Hors ligne

#63 Le 23/06/2011, à 18:08

Zuran67

Re : Virtual box ne marche pas...

Ben star wars empire at war quand même...

Pour wine c'est strictement impossible, j'ai déjà installé, ça ne marche pas même avec les jeux qu'ils disent donc jouer c'est impossible.

J'ai testé, ça n'a pas marché, donc pour moi perso c'est pas possible.

Merci beaucoup de cette aide, même si c'était pas possible finalement de jouer... (ce qui est dommage...)

Dernière modification par Zuran67 (Le 23/06/2011, à 18:08)

Hors ligne

#64 Le 23/06/2011, à 18:59

L_d_v_c@

Re : Virtual box ne marche pas...

ok mais ce n'est pas de la m... wink


Plus rien sur 1001HA ni sur K50IE ; Ubuntu Studio 12.04 MAO. sur E6600
CentOS 6.5 sur Tyan S2915E RAID 5
Pourquoi Linux
Bug -1 : Derrière chaque bogue se cache constamment la faille humaine !

Hors ligne

#65 Le 23/06/2011, à 19:55

RegisBurin

Re : Virtual box ne marche pas...

Zuran67 a écrit :

Ben star wars empire at war quand même...

Pour wine c'est strictement impossible, j'ai déjà installé, ça ne marche pas même avec les jeux qu'ils disent donc jouer c'est impossible.

J'ai testé, ça n'a pas marché, donc pour moi perso c'est pas possible.

Pas parce que t'as pas réussi que c'est pas faisable (nuance)... , il est en Gold sur certaines versions... Faut juste lire les docs, et poser les bonnes questions...

Zuran67 a écrit :

Merci beaucoup de cette aide, même si c'était pas possible finalement de jouer... (ce qui est dommage...)

La faute aux éditeurs qui ne font pas porter leur jeux sur nos plateformes... certainement pas l'inverse !

@+


Ma config (M-AUDIO Delta44/Wacom CTH661) | BabyBox[WIP]
Moi sur le web ("Régis est un cool") / Moi, IRL mais sur le web / Ma maison sur le web

Hors ligne

#66 Le 23/06/2011, à 20:12

L_d_v_c@

Re : Virtual box ne marche pas...

RegisBurin a écrit :

La faute aux éditeurs qui ne font pas porter leur jeux sur nos plateformes... certainement pas l'inverse !

@+

+9^9^9


Plus rien sur 1001HA ni sur K50IE ; Ubuntu Studio 12.04 MAO. sur E6600
CentOS 6.5 sur Tyan S2915E RAID 5
Pourquoi Linux
Bug -1 : Derrière chaque bogue se cache constamment la faille humaine !

Hors ligne

#67 Le 10/07/2011, à 12:44

topouaibe

Re : Virtual box ne marche pas...

mmmh, je précise qd même : j'ai ajouté la ligne du dépôt dans le gestionnaire Synaptic et j'avais une erreur   "Impossible de trouver l'entrée « contrib/source/Sources » attendue dans le fichier « Release » :  ligne non valable dans sources.list ou fichier corrompu"

comme je n'aime pas installer des deb directement, je suis allé faire un tour dans le /etc/apt/sources.list  , et si on commente (# en début de ligne) la ligne de source, ça passe alors comme par magie !

Hors ligne

Haut de page ↑