Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 22/05/2005, à 16:14

wam

[résolu]partition swap mal formattée

J'ai installé ubuntu mais mon ordi a une fâcheuse tendance à ramer, alors qu'il n'est pas complètement HS je crois (256 de ram, athlon2500+)
j'ai donc fait un petit tour sur le "moniteur système" qui me signale que la ram est untilisée à 75% en moyenne, mais la swap à 0.
après un petit tour sur ce forum, je lance kinfocenter, qui me précise dans la section "memory"
total swap memory:0 bytes
free swap memory:0 bytes

alors là je ne comprends pas, je croyais pourtant avoir correctement réalisé mon installation
voici mon /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda2       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda4       /dos            vfat    defaults,umask=0 0       0
/dev/hda1       /windows        vfat    defaults        0       0
/dev/hda3       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 ro,user,noauto  0       0
/dev/hdd        /media/cdrom1   udf,iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

ah, ok, gparted me signale que j'ai une partition de 477Mo de type inconnu sur /dev/hda3

qu'est ce que vous en pensez? /etc/fstab c'est un fichier d'information ou ça dit ce qu'il y a vraiment sur le disque?

Qu'est ce que vous me conseillez de faire pour résoudre ce problème sans tout faire planter?

Dernière modification par wam (Le 28/05/2005, à 00:13)

Hors ligne

#2 Le 22/05/2005, à 16:24

ZeBob

Re : [résolu]partition swap mal formattée

hum une fois quand j'ai installer ubuntu j'avais oublié de créer un swap...mais la ram n'était pas pour autant surchargée.
dans ton cas essaye de formater /dev/hda3 en swap

Hors ligne

#3 Le 22/05/2005, à 16:27

wam

Re : [résolu]partition swap mal formattée

le problème c'est que je viens de me rappeler que j'ai déjà eut ce problème, et que j'avais réussi à tout formater avec gparted au lieu de refaire la swap.
Quel logiciel est le plus adapté pour faire ce genre de choses?

Hors ligne

#4 Le 22/05/2005, à 16:38

ZeBob

Re : [résolu]partition swap mal formattée

essaye avec cfdisk (dans un terminal)

Dernière modification par ZeBob (Le 22/05/2005, à 16:38)

Hors ligne

#5 Le 22/05/2005, à 17:07

wam

Re : [résolu]partition swap mal formattée

mais c'est quand même bizarre que cette partition ne soit pas reconnue non alors que je ne l'ai pas oubliére à l'install?
surtout si c'est la 2éme fois que ça se produit
ça me parait louche tout ça

Hors ligne

#6 Le 22/05/2005, à 17:20

cep

Re : [résolu]partition swap mal formattée

D'après ton fstab ta partition de swap est présente sur hda3.

Tu peux éventuellement le vérifier par sudo fdisk -l (ou sudo fdisk -l /dev/hda) et vérifier aussi son utilisation en lançant de nombreuses application et tapper ensuite free en console.

Voir aussi man swapon.

Hors ligne

#7 Le 22/05/2005, à 18:57

wam

Re : [résolu]partition swap mal formattée

fdisk -l me retourne
Disque /dev/hda: 81.9 Go, 81964302336 octets
16 têtes, 63 secteurs/piste, 158816 cylindres
Unités = cylindres de 1008 * 512 = 516096 octets

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/hda1   *           1       19376     9765472+   7  HPFS/NTFS
/dev/hda2           19377       38752     9765504   83  Linux
/dev/hda3           38753       39721      488376   83  Linux
/dev/hda4           39722      158816    60023880    c  W95 FAT32 (LBA)

et swapon refuse d'utiliser hda3:
nous@machine:~ $ sudo swapon -a
Password:
swapon: /dev/hda3: Argument invalide

je me demande en quoi a été formaté cette partition...
d'autant que ça n'est même pas moi qui ai réécrit le fstab pour mettre swap

Hors ligne

#8 Le 22/05/2005, à 18:59

wam

Re : [résolu]partition swap mal formattée

pour ce qui est de cfdisk, il me retourne

  Nom         Fanions    Part Type  Type SF          [Étiq.]        Taille (Mo)
------------------------------------------------------------------------------
    hda1        Amorce      Primaire  NTFS             []               9999,88
    hda2                          Primaire  Linux ext3                       9999,88
    hda3                          Primaire  Linux                              500,10
    hda4                          Primaire  W95 FAT32 (LBA)             61464,46

ça signifie quoi pour vous "linux" pour hda3?

Dernière modification par wam (Le 22/05/2005, à 19:01)

Hors ligne

#9 Le 22/05/2005, à 19:38

cep

Re : [résolu]partition swap mal formattée

/dev/hda3           38753       39721      488376   83  Linux

Swap est en 82.
Il semble donc que tu doives démonter puis mkswap.
Ou, si tu préferres, tu redémarres avec un live cd et tu formates hda3 (82)

Hors ligne

#10 Le 28/05/2005, à 00:12

wam

Re : [résolu]partition swap mal formattée

c'est bon, ça marche en reformatant, merci

Hors ligne

Haut de page ↑