Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 31/05/2005, à 12:16

marathonien errant

Xfree86-Dri???

Bonjour à tous!
Je tourne sous le xorg livré avec Hoary avec xfce mais certaines applis (dont glxgears) me renvoient ce message: Xlib: extension "XFree86-DRI" missing on display ":0.0" . Je n'ai pourtant aucun pb d'affichage sous X. Du coup, tout les jeux tournent au ralenti et glxgears plafonne à  soit 37000fps.
Bon je sais ce n'est ni très précis ni très clair, mais je suis débutant hein...:rolleyes:
Merci de votre aide!


You never know what you can do until you try.
http://doc.ubuntu-fr.org/windowmaker

Hors ligne

#2 Le 01/06/2005, à 02:51

Stemp

Re : Xfree86-Dri???

37000 fps, moi qui n'arrive jamais au dessus de 1100 lol
Pour pouvoir t'aider il faudrait un peu plus d'informations, carte graphique, driver utilisé, etc....
Regarde un peu ton log xorg (/var/log/Xorg.0.log, je crois) pour essayer de voir si tu n'as pas un autre message d'erreur.


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#3 Le 05/06/2005, à 04:04

LordFarquaad

Re : Xfree86-Dri???

Hello

Plusieurs jours que j'essaie un peu tout pour avoir une bonne config pour mon ati9600 mais rien ne va... Hier encore le seul moyen d'avoir une résolution convenable était de laisser Driver "ati" dans mon xorg.conf (ce qui foncionnait en 1280*1024), sinon je me retrouvais en 640*480, et quand je voulais monter en 1024 (la seule autre possibilité que m'offrait xrandr), cela fonctionnait en mode défilement (je connais pas le nom approprié mais c'est le truc avec l'écran qui défile quand on approche la souris du bord, pour émuler une résolution supérieure).

Aujourd'hui j'ai suivi ton ton tutoriel pour les radeon sur le wiki (merci ;-)) mais bon à part avoir désinstallé mes drivers fglrx et avoir mis radeon à la place de ati dans mon xorg.conf, je vois pas ce qui a changé... J'ai le même problème que le marathonien ci-dessus, avec glxgears qui plafonne à 361.6fps (768.4 quand je minimise la ch'tite animation big_smile) et le cpu à 100% pendant le test... En gros les copains pourraient toujours rire de moi roll

Alors dans /var/log/Xorg.0.log, on ne trouve pas d'erreur, juste quelques warnings:
- problèmes de chargements de certains fonts
- (WW) Open APM failed (/dev/apm_bios) (No such file or directory)
- après "(II) All system resource ranges":

(WW) Ignoring request to load module GLcore

- juste après la liste des cg radeon supportées, y a ceci:

(II) Primary Device is: PCI 02:00:0
(WW) RADEON: No matching Device section for instance (BusID PCI:2:0:1) found
(--) Chipset ATI Radeon 9600 AP (AGP) found

- et vers la fin:

(==) RADEON(0): Write-combining range (0xc0000000,0x8000000)
(WW) RADEON(0): Direct rendering not yet supported on Radeon 9500 and newer cards
(II) RADEON(0): Memory manager initialized to (0,0) (1280,8191)

J'ai beaucoup chipotté à mon xorg.conf, restauré des backups etc. mais bon je crois qu'il est pas dans un trop mauvais état, donc tant que j'y suis je le colle ici:

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"type1"
	Load	"v4l"
	Load	"vbe"
EndSection

Section "Extensions"
   Option "RENDER" "Enable"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"be"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "Device"
	Identifier	"ATI Technologies, Inc. Radeon 9600 (R300 AP)"
	Driver		"radeon"
	BusID		"PCI:2:0:0"
EndSection

Section "Monitor"
	Identifier	"Proview Electronics 786N"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies, Inc. Radeon 9600 (R300 AP)"
	Monitor		"Proview Electronics 786N"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1200x800" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1200x800" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1200x800" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1200x800" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1200x800" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1200x800" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection

Hors ligne

#4 Le 05/06/2005, à 09:50

Stemp

Re : Xfree86-Dri???

Salut,

Malheureusement pour toi, conçernant le driver "radeon" :

Cartes ne supportant que la 2D

RV350 : Radeon 9600PRO/9600SE/9600, M10/M11, FireGL T2

Pour la 3D, il va te falloir utiliser les drivers fglrx, voir le wiki (de Kagou) : http://wiki.ubuntu-fr.org/materiel/ati

Ensuite peut-être ce post (voir le 3ème mssage).


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#5 Le 05/06/2005, à 10:00

LordFarquaad

Re : Xfree86-Dri???

Merci, j'avais essayé la procédure ati proposée sur le wiki mais ça n'avait pas marché... (d'ailleurs cette page a changé de nom et il y a plein d'autres pages qui y faisaient référence, que ce soit dans le wiki, sur les forums ou ailleurs... il faudrait mettre en place une redirection)
Pour ce qui est du post que tu propose je l'avais un peu survolé, enfin bon je vais réessayer encore alors ;-)

Et si ça marche, je vais pouvoir encore m'amuser avec mon deuxième écran, basculé de 90° dans le sens des aiguilles d'une montre big_smile

(beuh je voudrais un bouton "prévisualisation" dans le formulaire de réponse rapide moi)

Hors ligne

Haut de page ↑