Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#2526 Le 20/05/2019, à 09:37

DjDeViL

Re : Script d'installation pour imprimantes Brother

J'ai fait le script de la première page.

djdevil@Ryzen1600:~$ wget https://bitbucket.org/demonipuch/brprinter-installer/get/master.zip
--2019-05-20 09:30:50--  https://bitbucket.org/demonipuch/brprinter-installer/get/master.zip
Résolution de bitbucket.org (bitbucket.org)… 18.205.93.1, 18.205.93.0, 18.205.93.2, ...
Connexion à bitbucket.org (bitbucket.org)|18.205.93.1|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 5475 (5,3K) [application/zip]
Enregistre : «master.zip»

master.zip          100%[===================>]   5,35K  --.-KB/s    ds 0s      

2019-05-20 09:30:50 (623 MB/s) - «master.zip» enregistré [5475/5475]

djdevil@Ryzen1600:~$ unzip master.zip
Archive:  master.zip
6e4cce8c163b04b0896286f6a76352a675505732
   creating: demonipuch-brprinter-installer-6e4cce8c163b/
 extracting: demonipuch-brprinter-installer-6e4cce8c163b/.gitignore  
  inflating: demonipuch-brprinter-installer-6e4cce8c163b/brprinter-installer  
djdevil@Ryzen1600:~$ cd demonipuch-brprinter-installer-*
djdevil@Ryzen1600:~/demonipuch-brprinter-installer-6e4cce8c163b$ sudo bash brprinter-installer
[sudo] Mot de passe de djdevil : 
Entrez votre modèle : DCP-L2510D
Sélectionner le type de connectivité : [0] USB - [1] Réseau
Entrez votre choix : 0
Téléchargement des pilotes de l'imprimante
 * Recherche des pilotes...                                              [ OK ] 
 * Téléchargement du paquet : dcpl2510dpdrv-4.0.0-1.i386.deb...          [ OK ] 
 * Téléchargement du paquet : brscan4-0.4.7-1.amd64.deb...               [ OK ] 
 * Téléchargement du paquet : brscan-skey-0.2.4-1.amd64.deb...           [ OK ] 
 * Téléchargement du paquet : brother-udev-rule-type1-1.0.0-1.all.deb... [ OK ] 
Vérification des pré-requis
 * Mise à jour de la liste des paquets...                                [ OK ] 
 * Recherche du paquet 'multiarch-support' sur votre système...          [ OK ] 
 * Recherche du paquet 'lib32stdc++6' sur votre système...               [ OK ] 
 * Recherche du paquet 'cups' sur votre système...                       [ OK ] 
 * Recherche du paquet 'sane-utils' sur votre système...                 [ OK ] 
 * Recherche du paquet 'libusb-0.1-4' sur votre système...               [ OK ] 
 * Recherche du dossier '/usr/share/cups/model' sur votre système...     [ OK ] 
 * Recherche du dossier '/var/spool/lpd' sur votre système...            [ OK ] 
Installation des pilotes
 * Installation du paquet : dcpl2510dpdrv-4.0.0-1.i386.deb...            [ OK ] 
 * Installation du paquet : brscan4-0.4.7-1.amd64.deb...                 [ OK ] 
 * Installation du paquet : brscan-skey-0.2.4-1.amd64.deb...             [ OK ] 
 * Installation du paquet : brother-udev-rule-type1-1.0.0-1.all.deb...   [ OK ] 
Configuration de l'imprimante
 * Recherche d'un fichier PPD sur votre système...                       [ OK ] 
 * Ajout de l'imprimante DCP-L2510D...                                   [ OK ] 
Configuration du scanner
grep: /lib/udev/rules.d/60-libsane1.rules: Aucun fichier ou dossier de ce type
sed: impossible de lire /lib/udev/rules.d/60-libsane1.rules: Aucun fichier ou dossier de ce type
 * Copie des librairies nécessaires...                                          cp: '/usr/lib64/sane/libsane-brother4.so.1.0.7' et './libsane-brother4.so.1.0.7' identifient le même fichier
                                                                         [ OK ]

Le contenu de brprinter.log

C'est bien ce log là ?

1558337851-capture.png

# Ubuntu Codename : disco
# Architecture : x86_64
# Modèle de l'imprimante : DCP-L2510D
# Connexion : USB
# Fichier d'informations : http://www.brother.com/pub/bsc/linux/infs/DCPL2510D
 - Paquet trouvé : dcpl2510dpdrv-4.0.0-1.i386.deb
 - Paquet trouvé : brscan4-0.4.7-1.amd64.deb
 - Paquet trouvé : brscan-skey-0.2.4-1.amd64.deb

# Téléchargement du paquet : dcpl2510dpdrv-4.0.0-1.i386.deb
--2019-05-20 09:31:46--  http://www.brother.com/pub/bsc/linux/packages/dcpl2510dpdrv-4.0.0-1.i386.deb
Résolution de www.brother.com (www.brother.com)… 23.38.7.33
Connexion à www.brother.com (www.brother.com)|23.38.7.33|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 122972 (120K)
Enregistre : «/home/djdevil/demonipuch-brprinter-installer-6e4cce8c163b/./packages/dcpl2510dpdrv-4.0.0-1.i386.deb»

     0K .......... .......... .......... .......... .......... 41% 2,35M 0s
    50K .......... .......... .......... .......... .......... 83% 2,35M 0s
   100K .......... ..........                                 100% 8,45M=0,04s

2019-05-20 09:31:46 (2,67 MB/s) - «/home/djdevil/demonipuch-brprinter-installer-6e4cce8c163b/./packages/dcpl2510dpdrv-4.0.0-1.i386.deb» enregistré [122972/122972]


# Téléchargement du paquet : brscan4-0.4.7-1.amd64.deb
--2019-05-20 09:31:46--  http://www.brother.com/pub/bsc/linux/packages/brscan4-0.4.7-1.amd64.deb
Résolution de www.brother.com (www.brother.com)… 23.38.7.33
Connexion à www.brother.com (www.brother.com)|23.38.7.33|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 88038 (86K) [application/x-troff-man]
Enregistre : «/home/djdevil/demonipuch-brprinter-installer-6e4cce8c163b/./packages/brscan4-0.4.7-1.amd64.deb»

     0K .......... .......... .......... .......... .......... 58% 2,37M 0s
    50K .......... .......... .......... .....                100% 1,86M=0,04s

2019-05-20 09:31:46 (2,12 MB/s) - «/home/djdevil/demonipuch-brprinter-installer-6e4cce8c163b/./packages/brscan4-0.4.7-1.amd64.deb» enregistré [88038/88038]


# Téléchargement du paquet : brscan-skey-0.2.4-1.amd64.deb
--2019-05-20 09:31:46--  http://www.brother.com/pub/bsc/linux/packages/brscan-skey-0.2.4-1.amd64.deb
Résolution de www.brother.com (www.brother.com)… 23.38.7.33
Connexion à www.brother.com (www.brother.com)|23.38.7.33|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 50852 (50K) [application/x-troff-man]
Enregistre : «/home/djdevil/demonipuch-brprinter-installer-6e4cce8c163b/./packages/brscan-skey-0.2.4-1.amd64.deb»

     0K .......... .......... .......... .......... ......... 100% 2,34M=0,02s

2019-05-20 09:31:47 (2,34 MB/s) - «/home/djdevil/demonipuch-brprinter-installer-6e4cce8c163b/./packages/brscan-skey-0.2.4-1.amd64.deb» enregistré [50852/50852]

# Téléchargement du paquet : brother-udev-rule-type1-1.0.0-1.all.deb
--2019-05-20 09:31:47--  http://www.brother.com/pub/bsc/linux/dlf/brother-udev-rule-type1-1.0.0-1.all.deb
Résolution de www.brother.com (www.brother.com)… 23.38.7.33
Connexion à www.brother.com (www.brother.com)|23.38.7.33|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 1490 (1,5K)
Enregistre : «/home/djdevil/demonipuch-brprinter-installer-6e4cce8c163b/./packages/brother-udev-rule-type1-1.0.0-1.all.deb»

     0K .                                                     100%  111M=0s

2019-05-20 09:31:47 (111 MB/s) - «/home/djdevil/demonipuch-brprinter-installer-6e4cce8c163b/./packages/brother-udev-rule-type1-1.0.0-1.all.deb» enregistré [1490/1490]

# Vérification des pré-requis
 - Paquet 'multiarch-support' installé
 - Paquet 'lib32stdc++6' installé
 - Paquet 'cups' installé
 - Paquet 'sane-utils' installé
 - Paquet 'libusb-0.1-4' installé

# Installation du paquet : dcpl2510dpdrv-4.0.0-1.i386.deb
(Lecture de la base de données... 189096 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../dcpl2510dpdrv-4.0.0-1.i386.deb ...
lpadmin : The printer or class does not exist.
Dépaquetage de dcpl2510dpdrv:i386 (4.0.0-1) sur (4.0.0-1) ...
Paramétrage de dcpl2510dpdrv:i386 (4.0.0-1) ...
lpadmin -p DCPL2510D -E -v usb://dev/usb/lp0 -P /usr/share/ppd/brother/brother-DCPL2510D-cups-en.ppd

# Installation du paquet : brscan4-0.4.7-1.amd64.deb
(Lecture de la base de données... 189096 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../brscan4-0.4.7-1.amd64.deb ...
Dépaquetage de brscan4 (0.4.7-1) sur (0.4.7-1) ...
Paramétrage de brscan4 (0.4.7-1) ...
This software is based in part on the work of the Independent JPEG Group.

# Installation du paquet : brscan-skey-0.2.4-1.amd64.deb
(Lecture de la base de données... 189096 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../brscan-skey-0.2.4-1.amd64.deb ...
Dépaquetage de brscan-skey (0.2.4-1) sur (0.2.4-1) ...
Paramétrage de brscan-skey (0.2.4-1) ...

# Installation du paquet : brother-udev-rule-type1-1.0.0-1.all.deb
(Lecture de la base de données... 189096 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../brother-udev-rule-type1-1.0.0-1.all.deb ...
Dépaquetage de brother-udev-rule-type1 (1.0.0-1) sur (1.0.0-1) ...
Paramétrage de brother-udev-rule-type1 (1.0.0-1) ...

# Recherche d'un fichier PPD
 - Fichier PPD : /opt/brother/Printers/DCPL2510D/cupswrapper/brother-DCPL2510D-cups-en.ppd

# Ajout de l'imprimante DCP-L2510D
 - Backup du fichier /etc/cups/printers.conf.O
 - Arret du service CUPS
 - Restauration du fichier printers.conf
 - Redémarrage du service CUPS
 - Restauration du fichier printers.conf.O

# Configuration du scanner
(Lecture de la base de données... 189096 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../brother-udev-rule-type1-1.0.0-1.all.deb ...
Dépaquetage de brother-udev-rule-type1 (1.0.0-1) sur (1.0.0-1) ...
Paramétrage de brother-udev-rule-type1 (1.0.0-1) ...
Adding ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes" to ${UDEV_RULES}

Hors ligne

#2527 Le 20/05/2019, à 12:08

fabux

Re : Script d'installation pour imprimantes Brother

Salut,

Etrange tout semble OK.
À tout hasard tu as bien redémarré PC et imprimantes ?

Sinon je pensais à un autre truc : tu serais pas sur USB 3?

Hors ligne

#2528 Le 20/05/2019, à 14:17

eric63

Re : Script d'installation pour imprimantes Brother

@ DjDeViL

/usr/lib64/sane/libsane-brother4.so.1.0.7

là je pense qu'on a un problême avec les trois lib libsane-brother qui ne sont pas dans le bon dossier (içi elles sont dans /usr/lib64/sane)
mais elles devraient être (comme tu as le paquet 64 bits brscan4)
dans /usr/lib/X86_64-linux-gnu/sane

Dernière modification par eric63 (Le 20/05/2019, à 14:26)


kdeïste convaincu avec Kubuntu 19.04 - 64 bits + backports = plasma 5.16.5 et KDE framaworks 5.62.0 Qt 5.12.2
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2529 Le 20/05/2019, à 15:44

DjDeViL

Re : Script d'installation pour imprimantes Brother

fabux a écrit :

Salut,

Etrange tout semble OK.
À tout hasard tu as bien redémarré PC et imprimantes ?

Sinon je pensais à un autre truc : tu serais pas sur USB 3?

Si je suis en USB 3 j'ai pas d'USB 2 derrière le pc et j'ai testé en USB 2 devant cela ne change pas au prob.

Si je veux imprimer une seule page:

L'imprimante se met en route pour imprimer mais elle tourne en boucle, elle prend le papier et elle me donne des pages blanches je dois annuler sur l'imprimante pour qu'elle s'arrête roll

Dernière modification par DjDeViL (Le 20/05/2019, à 15:44)

Hors ligne

#2530 Le 20/05/2019, à 15:48

DjDeViL

Re : Script d'installation pour imprimantes Brother

eric63 a écrit :

@ DjDeViL

/usr/lib64/sane/libsane-brother4.so.1.0.7

là je pense qu'on a un problême avec les trois lib libsane-brother qui ne sont pas dans le bon dossier (içi elles sont dans /usr/lib64/sane)
mais elles devraient être (comme tu as le paquet 64 bits brscan4)
dans /usr/lib/X86_64-linux-gnu/sane

1558359917-capture.png

/usr/lib/X86_64-linux-gnu/sane

Ce dossier n'existe pas chez moi hmm

Hors ligne

#2531 Le 20/05/2019, à 18:06

eric63

Re : Script d'installation pour imprimantes Brother

oui il s'agit bien de ces 3 libs
et c'est /usr/lib/x86_64-linux-gnu/sane désolé
la commande qui créer le dossier et copie les libs

sudo cp /usr/lib64/sane/* /usr/lib/x86_64-linux-gnu/sane

Dernière modification par eric63 (Le 20/05/2019, à 18:11)


kdeïste convaincu avec Kubuntu 19.04 - 64 bits + backports = plasma 5.16.5 et KDE framaworks 5.62.0 Qt 5.12.2
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2532 Le 20/05/2019, à 18:43

DjDeViL

Re : Script d'installation pour imprimantes Brother

Merci

Mais j'ai cela lorsque je fais la cmd hmm

djdevil@Ryzen1600:~$ sudo cp /usr/lib64/sane/* /usr/lib/x86_64-linux-gnu/sane
[sudo] Mot de passe de djdevil : 
cp: '/usr/lib64/sane/libsane-brother4.so' et '/usr/lib/x86_64-linux-gnu/sane/libsane-brother4.so' identifient le même fichier
cp: '/usr/lib64/sane/libsane-brother4.so.1' et '/usr/lib/x86_64-linux-gnu/sane/libsane-brother4.so.1' identifient le même fichier
cp: '/usr/lib64/sane/libsane-brother4.so.1.0.7' et '/usr/lib/x86_64-linux-gnu/sane/libsane-brother4.so.1.0.7' identifient le même fichier
djdevil@Ryzen1600:~$ 

Hors ligne

#2533 Le 20/05/2019, à 21:26

eric63

Re : Script d'installation pour imprimantes Brother

ça signifie que tu as déjà ces fichiers dans le dossier /usr/lib/x86_64-linux-gnu/sane/ ou qu'il y a un lien de créé


kdeïste convaincu avec Kubuntu 19.04 - 64 bits + backports = plasma 5.16.5 et KDE framaworks 5.62.0 Qt 5.12.2
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2534 Le 20/05/2019, à 21:51

DjDeViL

Re : Script d'installation pour imprimantes Brother

Ok c'est ce que je pensais mais l'imprimante ne fonctionne pas, elle se met en route mais tourne en boucle des pages blanches, le scanner lui fonctionne c'est déjà ça big_smile

Bon W10 d'office pour imprimer pour le moment j'espère que dans le temps, il sera nativement pris en charge par Ubuntu comme c'était le cas avec ma Samsung CLX 3300 smile

Hors ligne

#2535 Le 20/05/2019, à 23:03

eric63

Re : Script d'installation pour imprimantes Brother

tu as essayé tous les pilotes de ton imprimante ?
peut être aussi un problème avec le paquet ghostscript (faut voir avec les post de l'africain qui explique ça très bien)


kdeïste convaincu avec Kubuntu 19.04 - 64 bits + backports = plasma 5.16.5 et KDE framaworks 5.62.0 Qt 5.12.2
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2536 Le 21/05/2019, à 10:19

DjDeViL

Re : Script d'installation pour imprimantes Brother

yep j'ai tout installé ce que je pouvais roll

Hors ligne

#2537 Le 21/05/2019, à 10:28

fabux

Re : Script d'installation pour imprimantes Brother

au risque d'insister tu as redémarrer le tout (pc +imprimante) quand tu as testé en usb 2 ? je sais ça fais windows mais je ne me rappel plus la commande pour relancer le service utile à l'usb (il doit y avoir udev mais pas que)
sinon elle fait pas réseau ton imprimante à tout hasard ?

Hors ligne

#2538 Le 21/05/2019, à 10:55

jibel

Re : Script d'installation pour imprimantes Brother

@fabux,
Pour moi, cela a été toujours les ennuis d'installe des imprimantes avec +/- 4 fonctions! Peut importe de quelle marque il s'agit. Par contre le tuto de demonipuch a été au top pour les OSs libres. Malheureusement les PBs d'installes n'ont presque jamais étés résolus. C'est dommage, encore une fois, si on est dans Windows ou Mac pas de soucis, les marques fournissent un CD d'installe de leur matériel. Tout sera réalisé en QQs minutes pour installer les imprimantes! D'où peut bien provenir ces ennuis? Est-ce par zazar les intérêts financiers entre Microsoft et les marques d'imprimantes ?? Mystère ! Mais on en est pas bien loin ! Il faut des gars comme demonipuch de faire des scripts a Fd la caisse pour que les installes des imprimantes soient résolus et utilisés pour les OSs libres ?? Bon dac-o-dac mon commentaire n'a rien a faire  dans ce post, mille excuses @ +  wink


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur. Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit et toc !

Avec Mint.17.3, Xub 16.04, Voyager X2 et X8, Debian 9.9 stretch, MX-linux, Hybryde 14.04, Arco .PC medion akira  DD 1T + 2 .

Hors ligne

#2539 Le 21/05/2019, à 15:19

DjDeViL

Re : Script d'installation pour imprimantes Brother

fabux a écrit :

au risque d'insister tu as redémarrer le tout (pc +imprimante) quand tu as testé en usb 2 ? je sais ça fais windows mais je ne me rappel plus la commande pour relancer le service utile à l'usb (il doit y avoir udev mais pas que)
sinon elle fait pas réseau ton imprimante à tout hasard ?

J'avais pas redémarrer mais je l'ai fait et cela ne règle pas le pépin et non elle ne fait pas réseau, elle essentiellement utilisée comme photocopieuse mais parfois on a besoin d'imprimer.

J'ai un dual boot donc c'est pas très grave mais bon la flemme de redémarrer.

Le scanner fonctionne très bien lui et c'est déjà bien parce que je dois faire pas mal de pdf cool

J'espère qu'un jour l'imprimante sera intégré par défaut ma samsung clx-3300 ne fonctionnait pas sous ubuntu qq années après elle fonctionnait très bien sous Ubuntu smile

Dernière modification par DjDeViL (Le 21/05/2019, à 15:20)

Hors ligne

#2540 Le 21/05/2019, à 15:40

eric63

Re : Script d'installation pour imprimantes Brother

haha j'ai retrouvé les commandes pour le problème d'impression
essaye et reboot l'ordi

sudo rmdir /usr/share/ghostscript/9.25/iccprofiles
sudo apt-get install --reinstall libgs9-common

kdeïste convaincu avec Kubuntu 19.04 - 64 bits + backports = plasma 5.16.5 et KDE framaworks 5.62.0 Qt 5.12.2
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2541 Le 21/05/2019, à 16:09

ylag

Re : Script d'installation pour imprimantes Brother

@eric63:

Salut,

Ghostscript est probablement maintenant en version 9.26 ou 9.27; peut-être faut-il ajuster la commande en conséquence:

sudo rmdir /usr/share/ghostscript/9.2*/iccprofiles

?

Dernière modification par ylag (Le 21/05/2019, à 16:10)

Hors ligne

#2542 Le 21/05/2019, à 17:22

eric63

Re : Script d'installation pour imprimantes Brother

exact
ta commande est plus indiquée


kdeïste convaincu avec Kubuntu 19.04 - 64 bits + backports = plasma 5.16.5 et KDE framaworks 5.62.0 Qt 5.12.2
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2543 Le 21/05/2019, à 19:43

DjDeViL

Re : Script d'installation pour imprimantes Brother

djdevil@Ryzen1600:~$ sudo rmdir /usr/share/ghostscript/9.2*/iccprofiles
[sudo] Mot de passe de djdevil : 
rmdir: impossible de supprimer '/usr/share/ghostscript/9.26/iccprofiles': N'est pas un dossier

De toute façon c'est rm et pas rmdir la bonne cmd c'est celle ci

djdevil@Ryzen1600:~$ sudo rm /usr/share/ghostscript/9.2*/iccprofiles

Puis j'ai réinstallé le paquet c'est bien ça ?

djdevil@Ryzen1600:~$ sudo apt-get install --reinstall libgs9-common
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 5.094 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Réception de :1 http://be.archive.ubuntu.com/ubuntu disco-updates/main amd64 libgs9-common all 9.26~dfsg+0-0ubuntu7.1 [5.094 kB]
5.094 ko réceptionnés en 1s (6.398 ko/s)
(Lecture de la base de données... 189096 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libgs9-common_9.26~dfsg+0-0ubuntu7.1_all.deb ...
Dépaquetage de libgs9-common (9.26~dfsg+0-0ubuntu7.1) sur (9.26~dfsg+0-0ubuntu7.1) ...
Paramétrage de libgs9-common (9.26~dfsg+0-0ubuntu7.1) ...

J'ai redémarré et testé cela me fait le même bug hmm (page blanche en bloucle)

Dernière modification par DjDeViL (Le 21/05/2019, à 19:54)

Hors ligne

#2544 Le 21/05/2019, à 22:41

ylag

Re : Script d'installation pour imprimantes Brother

Salut,

DjDeViL a écrit :

De toute façon c'est rm et pas rmdir ...

Oui et non, le but de l'utilisation de rmdir était de vérifier si iccprofiles est un dossier au lieu d'être un lien symbolique, tel que créé correctement par l'installation/réinstallation du paquet libgs9-common.

Il arrivait lors d'une mise à niveau 16.04 -> 18.04 qu'un dossier iccprofiles soit conservé et empêche l'installation correcte du paquet libgs9-common.
Le but de la manip était de se débarasser de ce dossier, puis de réinstaller correctement libgs9-common qui contient iccprofiles.

A+

Dernière modification par ylag (Le 22/05/2019, à 13:28)

Hors ligne

#2545 Le 22/05/2019, à 00:24

DjDeViL

Re : Script d'installation pour imprimantes Brother

ok merci pour ton aide smile

Hors ligne

#2546 Le 25/05/2019, à 11:19

sinbad83

Re : Script d'installation pour imprimantes Brother

Bonjour à tous,
depuis que je suis passé en 18.04 je n'arrive plus à scanner avec la Brother MFC-490 CW.
Voilà ce qui est installé:

dpkg -l |grep Brother
ii  brscan-skey                                                 0.2.4-1                                      amd64        Brother Linux scanner S-KEY tool
ii  brscan3                                                     0.2.13-1                                     amd64        Brother Scanner Driver
ii  mfc490cncupswrapper:i386                                    1.1.2-2                                      i386         Brother CUPS Inkjet Printer Definitions
ii  mfc490cnlpr:i386                                            1.1.2-2                                      i386         Brother lpr Inkjet Printer Definitions
ii  printer-driver-brlaser                                      4-1                                          amd64        printer driver for (some) Brother laser printers
ii  printer-driver-ptouch                                       1.4.2-3                                      amd64        printer driver Brother P-touch label printers
ii  brscan-skey                                                 0.2.4-1                                      amd64        Brother Linux scanner S-KEY tool
ii  brscan3                                                     0.2.13-1                                     amd64        Brother Scanner Driver
ii  gawk                                                        1:4.1.4+dfsg-1build1                         amd64        GNU awk, a pattern scanning and processing language
ii  libcaribou-common                                           0.4.21-5                                     all          Configurable on screen keyboard with scanning mode - common files
ii  libcaribou0:amd64                                           0.4.21-5                                     amd64        Configurable on screen keyboard with scanning mode - library
ii  libsane-common                                              1.0.27-1~experimental3ubuntu2                all          API library for scanners -- documentation and support files
ii  libsane1:amd64                                              1.0.27-1~experimental3ubuntu2                amd64        API library for scanners
ii  mawk                                                        1.3.3-17ubuntu3                              amd64        a pattern scanning and text processing language
ii  netdiscover                                                 0.3beta7~pre+svn118-5                        amd64        active/passive network address scanner using ARP requests
ii  sane                                                        1.0.14-12build1                              amd64        scanner graphical frontends
ii  sane-utils                                                  1.0.27-1~experimental3ubuntu2                amd64        API library for scanners -- utilities
ii  simple-scan                                                 3.28.0-0ubuntu1                              amd64        Simple Scanning Utility
ii  xsane                                                       0.999-5ubuntu2                               amd64        featureful graphical frontend for SANE (Scanner Access Now Easy)
dpkg -l sane-utils simple-scan xsane
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                    Version          Architecture     Description
+++-======================-================-================-=================================================
ii  sane-utils             1.0.27-1~experim amd64            API library for scanners -- utilities
ii  simple-scan            3.28.0-0ubuntu1  amd64            Simple Scanning Utility
ii  xsane                  0.999-5ubuntu2   amd64            featureful graphical frontend for SANE (Scanner A

Voilà ce que voit l'ordinateur!

brscan-skey  -l
 SCANNER           : brother3:net1;dev0  : 192.168.123.30       Active
 MFC-490CN         : brother3:net1;dev1  : 192.168.123.30       Active
 scanimage -L
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

sudo sane-find-scanner tool
  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

Merci à ceux qui peuvent aider.


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop  8x AMD FX-8120, RAM 8GB, Ubuntu 18.04 et Ten,   HP Pavillon G6 U18.04 et Ten, Serveur Ubuntu 18.04

Hors ligne

#2547 Le 25/05/2019, à 12:41

jibel

Re : Script d'installation pour imprimantes Brother

@sinbad83,

sudo sane-find-scanner tool
  # sane-find-scanner will now attempt to detect your scanner.

T'as vraiment pas de bol...Si tu as xsane installé? ouvre xsane si le résultat détecte que l'option scanner est présent? Apparemment? Non! Si par contre cette installe n'est pas au top! Peut-être qu'en suivant le tuto de demonipuch?? tout sera OK? J'ai des doutes? cool cool
Je suppose que ton imprimante avec ces XXX fonctions, tout était OK avec la version 16.04? Ce qui veut dire qu'a chaque changement de version, a chaque fois il y aura des oublies des concepteurs de la version 18.04 pour que ton imprimante soit en fonction scanner compris!
Voila ou se trouve le super PB... Aie, aie...

Dernière modification par jibel (Le 25/05/2019, à 12:46)


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur. Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit et toc !

Avec Mint.17.3, Xub 16.04, Voyager X2 et X8, Debian 9.9 stretch, MX-linux, Hybryde 14.04, Arco .PC medion akira  DD 1T + 2 .

Hors ligne

#2548 Le 25/05/2019, à 15:36

xunil2003

Re : Script d'installation pour imprimantes Brother

Bonjour

Je suis sur l'os Linux Mint  17.1 Rebecca XFCE X64.
Lorsque j'execute votre script

laurent@I5-2500K:~/pilotes/brother$ sudo ./install.sh

Rien ne se passe, il bloc ?

Bien que nous ne somme pas sur un forum Linux Mint pouvez-vous m'aider ?
Linux Mint  17.1 Rebecca est en faite une version de Ubuntu 14.04.

Dans votre script "install.sh"  j'ai vue qu'il y avait linux mint mais pas rebecca, faut il l'ajouter ?

CheckSourceList() {
case ${os} in
	Debian)
		repo="main"
		os="debian"
		rules="/lib/udev/rules.d/60-libsane.rules"
	;;
	Ubuntu)
		repo="universe"
		os="ubuntu"
		rules="/lib/udev/rules.d/40-libsane.rules"
	;;
	LinuxMint)
		case ${codename} in
			debian)
				os=""
				repo="main"
				rules="/lib/udev/rules.d/60-libsane.rules"
			;;
			petra)
				codename="saucy"
				os="ubuntu"
				repo="universe"
				rules="/lib/udev/rules.d/40-libsane.rules"
			;;
			olivia)
				codename="raring"
				os="ubuntu"
				repo="universe"
				rules="/lib/udev/rules.d/40-libsane.rules"
			;;
			nadia)
				codename="quantal"
				os="ubuntu"
				repo="universe"
				rules="/lib/udev/rules.d/40-libsane.rules"
			;;
			maya)
				codename="precise"
				os="ubuntu"
				repo="universe"
				rules="/lib/udev/rules.d/40-libsane.rules"
			;;
			lisa)
				codename="oneiric"
				os="ubuntu"
				repo="universe"
				rules="/lib/udev/rules.d/40-libsane.rules"
			;;
			katya)
				codename="natty"
				os="ubuntu"
				repo="universe"
				rules="/lib/udev/rules.d/40-libsane.rules"
			;;
			julia)
				codename="maverick"
				os="ubuntu"
				repo="universe"
				rules="/lib/udev/rules.d/40-libsane.rules"
			;;
			isadora)
				codename="lucid"
				os="ubuntu"
				repo="universe"
				rules="/lib/udev/rules.d/40-libsane.rules"
			;;
		esac
	;;
	elementary\ OS)
		repo="universe"
		os="ubuntu"
		if [[ ${codename} == "luna" ]]; then
			codename="precise"
		fi
		rules="/lib/dev/rules.d/40-libsane.rules"
	;;
esac

Ps : Zenity est installé.
Merci d'avance, pour votre aide.

Dernière modification par xunil2003 (Le 25/05/2019, à 15:38)


- Intel Pentium I7 960 / 12 Go de Ram - 6 HDD de 2 T0 - Kubuntu & Ubuntu 12.04 x64 / Mageia 2 x64 / Windows 7 x64 / Lamp...
- DreamPlug Multi Boot / Marvel 1.22 Ghz / Architecture ARM / 512 Mo Ram / Carte-sd 16 Go class 10 / 5 Watts / Debian Squeeze 2.6.39.4 ----> http://www.newit.co.uk/shop/proddetail. … ream_Multi ----> appellé également plug computer
JE SUIS CHARLIE

Hors ligne

#2549 Le 25/05/2019, à 15:46

jibel

Re : Script d'installation pour imprimantes Brother

@xnull2003,
Il serait bien que tu te diriges sur le forum de "limux-mint" pour leur poser ta question? p'têt bien, que tu sauras ce que tu devrais faire pour installer ton imprimante brother pour ta version de linux-mint 17.1 rebecca Xfce wink cordialement


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur. Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit et toc !

Avec Mint.17.3, Xub 16.04, Voyager X2 et X8, Debian 9.9 stretch, MX-linux, Hybryde 14.04, Arco .PC medion akira  DD 1T + 2 .

Hors ligne

#2550 Le 25/05/2019, à 15:47

michel_04

Re : Script d'installation pour imprimantes Brother

Bonjour,


xunil2003 a écrit :

Linux Mint  17.1 Rebecca est en faite une version de Ubuntu 14.04.

Ubuntu 14.04 LTS («The Trusty Tahr»)

Doc a écrit :

Fin de vie depuis le 30 avril 2019
Depuis le 30 avril 2019, Ubuntu 14.04 est en fin de vie (end of life, EOL). Elle ne profite plus de nouvelle mise à jour de sécurité, exceptés aux adhérents du programme Ubuntu ESM, et les paquets logiciels pour cette version sont déplacés dans des serveurs d'archive. Pour continuer à recevoir des mises à jour de sécurité, veuillez mettre à niveau votre version d'Ubuntu vers une version activement soutenue.


A+


:D
Comment Poser Les Questions De Manière Intelligente
[url=[modéré : pas d’auto-pub, merci]]l'Almanet doLys de nam1962 et ses amis[/url] - Forum Ubuntu-fr - Documentation Ubuntu

Hors ligne