Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 23/10/2011, à 16:02

th67

Audacity inutilisable pour édition wav sous Natty et Oneiric

Bonjour,

Ce problème a déjà été soulevé dans des forums anglophones mais, sauf erreur, pas ici.

D'abord, ma config actuelle d'après hardinfo (System Profiler and Benchmark) :
-Computer-
Processor                        : 2x AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
Memory                            : 2056MB (792MB used)
Operating System           : Ubuntu 10.10
Kernel                               : Linux 2.6.35-30-generic (x86_64)
-Display-
Resolution                        : 1680x1050 pixels
OpenGL Renderer          : Mesa DRI R600 (RV630 9588) 20090101  TCL DRI2   [ATI Radeon HD 2600XT]
X11 Vendor                      : The X.Org Foundation
Effets visuels Compiz     : "normaux"
-Multimedia-
Audio Adapter                 : HDA-Intel - HDA NVidia
Audio Adapter                 : HDA-Intel - HDA ATI HDMI

J'utilise Audacity pour éditer des courbes wav à zoom élevé (chaque échantillon étant individualisé). Pas de problème sous Maverick, la sélection des échantillon est rapide et le déplacement des courbes suit bien le déplacement de la souris.

Par curiosité j'ai voulu essayer Natty, en double-boot heureusement... La cata ! La sélection de quelques échantillons prend une dizaine de secondes, avec 100% d'utilisation du CPU ; l'ajustement précis de la position d'une courbe est pratiquement impossible... Le test a été fait avec les mêmes fichiers wav que sous Maverick (2 fichiers ouverts, env. 15 MB et 6 MB), avec et sans Unity (avec ou sans effets visuels), en 32 bits et en 64 bits. C'est un peu moins mauvais avec le bureau classique, mais on est encore loin de pouvoir manipuler les courbes wav correctement.  La mémoire vive minimale allouée à Audacity était la même dans tous les cas (défaut, soit 16 MB). Cela n'a rien arrangé de l'augmenter à 50 MB. Remarque : Audacity n'utilise qu'un des CPU, que ce soit sous Maverick ou sous Natty. 

Rebelotte avec Oneiric. Même problème que sous Natty --> Retour à Maverick.

Il y a plusieurs bugs qui se rapportent à ça dans Launchpad. Le problème viendrait de wxWidget (plus précisément de la bibliothèque libwxgtk2.8-0), mais un patch a été publié ( https://bugs.launchpad.net/ubuntu/+sour … bug/722375 ). Est-ce que ce patch n'a pas encore trouvé son chemin vers Ubuntu, ou y a-t-il un autre problème ?

Est-ce que quelqu'un d'autre a un bug de ce genre avec Audacity ?

Cordialement.

Hors ligne

#2 Le 25/10/2011, à 20:19

L_d_v_c@

Re : Audacity inutilisable pour édition wav sous Natty et Oneiric

Audacity n'utilise qu'un des CPU, que ce soit sous Maverick ou sous Natty.

Je possède un bi-quad ... en effet audacity n'utilise qu'un seul cœur ... sad


Ubuntu 14.04 sur 1001HA / Ubuntu 12.04 E6600 et K50IE
M.A.O. UbuntuStudio 12.04 sur Tyan S2915E RAID 5
Pourquoi Linux.
Bug -1 : Derrière chaque bogue se cache constamment la faille humaine !

En ligne

#3 Le 26/10/2011, à 21:16

th67

Re : Audacity inutilisable pour édition wav sous Natty et Oneiric

Comme dit plus haut, Audacity fonctionne correctement sous Maverick avec mon matériel, mais je ne dirais pas que c'est très fluide. La sélection de quelques échantillons est rapide mais pas instantanée. De même le déplacement de la courbe wav "traîne" un peu lorsqu'on fait bouger la souris rapidement, surtout lorsque d'autres programmes tournent en même temps. Sous Lucid, Audacity me semblait beaucoup plus fluide. Mais comme on ne peut pas se fier à ses souvenirs, j'ai réinstallé Lucid en double-boot avec Maverick (bye bye Natty & Oneiric, it was nice to meet you!) et fait la même manip sur Maverick et Lucid, avec contrôle de l'utilisation du CPU par le moniteur système.

La manip :
- ouvrir un fichier wav de 13 minutes 1/2 (test_138Mio.wav) avec  Audacity ;
- afficher 10 millisecondes de la courbe wav sur la largeur de la fenêtre ;
- "sélection 2ms" : sélectionner 88 échantillons (2 millisecondes) et les afficher - faire une copie d'écran ;
- "déplacement aller-retour" : déplacer la courbe de gauche à droite, puis de droite à gauche sur toute la largeur de la fenêtre - faire une copie d'écran.

J'ai retrouvé avec plaisir la fluidité d'Audacity sous Lucid. En comparaison, il semble bien lourd sous Maverick... Les 4 copies d'écran donnent un début d'explication (Maverick à gauche, Lucid à droite, 1er test en haut, 2e test en bas) :
Utilisation CPU sous Maverick et Lucid
On constate que, sous Maverick, la simple sélection de 88 échantillons mobilise jusqu'à 80% d'un processeur pendant 2 à 3 secondes. Par contre, sous Lucid, la charge semble mieux répartie entre les 2 processeurs.
Observation similaire à propos des déplacements de la courbe.

Donc Audacity semble utiliser les 2 processeurs sous Lucid, mais un seul sous Maverick ! Comment est-ce possible ?
Notez que mes 2 installations sont aussi semblables que possible, mais le pilote graphique n'est pas le même : fglrx pour Lucid, et radeon pour Maverick (impossible d'installer fglrx, et d'ailleurs radeon fonctionne très bien). Mais je ne vois pas comment cela pourrait expliquer la différence d'utilisation des processeurs.

Quelqu'un a-t-il une explication pour ce que je considère comme une régression ?

Hors ligne

#4 Le 26/10/2011, à 22:17

L_d_v_c@

Re : Audacity inutilisable pour édition wav sous Natty et Oneiric

Sous Natty, la version d'Audacity est la 1.3.13 beta, qu'en est-il sous Lucid ?


Ubuntu 14.04 sur 1001HA / Ubuntu 12.04 E6600 et K50IE
M.A.O. UbuntuStudio 12.04 sur Tyan S2915E RAID 5
Pourquoi Linux.
Bug -1 : Derrière chaque bogue se cache constamment la faille humaine !

En ligne

#5 Le 26/10/2011, à 22:51

Poun64

Re : Audacity inutilisable pour édition wav sous Natty et Oneiric

Bonsoir toul'monde smile !

Sur ma Lucid, c'est la version 1.3.12-beta (indiqué dans la section "A propos" d'Audacity).
Le paquet installé est en version 1.3.12-2.

smile

Dernière modification par Poun64 (Le 26/10/2011, à 22:52)


L'expérience est une chandelle qui n'éclaire que celui qui la porte.
=======================================================================
Ubuntu 12.04.2 LTS - Gigabyte GA H77M - Intel Core I7 3770K / Ivy Bridge - 4 cœurs - 3,5 Ghz - 8 Go de RAM
Ubuntu 12.04.3 LTS - ASRock N68C-GS FX - AMD Phenom X4 Quad-Core 9500 - 2,2 Ghz - GeForce 8600 GT - 4 Go de RAM

Hors ligne

#6 Le 26/10/2011, à 22:58

L_d_v_c@

Re : Audacity inutilisable pour édition wav sous Natty et Oneiric

Ok Poun64, le problème peut venir de là également ...


Ubuntu 14.04 sur 1001HA / Ubuntu 12.04 E6600 et K50IE
M.A.O. UbuntuStudio 12.04 sur Tyan S2915E RAID 5
Pourquoi Linux.
Bug -1 : Derrière chaque bogue se cache constamment la faille humaine !

En ligne

#7 Le 26/10/2011, à 23:06

Poun64

Re : Audacity inutilisable pour édition wav sous Natty et Oneiric

Bin, ouais... hmm

Dernière modification par Poun64 (Le 26/10/2011, à 23:06)


L'expérience est une chandelle qui n'éclaire que celui qui la porte.
=======================================================================
Ubuntu 12.04.2 LTS - Gigabyte GA H77M - Intel Core I7 3770K / Ivy Bridge - 4 cœurs - 3,5 Ghz - 8 Go de RAM
Ubuntu 12.04.3 LTS - ASRock N68C-GS FX - AMD Phenom X4 Quad-Core 9500 - 2,2 Ghz - GeForce 8600 GT - 4 Go de RAM

Hors ligne

#8 Le 26/10/2011, à 23:08

L_d_v_c@

Re : Audacity inutilisable pour édition wav sous Natty et Oneiric

La 1.3.13 beta reste une version beta comme la 1.3.12-2 beta ...


Ubuntu 14.04 sur 1001HA / Ubuntu 12.04 E6600 et K50IE
M.A.O. UbuntuStudio 12.04 sur Tyan S2915E RAID 5
Pourquoi Linux.
Bug -1 : Derrière chaque bogue se cache constamment la faille humaine !

En ligne

#9 Le 26/10/2011, à 23:14

th67

Re : Audacity inutilisable pour édition wav sous Natty et Oneiric

Sous Maverick, la version d'Audacity est la 1.3.12-beta d'après "A propos", comme sous Lucid, mais le paquet installé est en version 1.3.12-7.

Hors ligne

#10 Le 26/10/2011, à 23:32

th67

Re : Audacity inutilisable pour édition wav sous Natty et Oneiric

Autre différence : la version du noyau linux. 2.6.32-34 pour Lucid et 2.6.35-30 pour Maverick. La gestion des multiprocesseurs est peut-être différente ?

Hors ligne

#11 Le 15/05/2013, à 11:10

PITHON

Re : Audacity inutilisable pour édition wav sous Natty et Oneiric

J'ai le même problème à l'enregistrement. Audacity se bloque ! Voilà sur le terminal ce qui m'est dit. Personnellement je n'ai pas la capacité de le traduire :
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.EMU10K1.pcm.surround71.0:CARD=0'
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_refer returned error: Aucun fichier ou dossier de ce type
ALSA lib conf.c:4720:(snd_config_expand) Evaluate error: Aucun fichier ou dossier de ce type
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM surround71
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
bt_audio_service_open: connect() failed: Connexion refusée (111)
bt_audio_service_open: connect() failed: Connexion refusée (111)
bt_audio_service_open: connect() failed: Connexion refusée (111)
bt_audio_service_open: connect() failed: Connexion refusée (111)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541
Expression 'err' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 3286
Expression 'ContinuePoll( self, StreamDirection_In, &pollTimeout, &pollCapture )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 3813
Expression 'PaAlsaStream_WaitForFrames( stream, &framesAvail, &xrun )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4185

(Audacity:7074): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're its parent.

(Audacity:7074): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're its parent.

(Audacity:7074): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're its parent.

(Audacity:7074): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're its parent.

(Audacity:7074): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're its parent.

(Audacity:7074): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're its parent.

(Audacity:7074): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're its parent.

(Audacity:7074): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're its parent.

(Audacity:7074): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're its parent.
pithon@nordinou:~$

Hors ligne

Haut de page ↑