Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 04/12/2011, à 19:02

janvier42

iSight ne fonctionne pas

Bonjour, voilà ma configuration

Macbook 13' 4.1

cat /proc/version
Linux version 3.0.0-13-generic (buildd@crested) (gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3) ) #22-Ubuntu SMP Wed Nov 2 13:27:26 UTC 2011
cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"

et mon problème :
Je voudrais faire fonctionner ma webcam isight

Elle est bien connecté

lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 05ac:8501 Apple, Inc. Built-in iSight [Micron]
Bus 003 Device 003: ID 046d:c051 Logitech, Inc. G3 (MX518) Optical Mouse
Bus 005 Device 002: ID 0603:00f2 Novatek Microelectronics Corp. 
Bus 007 Device 002: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 007 Device 003: ID 05ac:022a Apple, Inc. Internal Keyboard/Trackpad (MacBook Pro) (ISO)
Bus 003 Device 006: ID 05ac:8205 Apple, Inc. Bluetooth HCI

J'ai suivi ce tuto avec isight-firmware-tools https://help.ubuntu.com/community/Macte … ppleiSight avec un fichier AppleUSBVideoSupport téléchargé car en simple boot.
le fichier isight.fw est bien présent dans /lib/firmware/

Lorsque je test la camera avec kamoso ou skype la led vert à côté de l'objectif s'allume mais la capture vidéo retransmise par les logiciels correspond à une image noir.

Est-ce que quelqu'un peut m'aider ?

Merci d'avance

Hors ligne

#2 Le 05/12/2011, à 00:40

MelliW

Re : iSight ne fonctionne pas

Salut,

Tu pourrais peut-être lancer cette commande dans un terminal :

locate v4l1compat.so

Ça devrait te renvoyer un chemin (par exemple, chez moi : /usr/lib/i386-linux-gnu/libv4l/v4l1compat.so)

Tu peux tester Skype avec le chemin obtenu, en lançant dans un terminal :

env LD_Preload=le_chemin_obtenu skype

chez moi, ce serait :

env LD_Preload=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

Une fois Skype ainsi lancé, fais un test vidéo pour voir si ça fonctionne. Si c'est le cas, tu pourras automatiser cette commande en l'associant au fichier d'exécution de Skype.

Hors ligne

#3 Le 05/12/2011, à 23:12

janvier42

Re : iSight ne fonctionne pas

Merci de ta réponse.

Je viens d'essayer mais ça na pas résolu le problème.
Je pensais que ca venait peu être du fichier que j'avais téléchargé alors j'ai essayé avec une autre source mais rien n'a changé.

Avant j'étais sous lucid et elle marchait

Hors ligne

#4 Le 07/12/2011, à 21:35

janvier42

Re : iSight ne fonctionne pas

Personne d'autre n'a une idée ?

Hors ligne

#5 Le 01/02/2013, à 00:24

jacqogier

Re : iSight ne fonctionne pas

Bonjour,
Je reprends cette discussion un + d'an après son début... Je ne sais pas si ce sera utile à quelqu'un...
J'avais aussi des soucis avec iSight ( j'ai un MacBook Pro - Ubuntu 12.10 en dual boot) sur skype : des fois ça marche, des fois ça marche pas sans que je comprenne vraiment ce qui se passe. En cherchant sur les forum j'ai fini par avoir une piste : charger le firmware ad-hoc. Sur le "gestionnaire de paquets Synaptic" j'ai tapé iSight dans le filtre rapide. J'ai "appliquer" l'installation et laissé faire le programme et j'ai relancé la machine et maintenant cela semble marcher...

Hors ligne

Haut de page ↑