Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 11/11/2006, à 18:02

lapatache

[resolu]Eclipse + CDT : "Error notifying a preference change listener"

Re-bonjour à tous,

J'ai ce message en lancant eclipse et je n'arrive pas à m'en débarrasser:

"Error notifying a preference change listener. Check the log for details".

Celà me bloque le démarrage d'éclipse

Si quelqu'un peut me débloquer...

Merci

Dernière modification par lapatache (Le 11/11/2006, à 22:14)

Hors ligne

#2 Le 11/11/2006, à 19:22

lapatache

Re : [resolu]Eclipse + CDT : "Error notifying a preference change listener"

Pour régler ce problème, je voudrait supprimer le plug in cdt pour le réinstaller, mais j'ai un message qui me dit que je n'ai pas le droit de supprimer!!! pourtant j'ai encore le compte oem qui a tous les droits non?

sinon, quelqu'un pourrait-il me donner le nom d'un IDE sans souci pour programmer en C? je galere depuis plusieurs semaines avec eclipse sous windows et linux alors que je veux juste "travailler" sous C et pas rester des heures à trouver quel paramètre changer... sans avoir à rester sur notepad sniff

Hors ligne

#3 Le 11/11/2006, à 22:13

lapatache

Re : [resolu]Eclipse + CDT : "Error notifying a preference change listener"

Bon bah une réponse :

J'ai supprimé le dossier .plugins dans le dossier workspace\.metadata et celà refonctionne...

Etrange...

Hors ligne

#4 Le 07/12/2006, à 19:58

Creak

Re : [resolu]Eclipse + CDT : "Error notifying a preference change listener"

Je pense avoir trouvé une solution plus sympa à ton problème smile
Si je ne m'abuse, là tu dois réinstaller la CDT à chaque fois sinon il te pète l'erreur infinie, c'est ça ?

Apparemment c'est parce que la version de la CDT sur le dépôt est la 3.0 et elle n'est pas compatible avec la version 3.2 d'Eclipse, elle aussi sur le dépôt roll
La solution est d'utiliser le système d'installation de plugin intégré à Eclipse...
* Tu va dans "Help > Software Updates > Find and Install..."
* Tu cliques sur "Search for new features to install"
* Tu sélectionnes le "Callisto Discovery Site" et tu cliques sur "Finish"
* Tu attends  que ça se connecte et tu sélectionnes un site de téléchargement parmi la liste
* Tu parcours les éléments du "Callisto Discovery Site" et tu sélectionnes le plugin "CDT C/C++ ..."
* Tu clique sur Next et ça devrait être bon (à quelques cliques près smile)

Dernière modification par Creak (Le 07/12/2006, à 19:58)

Hors ligne

#5 Le 20/12/2006, à 23:02

pika

Re : [resolu]Eclipse + CDT : "Error notifying a preference change listener"

Merci beaucoup pour cette idée, j'avais également ce problème !

Dernière modification par pika (Le 20/12/2006, à 23:04)

Hors ligne

#6 Le 31/03/2007, à 14:41

hector

Re : [resolu]Eclipse + CDT : "Error notifying a preference change listener"

Niveau dépôt, on a eu droit à une mise à jour récemment de eclipse-cdt, il me semble que ça a résolu le problème (que j'avais aussi): à vérifier ...

Hors ligne