Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#26 Le 28/12/2011, à 18:39

Luros

Re : Skyrim

Ben justement, j'avais essayer j'ai trouver le code source 1.3.34 en tar.bz2, desintaller wine desarchiver avec tar xvjs, et compiler avec make, après 30 minutes de compilation, je tape wine --version il m’indique 1.3.35, mais je vais essayer de trouver le .deb.

EDIT : Bon là je suis sûr de bien avoir supprimer les paquets de wine, je recompile en tar/bz, mais c'est looooooong.

Dernière modification par Luros (Le 28/12/2011, à 18:47)

Hors ligne

#27 Le 28/12/2011, à 19:15

abelthorne

Re : Skyrim

Pas la peine de recompiler, les paquets DEB sont dispo sur le site de Wine. Et ça installera tout ce qu'il faut où il faut...

En ligne

#28 Le 28/12/2011, à 21:11

Luros

Re : Skyrim

Bizzard j'ai beau fouiller partout impossible de trouver les paquets debian des versions anterieurs, et en tar.bz2 ça a beau compiler ça ne marche pas... enfin je suis peut-être passer a côté de quelque chose d'énorme, je sais pas.

Hors ligne

#29 Le 28/12/2011, à 23:08

abelthorne

Re : Skyrim

Effectivement, je ne vois plus non plus les archives des paquets DEB sur le site de Wine. Ils les ont peut-être virées.

EDIT : ah, si. Là : http://wine.budgetdedicated.com/archive/binary/

Dernière modification par abelthorne (Le 28/12/2011, à 23:08)

En ligne

#30 Le 29/12/2011, à 00:12

Luros

Re : Skyrim

Merci à toi, mais même sous wine 1.3.34 ça ne marche pas, j’essaierai d'autres version mais je m’arrête là pour aujourd'hui.

Hors ligne

#31 Le 08/09/2013, à 10:13

gelin.julien81

Re : Skyrim

Bonjour à tous,

j'ai écumé pas mal de forums et essayer pas mal de choses sans réussir à bien faire fonctionner Skyrim

j'ai installé Skyrim en utilisant Wine. Mais quand je lance Skyrim le jeu est extrêmement lent même en mettant la résolution à faible.
Quand j'y jouais sous Windows XP je n'avais aucun problème.

Voici ma configuration :

Intel® Core™ i5 CPU 750 @ 2.67GHz × 4
Advanced Micro Devices, Inc. [AMD/ATI] RV770 [Radeon HD 4850]
12G de RAM
Ubuntu 12.04
wine-1.4

Avez-vous des idées ?

Hors ligne

#32 Le 08/09/2013, à 11:21

sounderk

Re : Skyrim

T'as intérêt d'avoir une bête de course si tu veut émulé Skyrim sous Linux ( émulation = grosse galére)


L'homme de la PamPa. Linux pourquoi faire simple quand tous peut être compliqué. Du bon son dans le casque https://www.youtube.com/watch?v=wWtqkz6SH1Y
Une petite pensée pour  Eli Wallach ....merçi encore Tuco

Hors ligne

#33 Le 08/09/2013, à 11:27

gelin.julien81

Re : Skyrim

Et ma configuration ne serait pas suffisante ? neutral

Hors ligne

#34 Le 08/09/2013, à 13:07

Madeba

Re : Skyrim

Skyrim tourne bien sur ma  config actuelle : Core i5 3550+gtx 460-8 Go, mais était un peu juste sur un athlon 455 X3.
Peut être peux tu essayer le nouveau wine patché "multithread pour DIrectX".
Si tu utilises PlayOnlinux,
1) charge le .deb que tu trouveras sur cette page ,
2) crée un répertoire /home/julien/.PlayOnLinux/1.7.1-patch et  copies y les dossiers bin, lib et share depuis le paquet.
et  utilise cette version pour lancer Skyrim...
J'ai testé, mais comme la plupart des jeux sont fluides sur ma config, je n'ai pas vu de différence notable (l'auteur du patch annonce 50 à 100% de vitesse en plus sur les jeux "récents")...

Dernière modification par Madeba (Le 08/09/2013, à 13:08)

Hors ligne

#35 Le 08/09/2013, à 13:14

Madeba

Re : Skyrim

Ceci dit, en regardant les perfs des processeurs, ton processeur est 20% plus rapide qu'un Athlon x3 455. Le jeu peut ne pas être 100% fluide, mais ne devrait pas non plus ramer à mort...

Hors ligne

#36 Le 08/09/2013, à 15:33

gelin.julien81

Re : Skyrim

Merci beaucoup pour ces explications et ces conseils.

J'ai installé Skyrim avec PlayOnLinux et après j'ai téléchargé le fichier .deb que tu m'as conseillé puis j'ai copié les fichiers indiqués dans un répertoire 1.7.1-patch. Enfin j'ai lancé le jeu (en faisant un double clic sur l’icône du jeu). Et au final il n'y a pas de différence.
Mais quand tu dis « utilise cette version pour lancer Skyrim » il y a peut être quelque chose que je n'ai pas bien fait...

Hors ligne

#37 Le 08/09/2013, à 17:01

Madeba

Re : Skyrim

Il faut bien lui indiquer la version 1.7.1-patch dans Playonlinux (configurer->general->version de Wine) et aussi mettre  affichage->ordonnancement strict draw sur disabled/desactivé

Hors ligne

#38 Le 08/09/2013, à 19:08

gelin.julien81

Re : Skyrim

Quand je cherche à configurer la version 1.7.1-patch je ne le trouve pas. Je trouve seulement 1.7.1...

Hors ligne

#39 Le 08/09/2013, à 19:22

gelin.julien81

Re : Skyrim

La version 1.7.1-patch n’apparaît pas dans la liste : "version de wine disponible"

Hors ligne

#40 Le 08/09/2013, à 20:45

Madeba

Re : Skyrim

1.7.1-patch, c'est normalement le nom du dossier que tu as toi même créé dans
/home/julien/.PlayOnLinux/wine/linux-x86
Le jeu doit avoir été créé pour un prefixe 32 bits (car paquet compilé en 32 bits).
C'est vrai que je n'avais pas précisé pour "linux-x86". Le cas échéant, déplace  le dossier de 
./PlayOnLinux/wine/1.7.1-patch
vers 
./PlayOnLinux/wine/linux-x86/1.7.1-patch.

Hors ligne

#41 Le 08/09/2013, à 21:54

gelin.julien81

Re : Skyrim

J'ai mis le fichier au bon endroit et je l'ai trouvé dans "configurer" hélas le jeu rame toujours autant.
J'ai bien peur qu'il faille changer de processeur...

Hors ligne

#42 Le 08/09/2013, à 22:53

Horigo

Re : Skyrim

J'avais un problème avec skyrim, il tournait à 1 ips quelquesoit les réglages, puis je l'ai installé dans crossover et il marche très bien.

Hors ligne

#43 Le 09/09/2013, à 00:02

Madeba

Re : Skyrim

Si ça rame vraiment, ça ne vient pas du processeur, plutôt un pb de config quelque part. Certains disent de baisser la qualité à medium, plutôt que de jouer sur la résolution...
Playonlinux en mode "débugger" ne donne aucune erreurs "bizarres"?

Hors ligne

#44 Le 09/09/2013, à 21:03

gelin.julien81

Re : Skyrim

Bonjour,

Je l'ai lancé en mode debbug mais je ne sais pas vraiment comment lire le log. Je vois bien quelques lignes avec "error" mais je ne sais pas s'il s'agit d'une vraie erreur... J'ai mis le fichier à cette adresse : http://dl.free.fr/m6IBXejKm (mot de passe : skyrim). Si jamais tu arrives à y voir quelque chose je suis preneur.

Bonne soirée

Hors ligne

#45 Le 09/09/2013, à 21:49

Madeba

Re : Skyrim

Retire moi un doute : tu utilises bien le pilote proprio?

Hors ligne

#46 Le 14/09/2013, à 09:12

gelin.julien81

Re : Skyrim

Bonjour,

La dernière fois que j'avais essayé d'installer le pilote propriétaire, j'avais été obligé de réinstaller complètement Ubuntu.
Mais suite à ton commentaire je me suis remis à essayer de l'installer. Je suis donc allé sur les différentes pages de forum pour essayer de bien le faire. J'ai rencontré des difficultés que je n'ai pas réussi à surmonter. Mais au final, j'ai donc appliqué le forum http://forum.ubuntu-fr.org/viewtopic.php?pid=12528911 mais je n'arrive pas à installer les trois paquets dont il parle.
Alors j'ai essayé (tout simplement) la commande

sudo sh amd-driver-installer-catalyst-13.1-linux-x86.x86_64.run --install

A ce moment là j'ai l'interface d'AMD Catalyst qui se lance et je demande à lancer l'installation et là j'ai ce message qui apparaît : "Your graphics adapter is not supported by this driver. Installation will not proceed".

J'ai cherché des pistes sur d'autres forum mais sans succès.

Je dois bien avoué que je ne sais pas trop quoi faire...

As-tu une idée ?

Hors ligne

#47 Le 14/09/2013, à 10:48

abelthorne

Re : Skyrim

Attention, parce que le tuto en question concerne l'installation de Catalyst 13.1 sur Ubuntu 12.04 et je ne suis pas sûr qu'il soit complet. Le problème c'est surtout que le pilote ne marche que jusqu'à une version spécifique du serveur X (le serveur d'affichage, X.org) et du noyau. Donc pour les Ubuntu récentes qui ont un X et un noyau plus récent, il faut en plus repasser X à une vieille version et soit utiliser un pilote patché pour le noyau, soit rester sur un vieux noyau. Je n'ai plus la méthode sous la main, il doit y avoir des messages sur le forum qui en parlent. Et il y a un PPA qui s'occupe de faire tout ça automatiquement : https://launchpad.net/~makson96/+archive/fglrx
Attention : lis bien la description du PPA pour savoir ce qui est supporté ou non, en fonction du modèle de ton GPU et de ta version exacte d'Ubuntu (notamment si tu es en 12.04, selon que tu as installé la 12.04, 12.04.2 ou 12.04.3).

EDIT : cela dit, je vois que tu as une RadeonHD 5730M (puce de portable). Théoriquement, la branche 5xxx devrait encore être gérée par le pilote standard. Donc si l'installeur Catalyst te dit que ce n'est pas le cas, il y a peut-être en plus un truc spécifique pour les puces mobiles. Avant de faire des manips avec le PPA, je te suggère de faire des recherches sur le support de ta puce en particulier. Peut-être sur ce wiki : http://wiki.cchtml.com/index.php/Main_Page

Dernière modification par abelthorne (Le 14/09/2013, à 10:53)

En ligne

#48 Le 14/09/2013, à 13:06

Madeba

Re : Skyrim

Il a une 4850 en fait. C'est la série de pilotes  "legacy" (obsolète).
Il faut installer :
1) les "entêtes"  correspondant à ton noyau (linux-headers-num_noyau ) que tu vois au démarrage de ta machine ou en tapant "uname -a". ça sert à la compilation du pilote et c'est sans doute  déjà installé.
2) fglrx-legacy-modules-dkms (il compile seul le pilote et l'installe)
3)Indiquer au système que tu veux utiliser ce pilote, en créant le fichier de conf "/etc/X11/xorg.conf" à l'aide de l'outil ATI. aticonfig --initial si mes souvenirs sont bons (je suis sous nvidia)
4)redémarrer.

DKMS t'assure en principe une réinstall propre du pilote à chaque maj du noyau.
En bref : Header, dkms, aticonfig, reboot.

Dernière modification par Madeba (Le 14/09/2013, à 13:08)

Hors ligne

#49 Le 14/09/2013, à 15:49

gelin.julien81

Re : Skyrim

Merci à vous 2 pour ces informations.

Voilà ce que j'ai fait :

1) pour les "en têtes", quand je fais uname -a, j'obtiens :

Linux gelin-System-Product-Name 3.5.0-40-generic #62~precise1-Ubuntu SMP Fri Aug 23 17:59:10 UTC 2013 i686 i686 i386 GNU/Linux

Alors j'ai cherché les différentes informations qui sont en lien avec. J'en suis arrivé au point où j'ai cherché à installer le paquet: linux-headers-3.5.0-40-generic_3.5.0-40.62~precise1_i386.deb. Il était déjà installé. Donc je pense que l'étape 1 est validée.

2)J'ai installé le paquet fglrx-legacy-modules-dkms

3) Quand je fais :

sudo aticonfig --initial

J'ai pour réponse :

aticonfig: No supported adapters detected

Donc je ne parviens pas à aller plus loin...

Hors ligne

#50 Le 14/09/2013, à 16:32

sergei_ruskof

Re : Skyrim

Bonjour,

D'apres ce que j'ai lu sur le forum steam linux,les catalyst legacy sont pas terrible et le pilote libre radeon aurai une meilleur fluidité même si les fps sont moins haut.

De gros progrès ont été fait sur le driver libre récement,ce qui a grandement augmenter les performances pour les cartes anciennes.

Si tu veux mettre tes drivers libre a jour il y a ce ppa de disponnible : https://launchpad.net/~oibaf/+archive/graphics-drivers/

Hors ligne

Haut de page ↑