Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 01/12/2006, à 14:54

Scurz

Kernel 2.6.19

Hello,

La version 2.6.19 du noyau est sortie hier, c'est une version stable, je l'ai compilé hier soir sur mon serveur qui est sous debian, nickel, beaucoup de nouveautés sont au rendez-vous, ext4 a été inséré (le ext4 n'est pour le moment qu'experimental), etc.

Voir le billet sur mon blog
Voir sur Linuxfr
Voir sur le site officiel

Pour tous ceux qui souhaitent utiliser cette nouvelle version stable du kernel, il faut compiler ;-)

Bye.

Dernière modification par Scurz (Le 01/12/2006, à 14:55)

#2 Le 01/12/2006, à 15:52

bruno

Re : Kernel 2.6.19

Compiler pourquoi faire ? Il fonctionne parfaitement sur ma Feisty big_smile
Attention à la nouvelle gestion des périphériques PATA/SATA, mes partitions son passées de hdax à sdax, ce qui n'est pas gênant dans la mesure où le fstab utilise les UUID et non les /dev/*

Hors ligne

#3 Le 01/12/2006, à 16:00

Kiraa

Re : Kernel 2.6.19

bruno a écrit :

Compiler pourquoi faire ?

pour avoir un kernel léger qui ne contient que ce dont on à besoin big_smile

Hors ligne

#4 Le 01/12/2006, à 17:18

Nizarus

Re : Kernel 2.6.19

Quand sera t'il dispo dans les dépôt d'edgy ???
En fait c'est quoi la philosophie d'ubuntu sur ce point ?? Elle garde le même noyau qui n'évolue que d'une version à une autre ou c'est dans les dépôts quand c'est disponible ?:/

Hors ligne

#5 Le 01/12/2006, à 18:13

Scurz

Re : Kernel 2.6.19

bruno a écrit :

Compiler pourquoi faire ?

Je ne suis pas sous Ubuntu (mais plutôt sous debian), je ne sais donc pas à quelle version exacte êtes-vous au niveau du noyau wink

#6 Le 01/12/2006, à 18:30

bruno

Re : Kernel 2.6.19

Pour Edgy on est en 2.6.17, désolé Nizarus il n'y aura pas de maj hormis les maj de sécurité

Pour Feisty (version de dév.) on est en 2.6.19 et la version finale sera sans doute publiée avec le 2.6.20

Hors ligne

#7 Le 01/12/2006, à 18:31

Nizarus

Re : Kernel 2.6.19

Je suis sous edgy, et la version du kernel c'est une vielle 2.6.17 sad
@bruno : merci pour l'info, mais c'est une grosse déception pour moi la lenteur de l'évolution des logiciels dans les dépôt. Sinon sous feisty ça se passe comment ? c'est "stable" comme version, ou il peut y avoir des mauvaises surprises ?

Dernière modification par Nizarus (Le 01/12/2006, à 18:37)

Hors ligne

#8 Le 01/12/2006, à 18:51

Scurz

Re : Kernel 2.6.19

@bruno => oké, si une version 2.6.20 sort, ça sera peut-être dans la branche des 2.7.* mais les dev du kernel n'ont pas l'air décidé à ce sujet.

@Nizarus => 2.6.17 n'est pas un vieux noyau, tu sais, il n'est pas forcément nécessaire d'avoir la dernière version à part si tu as besoin de quelque chose en particulier ou pour t'amuser wink

Dernière modification par Scurz (Le 01/12/2006, à 18:51)

#9 Le 01/12/2006, à 18:59

Nizarus

Re : Kernel 2.6.19

oui Scruz je sais bien que le .17 n'est pas si vieux que ça !! mais mon principe c'est puisqu'il y a une nouvelle plus évoluée version avec des améliorations pourquoi s'en priver wink
Donc pour m'amuser un peut oui c'est possible tongue

Hors ligne

#10 Le 01/12/2006, à 19:00

Scurz

Re : Kernel 2.6.19

Compile-le alors wink

#11 Le 01/12/2006, à 23:26

Euskaral

Re : Kernel 2.6.19

ou installe le a partir des depots feisty (ajouer le depot, installer le noyeau, retirer le depot).

Hors ligne

#12 Le 02/12/2006, à 00:14

Nizarus

Re : Kernel 2.6.19

@Euskaral : c'est ce que j'ai fait big_smile et je profite en même temps pour la maj de mes softs préférés winktongue

Hors ligne

#13 Le 02/12/2006, à 14:02

strataoïde

Re : Kernel 2.6.19

Depuis deux jours, je fais aussi mumuse avec la compilation des noyaux. J'ai remarqué un truc intéressant, le noyaux généric est en fait un noyau pour l'architecture i686. Il me semble que les utilisateurs d'amd auraient tout intérêt  à aller faire mumuse là dedans. D'autant plus que l'on peux tailler à la serpe dans la configuration (qui utilises encore des disques atari ici ? tongue).

A noter qu'on peut compiler le noyau en archive  .deb avec make-kpkg le paquet créé et installé, met même grub à jour.

Dernière modification par strataoïde (Le 02/12/2006, à 14:05)


la commande la plus utile sous linux? man bien sur!

Hors ligne

#14 Le 04/12/2006, à 12:10

skateinmars

Re : Kernel 2.6.19

Nizarus a écrit :

Quand sera t'il dispo dans les dépôt d'edgy ???
En fait c'est quoi la philosophie d'ubuntu sur ce point ??

D'avoir des versions stables....
Faut pas s'étonner que les gens ralent contre des distribs pleines de bugs si ils demandent du bleeding edge hmm

Hors ligne

#15 Le 04/12/2006, à 12:16

Mornagest

Re : Kernel 2.6.19

Bizarre, j'ai un AMD Athlon 1.2 GHz (oui je sais c'est vieux mais je m'en fiche tongue) mais il m'a embêté avec le noyau generic, j'ai dû passer en 386... non pas que ça me frustre, mais j'ai pas compris pourquoi... neutral

+1 pour la stabilité, si tout le monde se mange un nouveau noyau expérimental, c'est pas comme ça qu'Ubuntu gagnera des utilisateurs wink il faut du stable, pour les débutants à tout le moins.

Hors ligne

#16 Le 04/12/2006, à 14:11

Nizarus

Re : Kernel 2.6.19

Ok pour la stabilité !! et la version 2.6.19 est une version stable d'après le kernel.org, il manque juste à l'empaqueter, non roll

Hors ligne

#17 Le 04/12/2006, à 15:57

strataoïde

Re : Kernel 2.6.19

Je suis d'accord avec Nizarus. Il ne faut pas oublier que sur d'autres distribs, compiler un kernel est une opération courante. De plus les fichiers .config sont relativement exportables d'un kernel à l'autre, ce qui fait que l'on n'est pas forcé de tout systématiquement reconfigurer. Enfin, il me semble que la seule grosse gène provienne des drivers propriétaires nvidia et des modules, mais c'est déjà le cas quand l'on fait une mise à jour du kernel par synaptic. Il suffit de savoir ou mettre les pieds et le faire avec prudence.  C'est ça la liberté..

De plus, en cas de crise, il ne faut pas oublier que synaptic permet facilement de réinstaller un kernel générique et que make-kpkg ne fait rien d'autre que générer un deb.

Alors la compile, c'est bon, mangez-en, vous rajouterez une dioptrie à vos lunettes, mais vous serez vraiment libres.


la commande la plus utile sous linux? man bien sur!

Hors ligne

#18 Le 04/12/2006, à 16:11

strataoïde

Re : Kernel 2.6.19

Bon, je vais quand même nuancer mes propos. lol
La compile c'est bon, mangez-en si vous êtes patient et vous savez ce que vous faites.


la commande la plus utile sous linux? man bien sur!

Hors ligne

#19 Le 07/12/2006, à 18:54

coincoin169

Re : Kernel 2.6.19

Salut,

J'ai aussi compilé mon 2.6.19 mais j'ai fait ça comme un porc car quand je lis une vidéo avec mplayer et dès que je fais un truc (style agrandir une fenetre, ou mettre une fenetre sur la barre des taches) la video saccade horriblement alors qu'avant dans les kernel 2.6.18.x que j'avais aussicompile ca machait nickel. Je me demande si c'est pas le nouveau support PATA, SATA. Je l'ai coché en dur sans enlever l'ancien support qui est en dur. Est-ce que ça vient de la ? je sais pas, sur internet pas de réponse. Au moment ou j'ecris je suis en train de recompiler le 2.6.19 avec le nouveau support PATA, SATA en dur et sans les anciens drivers. Mais je doute que mon système boote ... enfin je vous dirai ca tout a l'heure. Pour info j'ai un chipset intel ICH7, mon pc est qu'en SATA.

La doc est pas claire sur le Intel PIIX/ICHx SATA support dans la nouvelle branche PATA SATA ! Pouvez-vous m'éclairer ?

Merci pour vos réponses

#20 Le 07/12/2006, à 19:00

tontonsalam

Re : Kernel 2.6.19

Bonjour,
Je suis sous edgy et je crois que j'ai le 2.6.17. Est ce que si j'installe le noyau 2.6.19 il y a des chances que mes problème de shutdown soient résolus?

Dernière modification par tontonsalam (Le 10/12/2006, à 14:54)


Ca va passer

Hors ligne

#21 Le 07/12/2006, à 20:29

Scurz

Re : Kernel 2.6.19

tontonsalam a écrit :

Bonjour,
Je suis sous edgy et je crois que j'ai le 2.6.16 (à véfifier) est ce que si j'installe un nouveau noyau il y a des chances que mes problème de shutdown soient résolus?

Oui, j'ai eu le cas sur une machine qui ne s'éteignait pas avec un noyau précèdent le 2.6.19, avec ce noyau, la machine s'éteint correctement.

#22 Le 07/12/2006, à 23:46

tontonsalam

Re : Kernel 2.6.19

Euskaral a écrit :

ou installe le a partir des depots feisty (ajouer le depot, installer le noyeau, retirer le depot).

ça me plait bien ça comme idée, quels dépots j'installe, pour faire ça?
Quelles précautions je doit prendre?
Normalement si j'upgrade le kernel je peux toujours par la suite redémarrer avec l'ancien? ou alors je peux me retrouver avec des dépendances non satisfaites?


Ca va passer

Hors ligne

#23 Le 08/12/2006, à 11:40

Nizarus

Re : Kernel 2.6.19

ça me plait bien ça comme idée, quels dépots j'installe, pour faire ça?

tu doit installer les dépôts de feisty

Quelles précautions je doit prendre?

ne supprime aucun package de l'ancien kernel, et note leurs noms à coté.

Normalement si j'upgrade le kernel je peux toujours par la suite redémarrer avec l'ancien? ou alors je peux me retrouver avec des dépendances non satisfaites?

Oui, et pour éviter les problèmes il faut installer les mêmes packages que l'ancien kernel (ceux que tu a noté à coté)

Hors ligne

#24 Le 08/12/2006, à 21:36

Euskaral

Re : Kernel 2.6.19

tontonsalam a écrit :
Euskaral a écrit :

ou installe le a partir des depots feisty (ajouer le depot, installer le noyeau, retirer le depot).

ça me plait bien ça comme idée, quels dépots j'installe, pour faire ça?

Ceux de feisty (fais une recherche dans le forum)

Quelles précautions je doit prendre?

Ne surtout rien installer d'autre que le kernel, tant que les depots feisty sont activés. En effet, de nombreux logiciels sur ce dépot sont loins d'être stables

Normalement si j'upgrade le kernel je peux toujours par la suite redémarrer avec l'ancien? ou alors je peux me retrouver avec des dépendances non satisfaites?

Tu n'auras pas de souci avec ça ;-)

Hors ligne

#25 Le 10/12/2006, à 02:28

tontonsalam

Re : Kernel 2.6.19

ah! c'est pas vrai!
Evidemment moi ça a foiré...
J'ai mis à jour le kernel, du coup il a upgradé trois librairies:
libc6
lib-c6-dev
libc6-i686
et quand j'ai voulu redémarrer avec le nouveau kernel, le serveur X n'a pas redemarrer.
Heureusement que ça marche toujours très bien avec l'ancien kernel...
est ce que je dois désinstaller le nouveau kernel et downgrader les trois lib ou alors je reste comme ça?


Ca va passer

Hors ligne