Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#26 Le 16/12/2006, à 18:23

valente

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,

Grogro a écrit :

Bonne lecture et merci d'avance smile

Même si je préfère la lecture de "Charlie Hebdo" il me semble que les install précédentes n'ont pas été correctement éliminé !
- Il faut effacer TOUTES les anciennes installations ! Vérifie ce qui a été installé via Synaptic.
le script "sh /usr/bin/ueaglediag" indique clairement qu'il y'a confusion :
a) Compilateur différent
b) Aucun module (pilote) chargé en mémoire (/proc/net/atm/ueagle-atm)
- Quelque soit la méthode utilisé, cela doit fonctionner, l'idéal étant une installation "fraiche".

Lukubuntu a écrit :

En effet lorsque je démarre mon ordi, les 2 lumières ADSL et PWR s'allument au demarrage de kubuntu et restent allumées toutes les 2 (c.a.d sans clignoter).

Quelques pistes... je n'en suis pas sure smile

- Peut être un conflit avec l'ACPI :
Pour stopper le service au démarage de l'ordinateur

sudo update-rc.d -f acpid remove

et

update-rc.d -f acpi-support remove

Reboot pour vérifier si le modem fonctionne normalement au démarage.

Pour remettre les deux services dans l'attente de ta réponse :

update-rc.d acpi-support start 99 2 3 4 5 . stop 20 1 6 0 .
sudo update-rc.d acpid start 10 2 3 4 5 . stop 21 1 6 0 .

- Vérifie les paramètres du BIOS (USB et ACPI)

@+

#27 Le 17/12/2006, à 14:36

RaSk

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Cathou > Tu as terminé ton PPPoA ? J'ai impatience de le tester !

#28 Le 18/12/2006, à 14:09

Cathou

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Oui il est dispo.
N'oublie pas de faire 'Reload' dans Firefox cool

#29 Le 20/12/2006, à 21:50

pendragon12

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

F@st800 WA pour la zone je sais pas
Ubuntu 6.06

j'ai utiliser la méthode Catou

avec le cd -> du premier coup smile))

par contre en faisant pareil sur ma version installée -> connexion-config m'a renvoyé "echec du ping"
j'avais essayer des scripts mais je sais pas ceux qu'ils ont fait, ptet que ça vien de la?
en tout cas en rebootant apres c'est bon pon poff ok ça roule
super

merci smile))

#30 Le 22/12/2006, à 00:53

Lukubuntu

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Désolé pour le retour tardif mais j'étais chez nos amis teutons.

La première commande marche mais la seconde me jette.

$ update-rc.d -f acpi-support remove

 Removing any system startup links for /etc/init.d/acpi-support ...
   /etc/rc1.d/K20acpi-support
update-rc.d: unlink: Permission non accordée

Du coup au démarrage mes petites LED clignotent correctement mais quand je lance la commande start, la connexion n'est pas établie. Je dois toujours débrancher puis rebrancher le modem avant de lancer la cmd start.

#31 Le 24/12/2006, à 12:01

remyb

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Retour d'experience pour la methode Valente.

1 - Le lien ne marche pas quand on utilise cette m#$%& de IE. On arrive automatiquement sur eagleedgy.site.voila.fr/navigateur.html
Dans ce condition, pas facile d'avoir le lien vers le packet a telecharger :  http://eagleedgy.site.voila.fr/eagleFirmware.deb

2 - En tant que debutant, j'ai eu un doute pour l'installation du packet. Meme si c'est tout simple :

sudo dpkg -i ./eagleFirmware.deb

3 - En regardant le fil http://forum.ubuntu-fr.org/viewtopic.php?id=78283 , j'ai compris qu'il fallait modifier  les fichiers /etc/ppp/peers/dsl-provider et /etc/ppp/chap-secrets sauf que j'ai fait une erreur dans le nom du second fichier sad ...
(d'abitude, pour eviter les erreus, je fais des copier-coller, mais quand on n'a pas le net.)

Une fois ces erreurs idioles corrigees, ma connection fonctionne nickel.

Merci VALENTE smile

Config :

XUbuntu sur PII avec 128Mo de ram
FAI : Wanadoo ADSL non-degroupe

Hors ligne

#32 Le 25/12/2006, à 13:36

Goalgauth

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,
Je viens d'installer dapper sur un P3 avec ce modem et wanadoo comme FAI.
C'est une magnifique réussite du premier coup avec la méthode Cathou!

Par contre, je dois théoriquement faire une adaptation du noyau 386 vers 686, ce que je n'ai pas pu faire avant l'établissement de la connexion internet. J'hésite un peu car j'ai peur de galérer pour réinstaller la connexion après (j'ai bien vu les méthodes conseillées dans le premier post... mais...). Je pense donc éviter de faire cette optimisation du noyau. Qu'en pensez-vous?
Merci.

Hors ligne

#33 Le 25/12/2006, à 15:50

Goalgauth

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bon, j'ai parlé un peu vite: Après la première mise à jour du noyau vers le 2.6.15-27-386, je n'ai plus de connexion...

Hors ligne

#34 Le 25/12/2006, à 18:54

Goalgauth

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

En fait, si j'ai bien compris, je risque d'avoir le même problème à chaque MAJ du noyau sous dapper alors que la même connexion semble marcher même après MAJ sous edgy avec ce tuto-ci http://eagleedgy.site.voila.fr/index.html...
S'il y a ce problème sous dapper et comme j'installe ubuntu pour faciliter la vie de quelqu'un qui ne sait pas faire d'analyse antivirus, de défragmentation ou autres besognes d'entretien sous w$, je crois que je vais le mettre aussi sur edgy (si ça passe, car le live cd d'edgy ne passe pas graphiquement...)

Hors ligne

#35 Le 26/12/2006, à 16:34

valente

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

remyb a écrit :

1 - Le lien ne marche pas quand on utilise cette m#$%& de IE. On arrive automatiquement sur eagleedgy.site.voila.fr/navigateur.html

Désolé :
- je suis fainéant et les recommandations W3C sont plus simples et plus pratiques pour faire des pages sur le "ouaibe". La "page" correspond a ce que l'on faisait en 2000 ! Depuis on a changé de millénaire mais pas «cette m#$%& de IE» si j'en crois ta remarque! lol
La page est visible avec un navigateur "texte" et assez respectueuse de l'accéssébilité des personnes avec handicape.

remyb a écrit :

(d'abitude, pour eviter les erreus, je fais des copier-coller, (...)

La doc est maintenant incluse dans le paquet, c'est là : /usr/doc/ueaglefirmware/install-fr.txt smile

@Lukubuntu Réponse tardive et désolé, il faut saisir :

sudo update-rc.d -f acpi-support remove

Il serait peut être plus judicieux de réinstaller l'ACPI... si quelqu'un peut renseigner !?! smile

@+

#36 Le 01/01/2007, à 18:09

benich

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,

J'ai installé le paquet de Valente. Tout c'est bien déroulé jusqu'au moment du branchement du modem : seul le voyant power c'est allumé.

Voici la réponse de la commande "sh /usr/bin/ueaglediag" :

Diagnostic () driver ueagle-atm 20070101162822
# System Information
Linux version 2.6.15-23-386 (buildd@rothera) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 PREEMPT Tue May 23 13:49:40 UTC 2006
version gcc 4.0.3 (Ubuntu 4.0.3-1ubuntu5)
usb_storage            74176  1
pppoatm                 6400  0
ppp_generic            30100  3 pppoatm,pppoe,pppox
eagle_usb             125220  0
usbcore               129668  5 usb_storage,eagle_usb,ehci_hcd,uhci_hcd
scsi_mod              139496  6 usb_storage,sr_mod,sbp2,sg,sd_mod,libata
cat: /proc/net/atm/ueagle-atm:*: Aucun fichier ou répertoire de ce type
benich    5179  0.0  0.0   2924   812 pts/0    S+   16:28   0:00 grep atmarp
eth0      Lien encap:Ethernet  HWaddr 00:13:D3:FE:F8:8B
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          Octets reçus:0 (0.0 b) Octets transmis:0 (0.0 b)

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:21 erreurs:0 :0 overruns:0 frame:0
          TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          Octets reçus:1456 (1.4 KiB) Octets transmis:1456 (1.4 KiB)

sit0      Lien encap:IPv6-dans-IPv4
          NOARP  MTU:1480  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          Octets reçus:0 (0.0 b) Octets transmis:0 (0.0 b)

Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
# ping IP ?              [ KO ]
# test DNS resolution ?  [ KO ]

En espérant que quelqu'un puisse m'aider et bonne année 2007 a tous smile

PS : j'ai déjà posté dans ce topic mais j'ai préféré venir poster aussi ici wink

Hors ligne

#37 Le 01/01/2007, à 18:28

valente

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,

Réponse simple grâce au script (merci Benoît Audouard)

>Linux version 2.6.15-23-386
1- le paquet que tu as téléchargé est uniquement  pour la version Ubuntu Edgy !
Il faut le désinstaller :

dpkg -r ueaglefirmware

>eagle_usb
Si tu as Ubuntu Dapper ou une autre version essaye les paquets de Cathou c'est le plus complet  pour Sagem fast I, II, III
ou
http://forum.ubuntu-fr.org/viewtopic.php?id=85242
Distrib Ubuntu Edgy & Dapper  pour Sagem fast I, II, III

A tout de suite sous Ubuntu !

@+

#38 Le 01/01/2007, à 20:58

benich

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Merci la méthode de Cathou a marché impécablement big_smile

Modem-diagnostic :

Distro:                         Ubuntu 6.06 LTS
Noyau actuel:                   2.6.15-23-386
Noyau(x) installé(s):
2.6.15-23-386   (2.6.15-23.39)
386     (2.6.15.22)

Pilote pour noyau actuel:       [ok]
Présence firmwares:             [ok]
Absence eagle-usb sur disque:   [ok]
Absence eagle-usb en mémoire:   [ok]
Présence ueagle-atm en mémoire: [ok]

FATAL: Module usbatm is in use.
Tentative de synchronisation du modem - Patientez SVP...

Chipset: Eagle III

Le modem est fonctionnel - Synchro en 20 secondes.

Connexion-diagnostic :

ppp0:                 [ok]
ping:                 [KO]
résolution de noms:   [KO]

Euh tout n'est pas parfait non ?

Hors ligne

#39 Le 01/01/2007, à 21:57

valente

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,

Si j'ai bien suivi les deux topic :
- tu es chez Orange/Wanadoo.
- tu as installe ueagle-atm-firmwares.deb +  ueagle-atm-2.6.15-23-386.deb & ueagle-pppoa.deb (paquet de Cathou)
- Pour Orange / Wanadoo avec CD dapper Live 6.06 i386 :

sudo dpkg -i ueagle-atm-firmwares.deb ueagle-atm-2.6.15-23-386.deb ueagle-pppoa.deb

- Et enfin toujours depuis ton terminal :

sudo /usr/bin/connexion-config

pour sélectionner le FAI (Orange) et saisir lton login et mot de passe.


Question :
Que donne comme info ces commandes :

lsmod | grep ueagle

et

sudo /etc/init.d/ueagle-pppoa stop

puis 

sudo /etc/init.d/ueagle-pppoa start

@+

#40 Le 01/01/2007, à 22:26

benich

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Tu as bien suivi wink


lsmod | grep ueagle

ueagle_atm             29100  0
usbatm                 19840  2 ueagle_atm
usbcore               129668  6 ueagle_atm,usbatm,usb_storage,ehci_hcd,uhci_hcd

sudo /etc/init.d/ueagle-pppoa stop

Stopping ueagle-pppoa
.
Starting ueagle-pppoa
Plugin pppoatm.so loaded.

sudo /etc/init.d/ueagle-pppoa start

Starting ueagle-pppoa
Plugin pppoatm.so loaded.

Mais bon le plus important c'est que je soit connecté big_smile

Dernière modification par benich (Le 01/01/2007, à 22:27)

Hors ligne

#41 Le 01/01/2007, à 23:46

benich

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Rahh !!

J'ai fait les mises à jour demandés par le systeme et ma version du kernel est maintenant 2.6.15-27-386  ...

Or aucun paquet ne correspond a cette version...

Que puis je faire ? sad

Hors ligne

#42 Le 02/01/2007, à 10:44

Valente

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,

Quel info renvoie la commande :

modinfo ueagle_atm

Si ce module est présent tu devrais pouvoir te connecter.
Et :

lsmod | grep eagle

@+

#43 Le 02/01/2007, à 12:52

benich

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Alors :

modinfo ueagle_atm

could not find module ueagle-atm

lsmod | grep eagle ( je n'arrive pas a faire le "|" sous ubuntu... hmm )

Usage lsmod

En fait, si j'ai bien compris le problème, il me manque le paquet deb de mon kernel... sad

Hors ligne

#44 Le 02/01/2007, à 14:49

Valente

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,

benich a écrit :

lsmod | grep eagle ( je n'arrive pas a faire le "|" sous ubuntu... hmm )

Il suffit de maintenir la touche [Alt Gr] enfoncé et d'appuyer sur la touche [6] <-- au dessus du [T] & [Y] (donc pas le [6] coté pavé numérique)

benich a écrit :

En fait, si j'ai bien compris le problème, il me manque le paquet deb de mon kernel... sad

C'est l'impression que j'ai sad

@+

#45 Le 02/01/2007, à 16:47

benich

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Salut smile

Valente a écrit :

Bonjour,

benich a écrit :

lsmod | grep eagle ( je n'arrive pas a faire le "|" sous ubuntu... hmm )

Il suffit de maintenir la touche [Alt Gr] enfoncé et d'appuyer sur la touche [6] <-- au dessus du [T] & [Y] (donc pas le [6] coté pavé numérique)

Merçi moi je fesais [Ctrl] + [Alt] + [6] et ca n'allait pas tongue

Le mieux serait peut être de désinstaller les paquets installés et d'assayer un autre méthode ( je pense a celle de PierreR ). hmm

Euh quelle est la commande pour défaire les paquets eagle installés ? wink

Hors ligne

#46 Le 02/01/2007, à 20:49

valente

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,


benich a écrit :

Le mieux serait peut être de désinstaller les paquets installés et d'assayer un autre méthode ( je pense a celle de PierreR ).

C'est aussi une excellente solution.... mais il te faut le module ueagle-atm comme pour le paquet Cathou !

En théorie (je suis sou Edgy) c'est intégré dans la mise à jour... pour en être sure :

lsmod | grep eagle

@+

#47 Le 02/01/2007, à 22:52

benich

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

lsmod | grep eagle ne renvoie rien...

J'ai télécharger edgy et je vais l'installer smile ( en espérant que ce fontionne ^^ ( je vait tester la méthode de PierreR )

EDIT : ca a marché sur le live CD, j'installe !

EDIT 2 : c'est Ok après réinstallation smile

Dernière modification par benich (Le 02/01/2007, à 23:30)

Hors ligne

#48 Le 04/01/2007, à 13:48

gene69

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,
j'ai fait la methode "Valente". Install à partir du livecd, marche nickel.
Mise à jour du noyau, marche plus. il faut r'installer le "firmware.deb" et relancher le service "adsl" et le problème est "fixé". Le plus beau c'est que les fichiers de config ne sont pas modifiés!

ensuite, j'ai un conseil pour valente c'est de mettre par défaut le mtu à 1492 pour éviter la fragmentation pour ce qui me semble le plus grand des cas. (pis perdre 8 octet c'est moins consommateur de resource que de fragmenter).


Le problème en sera toujours un tant que sagem ne fera pas un pilote.

Merci beaucoup.


Quand le berger est lâche, le loup chie de la laine.
A (draft) guide to UFO Alien-Invasion

Hors ligne

#49 Le 04/01/2007, à 22:21

valente

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,

gene69 a écrit :

ensuite, j'ai un conseil pour valente c'est de mettre par défaut le mtu à 1492 pour éviter la fragmentation pour ce qui me semble le plus grand des cas. (pis perdre 8 octet c'est moins consommateur de resource que de fragmenter).

Cette valeur de MTU est une simple recommandation
Liste partiel des MTU  (taille maximale d’un paquet transitant par l'interface)

Ethernet : 1500
ATM      : 9180
PPPoA    : 1500
PPPoE    : 1492
PPTP     : 1500

Tu as la possibilité de le constater par toi même et c'est beaucoup mieux smile
Après quelque temps sur la toile avec ton ordi.... exemple avec mo PC je suis en mode PPPoA:

ifconfig ppp
ppp0      Lien encap:Protocole Point-à-Point
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          Packets reçus:2925 erreurs:0 :0 overruns:0 frame:0
          TX packets:2950 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:3
          Octets reçus:2557525 (2.4 MiB) Octets transmis:370350 (361.6 KiB)

Valeurs recommandés depuis le site de développement : http://atm.eagle-usb.org

Et libre a toi de la modifié le fichier /etc/ppp/peers/dsl-provider en effectuant des testes smile
Il me semble avoir vu un truc en mode PPPoe ( j'ai plus le lien) ou l'on parlait effectivement de fragmentation... si tu as plus d'infos....

@+

#50 Le 05/01/2007, à 01:08

Cathou

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

pendragon12 a écrit :

connexion-config m'a renvoyé "echec du ping"

benich a écrit :

Connexion-diagnostic [..] Euh tout n'est pas parfait non ?

Comme indiqué sur ma page, le programme connexion-diagnostic fourni dans le paquet 'pppoa' est pour l'instant beaucoup plus rudimentaire que celui fourni dans le paquet 'static'. Par conséquent, ce qui peut arriver est qu'il signale des erreurs alors que tout baigne smile

Remarques:

1) en cas de pépin, on peut retomber sur ses pieds en faisant:

sudo /etc/init.d/ueagle-pppoa restart

2) Ce qui n'est pas indiqué sur ma page est que l'accès internet est disponible dès le démarrage, même si on boote en mode 'recovery' et c'est pratique de pouvoir utiliser apt-get dans ce mode wink

benich a écrit :

Rahh !!

J'ai fait les mises à jour demandés par le systeme et ma version du kernel est maintenant 2.6.15-27-386  ...

Or aucun paquet ne correspond a cette version...

Si si le paquet correspondant existe, mais tu ne l'as pas téléchargé AVANT d'effectuer les mises à jour.

En fait, ce qui t'es arrivé est un épiphénomène qui est assez pernicieux pour tous les gens qui ont des modules noyau en dehors du kernel tree:

- Par défaut, le méta-paquet linux-image-386 est installé.

- A cause de lui, quand le notificateur d'update détecte qu'une nouvelle version de noyau est disponible sur les dépots 'security', il télécharge et installe automatiquement cette version en remplacement de l'ancienne.

- Résultat: les gens qui ont des modules noyau (quels qu'ils soient, pas forcément ceux qui concernent le fast800..) se retrouvent marrons. Ils ont un beau noyau tout neuf mais pas les modules qui vont avec, et quand les modules en question sont destinés à un modem usb ou un matos wifi, retour à la case départ: pas d'internet.

La solution: désinstaller le méta-paquet linux-image-386
C'est absolument sans risque pour le noyau déja installé. Au contraire: installer un nouveau noyau depuis les dépots se fera en supplément de l'ancien noyau => 2 lignes supplémentaires dans le menu grub.

Avantages:
. sécurité: dans ces conditions on a la garantie d'avoir toujours au moins un noyau avec internet dans le menu grub
. contrôle fin des noyaux présents sur le système

Inconvénient:
. il faut se tenir au courant de temps en temps de la mise à disposition de nouveaux noyaux sur les dépots, car le notificateur d'update ne les signale plus

Apparemment, la mésaventure de benich s'est produite également pour Goalgauth. Puisqu'il doit installer ubuntu pour un(e) novice, je lui conseille d'installer edgy et d'utiliser la solution Valente ou la solution PierreR smile

gene69 a écrit :

Le problème en sera toujours un tant que sagem ne fera pas un pilote.

C'est pas demain la veille lol

Pour la question de la fragmentation, MTU=1492 est valable pour PPPoE. Pour les autres cas, IPoA et PPPoA, la valeur MTU=1500 est tout à fait correcte car les trames ATM sont beaucoup plus longues. Ceci m'a été confirmé par Matthieu Castet sur la ML de dev ueagle-atm.

Dernière modification par Cathou (Le 05/01/2007, à 20:38)

Haut de page ↑