Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 11/01/2007, à 13:18

cdi.cassin78

[Résolu] synaptic et proxy automatique

J'ai acces a internet dans firefox, mais synaptic n'arrive pas a se connecter. J'ai modifie apt.conf de la façon suivante : Acquire::http::Proxy "http://192.168.1.1/cgi-bin/slis.pac";
Je suis dans un college et la connexion proxy automatique se fait par un slis : http://192.168.1.1/cgi-bin/slis.pac ce qui fonctionne tres bien avec firefox
Merci pour votre aide

#2 Le 11/01/2007, à 13:52

inbox

Re : [Résolu] synaptic et proxy automatique

Bonjour,

Il faut modifier 2 fichiers : apt.conf et wgetrc

gedit  /etc/wgetrc
rechercher "# http_proxy" et décommenter cette ligne et la suivante qui commence par "# ftp_proxy". Puis après le signe "=" http://utilisateur:motdepasse@192.168.1.1/cgi-bin/slis.pac sur chacune des deux lignes.

La partie "utilisateur:motdepasse@" n'est peut-être pas nécessaire pour tout le monde. Mais si vous renseignez habituellement un compte et un mot de passe pour accéder Internet, il faut le faire dans ces deux fichiers.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#3 Le 11/01/2007, à 14:18

cdi.cassin78

Re : [Résolu] synaptic et proxy automatique

J'ai modifie wgetrc de la façon suivante mais ça ne fonctionne toujours pas

# You can set the default proxies for Wget to use for http and ftp.
# They will override the value in the environment.
http_proxy = http://192.168.1.1/cgi-bin/slis.pac
ftp_proxy = http://192.168.1.1/cgi-bin/slis.pac

# If you do not want to use proxy at all, set this to off.
# use_proxy = on

Merci pour l'aide

#4 Le 11/01/2007, à 14:47

inbox

Re : [Résolu] synaptic et proxy automatique

Il faut donc vérifier la configuration réseau afin d'être certain que le problème se trouve ailleurs. Mon fichier APT.CONF contient :

Acquire::http::Proxy "http://utilisateur:MotDePasse@adresseProxy:numéroport";

NB : le numéro de port est en standard le "80"

et le fichier /etc/wgetrc
http_proxy = http://utilisateur:MotDePasse@adresseProxy:numéroport/
ftp_proxy = http://utilisateur:MotDePasse@adresseProxy:numéroport/

Faire bien attention que les "/" et "/*;" de fin de ligne soient présents.
De même, êtes vous certain de ne pas devoir indiquer de compte de connexion avec mot de passe pour valider l'accès vers internet ?

[EDIT]Suppression du "/" après le n° de port.

Dernière modification par inbox (Le 17/09/2008, à 17:29)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#5 Le 11/01/2007, à 15:13

cdi.cassin78

Re : [Résolu] synaptic et proxy automatique

Ca ne fonctionne toujours pas, je n'ai pas besoin de mot de passe pour me connecter, le proxy est un SLIS utilise dans les etablissement scolaire avec un script automatique.
Si je ne trouve pas une solution je vais devoir repasser à Win
Merci quand même.

#6 Le 11/01/2007, à 15:49

inbox

Re : [Résolu] synaptic et proxy automatique

Essayer en décommentant la ligne "# use_proxy = on" dans wgetrc.

Puis, dans la console envoyer "sudo apt-get update" afin de voir les messages renvoyés. Si possible coller le résultat dans la réponse.

EDIT : Il semble que le port à indiquer soit le 8080. Donc :

APT.CONF contient :
Acquire::http::Proxy "http://192.168.1.1/cgi-bin/slis.pac:8080";

WGETRC contient :
# You can set the default proxies for Wget to use for http and ftp.
# They will override the value in the environment.
http_proxy = http://192.168.1.1/cgi-bin/slis.pac:8080/
ftp_proxy = http://192.168.1.1/cgi-bin/slis.pac:8080/

# If you do not want to use proxy at all, set this to off.
use_proxy = on

Faire un copier/coller des lignes ci-dessus dans vos fichiers et faire un "sudo apt-get update".

Dans le lien suivant, http://www.commentcamarche.net/forum/affich-2200814-proxy-recherche-solution-efficace , un administrateur SLIS précise "Le proxy doit identifier les utilisteurs par le nom d'ouverture de session Windows (pas d'identification suplémentaire)". Le problème d'accès pourrait venir de là.

Il est peut-être possible d'avoir plus d'information en contactant les personnes gérant SLIS au niveau national ?

[EDIT]Suppression du "/" après le n° de port.

Dernière modification par inbox (Le 17/09/2008, à 17:28)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#7 Le 14/01/2007, à 01:27

cdi.cassin78

Re : [Résolu] synaptic et proxy automatique

Bon, ça ne fonctionne toujours pas, visiblement je ne suis pas le seul à avoir des problèmes avec les proxys. Je vais donc réinstaller win :-( , c'est dommage il faudrait que les développeurs se penche sur ce problème. J'essaierai peut-être plus tard avec une autre version.

#8 Le 15/01/2007, à 18:26

inbox

Re : [Résolu] synaptic et proxy automatique

Bonjour,

En cherchant un peu plus j'ai trouvé un site de documentation SLIS ici : http://slis.ac-lyon.fr/docusager/

Plus précisément sur ce lien (http://slis.ac-grenoble.fr/doc/docbook/slis-howto/html/ch21s02.html) on parle de l'accès FTP vers l'extérieur. On peut donc constater que tout le monde ne peut accéder en FTP et qu'un identifiant est (semble) nécessaire.

Avez-vous essayé de vous connecter, depuis un PC sous Windows de vous connecter en FTP sur un site externe afin de confirmer/infirmer la possibilité d'utiliser ce protocole. Dans la négative, peut-être faudrait-il revoir la configuration du serveur SLIS ?

En cas de doute, vous devez pouvoir contacter un administrateur SLIS qui puisse vous renseigner sur ce qui est autorisé ou pas.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#9 Le 02/02/2007, à 17:49

maestria

Re : [Résolu] synaptic et proxy automatique

Coucou !
J'ai un problème similaire mais je n'ai pas de fichier apt.conf
Comment puis-je modifier le contenu d'un fichier qui n'existe pas? oO

Hors ligne

#10 Le 02/02/2007, à 18:00

maestria

Re : [Résolu] synaptic et proxy automatique

En fait, apparemment ce fichier doit bien être quelquepart, puisque quand je fais un

apt-config dump

ça m'affiche bien tout plein de paramètres smile

Mais lorsque j'essaye d'utiliser la commande apt-config -o pour spécifier une option, il n'en veut pas...
Voici le code de l'option que j'essaye de rentrer :

apt-config -o Acquire::http::Proxy=http://usr:pwd@proxy:port/

Quelqu'un aurait une solution ?

Hors ligne

#11 Le 02/02/2007, à 18:00

inbox

Re : [Résolu] synaptic et proxy automatique

Bonjour,

Le fichier apt.conf ne se trouve pas dans le même dossier "wgetrc". Donc pour l'éditer

sudo gedit /etc/apt/apt.conf

wink


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#12 Le 02/02/2007, à 18:03

maestria

Re : [Résolu] synaptic et proxy automatique

ok merci !

Hors ligne

#13 Le 15/05/2007, à 18:24

Imagine

Re : [Résolu] synaptic et proxy automatique

Bonjour

Je relance le post, il faut que je m'y attèle demain smile

Quelqu'un a réussi à se connecter à travers un SLIS ?

En Live CD, pour Firefox pas de problème, il suffit de régler les paramètres réseaux
mais comment faire pour apt, synaptic et autres pour passer le proxi et son script de connexion http://......./slis.pac ?

Hors ligne

#14 Le 16/05/2007, à 17:54

Imagine

Re : [Résolu] synaptic et proxy automatique

Testé ce matin et tout con en fait big_smile

Le script c'est que pour les pages Web (normal vu que Slis est là pour protéger nos chères têtes blondes des contenus tendancieux)

Pour ce connecter avec Synaptic ou apt, suffit de bien renseigner sa configuration réseau :

Adresse IP du Slis comme passerelle. 192.168.1.1 c'est pas vraiment dans les plans d'adressage académiques, dans mon bahut elle ne ressemble pas à ça big_smile

Masque de sous réseau : 255.255.0.0 Pour gérer les salles et les postes, 255 possibilités c'est insuffisant big_smile

Adresse IP du Slis comme serveur DNS

Et ça roule lol

Il n'y avait pas de raison que ce soit plus compliqué que sous W98

Dernière modification par Imagine (Le 16/05/2007, à 18:09)

Hors ligne

#15 Le 16/05/2007, à 18:09

inbox

Re : [Résolu] synaptic et proxy automatique

Salut,

C'est très con en effet. Je n'y avais pas pensé.

Il faudra prévenir cdi.cassin78 que ça fonctionne. cool

Je demande aux admins Ubuntu de passer le sujet en résolu.

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#16 Le 25/04/2008, à 16:24

landros

Re : [Résolu] synaptic et proxy automatique

Bonjour, la solution est de mettre directement dans synaptic :

mon_nom:mon_mot_de_passe@IP_serveur_mandataire_proxy

dans le champs de mandataire de synaptic

et

le numéro de port correspondant dans le champ prévu pour cela.

typiquement cela donne cela :

landros:0000@22.22.22.22

3128

à noter que cela ne fontionne pas quand j'écris la ligne :

Acquire::Proxy "http://user:password@IP_du_Proxy:Port_du_Proxy";

dans le fichier /etc/apt/apt.conf, mais seulement quand je le fait dans synaptic.

En effet, j'ai supprimé du dossier de apt le fichier apt.conf et cela fonctionne encore.

Bon courage

Hors ligne

#17 Le 25/04/2008, à 16:30

inbox

Re : [Résolu] synaptic et proxy automatique

Sympa, cela s'éclaircit. wink


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#18 Le 25/04/2008, à 16:33

landros

Re : [Résolu] synaptic et proxy automatique

j'ai galéré pendant toute le journée dessus donc je suis sur de la réponse si ya pas de résultat si le moi

Hors ligne

#19 Le 25/04/2008, à 16:35

landros

Re : [Résolu] synaptic et proxy automatique

à noter que le fichier apt.conf était un fichier qu'il fallait créer à la main

Hors ligne

#20 Le 27/06/2008, à 16:55

jelassi chokri

Re : [Résolu] synaptic et proxy automatique

Salut
j'ai slils3.2 a partir d'internet je l'ai installer sur ma machine mais j'arrive pas a me connecter a l'interface de configuration du serveur bien que j'ai bien configurer mon navigateur alors au démarrage du serveur il m'affiche un message d'erreur impossible de se connecter au serveur postgres pour utilisateur hadmin

#21 Le 27/06/2008, à 17:02

titi38

Re : [Résolu] synaptic et proxy automatique

Attention à la ligne de commande
Il manque les deux points de séparation
Acquire::http::Proxy "http://192.168.xxx.xxx:yyy";


Il n'y a pas de problème. Le plus dur étant de trouver une solution.

Hors ligne

#22 Le 17/09/2008, à 17:24

Pablo_de_Taix

Re : [Résolu] synaptic et proxy automatique

J'ai eu le pb,
Plusieurs d'entre vous m'ont beaucoup aidé
Mon PC sous ubuntu 8.04
mais il veut pas du # en début de ligne de commentaire
j'ai viré la ligne de commentaire et son # initial
il n'y a que la ligne Acquire.... qui finit par ...8080";
et ça fonctionne pour apt-get
ça suffit pour Firefox, mais c'est moins grave.
MERCI A TOUS Pablo

Hors ligne

Haut de page ↑