Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 23/05/2012, à 22:49

Gioca

[RESOLU] Demarrage Ubuntu impossible

Bonjour,

d abord je m excuse pour l ecriture, la configuration de mon clavier est fichue et je ne retrouve pas tous les accents...
je viens vers vous apres deux jours de tentatifs infructueux. Mais je voudrais que vous sachiez que je suis sur ubuntu depuis deux ans, mais je suis assez nul

Je vous dis ce qui c est passe :

J ai ubuntu version 10.04 lts, gnome

J ai debranche le courant pendant que ubuntu etait en train de se fermer.
La chose lui a deplu fortement, tant que apres il n a plus voulu demarrer.
apres la page de grub il s affiche une page avec cette erreur:

mount: mounting /dev on /root/dev failed : no such file or directory
mount: mounting /sys on /root/sys failed : no such file or directory
mount: mounting /proc on /root/proc failed : no such file or directory

Target file system doesn t have requested /sbin/init
No init found. Try passing init = bootarg
<initramfs>

Bref resume des tentatifs faillis :
- changement ligne boot
- redemarrage
- exclusion LAN dans le menu boot de l ordi
- liveUSB ubuntu 10.04 lts <qui ne permettait pas de faire quoi que ce soit>
- liveUSB ubuntu 10.04 alternate <ca chargait meme pas la cle au demarrage>

Ou j en suis :

- LiveUSB ubuntu 10.10 netbook
Me permet de vous ecrire une fois demarre en live, mais voila la copie des manipulations echouees sur le terminal:

ubuntu@ubuntu:~$ sudo fdisk -lu

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00096e37

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   150159359    75078656   83  Linux
/dev/sda2       150161406   156301311     3069953    5  Extended
/dev/sda5       150161408   156301311     3069952   82  Linux swap / Solaris

Disk /dev/sdb: 1010 MB, 1010827264 bytes
2 heads, 63 sectors/track, 15668 cylinders, total 1974272 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x005796de

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          32     1974271      987120    b  W95 FAT32
ubuntu@ubuntu:~$ sudo fdisk

Usage:
fdisk [options] <disk>    change partition table
fdisk [options] -l <disk> list partition table(s)
fdisk -s <partition>      give partition size(s) in blocks

Options:
-b <size>                 sector size (512, 1024, 2048 or 4096)
-c                        switch off DOS-compatible mode
-h                        print help
-u <size>                 give sizes in sectors instead of cylinders
-v                        print version
-C <number>               specify the number of cylinders
-H <number>               specify the number of heads
-S <number>               specify the number of sectors per track

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00096e37

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        9347    75078656   83  Linux
/dev/sda2            9348        9730     3069953    5  Extended
/dev/sda5            9348        9730     3069952   82  Linux swap / Solaris

Disk /dev/sdb: 1010 MB, 1010827264 bytes
2 heads, 63 sectors/track, 15668 cylinders
Units = cylinders of 126 * 512 = 64512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x005796de

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1       15669      987120    b  W95 FAT32
ubuntu@ubuntu:~$ sudo fsck -f -y /dev/sda1
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext4: Device or resource busy while trying to open /dev/sda1
Filesystem mounted or opened exclusively by another program?

ubuntu@ubuntu:~$ sudo fsck -f -y /dev/sda2
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext2: Attempt to read block from filesystem resulted in short read while trying to open /dev/sda2
Could this be a zero-length partition?

ubuntu@ubuntu:~$ sudo fsck -f -y /dev/sda3
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext2: No such file or directory while trying to open /dev/sda3

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

ubuntu@ubuntu:~$ sudo fsck /dev/sda1
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext4: Device or resource busy while trying to open /dev/sda1
Filesystem mounted or opened exclusively by another program?
ubuntu@ubuntu:~$ sudo fsck /dev/sda2
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext2: Attempt to read block from filesystem resulted in short read while trying to open /dev/sda2
Could this be a zero-length partition?
ubuntu@ubuntu:~$ sudo fsck /dev/sda3
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext2: No such file or directory while trying to open /dev/sda3

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

ubuntu@ubuntu:~$ fsck -y /dev/sda1
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext2: Permission denied while trying to open /dev/sda1
You must have r/w access to the filesystem or be root
ubuntu@ubuntu:~$ r
The program 'r' is currently not installed.  You can install it by typing:
sudo apt-get install littler
You will have to enable the component called 'universe'

ubuntu@ubuntu:~$ sudo apt-get install littler
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package littler
ubuntu@ubuntu:~$ fsck -y /dev/sda1
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext2: Permission denied while trying to open /dev/sda1
You must have r/w access to the filesystem or be root
ubuntu@ubuntu:~$ fsck -y /dev/sda2
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext2: Permission denied while trying to open /dev/sda2
You must have r/w access to the filesystem or be root
ubuntu@ubuntu:~$ fsck -y /dev/sda3
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext2: No such file or directory while trying to open /dev/sda3

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>



Quelqu un aurait le bon coeur de m aider au moins a recuperer mes files ?
Ou bien vous pensez que le disque est fichu ?

Merci par avance de l espace que vous m avez offert.
Je reste la nuit dessus, du coup n hesitez pas a m insulter pour les betises que j aurais certainement fait.

Bien a vous

Giovanni

Dernière modification par Gioca (Le 26/05/2012, à 11:55)

Hors ligne

#2 Le 24/05/2012, à 00:42

Gioca

Re : [RESOLU] Demarrage Ubuntu impossible

Ici la reponse au command: Mount

ubuntu@ubuntu:~$ mount
aufs on / type aufs (rw)
none on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
/dev/sdb1 on /cdrom type vfat (ro,noatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop0 on /rofs type squashfs (ro,noatime)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/ubuntu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ubuntu)

Hors ligne

#3 Le 26/05/2012, à 05:36

malbo

Re : [RESOLU] Demarrage Ubuntu impossible

En lisant ce post : http://forum.ubuntu-fr.org/viewtopic.ph … 1#p5919211
Je comprends qu'une liveUSB 10.10 ne peut pas réparer ton problème parce que la liveUSB 10.10 elle même est buggée. Il faut que tu te fasses une liveUSB d'une autre version. Et puisque ton Ubuntu installé est une version 10.04, tu devrais essayer de te faire une liveUSB 10.04


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#4 Le 26/05/2012, à 11:53

Gioca

Re : [RESOLU] Demarrage Ubuntu impossible

Bonjour Malbo,

merci beaucoup pour ta reponse, je ne m'y attendais plus.
De toute façon finalement j'ai reussi à resoudre en installant ubuntu 11.10 dans un autre ordi,
reparant tous les bug que 11.10 avait, en attachant mon disc dur, faisant un back up de home, en le verifiant et le reparant avec gparted.

Les versions 10.04 et 10.10 ont toutes les deux des problèmes en live usb. Ubuntu 11.10 donnait comme bug principale un conflit entre modules internet, avec le resultat d'une connexion trop lente, voir en écheque. À la fin de la reparation je ne suis pas encore arriver à donner du son à l'ordi!

En tous cas le miens est revenu à la normalité et quand les mises à jours m'ont demandé si je voulais passer à ubuntu 11.04, si j'avais eu un revolver j'aurais transpercé l'écran.

Vive linux, vive ubuntu, mais alors, j'ai posté dans la communauté italienne et francaise, pas une seule reponse avant Malbo, ni personne qui puisse me dire où est-ce que j'ai trompé dans la formulation et la mise en forme de la question.

Bon, au revoir, j'espère pas à une prochaine.

Giovanni

Hors ligne

Haut de page ↑