Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#26 Le 16/06/2012, à 19:28

MarieP

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

J'ai toujours branché le boîtier à l'arrière de la tour, je sais que pour les gros périphériques c'est mieux. En revanche, je branche mes clef USB à l'avant.

Du côté du BOIS, voici la config USB :

USB Device Enabled: None
USB 1.1 Controller            [Enabled]
USB 2.0 Controller            [Enabled]
Legacy USB Support    [Auto]
USB 2.0 Controller Mode [Hi Speed]

Je précise que j'utilise un clavier et une souris PS/2 et que je n'ai aucun périphérique USB branché en permanence sur ma tour. Je les branche quand j'en ai besoin et ils ne m'ont jamais posé problème.


Config : Linux Ubuntu Precise Pangolin 12.04 64 bits, en dual boot avec Windows XP.

Hors ligne

#27 Le 16/06/2012, à 19:34

PPdM

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Ben maintenant tu as  a un! hmm
Essayes un autre contrôleur , ils marchent par paire, un contrôleur commande une paire de prises,  c'est rare qu'il tombent tous en panne en même temps

Périphérioque USB non reconnu. L'un des périphériques USB reliés à cet ordinateur a mal fonctionné et Windows ne le reconnaît pas.

ce genre de message est typique, d'un cable hs ou d'un contrôleur en défaut

Dernière modification par pierguiard (Le 16/06/2012, à 19:36)

Hors ligne

#28 Le 16/06/2012, à 20:20

MarieP

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

J'ai essayé deux clefs USB sur les 4 ports arrière, toutes sont reconnues. Il y a juste un problème pour démonter la deuxième, mais je pense que c'est parce qu'elle est en FAT16 - GParted l'affiche comme démontée avec une icône d'alerte, et indique dans les propriétés qu'il n'arrive pas à l'ouvrir (je précise que ce n'est pas sur celle-ci que j'ai un fichier endommagé, mais sur l'autre) : http://cjoint.com/?BFquqXpgqOv
Quant au message de Windows dont tu parles c'était celui qui s'affichait avec l'ancien câble, qui était effectivement défectueux. Avec le nouveau je n'ai plus de problème sous XP, le DD s'affiche correctement.

Dernière modification par MarieP (Le 16/06/2012, à 20:23)


Config : Linux Ubuntu Precise Pangolin 12.04 64 bits, en dual boot avec Windows XP.

Hors ligne

#29 Le 16/06/2012, à 20:24

PPdM

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Branches ton disque et fais  un

lsusb

que l'on voit ce que ça dit

Hors ligne

#30 Le 17/06/2012, à 22:51

rmy

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Est-ce que tu as testé ce disque en interne ?
Si oui, soit il n'y a plus de problème, soit ça élimine le souci de l'usb... (encore que tu pourrais avoir deux problèmes en même temps).


récupération de données : vractopic uniquemon site pro : www.diskcard.fr
Je récupère et recycle volontiers tous vos disques durs HS (ou pas).
BLACKOUT

Hors ligne

#31 Le 20/06/2012, à 19:58

MarieP

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Bonjour pierguiard, bonjour rmy

Malheureusement la commande lsusb donne toujours la même chose

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Et pour rmy: oui, j'ai testé le disque en interne au tout début, mais maintenant que tu en parles je me souviens j'avais eu des soucis pour y accéder depuis Ubuntu, ce qui fait que je l'avais formaté depuis XP. Je re-teste ça demain et je te dis.

Encore merci à vous de m'aider, c'est très sympa. smile

Marie

Dernière modification par MarieP (Le 20/06/2012, à 19:59)


Config : Linux Ubuntu Precise Pangolin 12.04 64 bits, en dual boot avec Windows XP.

Hors ligne

#32 Le 21/06/2012, à 23:12

MarieP

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Bonsoir

Suite de mon post d'hier : j'ai installé le disque dur en interne sur ma carte mère et pas de problème, il est parfaitement monté par Ubuntu au démarrage.

D'où peut venir ce satané problème ? Un DD reconnu par XP mais pas par Ubuntu, comment ça peut se faire ?

Marie


Config : Linux Ubuntu Precise Pangolin 12.04 64 bits, en dual boot avec Windows XP.

Hors ligne

#33 Le 22/06/2012, à 18:28

MarieP

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Suite de mes aventures : ce soir, je me suis payé le luxe de récupérer un deuxième disque dur du même modèle que celui qui me pose problème, et qui lui est formaté en FAT 32 :
- reconnu sans problème par Ubuntu et XP quand il est monté sur la carte mère
- reconnu sans problème par XP quand il est dans le boîtier externe
- impossible de le faire reconnaître par Ubuntu quand il est dans le boîtier externe : nada, que couic, que t'chi, Ubuntu ne veut rien savoir.
Mais qu'est-ce qui manque, bon sang ??
Marie


Config : Linux Ubuntu Precise Pangolin 12.04 64 bits, en dual boot avec Windows XP.

Hors ligne

#34 Le 22/06/2012, à 21:31

PPdM

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

C'est sans doute ce que je t'avais dis au début, un souci avec le contrôleur USB/IDE.
Branches ton boîtier sans disque et fais un

lsusb

et refait le avec le disque dans le boitier

Dernière modification par pierguiard (Le 22/06/2012, à 21:31)

Hors ligne

#35 Le 23/06/2012, à 13:00

Khady

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Sur un laptop elitebook 8540p le disque marche bien avec le boitier (teste pendant une install party). Il est monte automatiquement.
Ubuntu 12.04 mis a jour hier avec unity. Configuration de base.
Voici les traces des differents tests.

Avec le disque branche
# lsusb

Bus 002 Device 007: ID 152d:2338 JMicron Technology Corp. / JMicron USA Technology Corp. JM20337 Hi-Speed USB to SATA & PATA Combo Bridge
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 138a:0007 Validity Sensors, Inc. VFS451 Fingerprint Reader
Bus 001 Device 004: ID 04f2:b15e Chicony Electronics Co., Ltd

Sans le disque
# lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 138a:0007 Validity Sensors, Inc. VFS451 Fingerprint Reader
Bus 001 Device 004: ID 04f2:b15e Chicony Electronics Co., Ltd

commande lancee avant de brancher le disque et log du branchement
# tail -f /var/log/syslog

Jun 23 12:51:19 caab-HP-EliteBook-8540p dhclient: DHCPREQUEST of 10.12.174.160 on eth1 to 10.40.22.2 port 67
Jun 23 12:51:20 caab-HP-EliteBook-8540p dhclient: DHCPACK of 10.12.174.160 from 10.40.22.2
Jun 23 12:51:20 caab-HP-EliteBook-8540p dhclient: bound to 10.12.174.160 -- renewal in 803 seconds.
Jun 23 12:54:01 caab-HP-EliteBook-8540p AptDaemon: INFO: Quitting due to inactivity
Jun 23 12:54:01 caab-HP-EliteBook-8540p AptDaemon: INFO: Quitting was requested
Jun 23 12:54:01 caab-HP-EliteBook-8540p dbus[886]: [system] Activating service name='org.debian.apt' (using servicehelper)
Jun 23 12:54:01 caab-HP-EliteBook-8540p AptDaemon: INFO: Initializing daemon
Jun 23 12:54:01 caab-HP-EliteBook-8540p dbus[886]: [system] Successfully activated service 'org.debian.apt'
Jun 23 12:54:01 caab-HP-EliteBook-8540p AptDaemon.PackageKit: INFO: Initializing PackageKit compat layer
Jun 23 12:57:10 caab-HP-EliteBook-8540p kernel: [ 3873.644141] usb 2-1.3: USB disconnect, device number 7
Jun 23 12:57:57 caab-HP-EliteBook-8540p kernel: [ 3920.634628] usb 2-1.3: new high-speed USB device number 8 using ehci_hcd
Jun 23 12:57:57 caab-HP-EliteBook-8540p mtp-probe: checking bus 2, device 8: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3"
Jun 23 12:57:57 caab-HP-EliteBook-8540p mtp-probe: bus: 2, device: 8 was not an MTP device
Jun 23 12:57:57 caab-HP-EliteBook-8540p kernel: [ 3920.731033] scsi12 : usb-storage 2-1.3:1.0
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.729820] scsi 12:0:0:0: Direct-Access     MAXTOR S TM3160215A            PQ: 0 ANSI: 2 CCS
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.731077] sd 12:0:0:0: Attached scsi generic sg2 type 0
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.731769] sd 12:0:0:0: [sdb] 312581808 512-byte logical blocks: (160 GB/149 GiB)
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.732913] sd 12:0:0:0: [sdb] Write Protect is off
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.732921] sd 12:0:0:0: [sdb] Mode Sense: 28 00 00 00
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.734354] sd 12:0:0:0: [sdb] No Caching mode page present
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.734361] sd 12:0:0:0: [sdb] Assuming drive cache: write through
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.737598] sd 12:0:0:0: [sdb] No Caching mode page present
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.737605] sd 12:0:0:0: [sdb] Assuming drive cache: write through
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.740993]  sdb: sdb1
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.743668] sd 12:0:0:0: [sdb] No Caching mode page present
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.743674] sd 12:0:0:0: [sdb] Assuming drive cache: write through
Jun 23 12:57:58 caab-HP-EliteBook-8540p kernel: [ 3921.743678] sd 12:0:0:0: [sdb] Attached SCSI disk

Envoyé depuis notre GNU/Linux

Hors ligne

#36 Le 23/06/2012, à 13:29

PPdM

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Tu as branché le boîtier sans disque dedans?
Cela ressemble fort a une incompatibilité matériel

Hors ligne

#37 Le 24/06/2012, à 15:23

MarieP

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Bon, alors finalement le problème a l'air en partie résolu... mais en partie seulement, et je ne sais pas très bien comment.
Je vais essayer de raconter les choses dans l'ordre, ce qui va répondre à la question de pierguiard.

pierguiard a écrit :

Tu as branché le boîtier sans disque dedans?

En fait je suis allée à une install party qui (heureuse coïncidence) avait lieu hier près de chez moi, avec mon disque et son boîtier. J'ai eu  au moins 4 ou 5 ubuntiens qui se sont occupés de mon cas et qui ont testé le boîtier sur les différents ordinateurs qu'ils avaient sous la main, et personne n'a vraiment compris l'origine du problème.

Voici les tests qui ont été faits :
- 1er test : branchement sur un PC portable sous Ubuntu 12.04, environnement Unity : le boîtier est reconnu automatiquement sans problème. Le résultat des différentes commandes se trouve dans le post précédent.
- 2ème test : PC de bureau sous ArchLinux, environnement KDE : pas détecté
- 3ème test : PC de bureau sous Fedora, environnement Gnome 3 : pas détecté
- 4ème test : PC portable sous ArchLinux sans environnement :  détecté automatiquement. La personne a essayé de créer un fichier bonjour.txt sur le disque (alors totalement vide) en ligne de commande, et ça a marché sans problème.
Ce qui, comme me l'a fait remarquer l'un des testeurs, a permis de constater aussi la chose suivante : le boîtier était détecté sur les PC portable mais pas sur les tours (or j'ai moi aussi une tour).

Je suis tout de même repartie avec plusieurs pistes :
- tout d'abord, je suis sous Gnome Classique et pas sous Unity. A priori, il n'y a aucune raison pour que l'environnement y soit pour quelque chose mais on m'a dit qu'il était possible qu'il se soit produit une erreur quand j'ai installé Gnome Classique à la place de Unity (en suivant ce tutoriel). Pour le vérifier on m'a indiqué d'utiliser la commande

tail -f /var/log/syslog

en m'indiquant que si elle ne renvoyait rien, c'est qu'il manquait un module dans le noyau, mais que si elle renvoyait quelque chose c'était la relation entre Gnome et Unity qui posait problème.
- l'autre piste consistait à tester le boîtier depuis un Live-CD, et je me suis bien demandée pourquoi je n'y avais pas pensé plus tôt...

Je suis donc revenue avec ces précieuses informations, et j'ai commencé par tester la commande tail. Et là... miracle, non seulement il y a eu un retour détectant le disque, mais en plus il s'est monté tout seul.

Jun 24 14:50:25 system kernel: [10010.928021] usb 1-2: reset high-speed USB device number 5 using ehci_hcd
Jun 24 14:50:25 system ata_id[4415]: HDIO_GET_IDENTITY failed for '/dev/sdc': Invalid argument
Jun 24 14:50:26 system usbmount[4425]: /dev/sdc does not contain a filesystem or disklabel
Jun 24 14:50:26 system usbmount[4446]: executing command: mount -tvfat -osync,noexec,nodev,noatime,nodiratime /dev/sdc1 /media/usb0
Jun 24 14:50:26 system usbmount[4446]: executing command: run-parts /etc/usbmount/mount.d
Jun 24 14:50:47 system kernel: [10032.296147] usb 1-2: USB disconnect, device number 5
Jun 24 14:50:47 system usbmount[4505]: executing command: umount -l /media/usb0
Jun 24 14:50:47 system usbmount[4505]: executing command: run-parts /etc/usbmount/umount.d
Jun 24 14:52:05 system kernel: [10111.088023] usb 2-2: new high-speed USB device number 2 using ehci_hcd
Jun 24 14:52:06 system mtp-probe: checking bus 2, device 2: "/sys/devices/pci0000:00/0000:00:04.1/usb2/2-2"
Jun 24 14:52:06 system kernel: [10111.222203] scsi10 : usb-storage 2-2:1.0
Jun 24 14:52:06 system mtp-probe: bus: 2, device: 2 was not an MTP device
Jun 24 14:52:07 system kernel: [10112.221815] scsi 10:0:0:0: Direct-Access     MAXTOR S TM3160215A            PQ: 0 ANSI: 2 CCS
Jun 24 14:52:07 system kernel: [10112.222792] sd 10:0:0:0: Attached scsi generic sg3 type 0
Jun 24 14:52:07 system kernel: [10112.224576] sd 10:0:0:0: [sdc] 312581808 512-byte logical blocks: (160 GB/149 GiB)
Jun 24 14:52:07 system kernel: [10112.226691] sd 10:0:0:0: [sdc] Write Protect is off
Jun 24 14:52:07 system kernel: [10112.226695] sd 10:0:0:0: [sdc] Mode Sense: 28 00 00 00
Jun 24 14:52:07 system kernel: [10112.228670] sd 10:0:0:0: [sdc] No Caching mode page present
Jun 24 14:52:07 system kernel: [10112.228673] sd 10:0:0:0: [sdc] Assuming drive cache: write through
Jun 24 14:52:07 system kernel: [10112.233669] sd 10:0:0:0: [sdc] No Caching mode page present
Jun 24 14:52:07 system kernel: [10112.233674] sd 10:0:0:0: [sdc] Assuming drive cache: write through
Jun 24 14:52:07 system kernel: [10112.238839]  sdc: sdc1
Jun 24 14:52:07 system kernel: [10112.243669] sd 10:0:0:0: [sdc] No Caching mode page present
Jun 24 14:52:07 system kernel: [10112.243674] sd 10:0:0:0: [sdc] Assuming drive cache: write through
Jun 24 14:52:07 system kernel: [10112.243676] sd 10:0:0:0: [sdc] Attached SCSI disk

Est-ce parce qu'un fichier y a été créé ? Je n'en sais rien. En tous cas, plusieurs problèmes demeurent :
- un problème que j'ai depuis quelques temps avec mes clefs USB (sans doute depuis que j'ai essayé de modifier mes paramètres de montage automatique pour essayer de régler cette histoire) : le disque est monté automatiquement dans /media/usb0 (et non dans /media/sdc) et dans Nautilus il apparaît deux fois dans la liste, en tant que dossier usb0 et en tant que disque dur 160Go. Et ensuite, je n'arrive plus à déconnecter le lecteur (Retirer le volume sans risque) ni à démonter usb0.
- le disque semble protégé en écriture : je peux ouvrir le fichier bonjour.txt mais je ne peux le supprimer qu'en mode administrateur. Je ne peux pas non plus créer de nouveau fichier en mode utilisateur, je dois ouvrir gedit en mode admin si je veux enregistrer un fichier texte.
- GParted met 15 plombes à ouvrir les partitions. Pareil quand je lui demande de démonter le disque.

J'ai déjà bien avancé depuis hier, au moins j'accède au disque et je pense du coup qu'il n'y a pas d'incompatibilité matérielle (sinon, de toute façon ça ne marcherait pas sous XP).
Pour info, et au cas où cela puisse venir de là, ci-dessous le contenu de mon fstab :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda2 during installation
UUID=9bbc2861-9e33-462f-b9e5-640a22c1850a /               ext3    errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=d06b545a-d4e2-4ac0-9060-a9ab2fea77c8 /home           ext3    defaults        0       2
# /media/windows was on /dev/sda5 during installation
UUID=1BCF-181C  /media/windows  vfat    utf8,umask=007,gid=46 0       1
# swap was on /dev/sda3 during installation
UUID=d812a415-e8c5-4c80-8e75-db50e2fb0b4c none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

Voilà, si quelqu'un a d'autres pistes... encore merci !

Marie

Dernière modification par MarieP (Le 24/06/2012, à 15:27)


Config : Linux Ubuntu Precise Pangolin 12.04 64 bits, en dual boot avec Windows XP.

Hors ligne

#38 Le 24/06/2012, à 15:32

PPdM

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Salut, cela a un peu avancé, mais c'est quand même bizarre le fait qu'il ne soit pas reconnu systématiquement par tout les PCs.
Je reste sur mon idée d'incompatibilité matérielle, car cela se manifeste souvent comme cela.
Si le contrôleur USB/IDE ou SATA a un bug ou une puce défectueuse, cela peut provoquer ce genre de soucis
Testes avec un Xubuntu sur ton PC pour voir.

Hors ligne

#39 Le 24/06/2012, à 18:27

rmy

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

D'après ce que tu dis :
Es-tu sûre que ce disque était formaté (c'est à dire avec un système de fichier) ?
Ne confonds-tu pas "reconnu" et "auto-mount" ?
Est-ce que par hasard ce ne serait pas à cette ubuntu party que ton disque a été formaté, et que don tu n'aurais pas le droits sur le système de fichier ?

Question subsidiaire :
Est-ce que tu peux tester ce disque avec un autre boîtier ?

Info complémentaire : le disque s'appelle sdc, mais l'automount le monte en fonction du nom de la partition, ici usb0 >> /media/usb0

Essaye un truc :
Une fois le disque branché, commence par le démonter :

sudo umount /dev/sdc1

puis le remonter via udev :

udisks --mount /dev/sdc1

Y as-tu accès ?
Ensuite, compare avec un montage manuel.
redémonte (cf ci-dessus)
puis remonte :

mkdir testmount && sudo mount /dev/sdc1 testmount/

Y as-tu accès ?

Enfin, si tu n'as aucun document sur ce disque, essaye éventuellement de le formater proprement :
0/ Unmount
1/ Des zéros sur le début du disque :

sudo dd if=/dev/zero of=/dev/sdc bs=512 count=63

2/ Création d'un MBR tout neuf :

sudo parted /dev/sdc mklabel msdos

3/ Création d'une partition primaire qui occupe tout le disque :

sudo fdisk /dev/sdc 

puis :
n -> valeurs par défaut
t -> identifiant 07
a
w
4/ Enfin, création d'un filesystem en ntfs :

sudo mkfs.ntfs /dev/sdc1 -f -L "MarieP"

Ensuite tu débranches le disque et dans l'ordre :
Allumage du boîtier, puis branchement de l'usb. Si ton automount fonctionne, tu devrais avoir un disque accessible en RW dans /media/MarieP/


récupération de données : vractopic uniquemon site pro : www.diskcard.fr
Je récupère et recycle volontiers tous vos disques durs HS (ou pas).
BLACKOUT

Hors ligne

#40 Le 25/06/2012, à 17:51

MarieP

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Bonjour

Encore un très grand et très sincère merci à vous, pierguiard et rmy de vous occuper de mon problème. smile

Je vais être loin de mon PC dans la semaine qui vient donc je ne vauis pas pouvoir pas tester ce que vous me demandez tout de suite. Je m'en occupe dès que je pourrai et je vous tiens au courant.

Marie P


Config : Linux Ubuntu Precise Pangolin 12.04 64 bits, en dual boot avec Windows XP.

Hors ligne

#41 Le 30/06/2012, à 22:05

mytaz

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Hello...
Je croyais avoir le même pb (HD externe non reconnu par le Pangolin) ; mais j'ai testé tout bêtement le lsusb : le disque n'était pas référencé !!! J'ai juste débranché le transfo d'alim. de ce dique (un iomega 500 Go), attendu qq secondes et rebranché. Un lsusb m'a fait voir que le disque était référencé et j'ai bien pu me balader dans ses différentes partitions !!!
Si ça peut vous aider...

Dernière modification par mytaz (Le 30/06/2012, à 22:05)

Hors ligne

#42 Le 15/07/2012, à 17:18

MarieP

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Bonjour

J'ai un peu de temps aujourd'hui pour m'occuper de mon problème de lecteur USB, donc je reviens vers vous.

Je vais essayer de répondre dans l'ordre.

pierguiard a écrit :

Je reste sur mon idée d'incompatibilité matérielle, car cela se manifeste souvent comme cela.
Si le contrôleur USB/IDE ou SATA a un bug ou une puce défectueuse, cela peut provoquer ce genre de soucis
Testes avec un Xubuntu sur ton PC pour voir.

Je t'avoue que je n'ai pas eu le courage d'installer Xubuntu à la place d'Ubuntu, mais il est possible que ce soit une défection matérielle car depuis mon dernier post, j'avais essayé une fois de rebrancher mon lecteur externe, en vain : il n'était plus détecté.
Mais dans ce cas, est-il facile de changer une puce sur une carte-mère ?

Mais aujourd'hui le boîtier est bien reconnu, donc j'en profite pour faire les manips indiquées par rmy.

rmy a écrit :

Es-tu sûre que ce disque était formaté (c'est à dire avec un système de fichier) ?

Tout à fait, c'était moi qui avais formaté le 1er disque, et le 2ème était bien formaté en FAT32, je l'avais vérifié.

rmy a écrit :

Ne confonds-tu pas "reconnu" et "auto-mount" ?

Non, je fais bien la distinction dans tous mes posts précédents entre "reconnu" et "montage automatique"... smile

rmy a écrit :

Est-ce que par hasard ce ne serait pas à cette ubuntu party que ton disque a été formaté, et que don tu n'aurais pas le droits sur le système de fichier ?

J'étais à côté de la personne quand elle a accédé à mon disque. Je n'ai pas clairement vu la commande qu'elle tapait (c'était une version de Linux sans interface), mais son action n'a duré que quelques secondes, et ensuite elle m'a simplement dit qu'elle venait de créer un fichier bonjour.txt et que cela avait marché. Si elle avait formaté le disque cela aurait pris nettement plus de temps, et surtout je pense qu'elle ne l'aurait pas fait sans me le dire. Mais c'est vrai que cette question de droits m'intrigue aussi.

rmy a écrit :

Est-ce que tu peux tester ce disque avec un autre boîtier ?

Malheureusement non, je n'ai pas d'autre boîtier. Mais j'ai testé plusieurs disques avec ce boîtier, tous donnaient le même résultat (et notamment, ils marchaient sous XP).

rmy a écrit :

Essaye un truc :
Une fois le disque branché, commence par le démonter :

sudo umount /dev/sdc1

Alors là, j'ai un truc bizarre [gratt-gratt] : quand je tape la commande sudo umount, en apparence ça marche (je n'ai pas de message d'erreur) sauf que ça ne me démonte rien du tout... neutral Le disque reste visible dans Nautilus et je peux toujours y accéder (et la commande fdisk -l continue de montrer le sdc). Du coup je n'ai pas testé le reste - mais je garde bien entendu le reformatage en vue, de toute façon je n'ai rien d'important sur ce disque.
Mais je commence aussi à me demander si je n'ai pas des problèmes avec la fonction montage/démontage, parce que depuis que je m'acharne à régler mon problème et que j'ai modifié des trucs, l'affichage de la fenêtre ne se fait plus automatiquement quand je branche une clef USB (alors qu'elle se monte bien, j'y accède sans problème depuis Nautilus), ni quand je mets un DVD dans le lecteur (là c'est plus compliqué, je dois d'abord ouvrir VLC et lancer le DVD depuis le logiciel).

Encore merci à vous de vous intéresser à mon problème ! smile

Marie

Dernière modification par MarieP (Le 15/07/2012, à 17:28)


Config : Linux Ubuntu Precise Pangolin 12.04 64 bits, en dual boot avec Windows XP.

Hors ligne

#43 Le 14/08/2012, à 09:51

djibi

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Salut à vous!

Y a-t-il du nouveau à ce sujet?
J'ai acheté le même boitier que MarieP

Bus 001 Device 007: ID 152d:2338 JMicron Technology Corp. / JMicron USA Technology Corp. JM20337 Hi-Speed USB to SATA & PATA Combo Bridge

Et les partitions du disque dur placé à l'intérieur ne sont pas montées automatiquement et je n'arrive pas à le faire manuellement.
Elles sont pourtant bien détectées...

$ sudo fdisk -l
Disk /dev/sdd: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 30400 cylinders, total 488378646 sectors
Units = sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0008e52d

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1         6763365  3905979839  2711964012   83  Linux
/dev/sdd2      3905979840  3907024064     4176900   82  Linux swap / Solaris

Si vous avez des mises à jour, merci de m'en faire profiter...

++


Linux, c'est bien.
Dites le avec des pavés!

Hors ligne

#44 Le 09/09/2012, à 15:26

MarieP

Re : [Réglé ms inexpliqué] Disque dur externe USB (via boîtier) non détecté

Bonjour à tous

J'espère que vous avez passé de bonnes vacances, si vous en avez pris. :-)

De mon côté et faute de mieux comprendre, j'ai finalement reformaté mon disque (en NTFS). Je l'ai fait deux fois : une première fois sous XP, seul OS depuis lequel j'y avais accès en mode admin, puis une deuxième fois sous Ubuntu, sous lequel j'ai testé le disque tout de suite après et qui était parfaitement reconnu.
Du coup, j'en ai profité pour reformater en NTFS le deuxième disque que j'avais récupéré, et qui lui était déjà formaté en FAT32.

Résultat des courses : tout fonctionne, les deux disques sont parfaitement reconnus sous les deux systèmes et monté automatiquement. Mieux, la fenêtre Nautilus s'ouvre toute seule.

Je vais donc marquer ce fil comme résolu, mais j'ignore toujours ce qui s'est passé... Et surtout, si je n'avais pas eu accès à une version de Windows en mode admin je ne m'en serais jamais sortie, car c'est bien grâce à son reformatage que j'ai pu m'en servir normalement sous Ubuntu...

Encore merci à tous pour votre aide et pour le temps que vous avez consacré à mon problème.

Marie

Dernière modification par MarieP (Le 09/09/2012, à 15:27)


Config : Linux Ubuntu Precise Pangolin 12.04 64 bits, en dual boot avec Windows XP.

Hors ligne

Haut de page ↑