Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#151 Le 03/12/2012, à 15:17

Isayama

Re : performances ubuntu.

Bonjour,

J'ai été renvoyé sur ce fil par malbo car la configuration de ma récente install correspondait au projet développé par faustus: une nouvelle partition Ubuntu (gnome remix x64) 12.10 (système 1) en dual-boot avec Win 7 (système 2), un swap et une partition de données derrière.

Je souhaiterais faire un ajout à la discussion qui est en même temps une question: en passant par l'utilitaire "Disques", j'ai défini le point de montage automatique et l'identification de ma partition de données "Data" issues de mon install précédente, donc en NTFS (cf capture d'écran des paramètres de la partition dans "Disques" et de mon fstab: 1354539961.png)
Je n'ai pas eu à rentrer le paramètre ntfs (cf dans la boîte de dialogue "Options de montage automatique" de disques "Type de système de fichiers => auto"), les autres paramètres je ne les ai pas spécialement choisis ("nosuid,nodev,nofail,x-gvfs-show,noauto"), mais après plusieurs redémarrages il apparaît que ma partition de données "Data" est toujours automatiquement montée sans que cela pose un quelconque problème, et je peux lire et écrire dedans sans souci (dans nautilus elle apparaît dans les périphériques).

Je n'ai pas encore fait les jonctions, mais c'est la prochaine étape. Apparemment via les options de Disques, il est donc possible de configurer très simplement la première partie de la procédure avec plusieurs choix (point de montage, type d'identification: UUID ou Label, et d'autres). J'espère que cela pourra servir à d'autres (et que ça marchera avec bind, ce que je viendrai confirmer par un edit).

Merci à faustus pour ses indications, l'option bind me paraît des plus utiles.


edit après avoir suivi les recommandations de malbo et d'avoir installer et utiliser "ntfs-conf",
1) celui-ci plante pas mal
2) il a ajouté la ligne

UUID=7E5B00DE4AE00F1F	/media/Data	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0

dans etc/fstab
3) après vérification, l'utilitaire "Disques" a bien traduit graphiquement ces changements:
1354571248.png
D'où la confirmation qu'on peut effectuer cette première étape graphiquement (pour les utilisateurs qui ne sauraient où trouver leur UUID et autres)


Malheureusement,  pour le reste, avec les jonctions, ça ne passe pas.
J'ai des erreurs de montage des dossiers à l'allumage (juste après grub, j'ai un message "Impossible de monter /home/neitsab/Documents", que je dois ignorer en tapant "s" - puis j'ai un message qui concerne ma partition de données nommée par son UUID... Message qui disparaît immédiatement (donc elle doit juste ne pas être trouvée immédiatement puis montée, mais j'ai l'impresson qu'elle l'est après la tentative de suivi de la jonction de mon /home, d'où peut-être le problème).
Après démarrage de la session, les dossiers "Musique", "Images" et "Documents" apparaissent dans la catégorie "Périphériques" de nautilus, mais quand je clique sur le raccourci "Documents" précité (donc normalement /media/Data/Documents), un message d'erreur affiche

"mount : seul le superutilisateur peut monter /media/Data/Mes Documents sur /home/neitsab/Documents"

.
En ce qui concerne "Images" et "Musique", le message est différent:

"mount : selon mtab, /media/Data/Mes images est déjà monté sur /home/neitsab/Images
échec de montage"

Quand j'essaye d'enregistrer une image depuis Firefox, je clique sur l'emplacement "Images" (donc /home/mon_nom/Images), qui me répète le message d'erreur précité.

Enfin, je dois préciser que tout cela empêche mon ordinateur de s'arrêter/redémarrer (la session se ferme correctement puis il tourne en ayant des "accès de ventilateur" pour ne jamais s'éteindre)... Je commence à m'arracher les cheveux.

=> il semblerait qu'une cause du problème soit les espaces dans mes noms de dossiers (Mes documents, Ma musique, Mes images) ainsi que les accents (Téléchargements).
J'ai essayer avec des " " et des ' ' autour mais ça n'a rien changé. Quelqu'un peut-il me dire s'il y a une autre manière de prendre en compte les noms de dossiers avec espaces, ou s'il faut que je renomme mes dossiers (qui à partir de là ne seront plus reconnus directement dans Windows)?

J'ai réglé le problème des espaces grâce à ce post du forum, en revanche la même astuce pour "Téléchargements" (caractères "é" remplacés par le code correspondant que je ne retrouve plus) donne des erreurs. Je l'ai donc supprimé puisque je n'arrive de toute façon pas à faire les autres jonctions.

Voici mon fstab, si quelqu'un peut y découvrir quelque chose:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

#Entry for /dev/sda2 :
UUID=809d4462-016a-40d6-aeeb-26486b431844	/	ext4	errors=remount-ro	0	1
#Entry for /dev/mapper/cryptswap1 :
UUID=900cc27d-6e08-4cc2-8a14-b501cfae1fce	none	swap	sw	0	0

#Entry for /dev/sda5 :
UUID=7E5B00DE4AE00F1F	/media/Data	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0
/media/Data/Mes\040Documents /home/neitsab/Documents none bind
/media/Data/Mes\040images /home/neitsab/Images none bind
/media/Data/Ma\040musique /home/neitsab/Musique none bind

J'ai remarqué que dans l'exemple de faustus, le deuxième chiffre qui suit le nom de sa partition de données est "2", tandis que chez moi il est à 0. Quelle en est la signification? Cela peut-il avoir un rapport (ordre de montage...?). (Dans les posts de ce fil, ce sont également des 0 mais bon...)

edit2: je me suis rendu compte en tapant la commande "mount" que mon dossier personnel était crypté (j'avais coché l'option lors de l'installation)... Se pourrait-il que cela entre en conflit avec le montage des jonctions pré-login (qui déchiffre le /home si j'ai bien compris)?

Si quelqu'un a des propositions, je suis preneur!

Merci d'avance

Dernière modification par Isayama (Le 04/12/2012, à 01:11)


Ubuntu GNOME Remix 12.10 x64 (Gnome-shell) sur Dell Studio 1745

Hors ligne

#152 Le 04/12/2012, à 22:31

patrick L

Re : performances ubuntu.

bonsoir

sur le premier message d'erreur : "seul le super utilisateur peut monter "  il faut lancer via

gksudo nautilus 

sur le second faut dans le fstab monter un device sur un dossier  vous voulez une partition Windows /dev/sda2 visible  dans le dossier /media/data   





/dev/sda2 /media/data  ntfs-3g defaults,iorcharset=utf8  0 0 

ensuite vous créez un lien symbolique dans votre home sur sous dossier

ln -s "/media/data/Mes documents" ~/DocumentsWindows
# et  
ls ~/DocumentsWindows 

ira dans le dossier mes documents de windows
et avant de faire un montage il faut démonter avant par

sudo umount /media/data 

les 0 0 indiquent que l'on affiche le contenu du montage ou pas pour le premier 0, et que l'on lance un fsck tous les N montages.

Dernière modification par patrick L (Le 04/12/2012, à 22:39)

Hors ligne

#153 Le 09/12/2012, à 19:48

Isayama

Re : performances ubuntu.

Bonsoir,

Merci pour votre réponse, après d'autres essais infructueux avec bind dans le fstab, j'ai décidé d'adopter la solution des liens symboliques en suivant la méthode décrite dans le post #2 de ce fil.

Ça marche à merveille, il faut bien penser à supprimer (en faisant une copie auparavant) les dossiers sur lesquels on va faire les jonctions dans le /home/user (Images, Documents, Musique, Téléchargements...), pour qu'ensuite se créent bien les liens (qui prennent automatiquement les icônes et les places des anciens dossiers dans les signets de Nautilus/Nemo) dans ~/.

Merci encore, même si je suis interpellé par le fait de n'avoir su débusquer l'erreur avec mes montages bind, je suis bien content d'avoir cette autre solution qui rend mon dual boot d'autant plus fonctionnel.


Ubuntu GNOME Remix 12.10 x64 (Gnome-shell) sur Dell Studio 1745

Hors ligne

Haut de page ↑