Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 03/07/2012, à 00:09

Libertaire00

[Résolu] Problème avec Conky

Salut tout le monde,
J'ai récemment installé conky sur ubuntu pangolin 12.04 avec comme interface Unity et j'ai un léger problème avec :
Quand je l'ai installé et configuré "aucun" problème. Mais une fois que je redémarre il active les ombres (qui sont désactivés dans le .conkyrc) et passe par dessus les fenêtres. Si je le relance (killall conky puis conky dans le terminal) ça redevient comme c'est indiqué dans le .conkyrc.
Deux screen pour être plus clair :
Normal
1341270345.png

Après redémarrage
1341270423.png

Mon .conkyrc :

# temps pour fermer conky en seconde. 0 = toujours actif 
total_run_times 0

# affiche le texte sur la sortie standard
out_to_console no

# réglage de la mémoire, pour éviter le clignotement
double_buffer yes
# Soustraire les mémoires tampons de la mémoire utilisée
no_buffers yes
text_buffer_size 2048

# taux de rafraichissement de la fenêtre (en secondes)
update_interval 1

# nombre d'échantillons à utiliser pour calculer la moyenne d'utilisation
cpu_avg_samples 4
net_avg_samples 2

# taille et positon
alignment top_left
minimum_size 320 5
maximum_width 380

# écart avec le bord x=gauche ou droit y= haut ou bas
gap_x 265
gap_y 350

#  afficher les ombres
draw_shades no
# afficher des contours
draw_outline no
# contours autour des blocs de texte
draw_borders no
# largeur du contour
border_width 0


#pour que conky tourne en arrière plan background no pour les tests
background yes

# utiliser sa propre fenêtre
own_window yes
#type de fenêtre : normal(avec le cadre) / override / desktop
own_window_type override # normal / override / desktop
#pseudo transparence si vous avez des icones sous le conky elle ne seront plus accessibles une fois conky activé
own_window_transparent yes

# Utiliser Xft (polices lissées etc)
use_xft yes
xftalpha .1
override_utf8_locale yes # force UTF8

#police a utiliser : use_xft doit être a "yes"
xftfont Fixed:size=7#OCR A Std:size=6
# Tout le texte en majuscule
uppercase no

# Ajoute des espaces après certains objets pour éviter de les faire bouger.
# Fonctionne uniquement avec les polices Fixes
use_spacer right

# Couleurs
default_color FFFFFF #blanc
default_shade_color 333333
default_outline_color black

color1 e49c16 
color2 CA0000 #rouge

color6 EEEEEE
color7 DDDDDD
color8 CCCCCC
color9 BBBBBB

TEXT
${color D21A1A}${font ZegoeLight-U:pixelsize=60}${time %A}${font} 
${color D21A1A}${font ZegoeLight-U:pixelsize=50}${time %B %d, %Y}${font}
___________________________________________________________

${color D21A1A}${font ZegoeLight-U:pixelsize=40}${time %H:%M:%S}${font}    

${color D21A1A}${font Zegoe Light - U:pixelsize=12}Uptime: $uptime_short | Power: ${battery_percent BAT0}% | Mem: $mem | Storage: ${fs_used /}

Merci d'avance smile

Dernière modification par Libertaire00 (Le 03/07/2012, à 12:30)

Hors ligne

#2 Le 03/07/2012, à 00:12

titou345

Re : [Résolu] Problème avec Conky

Tu as essayé de mettre ça ?

# utiliser sa propre fenêtre
own_window no

Machin a dit truc-bidule.
Bref, moi je suis cultivé quoi.

Hors ligne

#3 Le 03/07/2012, à 00:14

Libertaire00

Re : [Résolu] Problème avec Conky

Salut, merci pour ta réponse oui j'ai essayé mais cela posait le même problème.

EDIT : En fait non le problème n'était pas le même, le problème est que ça "clignote".

Je précise que dans la doc il est indiqué qu'il faut se rendre dans ce fichier "/etc/X11/xorg.conf" pour rajouter une ligne (Load "dbe") pour activer le double buffer mais je n'ai pas ce fichier dans le dossier X11 neutral
Mais je crois que le double buffer fonctionne car je n'ai pas le message d'erreur indiqué dans la doc. Quand je lance conky :

Conky: desktop window (1600095) is subwindow of root window (ad)
Conky: drawing to desktop window
Conky: drawing to double buffer

Dernière modification par Libertaire00 (Le 03/07/2012, à 00:32)

Hors ligne

#4 Le 03/07/2012, à 09:04

LapiGNU

Re : [Résolu] Problème avec Conky

Dans une 12.04 "normale", X est tout à fait prêt à afficher Conky sans réglage particulier. D'après la conf que tu as indiquée, je dirai que le problème se trouve dans la ligne :

own_window_type override # normal / override / desktop

que je te conseille de remplacer par

own_window_type desktop

Ce qui amènera Conky à dessiner sa fenêtre dans la couche la plus basse, celle du bureau, et sans inciter le gestionnaire de fenêtres à ajouter des fioritures comme des décorations ou des ombres, et sans que le Conky n'apparaisse dans la barre des tâches ni le pager.

Si tu veux plus d'informations, c'est ici : http://conky.sourceforge.net/config_settings.html

Personnellement, j'utilise Conky avec Compiz sans problème, et comme je veux pouvoir déplacer mes Conkies comme n'importe quelle autre fenêtre, je règle le own_window_type à normal et own_window_hints à undecorate,sticky,skip_taskbar,skip_pager,below ...

Tu peux voir ce que ça donne ici : http://www.tchitcha.info/?p=983

Hoplà !


frenchKISS sur www.tchitcha.info, Ubuntu clé en main pour les réseaux de postes de travail.
et surtout : Sauvez les arbres, mangez des castors. Sauvez les castors, ne mangez pas d'arbres !

Hors ligne

#5 Le 03/07/2012, à 10:57

Libertaire00

Re : [Résolu] Problème avec Conky

Salut,
Merci pour ta réponse. J'ai malheureusement déjà essayé l'option desktop et cela ne fonctionne pas non plus :
Les ombres apparaissent et dès que je clique sur le bureau conky disparaît.
Qu'est-ce que le gestionnaire de gadget que tu utilises dans ta video ? ConkyGUI ? Si c'est celui là je l'ai installé mais il ne se lance pas.

(J'ai unity donc je n'ai pas de barre de tâche.)

Hors ligne

#6 Le 03/07/2012, à 11:25

LapiGNU

Re : [Résolu] Problème avec Conky

Si Conky disparaît avec l'option desktop, alors il doit y avoir une ruse avec la gestion de ton fond d'écran. Tu as peut-être activé un truc en plus, comme Nitrogen ou un utilitaire qui change le fond à intervalle régulier, ou via le gestionnaire de configuration de Compiz (ccsm) ...

Le gestionnaire de gadgets de ma vidéo est un truc que j'ai développé ; quelques scripts en bash, et Easystroke pour rendre les Conkies cliquables. Tu trouveras des infos ici Session frechKISS et Conky Gadgets si tu veux en savoir plus. Je vais bientôt ajouter la dernière version du système sous forme d'archive et publier la nouvelle version de mon remaster, qui intégrera le tout par défaut.

Hoplà !


frenchKISS sur www.tchitcha.info, Ubuntu clé en main pour les réseaux de postes de travail.
et surtout : Sauvez les arbres, mangez des castors. Sauvez les castors, ne mangez pas d'arbres !

Hors ligne

#7 Le 03/07/2012, à 11:49

Libertaire00

Re : [Résolu] Problème avec Conky

Je viens juste d'installer ubuntu sur ce pc donc non je n'ai ni mis d'options particulières ni installé d'utilitaires (je n'ai pas compiz).

Merci pour le lien.

Hors ligne

#8 Le 03/07/2012, à 12:04

abelthorne

Re : [Résolu] Problème avec Conky

Libertaire00 a écrit :

Je viens juste d'installer ubuntu sur ce pc donc non je n'ai ni mis d'options particulières ni installé d'utilitaires (je n'ai pas compiz).

Je n'utilise pas Conky mais juste une précision : si tu utilises Unity, tu as Compiz, puisqu'Unity est un plugin de Compiz... Ubuntu utilise maintenant Compiz par défaut pour son interface.

Si le problème arrive uniquement au démarrage et pas en tuant/relançant Conky, j'aurais tendance à penser que le problème vient du fait qu'il se lance trop tôt, avant le gestionnaire de fenêtres ou autre (ce qui fait qu'il n'a pas le bon contexte lorsqu'il est lancé alors que c'est bon plus tard, quand tu le relances alors que tout est en place). Comment est-ce que tu le lances ?

Dernière modification par abelthorne (Le 03/07/2012, à 12:27)

Hors ligne

#9 Le 03/07/2012, à 12:16

Libertaire00

Re : [Résolu] Problème avec Conky

Salut, merci pour l'info.
Pour le lancement de conky je l'ai mis dans les applications au démarrage tel que c'est expliqué sur la doc. Il y a une explication pour lancer conky en "décalé" avec ou sans script, j'essaie ça et je vous dis.

EDIT : Merci tu as trouvé la solution, ça marche parfaitement !

Dernière modification par Libertaire00 (Le 03/07/2012, à 12:29)

Hors ligne

#10 Le 03/07/2012, à 12:33

LapiGNU

Re : [Résolu] Problème avec Conky

Pour information : ton own_window_type, finalement, il est override ou desktop ?


frenchKISS sur www.tchitcha.info, Ubuntu clé en main pour les réseaux de postes de travail.
et surtout : Sauvez les arbres, mangez des castors. Sauvez les castors, ne mangez pas d'arbres !

Hors ligne

#11 Le 03/07/2012, à 12:41

Libertaire00

Re : [Résolu] Problème avec Conky

Il est en override je crois que desktop me fait toujours le même problème (vu que le problème n'était pas au lancement dans ce cas) mais ça ne pose pas de problème vu que je n'ai pas de barre de tache (et qu'il n'est pas dans le lanceur) et qu'il ne passe pas par dessus les fenêtres.

Hors ligne

Haut de page ↑