Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 29/07/2012, à 22:07

microbulle

[Résolu] Perte des polices sous Gnome

Bonsoir,

J'ai un gros soucis. Je n'ai plus de polices disponible sous Gnome depuis ce soir. C'est très pénible !

Comment restaurer les polices installés ?

Sachant que /usr/share/fonts est bien remplis avec des fonts.

Autre questions, vue que fontmatrix m'a fichu le boxon, comment puis-je ajouter les autres polices que je me sert habituellement ?

Merci de votre réponse.

Dernière modification par microbulle (Le 30/07/2012, à 07:44)

Hors ligne

#2 Le 30/07/2012, à 00:00

Kooothor

Re : [Résolu] Perte des polices sous Gnome

Salut microbulle,

As-tu effectué cette commande pour reconstruire le cache des polices ?

$ sudo fc-cache -f -v

@+
~ktr


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#3 Le 30/07/2012, à 00:09

microbulle

Re : [Résolu] Perte des polices sous Gnome

Oui !

J'ai finalement remarqué que fontmatrix créais un fichier .font.conf . Il se trouve que j'ai regarder dedans, et puis, je me suis rendu compte qu'il m'avais mis tout les dossiers contenant les font inaccessible ! Du coup, j'ai tenter de le supprimer et c'est revenu !

Mais ça n'explique pas pourquoi si soudainement le comportement de fontmatrix est devenu si incohérent.

J'aimerais bien en savoir plus à ce sujet. Et surtout fixé le bug de façon à ce qu'il ne se reproduise plus. Idem si ça peut aider la communauté. franchement, j'ai bien cru que je serais obliger de réinstallé. (Mode rire : ON -> Ah zut, on pas pas sous Windows pourtant <- mode rire : OFF).

Hors ligne

#4 Le 30/07/2012, à 01:19

Kooothor

Re : [Résolu] Perte des polices sous Gnome

Adresse-toi aux développeurs de fontmatrix wink
http://oep-h.com/fontmatrix/
(leur site est tout cassé, pas étonnant que leur application le soit également...)

Dernière modification par Kooothor (Le 30/07/2012, à 01:19)


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#5 Le 30/07/2012, à 07:44

microbulle

Re : [Résolu] Perte des polices sous Gnome

Effectivement !

Bon ceci dit, j'ai viré l'application avec la mention [RENVOYÉ] smile

Ce matin RAS sur mon poste. Résolu donc !

P.S: Là par contre, j'aimerais en savoir plus au niveau d'UBUNTU au sujet de ce qui emploie ce fichier et comment il est organisé. Il serais peut-être intéressant de rajouter un bouton dans Gnome, dans la configuration -> Restaurer les polices X-Org et logiciel. Ainsi, chaque logiciel qui s'installe déclarerais automatiquement les polices qu'il emploie et viendrais mettre à jour la configuration. Dans la même optique, un soft met le bazar et hop on change le fichier grâce à ce bouton miracle. Voyez ce que je veux dire quoi smile
P.S2: Le met quand même en résolu car finalement le problème initiale est résolu smile
P.S3: Merci du coup de main (pieds car c'est vraiment débile d'avoir demander de l'aide alors que j'ai fini par trouver une solution viable).

Merci.

Hors ligne

Haut de page ↑