Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 14/10/2005, à 20:27

yoyovic

installation bizarre....

Bonjour,

j'ai telecharge wallpapoz qui est un tar.bz2. Or quand je fais make, la console m'affiche ceci:

victor13@angerbode:~/Desktop/wallpapoz-0.2$ make
bash: make: command not found

et je comprends pas pourquoi. J'ai suivi la méthode et ca fais ca a chaque fois...

Est ce quelqu'un pourrait m'aider?

merci bcp

Victor

Hors ligne

#2 Le 02/11/2005, à 01:18

ced_668

Re : installation bizarre....

Moi c'est pas mieux il me dit :

cedrique@ubuntu:~/wallpapoz-0.2$ make
g++ `pkg-config libxml++-2.6 --cflags` -c daemon_wallpapoz.cpp
/bin/sh: g++: command not found
make: *** [daemon_wallpapoz.o] Erreur 127

Donc là je suis perdu:(:(
Quelqu'un ne l'aurait pas en deb ou rpm ?

A L'AIDE !!!!!

Hors ligne

#3 Le 02/11/2005, à 01:28

Desintegr

Re : installation bizarre....

Il faudrait installer le paquet : « build-essential ».

Sans « make » ou sans compilateur, vous aurez du mal à compiler des programmes...
Mais je pense qu'il va vous manquer d'autres paquets.


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

#4 Le 02/11/2005, à 02:20

ced_668

Re : installation bizarre....

Bon j'ai installé build-essential et voila ce qu'il me donne:

cedrique@ubuntu:~/wallpapoz-0.2$ make
g++ `pkg-config libxml++-2.6 --cflags` -c daemon_wallpapoz.cpp
g++ -c Process.cpp
g++ `pkg-config libxml++-2.6 --cflags` `pkg-config libglademm-2.4 --cflags` -DENABLE_BINRELOC -c wallpapoz.cpp prefix.c
g++ `pkg-config libxml++-2.6 --cflags` `pkg-config libglademm-2.4 --cflags` -c walltreeview.cpp
g++ `pkg-config libglademm-2.4 --cflags` -DENABLE_BINRELOC -c main.cpp
g++ `pkg-config libxml++-2.6 --libs` daemon_wallpapoz.o Process.o -o bin/daemon_wallpapoz
/usr/bin/ld: ne peut ouvrir le fichier de sortie bin/daemon_wallpapoz: Aucun fichier ou répertoire de ce type
collect2: ld a retourné 1 code d'état d'exécution
make: *** [daemon_wallpapoz] Erreur 1

J'ai vu sur un tuto que l'on pouvait aussi utiliser le scrip install.sh mais là il me donne quasiment la meme erreur:
bin/daemon_wallpapoz: Aucun fichier ou répertoire de ce type
bin/wallpapoz: Aucun fichier ou répertoire de ce type

J'ai regarder dans le fichier que j'avais decompresser et en effet pas de fichier bin, il n'était donc pas a l'origine non plus dans le paquet que j'avais télécharger.
J'ai donc fait un petit test, j'ai creer le fichier bin avec a l'interieur des fichiers texte du meme nom que dans l'erreur et là l'installation fonctionne. Mais bon comme mes fichier sont bidons le programme ne fonctionne pas. Donc qu'est-ce que je doit mettre en réalité dans le fichier bin que j'ai creé?

Hors ligne

#5 Le 02/11/2005, à 08:47

biginoz

Re : installation bizarre....

des fois il y a deux paquets a télécharger , les sources et les data (= données , donc les applications bin etc...) donc regarde s'il n'y a pas deux paquets à tétécharger.


POUET!
http://generation-debian.org/
webtvorange, KIM pour nautilus, sweethome3d, WTO et webtv_ref
deb http://www.scolatix.org/depot/debian lenny main

Hors ligne

#6 Le 02/11/2005, à 10:59

Bob Morane

Re : installation bizarre....

exactement le même problème

g++ `pkg-config libxml++-2.6 --libs` daemon_wallpapoz.o Process.o -o bin/daemon_wallpapoz
/usr/bin/ld: ne peut ouvrir le fichier de sortie bin/daemon_wallpapoz: Aucun fichier ou répertoire de ce type
collect2: ld a retourné 1 code d'état d'exécution
make: *** [daemon_wallpapoz] Erreur 1
roland@Pinny:~/wallpapoz-0.2$

Il n'y a qu'un seul fichier à télécharger.
J'ai eu la même idée que ced_668, à savoir un truc à été oublié dans le fichier et c'est pour çà que çà ne marche pas! Créer simplement un fichier vide ne peut évidemment mener à rien car le ficheir ne servira à rien, mais créer un dossier vide n'est pas bien grave. J'ai donc créé un dossier "bin" dans le dossier source de wallpapoz, j'ai fait "make" et là tout marche. L'insatallation ne renvoye pas de message d'erreur, et wallpapoz se lance aussi. Apparemment tout marche. Je vous dirai à l'usage si tout continue à marcher. Voici donc la marche à suivre apparemment :

1) télécharger les sources là http://wallpapoz.sourceforge.net/
2) par synaptic aller chercher le packet : build-essential puis faire une recherche pour libglademm-2.4 et libxml++-2.10. J'ai insatllé les versions utilisation et développement puisque c'était pour compiler quelque chose.
3) Lancer le terminal et cd /la/ou/vous/avez/téléchargé/wallpapoz
4) mkdir bin (vous pouvez aussi le faire grapiquement via nautilus)
5) make
6) sudo sh install.sh /usr/local

En espérant avoir un peu aidé quelqu'un. Chez moi çà semble marcher.

Dernière modification par Bob Morane (Le 02/11/2005, à 11:02)

Hors ligne

#7 Le 02/11/2005, à 11:15

ced_668

Re : installation bizarre....

GENIIIIIIIIIIIIIIIIIIIIIIAAAAAAAAAAAAAAAAAAL !!!!!!!!!!!!!!!!!
Super ca marche enfin big_smile big_smile big_smile
Sa fait un moment que je cherche sur les forum et tous avait des problemes et sans solution.
Il ne reste plus qu'a faire un paquet .deb dispo

YOUPI !

Hors ligne

#8 Le 02/11/2005, à 11:45

ced_668

Re : installation bizarre....

Bon j'ai crier victoire trop tot! sad
l'application se lance sans problème, je peut selectionner les wallpaper pour chaque bureau. Mais après il ne s'affiche pas sur le bureau. j'ai essayer de redemarer le deamon en terminal:
cedrique@ubuntu:~$ sudo killall deamon_wallpapoz
deamon_wallpapoz: aucun processus tué
cedrique@ubuntu:~$ daemon_wallpapoz
Erreur de segmentation

Et moi qui voulais personaliser a fond mon bureau je crois que c'est foutu sad

Hors ligne

#9 Le 02/11/2005, à 19:15

yoyovic

Re : installation bizarre....

Victoire!!!! merci bob de ton aide!!!!!

Hors ligne

#10 Le 02/11/2005, à 23:19

ced_668

Re : installation bizarre....

Alors quelqu'un a une idé de ce que peut etre une erreur de segmentation. Peut etre a cause de gDesklets qui tourne lui aussi en meme temps? une idée?

Hors ligne

#11 Le 02/11/2005, à 23:29

Desintegr

Re : installation bizarre....

Quand un programme essaye d'accéder à un endroit de la mémoire qu'il n'est pas autorisé à accéder à cet endroit de la mémoire, on peut avoir une « erreur de segmentation ».

Ça peut être lié à un problème matériel (RAM de mauvaise qualité), à un programme mal codé, ou peut-être aussi « mal » compilé (CFLAGS trop agressifs par exemple).

Dernière modification par Desintegr (Le 02/11/2005, à 23:29)


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

#12 Le 03/11/2005, à 05:15

ced_668

Re : installation bizarre....

Ma RAM fonctionne bien, j'ai compiler le programme comme indiqué, chez certain ca marche. Alors qu'est-ce qui ne va pa ???????? sad sad

Hors ligne