Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 10/08/2012, à 09:28

Hada de la Luna

12.04 LTS : installation de Simon - modèles acoustiques en français ?

Bonjour,

je souhaite installer Simon (reconnaissance vocale pour une personne à mobilité réduite) et je procède ainsi:

  1. je vais là : http://sourceforge.net/projects/speech2 … ror=freefr

  2. je lui dis d'ouvrir le paquet avec la Logithèque

  3. et la logithèque me dit : Dépendance non satisfaite : libqt4-multimedia (>=4:4.6.1)

Comment faire, pour installer ? Je ne trouve pas ce paquet dans la logithèque, il doit donc être ailleurs... mais où et comment l'installer ? hmm

Dernière modification par Hada de la Luna (Le 21/08/2012, à 00:13)


Hada de la Luna :o)

Hors ligne

#2 Le 10/08/2012, à 10:50

Flambaz

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Yo,

J'ai bien peur que ce paquet ne soit plus supporté... (voir cette page)


Asus CG8250
i7-2600
12 Go de RAM
Voyager 13.04 64 bits

Hors ligne

#3 Le 10/08/2012, à 10:53

plandabourou

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Bonjour

Essaye là :

http://www.ubuntuupdates.org/package/co … multimedia

Mais il y a l'air d'avoir un problème sur le suivi des versions (http://www.ubuntuupdates.org/package/ku … multimedia)

Edit : Flambaz a donné la même info juste avant moi

Dernière modification par plandabourou (Le 10/08/2012, à 10:57)


Ubuntu depuis Hardy Héron - Ubuntu Gnome 13.10 - Gnome 3.10 - Handy Linux

Hors ligne

#4 Le 10/08/2012, à 13:50

Hada de la Luna

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Merci

Zut, c'était le seul qui avait l'air en état d'être utilisé directement après installation... hmm

  • CMU Sphinx : il y a des librairies dans tous les sens sans qu'on sache ce qui doit être installé ou pas et comment configurer...

  • gnome-voice-control : inconnu au bataillon...

  • Perlbox : inconnu au bataillon...

  • Simon : je viens d'essayer et si la librairie manquante n'est pas disponible pour 12.04 LTS et bien je ne suis pas magicienne, ou alors il faut quelqu'un de "bon" pour m"expliquer en détail comment faire...

  • X voice : utilise une librairie ViaVoice d'IBM qui est payante => on n'a pas de sous pour payer, le handicap c'est un truc qui rend pauvre...

  • VoiceExecute : inconnu au bataillon...

  • Dragon Naturally Speaking :  même problème qu'avec X voice

  • CVoiceControl : développement arrêté depuis 2002...

Des idées comment faire ?

Dernière modification par Hada de la Luna (Le 10/08/2012, à 14:12)


Hada de la Luna :o)

Hors ligne

#5 Le 10/08/2012, à 23:04

kinouchou

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

bonjour,

tu peux parler de ton souci sur la liste de diffusion april-accessibilité accessibilite[at]april[dot]org, peut-être que l'un d'entre nous pourra t'aider, soit à faire fonctionner une de ses solutions soit à en trouver une autre.

librement
kinouchou


Développeur, simple utilisateur, professionnel ou juste intéressé venez découvrir le groupe April Accessibilité et Logiciels Libres http://libre-et-accessible.org

Hors ligne

#6 Le 10/08/2012, à 23:15

Vikin712

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Bonsoir.

https://launchpad.net/~grasch-simon-lis … hive-extra
La liste des dépendances a été modifiée pour le paquet puisse être installé sur Precise.

Version 32 pour Precise
Version 64 pour Precise

Le dépôt https://launchpad.net/~grasch-simon-lis … hive/simon

Dernière modification par Vikin712 (Le 10/08/2012, à 23:17)

#7 Le 11/08/2012, à 09:08

Hada de la Luna

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Bonjour,

merci kinouchou smile

merci Vikin712, smile peux tu préciser les manœuvres et lignes de commandes à faire ?

j'ai tenté de copier coller le dépôt dans la logithèque et cela refuse, donc j'imagine que je n'ai pas mis exactement ce qu'il faut et, pour le reste, je ne suis pas assez "bonne" pour comprendre quoi en faire...


Hada de la Luna :o)

Hors ligne

#8 Le 11/08/2012, à 11:46

Vikin712

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Bonjour.

Tu peux télécharger ce paquet Version 32 pour Precise et l'installer via la logithèque comme tu as essayé de faire avec celui disponible sur Sourceforge,

ou

taper la ligne de commande ci-dessous dans un terminal, ce qui ajoutera le dépôt et installera le logiciel.

sudo add-apt-repository ppa:grasch-simon-listens/simon && sudo apt-get update && sudo apt-get install simon

#9 Le 11/08/2012, à 23:16

Hada de la Luna

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

La ligne de commande donne :

Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 simon : Dépend: libattica0 mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Hada de la Luna :o)

Hors ligne

#10 Le 11/08/2012, à 23:34

Vikin712

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Oui effectivement dans la liste des dépendances du paquet le numéro de version n'a pas été adapté.
Sur celui-ci oui.
https://launchpad.net/~simon-listens/+a … 3_i386.deb
N'ayant pas sur Precise 12.04 je n'ai pu tester , mais normalement l'installation via la logithèque comme tu as essayé de faire avec celui disponible sur Sourceforge devrait fonctionner.

#11 Le 12/08/2012, à 01:04

Hada de la Luna

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

La logithèque répond :

Impossible d'installer " libkhtml5:i386 "

Hada de la Luna :o)

Hors ligne

#12 Le 12/08/2012, à 15:34

Vikin712

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Bonjour.

Bizarre ce paquet est disponible dans les dépôts de Precise.

Peux-tu poster le retour de la commande :

uname -m

(À taper dans un terminal)

#13 Le 13/08/2012, à 00:52

Hada de la Luna

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

x86_64

Hada de la Luna :o)

Hors ligne

#14 Le 13/08/2012, à 12:11

Vikin712

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Bonjour.

Ok tu utilises une version 64.
Tu devrais pouvoir installer ce paquet https://launchpad.net/~simon-listens/+a … _amd64.deb

#15 Le 13/08/2012, à 13:30

Hada de la Luna

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

ce coup ci il m'a parlé d'une ancienne version de Simon existante dans les dépôts officiels
puis a affiché :

impossible d'installer "libqtmultimediakit1"

J'en ai conclu que les manoeuvres précédent ont "installé" un dépot contenant Simon et, du coup, j'ai essayé la version de Simon qui apparaît désormais dans la logithèque et cela à donné :

Les paquets suivants ont des dépendances non-satisfaites :

simon: Depends: libc6 (>= 2.7) mais la version 2.15-0ubuntu10 va être installée
       Depends: libgcc1 (>= 1:4.1.1) mais la version 1:4.6.3-1ubuntu5 va être installée
       Depends: libkdecore5 (>= 4:4.4.0) mais la version 4:4.8.4a-0ubuntu0.2 va être installée
       Depends: libkdeui5 (>= 4:4.4.0) mais la version 4:4.8.4a-0ubuntu0.2 va être installée
       Depends: libkhtml5 (>= 4:4.3.4) mais la version 4:4.8.4a-0ubuntu0.2 va être installée
       Depends: libkio5 (>= 4:4.5.1) mais la version 4:4.8.4a-0ubuntu0.2 va être installée
       Depends: libkjsapi4 (>= 4:4.3.4) mais la version 4:4.8.4a-0ubuntu0.2 va être installée
       Depends: libknewstuff3-4 (>= 4:4.4.0) mais la version 4:4.8.4a-0ubuntu0.2 va être installée
       Depends: libkparts4 (>= 4:4.3.4) mais la version 4:4.8.4a-0ubuntu0.2 va être installée
       Depends: libkutils4 (>= 4:4.4.90) mais la version 4:4.8.4a-0ubuntu0.2 va être installée
       Depends: libnepomuk4 (>= 4:4.3.4) mais la version 4:4.8.4a-0ubuntu0.2 va être installée
       Depends: libqt4-dbus (>= 4:4.5.3) mais la version 4:4.8.1-0ubuntu4.2 va être installée
       Depends: libqt4-network (>= 4:4.5.3) mais la version 4:4.8.1-0ubuntu4.2 va être installée
       Depends: libqt4-sql (>= 4:4.5.3) mais la version 4:4.8.1-0ubuntu4.2 va être installée
       Depends: libqt4-svg (>= 4:4.5.3) mais la version 4:4.8.1-0ubuntu4.2 va être installée
       Depends: libqt4-xml (>= 4:4.5.3) mais la version 4:4.8.1-0ubuntu4.2 va être installée
       Depends: libqtcore4 (>= 4:4.7.0~beta1) mais la version 4:4.8.1-0ubuntu4.2 va être installée
       Depends: libqtgui4 (>= 4:4.5.3) mais la version 4:4.8.1-0ubuntu4.2 va être installée
       Depends: libsoprano4 (>= 2.1.1) mais la version 2.7.5+dfsg.1-0ubuntu1 va être installée
       Depends: libstdc++6 (>= 4.1.1) mais la version 4.6.3-1ubuntu5 va être installée
       Depends: zlib1g (>= 1:1.1.4) mais la version 1:1.2.3.4.dfsg-3ubuntu4 va être installée
       Depends: kdelibs5 (>= 4.3.98-0ubuntu3) mais la version 4:4.8.4a-0ubuntu0.2 va être installée
       Depends: libattica0 mais il ne va pas être installé

Hada de la Luna :o)

Hors ligne

#16 Le 13/08/2012, à 21:05

Vikin712

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Je vais installé Precise 12.04 X64 sur un système virtuel pour tester l'installation de Simon histoire que l'on ne tourne pas plus en rond. wink
Je te donnerai une réponse demain.

#17 Le 14/08/2012, à 16:10

Vikin712

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Bonjour.

Voilà la marche à suivre.
Tape dans un terminal les commandes ci-dessous dans l'ordre suivant :

sudo add-apt-repository --remove ppa:grasch-simon-listens/simon && sudo apt-get update 

puis

sudo add-apt-repository ppa:simon-listens/releases && sudo apt-get update && sudo apt-get install simon

J'ai testé et ça fonctionne.

#18 Le 15/08/2012, à 00:47

Hada de la Luna

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Merci ! smile

j'ai installé et je vais configurer dans l'après midi car là il est tard...


Hada de la Luna :o)

Hors ligne

#19 Le 17/08/2012, à 12:24

Hada de la Luna

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

il est très bien installé, par contre peu utilisable car il a besoin de dictionnaires et de scénarios pour fonctionner...

je ne trouve aucun dictionnaire

quant aux scénarios... ils sont en anglais, allemand ou néerlandais... hmm

des pistes pour trouver ?
en effet, le nom du logiciel rend les recherches difficiles...


Hada de la Luna :o)

Hors ligne

#20 Le 21/08/2012, à 00:18

Hada de la Luna

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Bon, ils n'existent pas plus qu'un modèle de voix en français... seulement anglais, néerlandais et portugais...

Par contre, pour créer un modèle de voix personnel donc en français, il faut compléter l'installation de la façon suivante : http://www.simon-listens.org/wiki/index … allation_2

j'ai eu un tas d'erreurs en installant build-essential libx11-dev libasound2-dev... mais c'est installé (après savoir si c'est de façon fonctionnelle c'est une autre histoire)...

je reviens dès que j'ai avancé sur le reste... si vous avez des avis ou des pistes de simplification ce serait bien wink


Hada de la Luna :o)

Hors ligne

#21 Le 25/08/2012, à 15:51

benoitfra

Re : 12.04 LTS : installation de Simon - modèles acoustiques en français ?

Peut être que ceci peut aider:

http://spirit.blau.in/simon/2012/05/09/ … ech-model/
http://spirit.blau.in/simon/2010/04/06/ … -released/


Peut être as tu déjà vu ce site, la personne a à priori fait un dict en français et un un scénario.
Si cela fonctionne peut tu faire un retour...

Dernière modification par benoitfra (Le 25/08/2012, à 16:11)

Hors ligne

Haut de page ↑