Contenu | Rechercher | Menus

#1 Le 10/02/2005, à 22:53

Soulfly_tribe90
Membre

[Résolu] php

Impossible de faire fonctionner php mad
Alors voila j'ai commencé par un apt-get install apache2
Puis comme sous debian je sais que php4 remet apache donc j'install libapache2-mod-php4
Puis apt-get install php4 mais le je vois ke ca m'installe quand meme apache-common.
Enfin je passe outre pour voir si ca marche, j'installe mysql-server et phpmyadmin.

Bon une fois ca je fais un dossier public_html dans mon repertoire courant et j'y introduit un test.php avec seulement phpinfo();

je vais dans firefox et je tape donc http://localhost/~/test.php et la rien du tout
je fais un http://localhost/phpmyadmin et la rien non plus...

Donc la je sais pas du tout...

EDIT : j'ai essayé avec apache et la phpmyadmin fonctionne mais tjrs pas le php...

Hors ligne

#2 Le 10/02/2005, à 23:56

nikola
Membre

Re : [Résolu] php

Recherche sur le forum, ca a deja été abordé plusieurs fois.
Au pire, visite le blog de Play : http://gfabio.blog.free.fr et plus précisemment http://gfabio.blog.free.fr/?2004/12/12/101-ubuntu-installer-un-environnement-apache2-php4

Edit :

EDIT : j'ai essayé avec apache et la phpmyadmin fonctionne mais tjrs pas le php...

roll phpMyAdmin UTILISE php

Dernière modification par nikola (Le 10/02/2005, à 23:57)

Hors ligne

#3 Le 11/02/2005, à 13:53

Soulfly_tribe90
Membre

Re : [Résolu] php

Je veux bien mais si je fais ca technique ca me fait exactement comme sous debian.
Alors deja je fais comme il dit soit :
apt-get install apache2 libapache2-mod-php4
apt-get install mysql-server
apt-get install phpmyadmin

une fois ca je fais un http://localhost/phpmyadmin et la il me propose de telecharger un fichier
si je fais un http://localhost/~nicolas/test.php ben il me demande aussi de dl le fichier yikes

Et pour resoudre se probleme sous debian je faisait ca :

apt-get install apache2 libapache2-mod-php4
apt-get install php4

et apres c'etait bon mais la si je fais un apt-get install php4 ben il m'installe se fichu apache-common qui va me met la merde avec mon apache2-common.

Quelqu'un a une idée ??

Hors ligne

#4 Le 11/02/2005, à 15:28

nikola
Membre

Re : [Résolu] php

Oui mais c'est etonnant, tu dis que phpmyadmin fonctionne, c'est donc bien que php4 est installé et traite les fichiers php correctement, non ? D'autre part as tu ajouté les lignes de traitement AddType des fichier php dans ton apache2.conf ?

Hors ligne

#5 Le 11/02/2005, à 15:32

yeKcim
Membre

Re : [Résolu] php

Sujet déplacé


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#6 Le 13/02/2005, à 18:17

Soulfly_tribe90
Membre

Re : [Résolu] php

C'est bon ca fonctionne a present wink
Merci pour ton aide nikola big_smile

Hors ligne

#7 Le 07/03/2005, à 18:33

djkritick
Membre

Re : [Résolu] php

C'est koi la soluce alors car j'ai le même problème.
Est-il possible de resoudre cela sans phpmyadmin?:|

J'ai installer par synaptic :
apache2
apache2-common
apache2-mpm-prefork
libapache2-mod-php4

il interprète bien HTML mais pas le php...

Hors ligne

#8 Le 07/03/2005, à 18:46

coffee
Membre

Re : [Résolu] php

tu es allé dans php.ini (ou equivalent du 2) pour decommenter la ligne demandant le chargement du module php


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#9 Le 08/03/2005, à 10:10

djkritick
Membre

Re : [Résolu] php

finalement j'ai trouver.
Faut décommenter "AddType application/x-httpd-php .php" dans /etc/apache2/apache2.conf

cette ligne sert à interpréter les fichier php.

Hors ligne

#10 Le 08/03/2005, à 12:04

djkritick
Membre

Re : [Résolu] php

[resolu]:P

Hors ligne