Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#26 Le 29/07/2012, à 00:20

clement.analogue

Re : [SOLUTION] AMD/Intel Graphiques Commutables

J'ai soumis un rapport de bug pour ATI Mobility Radeon HD 5xxx Series :

https://bugs.launchpad.net/xserver-xorg … ug/1021024


Association Ubuntu-Lyon : Organisation d'événements autour d'Ubuntu sur Lyon.

Venez discuter philosophie, exposez vos textes et réflexions, ...
Forum Analogue : Philosophie, sciences, art, actualité, etc.

Hors ligne

#27 Le 04/08/2012, à 15:15

Odelfo

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Bonjour,

Merci pour ces explications claires qui m'ont permis de résoudre ce problème.

Voila ma configuration sur laquelle fonctionne bien cette méthode.

HP dv6-6b71ef , Intel HD , AMD 6490M, HDMI Intel/AMD: not tested/not tested, VGA Intel/AMD: not tested/not tested
J'indiquerai juste qu'il faut bien utiliser l'ACCC en mode administrateur.
J'ai longtemps cru que cela ne marchait pas car j'utilisais l'autre version.
Encore merci.

Dernière modification par Odelfo (Le 04/08/2012, à 15:28)

Hors ligne

#28 Le 04/08/2012, à 21:59

lejoh722

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Bonsoir.
Je me permet de re-poster ici, car je n'arrive pas à configurer mes cartes graphiques.
Plus  que la commutation, je voudrai pouvoir activer l'accélération graphique (pour pouvoir tester mes propres programmes).
Cependant, aucune solution ne fonctionne :
- Par la solution proposé, cette commande plante : sudo sh ./amd-driver-installer-12-4-x86.x86_64.run --buildpkg Ubuntu/precise

=====================================================================
 AMD Catalyst(TM) Proprietary Driver Installer/Packager 
=====================================================================
Generating package: Ubuntu/precise
Package build failed!
Package build utility output:
./packages/Ubuntu/ati-packager.sh: 294: ./packages/Ubuntu/ati-packager.sh: debclean: not found
dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor): -D_FORTIFY_SOURCE=2
dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2
dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor): -Wl,-Bsymbolic-functions -Wl,-z,relro
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 2:8.980-0ubuntu1
dpkg-buildpackage: source changed by AMD: Advanced Micro Devices. <http://ati.amd.com/support/driver.html>
 dpkg-source --before-build fglrx.nJ3Ga1
dpkg-buildpackage: host architecture amd64
 debian/rules build

du coups, j'ai "segmentation fault" quand je lance des programmes (y compris glxgears !)


- Après pas mal de manip, j'ai fini par essayer l'install à partir d'une interface graphique. Résultat, glxgears fonctionne, mais pas d'accélation graphique :

glxinfo | egrep render
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile 

Du coup tout est très lent, et je ne peux pas tester grand chose.
Pourriez-vous m'indiquer la voie à suivre pour avoir un environnement qui me permette de travailler correctement ?

Merci beaucoup.
Jonathan

EDIT : en fait j'ai ACCC installé, mais quand gksu m'affiche toujours une erreur, c'est normal?

Dernière modification par lejoh722 (Le 04/08/2012, à 22:18)

Hors ligne

#29 Le 05/08/2012, à 08:55

piopio59

Re : [SOLUTION] AMD/Intel Graphiques Commutables

j'ai essayé aussi cette solution,  mais pour l'instant, çà bloque :

Réception de : 19 http://fr.archive.ubuntu.com/ubuntu/ precise/main debhelper all 9.20120115ubuntu3 [616 kB]
Réception de : 20 http://fr.archive.ubuntu.com/ubuntu/ precise/main liburi-perl all 1.59-1 [90,3 kB]
Réception de : 21 http://fr.archive.ubuntu.com/ubuntu/ precise/main libencode-locale-perl all 1.02-2 [12,0 kB]
Réception de : 22 http://fr.archive.ubuntu.com/ubuntu/ precise/main libhttp-date-perl all 6.00-1 [10,1 kB]
Réception de : 23 http://fr.archive.ubuntu.com/ubuntu/ precise/main libfile-listing-perl all 6.03-1 [9 690 B]
Réception de : 24 http://fr.archive.ubuntu.com/ubuntu/ precise/main libhtml-tagset-perl all 3.20-2 [13,5 kB]
Réception de : 25 http://fr.archive.ubuntu.com/ubuntu/ precise/main libhtml-parser-perl i386 3.69-1build1 [99,2 kB]
Réception de : 26 http://fr.archive.ubuntu.com/ubuntu/ precise/main libhtml-tree-perl all 4.2-1 [205 kB]
Réception de : 27 http://fr.archive.ubuntu.com/ubuntu/ precise/main liblwp-mediatypes-perl all 6.01-1 [17,5 kB]
Réception de : 28 http://fr.archive.ubuntu.com/ubuntu/ precise/main libhttp-message-perl all 6.01-1 [77,6 kB]
Réception de : 29 http://fr.archive.ubuntu.com/ubuntu/ precise/main libhttp-cookies-perl all 6.00-2 [23,3 kB]
Réception de : 30 http://fr.archive.ubuntu.com/ubuntu/ precise/main libhttp-negotiate-perl all 6.00-2 [13,4 kB]
Réception de : 31 http://fr.archive.ubuntu.com/ubuntu/ precise/main libnet-http-perl all 6.02-1 [23,5 kB]
Réception de : 32 http://fr.archive.ubuntu.com/ubuntu/ precise/main libnet-ssleay-perl i386 1.42-1build1 [184 kB]
Réception de : 33 http://fr.archive.ubuntu.com/ubuntu/ precise/main libio-socket-ssl-perl all 1.53-1 [47,5 kB]
Réception de : 34 http://fr.archive.ubuntu.com/ubuntu/ precise/main liblwp-protocol-https-perl all 6.02-1 [6 746 B]
Réception de : 35 http://fr.archive.ubuntu.com/ubuntu/ precise/main libwww-robotrules-perl all 6.01-1 [14,1 kB]
Réception de : 36 http://fr.archive.ubuntu.com/ubuntu/ precise/main libwww-perl all 6.03-1 [156 kB]
Réception de : 37 http://fr.archive.ubuntu.com/ubuntu/ precise/main libxml-parser-perl i386 2.41-1build1 [264 kB]
Réception de : 38 http://fr.archive.ubuntu.com/ubuntu/ precise/main intltool all 0.50.2-2 [52,0 kB]
Réception de : 39 http://fr.archive.ubuntu.com/ubuntu/ precise/main dh-translations all 116 [21,6 kB]
Réception de : 40 http://fr.archive.ubuntu.com/ubuntu/ precise/main python-scour all 0.26-3 [46,5 kB]
Réception de : 41 http://fr.archive.ubuntu.com/ubuntu/ precise/main cdbs all 0.4.100ubuntu2 [47,6 kB]
Réception de : 42 http://fr.archive.ubuntu.com/ubuntu/ precise/main dh-make all 0.59ubuntu1 [33,8 kB]
Réception de : 43 http://fr.archive.ubuntu.com/ubuntu/ precise/main libalgorithm-diff-perl all 1.19.02-2 [50,7 kB]
Réception de : 44 http://fr.archive.ubuntu.com/ubuntu/ precise/main libalgorithm-diff-xs-perl i386 0.04-2build2 [12,9 kB]
Réception de : 45 http://fr.archive.ubuntu.com/ubuntu/ precise/main libalgorithm-merge-perl all 0.08-2 [12,7 kB]
Réception de : 46 http://fr.archive.ubuntu.com/ubuntu/ precise/main libfont-afm-perl all 1.20-1 [14,3 kB]
Réception de : 47 http://fr.archive.ubuntu.com/ubuntu/ precise/main libhtml-form-perl all 6.00-1 [22,8 kB]
Réception de : 48 http://fr.archive.ubuntu.com/ubuntu/ precise/main libhtml-format-perl all 2.10-1 [40,6 kB]
Réception de : 49 http://fr.archive.ubuntu.com/ubuntu/ precise/main libhttp-daemon-perl all 6.00-1 [16,7 kB]
Réception de : 50 http://fr.archive.ubuntu.com/ubuntu/ precise/main libsocket6-perl i386 0.23-1build2 [21,9 kB]
Réception de : 51 http://fr.archive.ubuntu.com/ubuntu/ precise/main libio-socket-inet6-perl all 2.69-2 [14,3 kB]
Réception de : 52 http://fr.archive.ubuntu.com/ubuntu/ precise/main libsys-hostname-long-perl all 1.4-2 [11,4 kB]
Réception de : 53 http://fr.archive.ubuntu.com/ubuntu/ precise/main libmail-sendmail-perl all 0.79.16-1 [26,5 kB]
Réception de : 54 http://fr.archive.ubuntu.com/ubuntu/ precise/main libmailtools-perl all 2.08-1 [84,0 kB]
14,9 Mo réceptionnés en 16s (888 ko/s)                                         
Extraction des modèles depuis les paquets : 100%
Selecting previously unselected package libunistring0.
(Lecture de la base de données... 257231 fichiers et répertoires déjà installés.)
Dépaquetage de libunistring0 (à partir de .../libunistring0_0.9.3-5_i386.deb) ...
Selecting previously unselected package libgettextpo0.
Dépaquetage de libgettextpo0 (à partir de .../libgettextpo0_0.18.1.1-5ubuntu3_i386.deb) ...
Selecting previously unselected package m4.
Dépaquetage de m4 (à partir de .../m4_1.4.16-2ubuntu1_i386.deb) ...
Selecting previously unselected package autoconf.
Dépaquetage de autoconf (à partir de .../autoconf_2.68-1ubuntu2_all.deb) ...
Selecting previously unselected package autotools-dev.
Dépaquetage de autotools-dev (à partir de .../autotools-dev_20120210.1ubuntu1_all.deb) ...
Selecting previously unselected package automake.
Dépaquetage de automake (à partir de .../automake_1%3a1.11.3-1ubuntu2_all.deb) ...
Selecting previously unselected package libstdc++6-4.6-dev.
Dépaquetage de libstdc++6-4.6-dev (à partir de .../libstdc++6-4.6-dev_4.6.3-1ubuntu5_i386.deb) ...
Selecting previously unselected package g++-4.6.
Dépaquetage de g++-4.6 (à partir de .../g++-4.6_4.6.3-1ubuntu5_i386.deb) ...
Selecting previously unselected package g++.
Dépaquetage de g++ (à partir de .../g++_4%3a4.6.3-1ubuntu5_i386.deb) ...
Selecting previously unselected package libtimedate-perl.
Dépaquetage de libtimedate-perl (à partir de .../libtimedate-perl_1.2000-1_all.deb) ...
Selecting previously unselected package libdpkg-perl.
Dépaquetage de libdpkg-perl (à partir de .../libdpkg-perl_1.16.1.2ubuntu7_all.deb) ...
Selecting previously unselected package dpkg-dev.
Dépaquetage de dpkg-dev (à partir de .../dpkg-dev_1.16.1.2ubuntu7_all.deb) ...
Selecting previously unselected package build-essential.
Dépaquetage de build-essential (à partir de .../build-essential_11.5ubuntu2_i386.deb) ...
Selecting previously unselected package html2text.
Dépaquetage de html2text (à partir de .../html2text_1.3.2a-15_i386.deb) ...
Selecting previously unselected package gettext.
Dépaquetage de gettext (à partir de .../gettext_0.18.1.1-5ubuntu3_i386.deb) ...
Selecting previously unselected package intltool-debian.
Dépaquetage de intltool-debian (à partir de .../intltool-debian_0.35.0+20060710.1_all.deb) ...
Selecting previously unselected package po-debconf.
Dépaquetage de po-debconf (à partir de .../po-debconf_1.0.16+nmu2ubuntu1_all.deb) ...
Selecting previously unselected package dh-apparmor.
Dépaquetage de dh-apparmor (à partir de .../dh-apparmor_2.7.102-0ubuntu3.1_all.deb) ...
Selecting previously unselected package debhelper.
Dépaquetage de debhelper (à partir de .../debhelper_9.20120115ubuntu3_all.deb) ...
Selecting previously unselected package liburi-perl.
Dépaquetage de liburi-perl (à partir de .../liburi-perl_1.59-1_all.deb) ...
Selecting previously unselected package libencode-locale-perl.
Dépaquetage de libencode-locale-perl (à partir de .../libencode-locale-perl_1.02-2_all.deb) ...
Selecting previously unselected package libhttp-date-perl.
Dépaquetage de libhttp-date-perl (à partir de .../libhttp-date-perl_6.00-1_all.deb) ...
Selecting previously unselected package libfile-listing-perl.
Dépaquetage de libfile-listing-perl (à partir de .../libfile-listing-perl_6.03-1_all.deb) ...
Selecting previously unselected package libhtml-tagset-perl.
Dépaquetage de libhtml-tagset-perl (à partir de .../libhtml-tagset-perl_3.20-2_all.deb) ...
Selecting previously unselected package libhtml-parser-perl.
Dépaquetage de libhtml-parser-perl (à partir de .../libhtml-parser-perl_3.69-1build1_i386.deb) ...
Selecting previously unselected package libhtml-tree-perl.
Dépaquetage de libhtml-tree-perl (à partir de .../libhtml-tree-perl_4.2-1_all.deb) ...
Selecting previously unselected package liblwp-mediatypes-perl.
Dépaquetage de liblwp-mediatypes-perl (à partir de .../liblwp-mediatypes-perl_6.01-1_all.deb) ...
Selecting previously unselected package libhttp-message-perl.
Dépaquetage de libhttp-message-perl (à partir de .../libhttp-message-perl_6.01-1_all.deb) ...
Selecting previously unselected package libhttp-cookies-perl.
Dépaquetage de libhttp-cookies-perl (à partir de .../libhttp-cookies-perl_6.00-2_all.deb) ...
Selecting previously unselected package libhttp-negotiate-perl.
Dépaquetage de libhttp-negotiate-perl (à partir de .../libhttp-negotiate-perl_6.00-2_all.deb) ...
Selecting previously unselected package libnet-http-perl.
Dépaquetage de libnet-http-perl (à partir de .../libnet-http-perl_6.02-1_all.deb) ...
Selecting previously unselected package libnet-ssleay-perl.
Dépaquetage de libnet-ssleay-perl (à partir de .../libnet-ssleay-perl_1.42-1build1_i386.deb) ...
Selecting previously unselected package libio-socket-ssl-perl.
Dépaquetage de libio-socket-ssl-perl (à partir de .../libio-socket-ssl-perl_1.53-1_all.deb) ...
Selecting previously unselected package liblwp-protocol-https-perl.
Dépaquetage de liblwp-protocol-https-perl (à partir de .../liblwp-protocol-https-perl_6.02-1_all.deb) ...
Selecting previously unselected package libwww-robotrules-perl.
Dépaquetage de libwww-robotrules-perl (à partir de .../libwww-robotrules-perl_6.01-1_all.deb) ...
Selecting previously unselected package libwww-perl.
Dépaquetage de libwww-perl (à partir de .../libwww-perl_6.03-1_all.deb) ...
Selecting previously unselected package libxml-parser-perl.
Dépaquetage de libxml-parser-perl (à partir de .../libxml-parser-perl_2.41-1build1_i386.deb) ...
Selecting previously unselected package intltool.
Dépaquetage de intltool (à partir de .../intltool_0.50.2-2_all.deb) ...
Selecting previously unselected package dh-translations.
Dépaquetage de dh-translations (à partir de .../dh-translations_116_all.deb) ...
Selecting previously unselected package python-scour.
Dépaquetage de python-scour (à partir de .../python-scour_0.26-3_all.deb) ...
Selecting previously unselected package cdbs.
Dépaquetage de cdbs (à partir de .../cdbs_0.4.100ubuntu2_all.deb) ...
Selecting previously unselected package dh-make.
Dépaquetage de dh-make (à partir de .../dh-make_0.59ubuntu1_all.deb) ...
Selecting previously unselected package libalgorithm-diff-perl.
Dépaquetage de libalgorithm-diff-perl (à partir de .../libalgorithm-diff-perl_1.19.02-2_all.deb) ...
Selecting previously unselected package libalgorithm-diff-xs-perl.
Dépaquetage de libalgorithm-diff-xs-perl (à partir de .../libalgorithm-diff-xs-perl_0.04-2build2_i386.deb) ...
Selecting previously unselected package libalgorithm-merge-perl.
Dépaquetage de libalgorithm-merge-perl (à partir de .../libalgorithm-merge-perl_0.08-2_all.deb) ...
Selecting previously unselected package libfont-afm-perl.
Dépaquetage de libfont-afm-perl (à partir de .../libfont-afm-perl_1.20-1_all.deb) ...
Selecting previously unselected package libhtml-form-perl.
Dépaquetage de libhtml-form-perl (à partir de .../libhtml-form-perl_6.00-1_all.deb) ...
Selecting previously unselected package libhtml-format-perl.
Dépaquetage de libhtml-format-perl (à partir de .../libhtml-format-perl_2.10-1_all.deb) ...
Selecting previously unselected package libhttp-daemon-perl.
Dépaquetage de libhttp-daemon-perl (à partir de .../libhttp-daemon-perl_6.00-1_all.deb) ...
Selecting previously unselected package libsocket6-perl.
Dépaquetage de libsocket6-perl (à partir de .../libsocket6-perl_0.23-1build2_i386.deb) ...
Selecting previously unselected package libio-socket-inet6-perl.
Dépaquetage de libio-socket-inet6-perl (à partir de .../libio-socket-inet6-perl_2.69-2_all.deb) ...
Selecting previously unselected package libsys-hostname-long-perl.
Dépaquetage de libsys-hostname-long-perl (à partir de .../libsys-hostname-long-perl_1.4-2_all.deb) ...
Selecting previously unselected package libmail-sendmail-perl.
Dépaquetage de libmail-sendmail-perl (à partir de .../libmail-sendmail-perl_0.79.16-1_all.deb) ...
Selecting previously unselected package libmailtools-perl.
Dépaquetage de libmailtools-perl (à partir de .../libmailtools-perl_2.08-1_all.deb) ...
Traitement des actions différées (« triggers ») pour « install-info »...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « doc-base »...
Processing 3 added doc-base files...
Paramétrage de libunistring0 (0.9.3-5) ...
Paramétrage de libgettextpo0 (0.18.1.1-5ubuntu3) ...
Paramétrage de m4 (1.4.16-2ubuntu1) ...
Paramétrage de autoconf (2.68-1ubuntu2) ...
Paramétrage de autotools-dev (20120210.1ubuntu1) ...
Paramétrage de automake (1:1.11.3-1ubuntu2) ...
update-alternatives: utilisation de « /usr/bin/automake-1.11 » pour fournir « /usr/bin/automake » (automake) en mode automatique.
Paramétrage de libtimedate-perl (1.2000-1) ...
Paramétrage de libdpkg-perl (1.16.1.2ubuntu7) ...
Paramétrage de dpkg-dev (1.16.1.2ubuntu7) ...
Paramétrage de html2text (1.3.2a-15) ...
Paramétrage de gettext (0.18.1.1-5ubuntu3) ...
Paramétrage de intltool-debian (0.35.0+20060710.1) ...
Paramétrage de po-debconf (1.0.16+nmu2ubuntu1) ...
Paramétrage de dh-apparmor (2.7.102-0ubuntu3.1) ...
Paramétrage de debhelper (9.20120115ubuntu3) ...
Paramétrage de liburi-perl (1.59-1) ...
Paramétrage de libencode-locale-perl (1.02-2) ...
Paramétrage de libhttp-date-perl (6.00-1) ...
Paramétrage de libfile-listing-perl (6.03-1) ...
Paramétrage de libhtml-tagset-perl (3.20-2) ...
Paramétrage de libhtml-parser-perl (3.69-1build1) ...
Paramétrage de libhtml-tree-perl (4.2-1) ...
Paramétrage de liblwp-mediatypes-perl (6.01-1) ...
Paramétrage de libhttp-message-perl (6.01-1) ...
Paramétrage de libhttp-cookies-perl (6.00-2) ...
Paramétrage de libhttp-negotiate-perl (6.00-2) ...
Paramétrage de libnet-http-perl (6.02-1) ...
Paramétrage de libnet-ssleay-perl (1.42-1build1) ...
Paramétrage de libio-socket-ssl-perl (1.53-1) ...
Paramétrage de libwww-robotrules-perl (6.01-1) ...
Paramétrage de python-scour (0.26-3) ...
Paramétrage de dh-make (0.59ubuntu1) ...
Paramétrage de libalgorithm-diff-perl (1.19.02-2) ...
Paramétrage de libalgorithm-diff-xs-perl (0.04-2build2) ...
Paramétrage de libalgorithm-merge-perl (0.08-2) ...
Paramétrage de libfont-afm-perl (1.20-1) ...
Paramétrage de libhtml-form-perl (6.00-1) ...
Paramétrage de libhtml-format-perl (2.10-1) ...
Paramétrage de libhttp-daemon-perl (6.00-1) ...
Paramétrage de libsocket6-perl (0.23-1build2) ...
Paramétrage de libio-socket-inet6-perl (2.69-2) ...
Paramétrage de libsys-hostname-long-perl (1.4-2) ...
Paramétrage de libmail-sendmail-perl (0.79.16-1) ...
Paramétrage de libmailtools-perl (2.08-1) ...
Paramétrage de g++-4.6 (4.6.3-1ubuntu5) ...
Paramétrage de g++ (4:4.6.3-1ubuntu5) ...
update-alternatives: utilisation de « /usr/bin/g++ » pour fournir « /usr/bin/c++ » (c++) en mode automatique.
Paramétrage de build-essential (11.5ubuntu2) ...
Paramétrage de libwww-perl (6.03-1) ...
Paramétrage de libxml-parser-perl (2.41-1build1) ...
Paramétrage de intltool (0.50.2-2) ...
Paramétrage de dh-translations (116) ...
Paramétrage de cdbs (0.4.100ubuntu2) ...
Paramétrage de libstdc++6-4.6-dev (4.6.3-1ubuntu5) ...
Paramétrage de liblwp-protocol-https-perl (6.02-1) ...
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place
jeremie@Odysseus:~$ cd ~/; mkdir catalyst12.4; cd catalyst12.4/
jeremie@Odysseus:~/catalyst12.4$ wget http://www2.ati.com/drivers/linux/amd-d … x86_64.run
--2012-08-05 08:42:08--  http://www2.ati.com/drivers/linux/amd-d … x86_64.run
Résolution de www2.ati.com (www2.ati.com)... 32.58.65.146
Connexion vers www2.ati.com (www2.ati.com)|32.58.65.146|:80... connecté.
requête HTTP transmise, en attente de la réponse... 200 OK
Longueur: 108360519 (103M) [application/octet-stream]
Sauvegarde en : «amd-driver-installer-12-4-x86.x86_64.run»

100%[======================================>] 108 360 519  887K/s   ds 2m 1s   

2012-08-05 08:44:09 (872 KB/s) - «amd-driver-installer-12-4-x86.x86_64.run» sauvegardé [108360519/108360519]

jeremie@Odysseus:~/catalyst12.4$ chmod +x amd-driver-installer-12-4-x86.x86_64.run
jeremie@Odysseus:~/catalyst12.4$ sudo sh ./amd-driver-installer-12-4-x86.x86_64.run --buildpkg Ubuntu/precise
Created directory fglrx-install.ZJhx5k
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-8.961.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
AMD Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
Generating package: Ubuntu/precise
Resolving build dependencies...
apt 0.8.16~exp12ubuntu10.2 for i386 compiled on Jun 15 2012 14:41:15
Usage: apt-get [options] command
       apt-get [options] install|remove pkg1 [pkg2 ...]
       apt-get [options] source pkg1 [pkg2 ...]

apt-get is a simple command line interface for downloading and
installing packages. The most frequently used commands are update
and install.

Commands:
   update - Retrieve new lists of packages
   upgrade - Perform an upgrade
   install - Install new packages (pkg is libc6 not libc6.deb)
   remove - Remove packages
   autoremove - Remove automatically all unused packages
   purge - Remove packages and config files
   source - Download source archives
   build-dep - Configure build-dependencies for source packages
   dist-upgrade - Distribution upgrade, see apt-get(8)
   dselect-upgrade - Follow dselect selections
   clean - Erase downloaded archive files
   autoclean - Erase old downloaded archive files
   check - Verify that there are no broken dependencies
   changelog - Download and display the changelog for the given package
   download - Download the binary package into the current directory

Options:
  -h  This help text.
  -q  Loggable output - no progress indicator
  -qq No output except for errors
  -d  Download only - do NOT install or unpack archives
  -s  No-act. Perform ordering simulation
  -y  Assume Yes to all queries and do not prompt
  -f  Attempt to correct a system with broken dependencies in place
  -m  Attempt to continue if archives are unlocatable
  -u  Show a list of upgraded packages as well
  -b  Build the source package after fetching it
  -V  Show verbose version numbers
  -c=? Read this configuration file
  -o=? Set an arbitrary configuration option, eg -o dir::cache=/tmp
See the apt-get(8), sources.list(5) and apt.conf(5) manual
pages for more information and options.
                       This APT has Super Cow Powers.
Unable to resolve  dh-modaliases execstack.  Please manually install and try again.
Package build failed!
Package build utility output:
./packages/Ubuntu/ati-packager.sh: 294: ./packages/Ubuntu/ati-packager.sh: debclean: not found
dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor): -D_FORTIFY_SOURCE=2
dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2
dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor): -Wl,-Bsymbolic-functions -Wl,-z,relro
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 2:8.961-0ubuntu1
dpkg-buildpackage: source changed by AMD: Advanced Micro Devices. <http://ati.amd.com/support/driver.html>
dpkg-source --before-build fglrx.chgr3X
dpkg-buildpackage: host architecture i386
debian/rules build
#Create important strings
for i in 10fglrx \
             dkms.conf \
             fglrx.install \
             fglrx-dev.install \
             fglrx-dev.links \
             fglrx-amdcccle.install \
             fglrx.grub-gfxpayload \
             fglrx.dirs \
             fglrx.links \
             fglrx.postinst \
             fglrx.postrm \
             fglrx.preinst \
             fglrx.prerm \
             overrides/fglrx; do \
        sed -e "s|#PKGXMODDIR#|usr/lib/fglrx/xorg/modules|g" \
            -e "s|#LIBDIR#|usr/lib|g" \
            -e "s|#LIBDIR32#|usr/lib32|g" \
            -e "s|#BINDIR#|usr/bin|g" \
            -e "s|#SYSCONFDIR#|etc|g" \
            -e "s|#MANDIR#|usr/share/man/man1|g" \
            -e "s|#LDSOCONF#|usr/lib/fglrx/ld.so.conf|g" \
            -e "s|#ALTLDSOCONF#|usr/lib/fglrx/alt_ld.so.conf|g" \
            -e "s|#ALTPRIORITY#|1000|g" \
            -e "s|#PXALTPRIORITY#|900|g" \
            -e "s|#AUTOSTARTDIR#|etc/xdg/autostart|g" \
            -e "s|#DATADIR#|usr/share|g" \
            -e "s|#PKGDESKDIR#|usr/share/fglrx|g" \
            -e "s|#PKGDATADIR#|usr/share/fglrx|g" \
            -e "s|#PKGCONFIGDIR#|usr/lib/fglrx|g" \
            -e "s|#PKGBINDIR#|usr/lib/fglrx/bin|g" \
            -e "s|#PKGLIBDIR#|usr/lib/fglrx|g" \
            -e "s|#PKGLIBDIR32#|usr/lib32/fglrx|g" \
            -e "s|#PKGDRIVERSDIR#|usr/lib/fglrx/xorg|g" \
            -e "s|#XORGEXTRA#|usr/lib/i386-linux-gnu/xorg/extra-modules|g" \
            -e "s|#PKGEXTENSIONDIR#|usr/lib/fglrx/xorg|g" \
            -e "s|#XORGEXTENSIONSDIR#|usr/lib/xorg/modules/extensions|g" \
            -e "s|#DRIVERNAME#|fglrx|g" \
            -e "s|#DRIVERDEVNAME#|fglrx-dev|g" \
            -e "s|#DRIVERSRCNAME#||g" \
            -e "s|#INCLUDEDIR#|usr/include|g" \
            -e "s|#PKGLIBCONFDIR#|lib/fglrx|g" \
            -e "s|#GRUBBLKLISTDIR#|usr/share/grub-gfxpayload-lists/blacklist|g" \
            -e "s|#PKGXMODDIR#|usr/lib/fglrx/xorg/modules|g" \
            -e "s|#PXDIR#|usr/lib/pxpress|g" \
            -e "s|#PXDIR32#|usr/lib32/pxpress|g" \
            -e "s|#PXXMODDIR#|usr/lib/pxpress/xorg/modules|g" \
            -e "s|#PXDIRNAME#|pxpress|g" \
            -e "s|#PXLIBDIR#|usr/lib/pxpress/lib|g" \
            -e "s|#PXLIBDIR32#|usr/lib32/pxpress/lib|g" \
            -e "s|#PXLDSOCONF#|usr/lib/pxpress/ld.so.conf|g" \
            -e "s|#ALTPXLDSOCONF#|usr/lib/pxpress/alt_ld.so.conf|g" \
            -e "s|#CVERSION#|8.961|g" \
            -e "s|#SRCXARCH#|xpic|g" \
            -e "s|#SRCARCH#|x86|g" \
            -e "s|#SRCLIBDIR#|lib|g" \
            -e "s|#DEB_HOST_MULTIARCH#|i386-linux-gnu|g" \
            -e "s|#OTHER_ARCH#|x86_64-linux-gnu|g" \
            debian/$i.in > debian/$i;      \
    done
# remove exec bit on everything
find arch \
        etc \
        lib \
        module \
        usr \
        xpic     -type f | xargs chmod -x
find: `module': No such file or directory
# set executable on user apps
find arch/x86/usr/sbin \
        arch/x86/usr/X11R6/bin \
        usr/sbin/ -type f | xargs chmod a+x
# set exec bit on scripts
find lib etc debian -name "*.sh" -type f | xargs chmod +x
# set the permissions on the pxpress scripts
chmod 744 debian/pxpress/switch*
dh build
   dh_testdir
   dh_auto_configure
   dh_auto_build
   dh_auto_test
debian/rules binary
# refresh copyright file
cat debian/copyright_stub_0 > debian/copyright
cat usr/share/doc/fglrx/LICENSE.TXT >> debian/copyright
cat debian/copyright_stub_1 >> debian/copyright
#Steps that we can't easily represent in debhelper files or .in files yet
# Remove any libraries that may be caught by shell expansion
find . -name libGLE* | xargs rm -f
find . -name libEGL* | xargs rm -f
dh_installdirs -pfglrx
dh_installdirs -pfglrx-dev
dh_installdocs -pfglrx usr/share/doc/fglrx/* --exclude LICENSE.TXT
dh_installdocs -pfglrx debian/AUTHORS
dh_installdocs -pfglrx debian/copyright
dh_installinit -pfglrx --name="atieventsd" --no-start --update-rcd-params="defaults 31"
#remove executable bits from stack
dh_install -pfglrx-amdcccle
execstack -c debian/fglrx-amdcccle/usr/lib/fglrx/bin/amdcccle
make: execstack: Command not found
make: *** [binary-arch] Error 127
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
Removing temporary directory: fglrx-install.ZJhx5k
jeremie@Odysseus:~/catalyst12.4$ sudo dpkg -i fglrx*.deb
dpkg : erreur de traitement de fglrx*.deb (--install) :
ne peut pas accéder à l'archive: Aucun fichier ou dossier de ce type
Des erreurs ont été rencontrées pendant l'exécution :
fglrx*.deb
jeremie@Odysseus:~/catalyst12.4$ sudo aticonfig --initial -f
Uninitialised file found, configuring.
PowerXpress info: Diagnostic output from /usr/lib/fglrx/switchlibglx:
update-alternatives: avertissement: forçage de la réinstallation de l'alternative /usr/lib/fglrx/ld.so.conf car le groupe de liens i386-linux-gnu_gl_conf est cassé
update-alternatives: avertissement: création de /etc/OpenCL/vendors/amdocl64.icd abandonnée car le fichier associé /usr/lib/fglrx/etc/OpenCL/vendors/amdocl64.icd (du groupe de liens i386-linux-gnu_gl_conf) n'existe pas.
update-alternatives: avertissement: création de /usr/lib32/libaticalcl.so abandonnée car le fichier associé /usr/lib32/fglrx/libaticalcl.so (du groupe de liens i386-linux-gnu_gl_conf) n'existe pas.
update-alternatives: avertissement: création de /usr/lib32/libaticalrt.so abandonnée car le fichier associé /usr/lib32/fglrx/libaticalrt.so (du groupe de liens i386-linux-gnu_gl_conf) n'existe pas.
update-alternatives: avertissement: /usr/lib/i386-linux-gnu/xorg/extra-modules ne sera pas remplacé par un lien.

Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.original-0
jeremie@Odysseus:~/catalyst12.4$

si quelqu'un a une idée de ce qui se passe?
Si il n'y a pas de solution, comment désinstaller ce qui est installé?
merci d'avance

Hors ligne

#30 Le 07/08/2012, à 10:55

lejoh722

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Bonjour.
@piopio59
Après une installation d'une live-usb, j'ai réussi à faire commuter mes cartes avec ubuntu 12.4 et Unity (je ne sais pas si c'est important ...)
j'ai eu à peu près le même problème que vous; je l'ai résolu en faisant:

sudo apt-get update # pas forcément nécessaire à mon avis, mais vu que je repartait sur un OS tout neuf ....
sudo apt-get upgrade # quelques modif, puis un message d'erreur
sudo apt-get install -f # en réponse au message d'erreur, j'ai réussi à installer les derniers composants

Ensuite j'ai refais l'install à partir de :
Installons ces paquets : sudo dpkg -i fglrx*.deb

Je vais rééssayer sur une vraie install, et je vous tiens au courant.

Hors ligne

#31 Le 07/08/2012, à 17:33

giblux

Re : [SOLUTION] AMD/Intel Graphiques Commutables

ca fonctionne bien aussi pour moi sauf une option importante qui manque dans catalyst-control-center voir ici
a part ca, ma machine est stable et de plus, je constate un abaissement de la temperature de l'ordre de 15 a 20 deg.c.( fait tres chaud ici) par rapport a l'utilisation des pilotes mesa qui font monter la temperature du prosso a ...71deg.c.!!!!!!

samsung 300E4Z, intel HM65, celeronB815, hdd SATA, 2gbDDR3, vram hybrid AMD HD6470M 1gbDDR3

Hors ligne

#32 Le 08/08/2012, à 12:54

Alexislavie

Re : [SOLUTION] AMD/Intel Graphiques Commutables

lejoh722 a écrit :

Bonjour,
J'ai donc retenté la manip' avec la version 12.6 du pilote, mais le résultat est exactement le même.
Je vais également me brancher sur le fil anglophone, merci du conseil.

Jonathan

Retente avec la 12.6 à partir d'une installation propre...

Hors ligne

#33 Le 10/08/2012, à 10:45

lejoh722

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Bonjour.
J'ai retenté une install avec ubuntu 12.04 LTS et j'ai installé le pilote ati 12.6, et cela semble s'installer correctement (aucun message d'erreur)
Cependant, quand je redémarre, j'ai un message du genre "passage en low graphics mode"
Du coups j'ai remis le Xorg.conf d'origine.
Je n'ai malheureusement pas plus de détails à vous donner. Quelqu'un peut-il tout-de-même m'indiquer la marche à suivre à présent?
Merci
Jonathan

EDIT : j'essaye de donner quelques précisions sur mon problème.
- pendant l'installation, les seuls "erreurs" que j'ai pu voir  sont celles-ci:

sudo dpkg -i fglrx*.deb
# pas mal de trucs, mais tout avait l'air normal je pense ....
fglrx:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-29-generic/updates/dkms/

DKMS: install completed. # du coup j'ai supposé que tout était OK
sudo aticonfig --px-igpu
PowerXpress info: Diagnostic output from /usr/lib64/fglrx/switchlibglx:
update-alternatives: avertissement: création de /etc/OpenCL/vendors/amdocl32.icd abandonnée car le fichier associé /usr/lib/fglrx/etc/OpenCL/vendors/amdocl32.icd (du groupe de liens x86_64-linux-gnu_gl_conf) n'existe pas.

PowerXpress: Integrated GPU is selected (Power-Saving mode), please restart Xserver(s) for changes to take effect!

Je donne ici le xorg.conf généré

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Un autre problème très bizarre intervient au redémarrage, après avoir remis le xorg.conf d'origine : quand je tente de me logguer,la page d'accueil revient toujours (en clair, je me log, et ça revient comme si je ne m'étais pas loggué). Très bizarre:  ça n'était pas le cas avant l'installation.

Voila, c'est tout ce que je peux donner comme info pour le moment désolé.
Merci pour l'aide apporté en tout cas
Jonathan

Dernière modification par lejoh722 (Le 11/08/2012, à 13:25)

Hors ligne

#34 Le 21/08/2012, à 17:10

Tktrope

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Edit:

Tout fonctionne sur mon hp pavilion dv6 6156sf !

Dernière modification par Tktrope (Le 22/08/2012, à 23:05)

Hors ligne

#35 Le 11/09/2012, à 10:56

sevenup30

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Merci beaucoup,
j'ai tout installé mais j'ai des plantage aléatoire, je redémarre X et ça fonctionne 5mn puis plante. J'ai donc désinstallé les drivers et tout refonctionne.

Je vais me pencher vers vga_switcheroo mais je crois qu'il fonctionne mal sur 12.04

Sinon j'ai un portable asus a55D (apu amd A8 vision)

Hors ligne

#36 Le 12/09/2012, à 17:13

Dempiller

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Un grand merci pour ce tuto qui a très bien fonctionné pour moi. smile
Cela fonctionne-t-il aussi bien si ou le fait avec une version plus récente de driver ?

Les commandes à faire après mises à jour, on peut les faire maintenant pour les resélectionner après mise à jour ? Ou non ? ^^


Modèle : Dell Vostro 3550. Cpu : Intel i5 2450M (2,50Ghz). Ram : 6 Ghz Ddr3. Carte graphique : Intel HD3000+Amd Radeon HD 6330M. Hdd : 500 Go en 7200 rpm. Ecran : Led HD 15,6". Wifi : Dell Wireless 1702 alias Atheros AR9285. Système : Kubuntu 12.10 (64 bits).

Hors ligne

#37 Le 12/09/2012, à 18:18

michel_04

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Bonjour,

Dempiller a écrit :

Cela fonctionne-t-il aussi bien si ou le fait avec une version plus récente de driver ?

Oui, j'ai installé le driver 12.8

Dempiller a écrit :

Les commandes à faire après mises à jour, on peut les faire maintenant pour les resélectionner après mise à jour ? Ou non ?

Tu les as déjà faites si tout fonctionne correctement.

ETAPE 2 - Réparer le bug de "direct rendering" sur la carte intégrée Intel :
Merci à Niccola pour avoir trouvé la solution actuelle.

Si jamais vous appliquez une mise-à-jour de fglrx ou votre système en applique une automatiquement, vous devrez répéter l'étape 2, autrement le gpu intégré au processeur ne sera pas capable d'afficher un rendu directement sur l'écran = pas de 3D (c-à-d Pas d'Unity 3D, de Gnome Shell ou de Gnome Classic + Compiz sur la carte Intel). Si vous avez une autre solution (comme un script au démarrage) postez-la.

Ouvrez le fichier /etc/X11/Xsession.d/10fglrx avec les droits root :

gksu gedit /etc/X11/Xsession.d/10fglrx

Si vous utilisez un système 32bits ajoutez à la fin de la 4ème ligne ce texte : "/usr/lib32/dri/" sans les guillemets. Le fichier devrait maintenant ressembler à ceci :

LIBGL_DRIVERS_PATH=/usr/lib/fglrx/dri
if [ `uname -m` = 'x86_64' ]; then
if [ -d /usr/lib32/fglrx/dri ]; then
LIBGL_DRIVERS_PATH=${LIBGL_DRIVERS_PATH}:/usr/lib32/fglrx/dri:/usr/lib32/dri
if [ ! -z $LD_LIBRARY_PATH ]; then
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:
fi
LD_LIBRARY_PATH=${LD_LIBRARY_PATH}/usr/lib32
export LD_LIBRARY_PATH
fi
fi
export LIBGL_DRIVERS_PATH

Si vous utilisez un système 64bits ajoutez à la fin de la 4ème ligne ce texte : "/usr/lib/x86_64-linux-gnu/dri" sans les guillemets. Le fichier devrait maintenant ressembler à ceci :

LIBGL_DRIVERS_PATH=/usr/lib/fglrx/dri
if [ `uname -m` = 'x86_64' ]; then
if [ -d /usr/lib32/fglrx/dri ]; then
LIBGL_DRIVERS_PATH=${LIBGL_DRIVERS_PATH}:/usr/lib32/fglrx/dri:/usr/lib/x86_64-linux-gnu/dri
if [ ! -z $LD_LIBRARY_PATH ]; then
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:
fi
LD_LIBRARY_PATH=${LD_LIBRARY_PATH}/usr/lib32
export LD_LIBRARY_PATH
fi
fi
export LIBGL_DRIVERS_PATH

Enregistrez le fichier et fermez-le.

A+

Hors ligne

#38 Le 12/09/2012, à 19:31

Dempiller

Re : [SOLUTION] AMD/Intel Graphiques Commutables

@michel_04 : Très bon à savoir pour le driver. smile Merci du renseignement.
En effet pour la manip, j'avais la tête ailleurs. ^^ Et donc si c'est pas assez efficiace, on vire le fichier de conf du server X et on relance X, c'est bien ca ? smile


Modèle : Dell Vostro 3550. Cpu : Intel i5 2450M (2,50Ghz). Ram : 6 Ghz Ddr3. Carte graphique : Intel HD3000+Amd Radeon HD 6330M. Hdd : 500 Go en 7200 rpm. Ecran : Led HD 15,6". Wifi : Dell Wireless 1702 alias Atheros AR9285. Système : Kubuntu 12.10 (64 bits).

Hors ligne

#39 Le 12/09/2012, à 19:45

michel_04

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Re,

Tu as bien lu. ;-)

Edit : J'ai déjà écrit que la commutation fonctionnait très bien. De plus l'autonomie sous Ubuntu 12.04 est même légèrement supérieure à celle sous Widows 7.
Bien sûr avec utilisation des mêmes logiciels pour la lecture des mêmes fichiers audio et vidéo.

A+

Dernière modification par michel_04 (Le 14/09/2012, à 11:25)

Hors ligne

#40 Le 14/09/2012, à 19:45

powerflower5

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Bonjour,
J'ai un souci d'écran noir quand je veux tester ubuntu. Une discussion a déjà commencé ici mais on m'a conseillé de demande de l'aide ici.

Voici également le retour de commande demandé au post 39 :

ubuntu@ubuntu:~$ lspci -vnn | grep '\''[030[02]\]'
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Manhattan [Mobility Radeon HD 5400 Series] [1002:68e0] (prog-if 00 [VGA controller])
ubuntu@ubuntu:~$ 

Merci d'avance pour votre aide.


PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Ubuntu 14.04 et Windows 7

Hors ligne

#41 Le 14/09/2012, à 20:09

clement.analogue

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Les graphiques commutables avec Mobility Radeon HD 5400 Series sont une catastrophe. Je te conseille d'aller sur la page du bug et de cliquer sur "yes, it affects me" et éventuellement de mettre des info en commentaire :
https://bugs.launchpad.net/xserver-xorg … ug/1021024
ça permettra à ce bug d'avoir de la visibilité et d'être corrigé.


Association Ubuntu-Lyon : Organisation d'événements autour d'Ubuntu sur Lyon.

Venez discuter philosophie, exposez vos textes et réflexions, ...
Forum Analogue : Philosophie, sciences, art, actualité, etc.

Hors ligne

#42 Le 14/09/2012, à 22:21

alca94

Re : [SOLUTION] AMD/Intel Graphiques Commutables

@ clement.analogue
Bonsoir
c'est moi qui est conseillé a powerflower5 de poster ici pour son probleme sur un PC HP . Vous vous faites comment pour fonctionner ,
j'ai vu que l'on pouvait désactiver la carte ATI/AMD dans le bios pour ne fonctionner que sur le INTEL .Si vous pouviez lui indiquer la marche a suivre.

Hors ligne

#43 Le 14/09/2012, à 22:38

clement.analogue

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Je n'ai pas de problème d'écran noir avec les drivers libres.
Dans le bios de mon laptop, je ne peux rien changer si ce n'est l'heure. Lorsque je commute sur la carte ATI, mes performances sont déplorables alors qu'avec le chipset Intel, ça va assez bien.

Une solution, mais je ne sais pas si c'est possible, serait de désactiver une des cartes avec vga_switcheroo dans grub.
http://doc.ubuntu-fr.org/vga_switcheroo


Association Ubuntu-Lyon : Organisation d'événements autour d'Ubuntu sur Lyon.

Venez discuter philosophie, exposez vos textes et réflexions, ...
Forum Analogue : Philosophie, sciences, art, actualité, etc.

Hors ligne

#44 Le 14/09/2012, à 22:47

alca94

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Eh bien c'est justement ça ,comment faites vous pour désactiver la carte ATI

Lorsque je commute sur la carte ATI, mes performances sont déplorables alors qu'avec le chipset Intel, ça va assez bien.

Hors ligne

#45 Le 14/09/2012, à 22:49

clement.analogue

Re : [SOLUTION] AMD/Intel Graphiques Commutables

echo OFF > sudo /sys/kernel/debug/vgaswitcheroo/switch


Association Ubuntu-Lyon : Organisation d'événements autour d'Ubuntu sur Lyon.

Venez discuter philosophie, exposez vos textes et réflexions, ...
Forum Analogue : Philosophie, sciences, art, actualité, etc.

Hors ligne

#46 Le 14/09/2012, à 22:55

alca94

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Entre-temps j'avais trouvé ça sur le forum

chibbata
tu as les 2 drivers intel et ati qui sont en fonctionnement
blacklist radeon pour l'empecher de se charger au demarrage
sudo -s
echo "blacklist radeon" >> /etc/modprobe.d/blacklist.conf
redemarres le pc
tu n'as plus besoin de radeon.modeset dans le grub
tu peux mettre aussi gpu discrete sur disabled dans le bios

qu'est-ce que vous en pensez ?

echo OFF > sudo /sys/kernel/debug/vgaswitcheroo/switch

c'est ce que vous vous faites car sur le lien que vous aviez donné ,apparemment ce n'était plus valable depuis la 11.04

Dernière modification par alca94 (Le 14/09/2012, à 22:58)

Hors ligne

#47 Le 14/09/2012, à 23:07

clement.analogue

Re : [SOLUTION] AMD/Intel Graphiques Commutables

C'est un bug corrigé avec le noyau 2.6.35, donc sur une 12.04, pas de soucis.

Edit: J'en pense qu'il faut tester ^^

Dernière modification par clement.analogue (Le 14/09/2012, à 23:08)


Association Ubuntu-Lyon : Organisation d'événements autour d'Ubuntu sur Lyon.

Venez discuter philosophie, exposez vos textes et réflexions, ...
Forum Analogue : Philosophie, sciences, art, actualité, etc.

Hors ligne

#48 Le 14/09/2012, à 23:12

clement.analogue

Re : [SOLUTION] AMD/Intel Graphiques Commutables


Association Ubuntu-Lyon : Organisation d'événements autour d'Ubuntu sur Lyon.

Venez discuter philosophie, exposez vos textes et réflexions, ...
Forum Analogue : Philosophie, sciences, art, actualité, etc.

Hors ligne

#49 Le 14/09/2012, à 23:26

alca94

Re : [SOLUTION] AMD/Intel Graphiques Commutables

@ clement.analogue
Bon ,merci a vous mais comme dit avant ça concerne "powerflower5" post 40 . Et comme il ne se manifeste pas ?

Hors ligne

#50 Le 15/09/2012, à 08:04

powerflower5

Re : [SOLUTION] AMD/Intel Graphiques Commutables

Bonjour,
Alca 94, j'étais juste partie me coucher ^^!!!
Je précise quand même, au passage que je n'ai pas installé ubuntu... je suis juste en version de teste! Du coup, qu'eqt-ce que je dois faire alors?


PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Ubuntu 14.04 et Windows 7

Hors ligne

Haut de page ↑