Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 21/08/2012, à 21:02

keyman

Erreur Yaboot 1st launch

Bonjour,
Je veux transformer un vieil minimac PPC (1,25Ghtz / 1G RAM) en serveur FTP et Samba
J'ai tenter d'installer la derniere version serveur d'ubuntu compatible PPC
l'installation a tres bien marché.
viens ensuite le reboot de fin d'installation,
et apparement la config yaboot par deffaut ne fonctionne pas avec moi.
J'ai pourtant reformater tout le disque dur, et il n'y a q'ubuntu d'installé.

J'ai cette erreur :

boot : Linux
Please Wait, loading kernel...
/pci@f4000000/ata-6@d/@0:3,/vmlinux: No such file or directory
boot :

J'ai tenter tout un tas de truc, mais je dois etre assez nul, et je n'y arrive toujours pas...
je ne comprends pas que ça ne fonctionne pas, vu que c'est l'install pas deffaut sans modif, sur disque dur vierge....
J'imagine qu'il y a un confli avec le firmware Mac PPC par deffaut non.?
Y'atil une solution simple please! ??

Merci de votre aide

Hors ligne

#2 Le 21/08/2012, à 21:43

gagoune

Re : Erreur Yaboot 1st launch

Si tu le laisse booter tout seul, il vient pas directement sous Ubuntu non plus ?
Je te recommande de partitionner ton HDD à la main. Que tu utilise un LiveCD (desktop edition) ou une alternate edition. Tu pourras ainsi forcer l'installation d'une partition 'bootstrap' d' 1Mo en premier avant de mettre le reste de tes partitions nécessaires (racine, swap, voire home si tu le désires).
Si tu as déjà fais ça merci de nous indiquer les différentes étapes de ton installation en commençant par la version que tu as choisi !
Bon courage !


«Chaque manipulation réalisée à l'aide de lignes de commande est un bug qu'il faut corriger» M. Shuttleworth
iBook DV 466MHz (palourde) 320Mo/--Go : (démonté)
iMac (alu : été 2007) 2GHz 20" 4Go/250Go : Snow Leopard
EEE-PC 4G (701) 900MHz 1Go/4Go : Lubuntu 12.04

Hors ligne

#3 Le 23/08/2012, à 20:12

Domeee

Re : Erreur Yaboot 1st launch

¡ Hola Amigos !
j'ai rien compris à la doc ou yaboot c'est fait pour du multiboot ? Or, keyman n'a QUE Ubuntu sur sa machine. C'est pas de là que vient le pb ?
Domeee

Hors ligne

#4 Le 24/08/2012, à 09:24

gagoune

Re : Erreur Yaboot 1st launch

Salut !

Pour Domeee : tu poses une question ou tu affirmes ? Parce que c'est pas la même chose !

De mémoire, il a toujours fallu une partition bootstrap pour booter un PPC sous GNU/Linux et ce qu'il soit en single ou multi-boot. Comme GNU/Linux n'est pas invasif (contrairement à M$ Win) il garde 'par défaut' la possibilité de garder un autre OS que ta distribution préférée. Même pour PC, l'installation place systématiquement Grub ou Lilo ou autre boot-loader. Il se trouve que pour les PPC, il faut Yaboot.

Maintenant, il ne s'agit là que d'expérience personnelle et pas d'affirmation sur une base de connaissance théorique.

Au fait, pour keyman : jette un oeil ici ça pourrait t'aider !

A bientôt !

Dernière modification par gagoune (Le 24/08/2012, à 09:42)


«Chaque manipulation réalisée à l'aide de lignes de commande est un bug qu'il faut corriger» M. Shuttleworth
iBook DV 466MHz (palourde) 320Mo/--Go : (démonté)
iMac (alu : été 2007) 2GHz 20" 4Go/250Go : Snow Leopard
EEE-PC 4G (701) 900MHz 1Go/4Go : Lubuntu 12.04

Hors ligne

#5 Le 25/08/2012, à 19:10

Domeee

Re : Erreur Yaboot 1st launch

Bonjour à tout le monde !
@ Gagoune : ah ben non, c'est une question, vu mon niveau d'expertise, je ne vais pas affirmer quoi que ce soit ici !
Mais en plus de la page yaboot qui fait état de multiboot, j'avais vu une page pour installer uniquement Ubuntu sur un ppc et ça ne parlait pas de yaboot => d'où ma question…
Après, c'est peut-être simplement comme tu dis au début, un partitionnement manuel qui a mal tourné. Pour info, comme je ne fais jamais confiance aux routines auto, j'ai toujours partitionné manuellement avant d'installer des Linux, et mis à part qq ratés  avec Grub très bien solutionnés par l'outil «Boot repair», je n'ai jamais eu d'embrouilles d'installation.
YannUbuntu se le sent de nous faire un «Yaboot repair» aussi efficace que «Boot repair» ? smile
Domeee

Hors ligne

Haut de page ↑