Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 24/08/2012, à 14:54

brital

Problème d'affichage Flightgear 2.8.0

Bonjour,
Je viens d'installer flightgear 2.8.0, tout ce passe bien jusqu'au lancement. Quand j'arrive dans le cockpit mon affichage est bizarre et les textures ne s'affichent pas. J'ai parcouru la doc et le forum mais je n'ai pas trouvé la réponse à mon problème, à noter que je n'ai pas ce problème sur Win Xp.

D'où peut venir le problème?

flightgear

Paquets installés:
flightgear  2.8.0-1 getdeb1
fgfs-base  2.8.0-1 getdeb1
simgear-dev  2.8.0-1 getdeb1
simgear2.8.0  2.8.0-1 getdeb1

Ma config:
2x Celeron(R) Dual-Core CPU       T3100  @ 1.90GHz
2508MB (465MB used)
Ubuntu 12.04.1 LTS
1280x800 pixels
Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2

Hors ligne

#2 Le 25/08/2012, à 17:37

brital

Re : Problème d'affichage Flightgear 2.8.0

Un petit up

J'arrive toujours pas à faire tourné Flightgear sad

Hors ligne

#3 Le 25/08/2012, à 19:05

lann

Re : Problème d'affichage Flightgear 2.8.0

Peux-tu lancer flightgear dans un terminal :

fgfs

Et donner la sortie

En ligne

#4 Le 25/08/2012, à 20:23

brital

Re : Problème d'affichage Flightgear 2.8.0

Voilà la sortie de fgfs dans un terminal:

KI266 dme indicator #0 initialized
loading scenario 'nimitz_demo'
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib audio/pcm_bluetooth.c:1614:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1614:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1614:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1614:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
Initializing Nasal Electrical System
KAP140 power up

Hors ligne

#5 Le 25/08/2012, à 21:49

lann

Re : Problème d'affichage Flightgear 2.8.0

A ce que je vois, pas de problèmes graphiques. Il faudrait avoir un log plus précis :

fgfs --log-level=alert > fgfs_log 2>&1

ça va te mettre toutes les alertes dans le fichier fgfs_log

Ensuite tu ouvres le fichier fgfs_log (gedit n'a pas fonctionné. Je l'ai fait avec Writer)

Tu recherches si tu as des erreurs qui proviennent de ta carte graphique.

Sinon tu augmentes la verbosité du log (warn, info, debug puis bulk) en faisant par exemple

fgfs --log-level=warn > fgfs_log 2>&1

En ligne

#6 Le 28/08/2012, à 03:36

brital

Re : Problème d'affichage Flightgear 2.8.0

OK je vais tester.

Hors ligne

#7 Le 02/10/2012, à 01:23

Beta Pictoris

Re : Problème d'affichage Flightgear 2.8.0

brital, je ne sais pas si tu as réussi à corriger ton problème, mais flightgear nécessite une carte 3d assez performante.
Même sous WIndows XP, ça doit ramer un max.
Et sous Linux, les pilotes vidéos Intel ne sont pas très optimisés.

Hors ligne

#8 Le 17/12/2012, à 17:02

Luc07

Re : Problème d'affichage Flightgear 2.8.0

Bonjour,

Je suis sous Ubuntu 12.04 en 64 bits.
J'ai une carte graphique NVidia (NVIDIA Corporation GF108 [GeForce GT 540M]) avec Optimus
J'ai installé Flightgear et FGo via les dépôts Ubuntu et FG n'arrive pas à se lancer.

En lançant FG dans un terminal avec la commande "fgfs", j'ai le message suivant :
Processing command line arguments
Xlib:  extension "GLX" missing on display ":0.0".
Error: :0.0 has no GLX extension.
getDefaultWindow: failed to create GraphicsContext
Xlib:  extension "GLX" missing on display ":0.0".
Error: :0.0 has no GLX extension.
getDefaultWindow: failed to create GraphicsContext
Xlib:  extension "GLX" missing on display ":0.0".
Error: :0.0 has no GLX extension.
  GraphicsWindow has not been created successfully.
Viewer::realize() - failed to set up any windows

Où se situe le problème ?
Merci d'avance, cordialement,

Hors ligne

#9 Le 17/12/2012, à 19:46

lann

Re : Problème d'affichage Flightgear 2.8.0

Tu ne dois pas avoir l'accélération matérielle activée
Je pense que tu n'as pas installé les drivers propriétaires de ta carte graphique.

Lis bien toute cette documentation et ça devrait aller : http://doc.ubuntu-fr.org/nvidia

Dernière modification par lann (Le 17/12/2012, à 19:47)

En ligne

#10 Le 17/12/2012, à 21:32

Luc07

Re : Problème d'affichage Flightgear 2.8.0

Bonsoir,
Merci, effectivement j'ai installé bumblebee et tout fonctionne.

Cordialement,

Dernière modification par Vivance (Le 10/02/2013, à 22:23)

Hors ligne

Haut de page ↑