Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Réservez vos DVD et clé USB Ubuntu-fr (premières livraisons mi-mai)

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

M.A.J. en cours du forum possibilité de bug, nous faisons le maximum pour les résoudre au plus vite

#1 Le 12/08/2012, à 22:57

olitask

montage des disques dans /run/media/$USER/sdc/ et fstab

Bonjour

Je viens de me rendre compte que maintenant le montage des disques durs amovibles et autre se fait dans /run/media/"utilisateur"/"nom du dd".
Manifestement c'est pareil pour d'autres distributions.

J'avais l'habitude de monter au démarrage mon second disque dur de stockage grâce à fstab  ( comme indiqué dans la doc du site) . Malheureusement dans ce répertoire /run/media/ "utilisateur"/  le dossier crée destiné a être le point de montage  est effacé à chaque redémarrage et donc le montage ne se fait pas.

Comment y remédier ?

J'ai essayé de faire un montage automatique avec gigolo ( je suis sous  xubuntu) mais je n'y arrive pas. si vous avez une  solution ?

Olivier

Hors ligne

#2 Le 12/08/2012, à 23:10

compte supprimé

Re : montage des disques dans /run/media/$USER/sdc/ et fstab

Tu crées un répertoire où tu veux, et tu t'en sers comme point de montage dans fstab. Par exemple :

sudo mkdir /mnt/toto

Et dans fstab

UUID=uuid_de_la_partition  /mnt/toto  ntfs-3g  defaults  0  0    <-- si ce n'est pas du ntfs, mets le bon format

Et si tu veux le répertoire "Truc" de ta partition sur le Bureau, tu commences par créer un point de montage sur ton Bureau :

sudo mkdir ~/Bureau/Truc

Puis tu ajoutes à fstab :

/mnt/toto/Truc  /home/user/Bureau/Truc  none  bind

Dernière modification par faustus (Le 12/08/2012, à 23:10)

#3 Le 30/08/2012, à 11:20

legluondunet

Re : montage des disques dans /run/media/$USER/sdc/ et fstab

J'ai upgradé un poste de teste de 12.04 vers 12.10 il y a quelques jours, tout s'est bien passé. Par contre j'ai été assez surpris lorsque, ayant connecté une clé USB, j'ai eu un message d'erreur comme quoi il ne pouvait pas monter le périphérique...
En effet, lors d'une upgrade d'Ubuntu vers 12.10, le répertoire portant le nom de votre login n'est pas automatiquement créé dans le répertoire de montage des médias amovibles /media/, j'ai du le créer moi-même à la mano. Rien d'insurmontable mais pour un débutant qui met à jour Ubuntu, cela peut-être très ennuyeux. Quelqu'un sait si ce bug a déjà été déclaré sur Launchpad?

Hors ligne