Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 30/08/2012, à 21:18

tobiasBora

[Presentation] Installation à partir d'un live USB sur un système EFI

[Dernière mise à jour le 04/10/2012]

Bonjour !

Je viens d'entrer en possession de cet ordinateur : un Asus R500VD-SX258V 15.6"
http://www.fnac.com/Asus-R500VD-SX258V- … 209888/w-4
J'en suis réellement très content, les performances sont là, design très sympa, touché agréable, pavé numérique apprécié etc...

Cependant, il y a quelques technologies qui nécessitent quelques configurations particulières :
- La technologie Optimus : grâce au travail remarquable de ArchangeGabriel, qui aide ceux qui en on besoin sur ce post : http://forum.ubuntu-fr.org/viewtopic.php?id=565321, ainsi qu'au logiciel Blumblebee, l'installation se fait en 30 secondes. (Cette technologie permet d'avoir deux cartes graphiques : l'une (Intel) de faible puissance, et l'autre, une nVidia plus puissante. On peux ainsi switcher de l'une à l'autre suivant nos besoins)
- Le disque dur est configuré avec une système EFI et je n'arrivais pas à booter sur ma clé USB en mode EFI. (En effet, ayant installé ubuntu sur ma clé en utilisant multisystem (qui ne gère pas encore les systèmes EFI), je ne pouvais booter qu'en mode classique)

Voici un petit résumé de comment j'ai pu configurer un dual boot, avec un kubuntu parfaitement fonctionnel :
I. Sauvegarde du système :

La première chose à faire est de sauvegarder le système windows avec toutes les tables avec le logiciel libre clonezilla dans un disque dur externe (penser à créer un dossier à la racine avant) :
http://clonezilla.org/

II. Installation de Kubuntu :

EDIT : Une installation classique d'ubuntu peut fonctionner sans problème avec cette documentation (merci YannUbuntu) :

http://doc.ubuntu-fr.org/efi#installer_ … r_de_l_efi
La méthode que je présente y ressemble beaucoup, sauf qu'elle décrit un peu plus en détail diverse opérations (parfois inutiles), et qu'elle rajoute une "sécurité" devenue inutile avec ubuntu 12.04 64bits. Si vous voulez installez ubuntu, il y a fort à parier que la méthode présenté ci dessus soit la meilleur et la plus simple. La résolution des problèmes matériels (optimus, lecteur carte SD, wifi lent...) sont en revanche toujours d'actualité.

--------
La première chose à faire est d'essayer de voir si vous pouvez booter sur votre DVD/clé USB en mode EFI et si c'est la cas, il vous suffit de suivre ces quelques étapes (merci YannUbuntu) :

* gravez un CD ou un liveUSB K*X*L*Ubuntu12.04.1-64bit (pas une version précédente ni une version 32bit)
* réglez votre BIOS pour démarrer votre pc sur ce disque en mode UEFI, vous devriez voir cet écran (et pas celui-là), choisissez "Essayer Ubuntu"
* installez Ubuntu normalement (sans vous préoccuper de l'EFI), puis redémarrez le PC (sans le CD) en réglant le BIOS pour qu'il démarre sur le disque dur en mode UEFI. Vous devriez avoir accès à l'Ubuntu installé.
* lancer la réparation recommandée de Boot-Repair afin d'ajouter Windows UEFI au menu GRUB.

Si vous ne pouvez pas booter en mode EFI, comme moi (j'ai utilisé multisystem pour installer ubuntu sur ma clé, et ce très bon logiciel ne permet malheureusement pas encore le boot en EFI), voici ce que j'ai fait :

Lors de l'installation de Kubuntu je me suis aperçu que le système de partition était en mode EFI (tables de partition en mode gpt). Cela posait un problème pour le dual boot : la partition Linux n'était pas reconnue par le système au boot. J'ai donc commencé à suivre ce tuto prudent (appelé prudent car l'installation du système de boot n'écrira pas dans la partition EFI crée par Windows.
Tuto suivi au début :
http://forum.ubuntu-fr.org/viewtopic.php?id=757311

Pour résumer, voici ce que j'ai fait :
1. Pour être sur que le système est EFI (je m'en doutais car j'avais vu dans le système de partition Windows une partition EFI), on peut lancer :

$ sudo parted -l

qui affichera « Table de partitions : msdos » (=>non EFI) ou « Table de partitions : gpt » (c'est bien un système EFI).
On peux également lire sur Gparted (à condition de l'avoir activé dans Affichage) sur la gauche « gpt » :


Pour une troisième méthode voir la source :http://forum.ubuntu-fr.org/viewtopic.php?pid=7200351#p7200351

2. Depuis Windows, diminuer la taille de C :, et supprimer D : pour avoir un gros espace de libre : http://doc.ubuntu-fr.org/repartitionner … n_et_vista
3. Grâce à Gparted : http://gparted.sourceforge.net/ , (il parait que depuis ubuntu en live CD ça plante) créer :
Une partition de 20M → 200M en fat16 pour la partition EFI
Une partition en ext4 pour la racine du système
Une partition en ext pour /home
Une partition swap plus grande que la mémoire RAM
Décocher le flag « boot » de la partition sda1 (EFI de windows) et la cocher pour la nouvelle partition EFI.

4. On reboot ensuite sur Kubuntu 64bits 12.04 (version francophone) installé sur une clé USB via multisystem :http://liveusb.info/dotclear/
Lancer en mode live la commande :

$dmesg | grep EFI

Si elle renvoie de nombreuses libres avec EFI : mem0x d'écrit, cela veut dire que l'on a booté en mode EFI (je ne l'ai encore jamais eu depuis une clé USB), si on a « EFI Variables », on n'a pas booté en EFI, et on va voir comment l'installer dans ce cas là.
5. Installer Kubuntu de manière classique, en allant en mode avancé pour définir les partitions / et /home.
6. Une fois l'installation terminée, on a un problème : lors du reboot on ne peux booter que sur Windows (on ne peux pas choisir le système d'exploitation). Pour rétablir ceci, deux manières :
- il suffit de booter sur la clé multisystem et de lancer dans les utilitaires (installés par défaut) le menu grub2. Cette entrée va essayer de trouver tous les systèmes d'exploitation de l'ordinateur (dont Linux installé en mode BIOS). Une fois qu'il a fini de scanner le système, booter sur Kubuntu puis suivre le 7.
- ou sinon, plus simple (solution proposée par Samoth59, je ne l'ai pas testée) : faire le 7. depuis le liveUSB.
7. Pour passer kubuntu en mode EFI (source : http://doc.ubuntu-fr.org/efi#convertir_ … ation_efi), il suffit d'installer boot-repair via le ppa :
sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update; sudo apt-get install -y boot-repair && boot-repair
http://doc.ubuntu-fr.org/boot-repair

Suivre les instructions, et une fois boot repair d'ouvert, aller dans les paramètres avancés, onglet « Emplacement de Grub » et cocher « partition /boot/efi séparée » en mettant sdax (x étant la partition EFI crée).
Note : on peux également mettre sda1 (EFI de windows), mais je ne sais pas si ça fonctionne toujours, j'ai préféré faire cela.
8. Lorsque l'on reboot, on a un dual boot. ATTENTION, le windows utilisable est à la fin (et non pas dans les deux premières entrée) : bootx64.efi.bkp
9. Pour configurer l'affichage des OS dans le grub, vous pouvez modifier le fichier /etc/grub.d/40_custom en y mettant :

#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

menuentry "Windows, version a lancer (bootx64.efi.bkp)" {
search --fs-uuid --no-floppy --set=root CE56-5403
chainloader (${root})/EFI/Boot/bootx64.efi.bkp
}

(inspirez vous du contenu déjà écrit par boot repair).
Vous pouvez également désactiver les entrées windows non valables dans le fichier /etc/default/grub en rajoutant les lignes :

# Pour désactiver les entrées windows non valables :
GRUB_DISABLE_OS_PROBER=true

10. Finir avec un « sudo update-grub » pour mettre à jour le grub.
11. Rebooter pour tester
12. Vérifier avec la commande « dmesg | grep EFI » que le systeme est bien en mode EFI (EFI mem d'affiché sur de nombreuses lignes)

FIXME #TODO : trouver comment activer la partition windows recovery
Note : il semble y avoir des choses intéressantes avec rEFInd Boot Manager pour un grub plus jolie.



Installation de Bumblebee pour avoir Optimus
Blumblebee permet d'avoir le support d'optimus pour sur sa machine (on peut tester avec supertuxkart pour la différence).
Sources :
http://doc.ubuntu-fr.org/bumblebee
http://doc.ubuntu-fr.org/nvidia_optimus … existantes
http://forum.ubuntu-fr.org/viewtopic.php?id=565321

Vérifier qu'il est compatible avec optimus :

lspci -vnn | grep '\''[030[02]\]'

→ Si il y a deux résultats (intel et nVidia) on est concerné.

Installation :

Blumblebee :

sudo apt-add-repository ppa:bumblebee/stable

Drivers nVidia :

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

Puis :

sudo apt-get update
sudo apt-get install bumblebee

Ensuite, un reboot est nécessaire.

Lancer glxspheres pour tester avec la carte intel, puis optirun glxspheres pour lancer avec la carte nVidia.

J'ai le message d'erreur suivant :
[ERROR]Cannot access secondary GPU - error: [XORG] (EE) [drm] failed to open device
Essayez de modifier l'option "Driver" dans /etc/bumblebee/bumblebee.conf en remplaçant "Driver=" par "Driver=nvidia", redémarrer et vérifier si cela a résolu le problème. Si le problème persiste, changer en plus KernelDriver=nvidia-current par KernelDriver=nvidia.
Si non, d'autres possibilités sont présentées sur la page d'optimus ubuntu.

Problème de wifi très lente
Ma Wifi était malheureusement TRES lente (plusieurs minutes pour charger une page). J'ai donc suivi ce conseil: http://forum.ubuntu-fr.org/viewtopic.php?pid=10624251
Pour tester :

sudo rmmod iwlwifi
sudo modprobe iwlwifi 11n_disable=1

si le wifi fonctionne, pour que ce soit permanent :

gksudo gedit /etc/modprobe.d/iwlwifi.conf

une page blanche s'ouvre,ajouter ceçi

options iwlwifi 11n_disable=1

enregistrer et quitter

-------------
Pour modifier le bit rate de 24M à 54M (une progression de 20 % semble observée, mais ce n'est pas obligatoire de le faire, la connexion est déjà rapide sans) :
http://doc.ubuntu-fr.org/wifi#connexion … _configure
I. Vérifiez le Bit Rate de la carte :

iwconfig

Si vous voyez Bit Rate=1Mb/s alors tapez

sudo ifdown wlan0
sudo iwconfig wlan0 rate 54M
sudo ifup wlan0

(ou ra0 suivant le nom de votre interface)
Enfin, faites "iwconfig" pour vérifier qu'il vous met bien Bit Rate=54Mb/s pour que ca reste permanent : Ajoutez dans /etc/rc.local (avant la ligne exit 0)

 ifconfig wlan0 up
 iwconfig wlan0 rate 54M

on redémarre et le tour est joué!

Problème de carte SD
Je me suis aussi apperçu que le lecteur de carte SD ne fonctionnait pas :
Solution en installant un paquet ici :https://bugs.launchpad.net/ubuntu/+source/udisks/+bug/971876
(Merci à lylambda pour sa solution : http://forum.ubuntu-fr.org/viewtopic.php?pid=10433341)

Etat des lieux : mon boot info : http://paste.ubuntu.com/1183841/ (Note : les versions de bootrepair changent souvent en ce moment, il y a donc peux être certaines modifications que j'ai faites qui ne sont plus nécessaires)


Et voilà, vous avez une belle distribution linux ! En espérant que ça pourra éviter à certaines personnes de rester plusieurs heures dans la doc ^^

Tobias Bora

Dernière modification par tobiasBora (Le 11/11/2012, à 22:52)

Hors ligne

#2 Le 01/09/2012, à 11:34

malbo

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Pour rendre plus accessible ta présentation, j'ai créé une ligne pour le modèle R500VD de Asus dans la doc des portables : http://doc.ubuntu-fr.org/liste_portables_asus?&#r
dans la colonne "modèle", le lien de "R500VD" renvoie vers une page qui n'existe pas encore ; http://doc.ubuntu-fr.org/asus_r500vd. Si tu te sens le courage de créer cette page en utilisant les matériaux de ta présentation, tu peux la créer. L'avantage étant que d'autres utilisateurs suivants de ce même modèle ou d'une variante pourront ajouter leurs remarques dans cette future page de doc. Sinon, tu laisses tomber et ceux qui ont quelque chose à préciser posteront dans la présente discussion (c'est moins puissant mais à défaut de merle...).

Edit : on manque d'infos sur les gens qui font des install réussies (pour ceux qui font n'importe quoi, on commence à avoir des échantillons, merci). Pourrais-tu modifier ton post #1 pour ajouter à la fin un petit paragraphe "Etat des lieux après install " en y donnant le lien vers ton Boot-Info. Pour faire le Boot-Info, c'est là : http://doc.ubuntu-fr.org/tutoriel/boot-info ( à l'étape 1, au lieu d'utiliser un liveCD ou liveUSB, tu peux tout bonnement démarrer sur ton Ubuntu installé, c'est plus simple.

Dernière modification par malbo (Le 01/09/2012, à 11:40)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

En ligne

#3 Le 01/09/2012, à 18:53

Samoth59

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Merci pour ton message ! Ca fait plusieurs heures que j'ai justement le nez dans les docs pour m'en sortir, et comme j'ai également acheté le même pc que toi, c'est top :-)

Hors ligne

#4 Le 01/09/2012, à 20:13

Samoth59

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

6. Une fois l'installation terminée, on a un problème : lors du reboot on ne peux booter que sur Windows (on ne peux pas choisir le système d'exploitation). Pour rétablir ceci, il suffit de booter sur la clé multisystem et de lancer dans les utilitaires (installés par défaut) le menu grub2. Cette entrée va essayer de trouver tous les systèmes d'exploitation de l'ordinateur (dont Linux installé en mode BIOS). Une fois qu'il a fini de scanner le système, booter sur Kubuntu.

Comment faire sans la clé multisystem ? Je n'arrive pas à booter sur la distribution avec Super Grub Disk :-/

j'apporte ma propre solution :

J'ai tout simplement installé et lancé boot-repair depuis le liveUSB d'Ubuntu

Dernière modification par Samoth59 (Le 01/09/2012, à 20:47)

Hors ligne

#5 Le 03/09/2012, à 15:37

juliech

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Bonjour,
je n'ai pas GRUB2 sur mon liveCD comment puis-je faire
j'ai tenté d'installer en tapant la commande apt-get install grub-efi-amd64 , ce qui semble avoir fonctionné.
Mais comment le lancer ensuite?
Merci

Hors ligne

#6 Le 03/09/2012, à 18:25

tobiasBora

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

@malbo : je vais essayer de la faire, mais je ne sais pas si j'aurai le temps, j'entre en prépa demain. Un simple copié coller suffit où il y a une structure à respecter ?  -- Edit: j'ai trouvé l'armature à suivre-- Et c'est bon, j'ai rajouté mon boot info, je ne sais pas si un lien pastebin suffit (vont ils le supprimer plus tard ?), mais je ne vois pas comment éviter de faire un message énormes sinon. (on ne peux pas faire de "rideau" que l'on peux ouvrir ou fermer ?)

@Samoth59 : Merci pour ton astuce qui facilite bien la tache. Je l'ai rajoutée dans mon 1er post.

@juliech : Quel OS essayes tu d'installer ? Je ne vois pas pourquoi essayer d'installer grub2, la simple installation de boot repair (qui installe automatiquement les dépendances) devrait faire l'affaire non ? En plus ce logiciel te configure automatiquement les fichiers sur les bonnes partitions EFI (ce que je ne sais pas faire en console). Et pour configurer le grub en principe c'est config-grub, mais à ta place je n'utiliserai cette commande qu'après avoir déjà tout configuré via boot repair.

Sinon, j'ai édité mon tuto car je me suis aperçu d'importantes lenteurs de ma connexion wifi. Merci à chibbata pour sa solution !

Dernière modification par tobiasBora (Le 03/09/2012, à 18:29)

Hors ligne

#7 Le 03/09/2012, à 18:35

malbo

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

tobiasBora a écrit :

j'entre en prépa demain.

Laisse-tomber. Ce que tu as fait dans le post #1 suffit très largement au bonheur de la communauté à mon avis. Bon courage pour demain.
Et merci pour le Boot-Info "état des lieux"

Dernière modification par malbo (Le 03/09/2012, à 18:36)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

En ligne

#8 Le 03/09/2012, à 18:45

tobiasBora

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

J'ai commencé la page, mais je n'ai pas le temps de la finir pour le moment. Si il y en a qui veulent s'y mettre, c'est avec plaisir ! Et si vous voulez le résultat d'une ou deux commandes,n'hésitez pas !

Hors ligne

#9 Le 04/09/2012, à 01:19

Samoth59

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

tobiasBora a écrit :

- Le disque dur est configuré avec une système EFI et je n'arrivais pas à booter sur ma clé USB en mode EFI.

A ce propos, après avoir créé une clé usb bootable Ubuntu avec l'aide de Rufus et de l'iso d'Ubuntu, le choix m'a été proposé de booter en mode bios ou en mode EFI.

Dernière modification par Samoth59 (Le 04/09/2012, à 01:24)

Hors ligne

#10 Le 04/09/2012, à 09:27

YannUbuntu

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Samoth59 a écrit :

le choix m'a été proposé de booter en mode bios ou en mode EFI.

intéressant. Pouvez-vous redémarrer sur cette clé et nous montrer une photo de ce menu svp?
Et aussi nous montrer des photos de votre BIOS ? (notamment l'écran "boot order")

(vous pouvez uploader les photos sur http://pix.toile-libre.org )


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#11 Le 04/09/2012, à 21:04

tobiasBora

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Ah... Intéressant... Et avec d'autres systèmes d'installation sur clé, si tu peux essayer, ça te le fais aussi ?

Je pense aussi que c'est spécifique au Bios, après je ne sais pas du tout comment différencier les Bios qui le permettent et les autres... Tu as quoi comme ordi/bios ?

Hors ligne

#12 Le 04/09/2012, à 22:05

Samoth59

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Voilà ce que ça fait lorsque je crée une clé usb bootable à partir de l'iso d'ubuntu avec rufus :
1346788726-photo0329-1.png
1346788984-photo0331-1.png
1346788715-photo0330-1.png

J'ai essayé, toujours avec Rufus, de mettre l'iso de Windows 7 premium, je n'ai alors pas eu l'option UEFI.

J'ai le même ordi que toi tobiasBora, un Asus R500VD-SX258V wink

Hors ligne

#13 Le 04/09/2012, à 22:11

tobiasBora

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Ummm je vois... Maintenant que tu le dis moi aussi de temps en temps j'avais la possibilité de booter en EFI (du moins l'option apparaissait DE TEMPS EN TEMPS), mais il me semblait que ça ne fonctionnait pas... Lorsque tu es en live USB, cette commande te dis que tu es en EFI :

dmesg | grep 'EFI: mem' && echo "Démarrage EFI" || echo "Démarrage classique"

?

Tu as essayé de l'installer en mode EFI ? Ca à créé automatiquement les bons secteurs de boot ?

Et je voulais aussi te demander quel raccourcis clavier tu as utilisé pour afficher la première image ? Car la seule manière pour booter sur USB que j'avais trouvé était d'aller changer l'ordre du Bios...

Hors ligne

#14 Le 04/09/2012, à 22:32

Samoth59

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Lorsque je démarre le pc, pendant le démarrage (lorsque "ASUS" apparait), appuie sur "Echap", le menu s'ouvre alors.

Menu apparaissant lorsque je boot sur la clée en mode EFI :
1346790603-photo0332-1.png

Après avoir fait "try Ubuntu", lorsque je lance la commande que tu m'as donnée :
1346790584-photo0333-1.png

Menu qui apparait en mode classique :
1346790565-photo0334-2.png
A savoir que c'est la première fois que je vois ce menu, avant je voyais un menu sous forme de liste sur fond violet, avec toutes les options en double... (Peut-être à cause de unetbootin ?)

puis lorsque je fais la commande :
1346791131-photo0335-1.png

Et je n'ai pas encore essayé de l'installer en mode EFI

edit :

moi a écrit :

A savoir que c'est la première fois que je vois ce menu, avant je voyais un menu sous forme de liste sur fond violet, avec toutes les options en double... (Peut-être à cause de unetbootin ?)

J'ai essayé à nouveau de créer la clé avec unetbootin, finalement l'option de booter en EFI est aussi apparue. La seule différence que j'ai pu remarquer, est donc bien le menu de démarrage classique :
1346791904-photo0336-1.png

Celui du démarrage en mode EFI est exactement le même.


Sinon pour l'anecdote, tous les tests sont fait ici alors que le pc est avec sa configuration initiale (j'ai joué avec les partitions et j'ai tout cassé, j'ai déjà du restaurer hier ^^')

Dernière modification par Samoth59 (Le 04/09/2012, à 22:59)

Hors ligne

#15 Le 04/09/2012, à 22:58

tobiasBora

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Super ! C'est exactement de raccourcis que je cherchais merci beaucoup !

Alors tu as bien démarré en EFI, félicitation, le tuto prudent devrai donc te sufir ! Tiens nous au courant de ton installation !

Je pense que sur ma clé il n'y a pas de secteur de boot efi donc elle ne doit pas pouvoir booter en EFI (d'ou ma technique). MultiSystem permet de faire du multiboot très sympa, mais pour le moment le développeur n'a pas d'ordinateur EFI, il ne se soucie donc pas des systèmes EFI pour l'instant.

Et ton logiciel fonctionne aussi sous linux ? Permet il le multi boot ? Est-ce qu'il formate la clé ? Est ce que l'on peux encore utiliser sa clé de manière classique aprés l'avoir installé ?

Merci !

Hors ligne

#16 Le 04/09/2012, à 23:12

Samoth59

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Je n'ai pas trouvé de version pour linux sur le site de Rufus. Par contre, une simple recherche google permet de tomber sur un forum où qqn explique comment l'installer sur linux (je n'ai pas essayé perso). Par contre, comme je l'ai dit dans l'edition de mon message plus haut, unetbootin m'a finalement aussi proposé de booter en EFI.

Qu'entends-tu par "permettre le multi boot" ? Si c'est, comme multisystem, pouvoir mettre plusieurs iso sur une même clées, alors je ne pense pas non.

Il formate bien la clée à chaque fois.

Et selon le site, après le formattage, la clée redevient à nouveau utilisable pour stocker d'autres données :

Finally, please remember that once formatted, your drive is still usable as before to transfer data: it doesn't have to be dedicated for DOS or ISO installation only.

Dernière modification par Samoth59 (Le 04/09/2012, à 23:14)

Hors ligne

#17 Le 04/09/2012, à 23:15

tobiasBora

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Ok, merci !

Et tiens nous au courant pour ton install !

Hors ligne

#18 Le 05/09/2012, à 09:47

YannUbuntu

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

@tobiasBora: d'après le post#4, Samoth a déjà réussi à installer Ubuntu en mode EFI.

@Samoth: Maintenant, quand tu démarres ton PC, ça démarre directement sur le menu GRUB?
peux-tu booter sur Ubuntu, lancer Boot-Repair, cliquer sur le bouton "Créer un rapport BootInfo" et nous indiquer l'URL qui apparaitra stp?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#19 Le 05/09/2012, à 17:03

tobiasBora

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

YannUbuntu : En effet, mais ici (post #4) il semble avoir installé grub avec boot repair en live avec une installation non EFI (je me trompe) ? En effet, d'après ce que j'ai cru voir il semblerait possible d'avoir un grub d'installé dans EFI sans rien faire lors d'une installation en mode EFI. Et vu que Samoth semble avoir du réinstaller ubuntu pour cause de bouzillage des partition (c'est rigolo de jouer avec les partitions, mais elles sont malheureusement moins joueuses que nous ^^), je me suis dit que la deuxième installation (cette fois démarrée en mode EFI) lui a permis de ne pas avoir besoin d'utiliser boot repair pour l'installation du grub. (par contre affiche-t-'il windows ?)

Hors ligne

#20 Le 05/09/2012, à 17:34

YannUbuntu

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

ok, j'avais loupé le bouzillage de partitions en post#14 smile


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#21 Le 05/09/2012, à 18:21

Samoth59

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Si je comprends bien, en bootant en EFI, je n'ai pas besoin de créer la partition EFI en fat 16 ? (normalement, du moins)

Dernière modification par Samoth59 (Le 05/09/2012, à 18:21)

Hors ligne

#22 Le 05/09/2012, à 18:28

tobiasBora

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Dans la théorie je ne crois pas. Dans la pratique je pense que c'est une bonne idée de le faire… (lors de l'installation je pense que la partition Efi est déterminée via le flag boot).

A toi de voir ! (Au pire si tu veux faire notre testeur, vu que tu commences à gérer les restaurations, tu peux essayer ^^)

Hors ligne

#23 Le 05/09/2012, à 18:57

YannUbuntu

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Samoth59 a écrit :

Si je comprends bien, en bootant en EFI, je n'ai pas besoin de créer la partition EFI en fat 16 ? (normalement, du moins)

Je ne comprends pas la question. Que veux-tu faire? réinstaller Ubuntu? Peux-tu indiquer ton BootInfo avant tout ?
Ce qui est sûr, c'est que:
- si tu veux installer Ubuntu en mode EFI, la méthode est indiquée ici: http://doc.ubuntu-fr.org/efi#installer_ … r_de_l_efi
- tu as besoin de créer toi-même une partition EFI seulement :
   - s'il n'y en a pas déjà une sur ton disque, ET que
   - soit tu ne passes pas par l'installateur automatique d'Ubuntu, soit tu l'as utilisé en mode Legacy


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#24 Le 06/09/2012, à 01:21

Samoth59

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

Je viens de voir ton message YannUbuntu, et je n'ai pas fait de bootinfo avant de me lancer dans l'instal hmm

Sinon donc :
- j'ai booté sur ma clé en EFI
- avec GParted, créé 3 partitions selon le tuto du premier post (une partition "boot" EFI, une ext4 et une swap)
- lancé l'installation en désignant ma partition ext4 en root

J'ai préféré créer une nouvelle partition efi, pour une installation "prudente" selon le tuto du premier post wink

Au redémarrage, j'ai eu le menu Grub qui s'est affiché. Tout semblait d'être bien passé, sauf que le "Windows 7 (Loader)", plutot que de lancer Windows, m'affiche "invalide EFI file path"... Néanmoins, j'ai toujours la possibilité de lancer windows en passant par le Bios.

1346886978-photo0337-1.png
1346886964-photo0338-1.png

Et pour le bootinfo après l'install, boot-repair reste bloqué lors du scan de ma machine.

Je ne sais pas si une solution permanente existe, étant tombé sur une première que tu as proposé YannUbuntu mais qui serait anéantie à la prochaine mise à jour de Grub, et une seconde qui consistait simplement à se contenter de passer par le bios pour lancer windows. Enfin si vous avez une idée, je suis preneur smile

Dernière modification par Samoth59 (Le 06/09/2012, à 01:22)

Hors ligne

#25 Le 06/09/2012, à 09:21

YannUbuntu

Re : [Presentation] Installation à partir d'un live USB sur un système EFI

La "Réparation Recommandée" de Boot-Repair devrait ajouter des entrées Windows valides dans le menu GRUB.
(j'espère seulement que le blocage d'hier a disparu aujourd'hui...)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

Haut de page ↑