Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 03/09/2012, à 11:46

Elève linuxien

[Résolu] Openvpn - Incompréhension !

Bonjour,

J'ai mis en place openvpn (tun) sur mon serveur en suivant ce tuto là "doc openvpn Ubuntu-fr", voici le réseau :

<Serveur bureau 192.168.20.100 (vpn 10.8.0.1)>----------<routeur 192.168.20.1>--------<box>----------------(Internet)---------------<box>-------<client nomade Windows 7 - 192.168.1.10 (vpn 10.8.0.6)>
                                                                                                             |
                                                                                                             |
                                                                                  <clients bureau 192.168.20.2/15>


Là où ça va vous paraitre bizarre, c'est que openvpn est bien connecté roll ; J'ai bien mes deux écran vert sur le client,  lorsque je ping le serveur (10.8.0.1) depuis mon client ça marche.
J'ouvre mon navigateur internet, dans l'adresse je tape 10.8.0.1 => j'arrive sur mon site, ok.

Si je veux pinguer le client depuis le serveur (10.8.0.6).... rien ! 100% perdu ?? (j'ai bien vérifié que le client répondait au ping - pour info une applic Iphone gratuite existe et fonctionne très bien).

Mon problème, c'est que mon serveur est un serveur de fichiers et que je dois pourvoir accéder à ces derniers en me connectant en vpn. Mais lorsque je vais dans mon explorateur réseau depuis mon client vpn, je n'ai pas le réseau avec mon serveur...

Auriez vous une idée ou une piste ?

Merci d'avance.

Dernière modification par Elève linuxien (Le 30/11/2012, à 10:39)


"Les ordinateurs sont inutiles : ils ne donnent que les réponses."
Pablo Picasso

Hors ligne

#2 Le 03/09/2012, à 23:22

Elève linuxien

Re : [Résolu] Openvpn - Incompréhension !

Up svp.


"Les ordinateurs sont inutiles : ils ne donnent que les réponses."
Pablo Picasso

Hors ligne

#3 Le 04/09/2012, à 08:59

droopy191

Re : [Résolu] Openvpn - Incompréhension !

Salut,

Le client qui pose problème est un windows 7 ? Il me semble bien que par défaut il ne répond pas au ping. Vérifiez depuis le réseau local sans vpn.

Hors ligne

#4 Le 04/09/2012, à 09:49

Elève linuxien

Re : [Résolu] Openvpn - Incompréhension !

Bonjour Droopy191,

Oui, j'ai bien configuré le windows 7 pour qu'il réponde au ping, et j'ai testé en local depuis mon iphone sur l'adresse locale du W7 (ipconfig : ipv4 192.167.1.13). J'ai  100% de retour.

ça doit venir d’ailleurs.

Merci de ton aide.


"Les ordinateurs sont inutiles : ils ne donnent que les réponses."
Pablo Picasso

Hors ligne

#5 Le 04/09/2012, à 11:46

Elève linuxien

Re : [Résolu] Openvpn - Incompréhension !

Re-bonjour,

Voici ce que j'ai mis en place :

J'ai activé le support WINS dans Samba : la résolutions des noms ne se fera plus avec un message broadcast, mais en utilisant un système similaire à DNS (je crois, si quelqu'un de plus calé que moi pouvait confirmer).

Pour faire cela j'ai mis dans la configuration du serveur Samba (smbd.conf) :

wins support = yes
wins server = res1:adresse_IP_serveur (pour moi 192.168.20.100) res2:ip_serveur_vpn (pour moi 10.8.0.1)
restart nmbd

Pour compléter j'ai ajouté, pour les clients Windows, dans la configuration du serveur OpenVPN :

push "dhcp-option WINS addresse_IP_du_serveur_WINS (pour moi 192.168.20.100)"

Et depuis j'ai accès à mes dossiers partagés de mon serveur via vpn en tapant dans la barre d'adresse dossier windows :

\\10.8.0.1\mon_dossier_partagé

Cependant, je ne vois tjs pas mon réseau dans l'explorateur réseau windows ; par conséquent je n'ai pas accès à mes clients coté serveur et le ping depuis le seveur ne marche pas...

auriez vous une piste ?


"Les ordinateurs sont inutiles : ils ne donnent que les réponses."
Pablo Picasso

Hors ligne

#6 Le 04/09/2012, à 13:58

droopy191

Re : [Résolu] Openvpn - Incompréhension !

Il n'y a jamais de garantie avec le voisinage réseau windows wink.

Par contre , pour le paramètrage du serveur samba, je ferais comme suit

wins support = yes
# wins server = res1:adresse_IP_serveur  # c'est pour un client samba pas pour le serveur
  domain master = yes
   local master = yes
   os level = 66

Et pour que ca marche, il faut indiquer l'ip du serveur samba dans le vpn 10.8.0.1 pour le serveur wins ( sinon il faut router entre les 2 réseaux).

push "dhcp-option WINS 10.8.0.1"

Meme si je ne suis pas sur que l'option soit vraiment acceptée par le client windows.

Autre option, ce serait de faire un vpn bridgé. Cad que le client vpn aura une adresse ip dans le réseau local du serveur. Pas forcement adapté, si les clients mobiles bougent bcp ou si il y bcp de clients mobiles.

Hors ligne

#7 Le 04/09/2012, à 23:08

Elève linuxien

Re : [Résolu] Openvpn - Incompréhension !

Je confirme, aucune garantie avec le voisinage réseau windows...

concernant le mode tap ce n'est pas possible à cause des nomades qui bougent.

Concernant les clients coté serveur, je n'arrive pas à les atteindre. j'aimerais pouvoir me connecter surtout à un windows (192.168.20.13) qui à un dossier de synchronisation d'agenda partagé et pouvoir imprimer sur l'imprimante réseau qui est coté serveur (192.168.20.2).

Cependant je n'y arrive pas, auriez vous une piste ?


"Les ordinateurs sont inutiles : ils ne donnent que les réponses."
Pablo Picasso

Hors ligne

#8 Le 05/09/2012, à 09:06

droopy191

Re : [Résolu] Openvpn - Incompréhension !

Donc les clients du vpn ont besoin d'accéder à des machines du lan ?

Il faut activer le routage sur le serveur

#Modification permanente pour activer le routage
éditez /etc/sysctl.conf
#et decommentez
net.ipv4.ip_forward=1
#Puis activez par
 sysctl -p

Ensuite il faut indiquer les routes aux machines du lan et du vpn.
Pour les clients vpns, ajoutez dans le fichier de conf de openvpn
A adapter suivant votre réseau LAN

push "route 192.168.20.0 255.255.255.0"

Etant donné que les clients vpn ont désormais connaissance du lan, on peut essayer de revenir a un seul serveur wins ( sans garantie ).

push "dhcp-option WINS 192.168.20.100"

Et sur la passerelle du lan ( la machine que vous avez nommé routeur dans votre 1er message),  il faut indiquer une route vers 10.8.0.0 passant par le serveur 192.168.20.100

Dernière modification par droopy191 (Le 05/09/2012, à 09:07)

Hors ligne

#9 Le 06/09/2012, à 10:50

Elève linuxien

Re : [Résolu] Openvpn - Incompréhension !

ok, je vais tester ça ce soir.

Juste une précision.

Lorsque vous dite :
"il faut indiquer une route vers 10.8.0.0 passant par le serveur 192.168.20.100"
Sur la passerelle (mon routeur wink ) j'ai déjà précisé que tout ce qui arrive sur le port 1194 est envoyé au serveur 192.168.20.100 ; est ce une autre route à précisé ? (je pense que oui, mais je préfère être sur de comprendre)

ça serait du style :
dans ma passerelle (192.168.20.1)=> LAN > Paramètre de routage statique
Adresse du réseau  - Masque de sous-réseau - Passerelle   
        |                                        |                                 |
  10.8.0.0                      255.255.255.0           192.168.20.100


"Les ordinateurs sont inutiles : ils ne donnent que les réponses."
Pablo Picasso

Hors ligne

#10 Le 06/09/2012, à 11:03

droopy191

Re : [Résolu] Openvpn - Incompréhension !

Elève linuxien a écrit :

ok, je vais tester ça ce soir.
ça serait du style :
dans ma passerelle (192.168.20.1)=> LAN > Paramètre de routage statique
Adresse du réseau  - Masque de sous-réseau - Passerelle   
        |                                        |                                 |
  10.8.0.0                      255.255.255.0           192.168.20.100

C'est bien ca,  sans cette route statique, les machines du lan n'ont pas connaissance de la route pour contacter les clients vpns qui sont dans le réseau 10.8.0.0

Hors ligne

#11 Le 06/09/2012, à 11:12

Elève linuxien

Re : [Résolu] Openvpn - Incompréhension !

Ok ! Merci !!!

Je crois que je viens de comprendre pourquoi je galère depuis un certain temps... En effet je pensais que le fait de router "le serveur virtuel"  (Port Entrant- Type - Adresse IP privée - Port privé) suffisait...

Je vous tiens informé.


"Les ordinateurs sont inutiles : ils ne donnent que les réponses."
Pablo Picasso

Hors ligne

#12 Le 06/09/2012, à 11:42

droopy191

Re : [Résolu] Openvpn - Incompréhension !

Elève linuxien a écrit :

Ok ! Merci !!!

Je crois que je viens de comprendre pourquoi je galère depuis un certain temps... En effet je pensais que le fait de router "le serveur virtuel"  (Port Entrant- Type - Adresse IP privée - Port privé) suffisait...

Je vous tiens informé.

La redirection de port rend le serveur joignable depuis internet pour les clients. Une fois le vpn établi, c'est comme si le serveur avait 2 cartes réseaux, d'un coté le lan et de l'autre le réseau vpn. Par défaut les 2 réseaux ne savent pas se parler. Il faut que le serveur route entre les 2, et indiquer à chaque réseau comment contacter son voisin.

Hors ligne

#13 Le 30/11/2012, à 10:36

Elève linuxien

Re : [Résolu] Openvpn - Incompréhension !

Bonjour,

désolé de revenir si longtemps après votre dernier message, mais j'ai du gérer un problème d'injection de code sur mon site internet..!

Concernant la redirection vers les postes clients (coté serveur) j'ai abandonné... J'ai solutionner le problème en migrant les services qu'il y avait sur les clients en direction du serveur et en utilisant un cloud pour la partie agenda.

Cependant, les manipulation faite plus haut on fait que je réussissais à atteindre le serveur avec l'ip 192.168.20.100.

Merci encore pour votre aide Droopy191, je suis sincère !

Cdlt.


"Les ordinateurs sont inutiles : ils ne donnent que les réponses."
Pablo Picasso

Hors ligne

Haut de page ↑