Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 25/07/2007, à 18:43

dom le vrai

[Résolu] K3B ne voit pas l'encodeur mp3

Salux,

pour raison de baladeur mp3 non-compatible avec le ogg, j'ai besoin d'encoder mes fichiers audio en mp3. Or, les encodeurs listés par k3B (bien que très nombreux et parfois très exotiques) ne contiennent pas l'encodeur mp3 (Lame), qui est pourtant installé et fonctionne très bien, à la fois en stand-alone et avec d'autres front-ends, comme Kaffeine. Mais je préférerais utiliser K3B, étant donné qu'il est plus rapide que Kaffeine, et que Kaffeine ne fonctionne pas lorsque le disque audio contient aussi des données, comme ça arrive relativement souvent.

Donc, ma question: comment faire pour que K3B me liste l'encodeur mp3?

Merci d'avance

Dernière modification par dom le vrai (Le 26/07/2007, à 22:37)

Hors ligne

#2 Le 25/07/2007, à 18:53

xabilon

Re : [Résolu] K3B ne voit pas l'encodeur mp3

Salut

D'abord je te conseillerais plutôt SoundKonverter pour convertir tes fichiers audio.

Sinon, dans la configuration des modules externes de K3B, dans la section "Audio Encoder", il y a un module qui permet d'utiliser un programme externe pour encoder.
Il suffit de le configurer et d'y rajouter la ligne de commande adaptée à Lame.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 25/07/2007, à 19:17

camembert

Re : [Résolu] K3B ne voit pas l'encodeur mp3

dom le vrai a écrit :

Salux,

pour raison de baladeur mp3 non-compatible avec le ogg, j'ai besoin d'encoder mes fichiers audio en mp3. Or, les encodeurs listés par k3B (bien que très nombreux et parfois très exotiques) ne contiennent pas l'encodeur mp3 (Lame), qui est pourtant installé et fonctionne très bien, à la fois en stand-alone et avec d'autres front-ends, comme Kaffeine. Mais je préférerais utiliser K3B, étant donné qu'il est plus rapide que Kaffeine, et que Kaffeine ne fonctionne pas lorsque le disque audio contient aussi des données, comme ça arrive relativement souvent.

Donc, ma question: comment faire pour que K3B me liste l'encodeur mp3?

Merci d'avance

Toutes les réponses sur l'encodage de fichiers audios avec K3B sous Kubuntu Feisty sont sur le fil suivant --> http://forum.kubuntu-fr.org/viewtopic.php?id=121118
(et notamment les commandes à rentrer pour encoder en mp3).

Camembert

Hors ligne

#4 Le 25/07/2007, à 19:33

camembert

Re : [Résolu] K3B ne voit pas l'encodeur mp3

PS : je fais le résumé du fil, ça ira plus vite : Attention, ceci ne vaut que pour K3B sous Kubuntu Feisty;

- sous K3B : installer les paquets lame, sox, flac et libk3b2-mp3; ces paquets permettent d'avoir tous les formats d'encodage et de pouvoir graver les mp3;
ensuite, ouvrir K3B,  aller sur : Configuration --> Configurer K3B --> Modules Externes --> K3B External Audio Encoder --> cliquer sur Configurer en bas à droite et rajouter à la main (faire un copier copier de la commande) :
Nom : Mp3 (Lame)
Extension : mp3
Commande : lame -h --tt %t --ta %a --tl %m --ty %y --tc %c - %f
Commande alternative : lame -b 320  -h --tt %t --ta %a --tl %m --ty %y --tc %c - %f
Ces commandes indiquent à K3B comment convertir un fichier en mp3.

Voila K3B sous Kubuntu Feisty est totalement opérationnel. Il serait bon que dans les prochaines versions, ces options soient intégrées à K3B d'origine smile, ce qui évitera à l'utilisateur non averti d'avoir à taper ces commandes barbares lol.

- sous Konqueror : si on veut extraire un CD en mp3, l'insérer et taper dans la barre d'adresse de Konqueror audiocd:/
L'affichage donne plusieurs répertoires dont celui qui est en format mp3.

Camembert

Hors ligne

#5 Le 25/07/2007, à 20:44

mars

Re : [Résolu] K3B ne voit pas l'encodeur mp3

camembert a écrit :

ensuite, ouvrir K3B,  aller sur : Configuration --> Configurer K3B --> Modules Externes --> K3B External Audio Encoder --> cliquer sur Configurer en bas à droite et rajouter à la main (faire un copier copier de la commande) :
Nom : Mp3 (Lame)
Extension : mp3
Commande : lame -h --tt %t --ta %a --tl %m --ty %y --tc %c - %f
Commande alternative : lame -b 320  -h --tt %t --ta %a --tl %m --ty %y --tc %c - %f
Ces commandes indiquent à K3B comment convertir un fichier en mp3.

Euh ...........; normalement c'est inutile de faire ca.
si ce n'est pas le cas dites le moi je vérifierais.

Hors ligne

#6 Le 25/07/2007, à 23:39

camembert

Re : [Résolu] K3B ne voit pas l'encodeur mp3

Ben si mars, c'est un truc qu'on avait fait remarquer le 21 mai dernier avec Plastik Boy sur le fil suivant : http://forum.kubuntu-fr.org/viewtopic.php?id=121118 mais le propos de ce fil était plus général et pas réservé uniquement à l'encodage au format  mp3, d'où ma suggestion plus haut : "Il serait bon que dans les prochaines versions, ces options soient intégrées à K3B d'origine, ce qui évitera à l'utilisateur non averti d'avoir à taper ces commandes barbares." Cela dit, l'encodage en mp3 sur K3B n'a pas fait l'objet de beaucoup de post à propos de sa configuration dans K. Feisty smile

Camembert

Hors ligne

#7 Le 26/07/2007, à 19:27

dom le vrai

Re : [Résolu] K3B ne voit pas l'encodeur mp3

Merci, ça marche, sauf le numéro de piste qui n'est pas rempli dans les tags.

Ce serait peut-être une bonne idée d'ajouter ça dans le wiki, non?

EDIT: Pour avoir le numéro de piste inscrit dans les tags, il faut rajouter l'option "--tn %n" dans la commande.

Dernière modification par dom le vrai (Le 26/07/2007, à 19:33)

Hors ligne

#8 Le 26/07/2007, à 22:20

camembert

Re : [Résolu] K3B ne voit pas l'encodeur mp3

dom le vrai a écrit :

Merci, ça marche, sauf le numéro de piste qui n'est pas rempli dans les tags.

Ce serait peut-être une bonne idée d'ajouter ça dans le wiki, non?

EDIT: Pour avoir le numéro de piste inscrit dans les tags, il faut rajouter l'option "--tn %n" dans la commande.

Content que ça fonctionne chez toi dom le vrai smile
Tu peux mettre un petit "résolu" dans le titre du post maintenant (si tu es inscrit, cliquer sur modifier en bas à droite du post originel et modifier le titre smile).

Camembert

Hors ligne

#9 Le 30/06/2009, à 15:16

elchuro

Re : [Résolu] K3B ne voit pas l'encodeur mp3

camembert a écrit :

PS : je fais le résumé du fil, ça ira plus vite : Attention, ceci ne vaut que pour K3B sous Kubuntu Feisty;

- sous K3B : installer les paquets lame, sox, flac et libk3b2-mp3; ces paquets permettent d'avoir tous les formats d'encodage et de pouvoir graver les mp3;
ensuite, ouvrir K3B,  aller sur : Configuration --> Configurer K3B --> Modules Externes --> K3B External Audio Encoder --> cliquer sur Configurer en bas à droite et rajouter à la main (faire un copier copier de la commande) :
Nom : Mp3 (Lame)
Extension : mp3
Commande : lame -h --tt %t --ta %a --tl %m --ty %y --tc %c - %f
Commande alternative : lame -b 320  -h --tt %t --ta %a --tl %m --ty %y --tc %c - %f
Ces commandes indiquent à K3B comment convertir un fichier en mp3.

Voila K3B sous Kubuntu Feisty est totalement opérationnel. Il serait bon que dans les prochaines versions, ces options soient intégrées à K3B d'origine smile, ce qui évitera à l'utilisateur non averti d'avoir à taper ces commandes barbares lol.

- sous Konqueror : si on veut extraire un CD en mp3, l'insérer et taper dans la barre d'adresse de Konqueror audiocd:/
L'affichage donne plusieurs répertoires dont celui qui est en format mp3.

Camembert

Excusez moi comment rentre t-on la commande alternative ?

Haut de page ↑