Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 05/09/2012, à 17:42

Diahovez-Ivan

Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

salut,

Chercher votre driver propriétaire ATI Radeon HD,
http://support.amd.com/fr/gpudownload/Pages/index.aspx

Important supprimer " compiz " avant toute installation.
Par synaptic completement.
ou,

& sudo apt-get remove compiz
& sudo apt-get remove compiz-core
& sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases linux-headers-generic xserver-xorg-core libgcc1 mesa-utils
& sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* 
& wget http://www2.ati.com/drivers/linux/amd-driver-installer-12-4-x86.x86_64.run
& chmod +x amd-driver-installer-12-4-x86.x86_64.run
& sudo  ./amd-driver-installer-12-4-x86.x86_64.run
& sudo aticonfig --initial
& sudo  reboot

ou

# reboot

Tester sa carte graphique.

& lspci -nn | grep VGA

Pour supprimer le driver ATI Radeon HD,

& cd /usr/share/ati/
& sudo ./amd-uninstall.sh

Dernière modification par Diahovez-Ivan (Le 25/09/2012, à 09:05)


Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#2 Le 05/09/2012, à 18:20

HP

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

Et on y gagne quoi ?

Hors ligne

#3 Le 06/09/2012, à 08:17

ZZ11

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

bjr
Voilà pour la première commande

fred@fred:~$ $ sudo apt-cache search -n fglrx
$ : commande introuvable
fred@fred:~$  sudo apt-cache search -n fglrx
[sudo] password for fred: 
fglrx - Pilote vidéo pour les accélérateurs graphiques AMD
fglrx-amdcccle - Centre de Contrôle Catalyst pour les accélérateurs graphiques AMD
fglrx-amdcccle-updates - Centre de Contrôle Catalyst pour les accélérateurs graphiques AMD
fglrx-dev - Pilote vidéo pour les accélérateurs graphiques AMD (fichiers de développement)
fglrx-updates - Pilote vidéo pour les accélérateurs graphiques AMD
fglrx-updates-dev - Pilote vidéo pour les accélérateurs graphiques AMD (fichiers de développement)
fred@fred:~$ 

??

Fred


OS: Xubuntu Voyager 12.04 LTS  64 bits + Windows XP familial  en dualboot
ACER aspire X1430  AMD E-450 APU with Radeon(tm) HD 6320 Graphics

Hors ligne

#4 Le 06/09/2012, à 11:46

Diahovez-Ivan

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

*

& sudo apt-cache search fglrx
raspouille@Ivan:~$ sudo apt-cache search fglrx
[sudo] password for raspouille: 
jockey-common - user interface and desktop integration for driver management
jockey-gtk - GNOME user interface and desktop integration for driver management
jockey-kde - KDE user interface and desktop integration for driver management
xserver-xorg-video-radeon - Serveur X de X.Org -- pilote d'affichage AMD/ATI Radeon
xvba-va-driver - XvBA-based backend for VA API (AMD fglrx implementation)
fglrx - Pilote vidéo pour les accélérateurs graphiques AMD
fglrx-amdcccle - Centre de Contrôle Catalyst pour les accélérateurs graphiques AMD
fglrx-amdcccle-updates - Centre de Contrôle Catalyst pour les accélérateurs graphiques AMD
fglrx-dev - Pilote vidéo pour les accélérateurs graphiques AMD (fichiers de développement)
fglrx-updates - Pilote vidéo pour les accélérateurs graphiques AMD
fglrx-updates-dev - Pilote vidéo pour les accélérateurs graphiques AMD (fichiers de développement)

Dernière modification par Diahovez-Ivan (Le 06/09/2012, à 11:48)


Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#5 Le 06/09/2012, à 11:55

obibann

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

Bonjour,

Qu'apporte cette version par rapport à celle disponible dans les dépôts ?

Merci


Ubuntu 14.04 / Ubuntu 12.04
Avec Windows, on fait ce qu'on peut... Avec Linux, on fait ce qu'on veut !! :p

Hors ligne

#6 Le 06/09/2012, à 15:31

salif130n=

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

bonjour  , je suis nouveau  sur linux  et il faut que j’installe se driver .......


vous pouvez me donner  un peu plus de détails svp

Dernière modification par salif130n= (Le 06/09/2012, à 15:41)

Hors ligne

#7 Le 06/09/2012, à 15:40

salif130n=

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

mon ordi  est très récent  et bug asser souvent  sur ubuntu        c'est un Toshiba  http://www.toshibadirect.com/td/b2c/pde … 2000035577
et pour comprendre mon probleme  http://forum.ubuntu-fr.org/viewtopic.php?id=1028621


donc j'ai lancer la commande de  Diahovez  et sa donne  :

salif130@salif130-Satellite-L840D:~$ & sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* 
bash: Erreur de syntaxe près du symbole inattendu « & »
salif130@salif130-Satellite-L840D:~$ & wget [url]http://www2.ati.com/drivers/linux/amd-driver-installer-12-3-x86.x86_64.run[/url]
bash: Erreur de syntaxe près du symbole inattendu « & »
salif130@salif130-Satellite-L840D:~$ & chmod +x amd-driver-installer-12-3-x86.x86_64.run
bash: Erreur de syntaxe près du symbole inattendu « & »
salif130@salif130-Satellite-L840D:~$ & ./amd-driver-installer-12-3-x86.x86_64.run
bash: Erreur de syntaxe près du symbole inattendu « & »
salif130@salif130-Satellite-L840D:~$ & sudo aticonfig –initial -f

Hors ligne

#8 Le 06/09/2012, à 17:33

obibann

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

@salif130n= : tu as copié les "&"... neutral

Sinon, je n'ai toujours pas compris le but de ce post ? Qu'apporte ce driver par rapport à celui installé via le gestionnaire des pilotes proprio ?

Merci


Ubuntu 14.04 / Ubuntu 12.04
Avec Windows, on fait ce qu'on peut... Avec Linux, on fait ce qu'on veut !! :p

Hors ligne

#9 Le 06/09/2012, à 19:23

Diahovez-Ivan

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

Salut,
J'ai un processeur Intel i7 et une puce graphique intégré ATI Radeon HD 6400m qui est pris en compte par les nouveaux OS GNU/Linux,donc 2D au boot.
A savoir que les sources des drivers ATI Radéon sont fermées,Nvidia non !
Le gestionnaire des pilotes propriétaire Ubuntu me fait une segmentation.
Donc on peut contourné l'activation de la 2D,a voir ...
Se matin,j'ai cassé Ubuntu en faisant un test et verrouillé et donc rattrapé ...

A+


Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#10 Le 06/09/2012, à 19:56

Diahovez-Ivan

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

@salif130n=:

&=c"est du bash dans un terminal (non root ) pas de sudo.
#=c"est du bash dans un terminal  (root ) pas de sudo.


Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#11 Le 06/09/2012, à 21:01

salif130n=

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

euh ........    mad    tu pourrais m'envoyer toute la commande        s'il te plait     j'y connais pas grand chose moi  .... big_smile

Dernière modification par salif130n= (Le 06/09/2012, à 21:02)

Hors ligne

#12 Le 07/09/2012, à 05:46

Gemnoc

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

Diahovez-Ivan a écrit :

A savoir que les sources des drivers ATI Radéon sont fermées,Nvidia non !

Hein ? Non.

Les sources des pilotes ATI Catalyst/fglrx et Nvidia proprio (nvidia-current) sont toutes les deux fermées. Les sources sont ouvertes pour les pilotes nouveau (nvidia), radeon (ATI) et Intel.


Pensez à consulter la documentation ! :-)

Hors ligne

#13 Le 07/09/2012, à 07:38

ljere

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

il n'y a aucun interet de passer en 12.3 alors que la 12.8 est deja sorti à la limite pour des problemes de compatibilité on peut prendre la 12.6 procedure qui est donné dans l'un des sujet épinglé ou dans la doc sinon voici la procédure pour mettre la 12.8:
on va commencer  par installer tous ce qui est utile pour compiler dependance etc...

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases linux-headers-generic xserver-xorg-core libgcc1 mesa-utils

si tu es sur 64 bit il te faut installer ça aussi

sudo apt-get install ia32-libs lib32gcc1 libc6-i386
cd /usr ; sudo ln -svT lib /usr/lib64

on peut maintenant télécharger le pilote AMD catalyst 12.8

cd ~/; mkdir catalyst12.8; cd catalyst12.8/
wget http://www2.ati.com/drivers/linux/amd-driver-installer-12-8-x86.x86_64.zip
unzip amd-driver-installer-12-8-x86.x86_64.zip
chmod +x amd-driver-installer-8.982-x86.x86_64.run

et créer des paquets Ubuntu à partir de celui-ci

sudo sh ./amd-driver-installer-8.982-x86.x86_64.run --buildpkg Ubuntu/precise

on installe le paquet

sudo dpkg -i fglrx*.deb

et on configure Xserver

sudo aticonfig --initial -f

on controle si tout est ok

fglrxinfo
glxinfo | egrep render
glxgears

si quelque chose ne fonctionne pas et que ton ordinateur ne démarre plus, appuyes sur CTRL+ALT+F1, entres ton pseudo et ton mot de passe

sudo rm /etc/X11/xorg.conf
startx

athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openboxubuntu 14.10 64 bit
Mon Blog et Une découverte

Hors ligne

#14 Le 07/09/2012, à 08:48

Diahovez-Ivan

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

Sauf quelle plante ...
Je vais encore la tester avec votre tuto @ljere ...
Sous VMware.

Dernière modification par Diahovez-Ivan (Le 07/09/2012, à 09:16)


Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#15 Le 07/09/2012, à 14:46

obibann

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

Gemnoc a écrit :
Diahovez-Ivan a écrit :

A savoir que les sources des drivers ATI Radéon sont fermées,Nvidia non !

Hein ? Non.

Les sources des pilotes ATI Catalyst/fglrx et Nvidia proprio (nvidia-current) sont toutes les deux fermées. Les sources sont ouvertes pour les pilotes nouveau (nvidia), radeon (ATI) et Intel.

+1

@Diahovez-Ivan : "Sous VMware." hmm
Tu ne risques pas de faire fonctionner le driver depuis une VMware. VMWare utilise une carte graphique virtuelle et ne communique pas directement avec ta carte graphique physique.
Cependant, tu peux tester depuis un Ubuntu live USB : à la création de celui-ci, tu peux cocher "conserver les données", ainsi tu peux rebooter dessus en conservant tes modifs, pratique pour effectuer des tests sans toucher à ton vrai système.
Et puis si tu casses tout où que tu veux revenir sur une base saine, tu formates ton disque USB et tu recommences smile

A+


Ubuntu 14.04 / Ubuntu 12.04
Avec Windows, on fait ce qu'on peut... Avec Linux, on fait ce qu'on veut !! :p

Hors ligne

#16 Le 07/09/2012, à 17:49

salif130n=

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

bonjour ,

alors pour la commande de  ljere   je sais pas si je l'ai bien fait .... mad mais quand je lance ta première commande sa donne   sa :

 salif130@salif130-Satellite-L840D:~$ sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases linux-headers-generic xserver-xorg-core libgcc1 mesa-utils
[sudo] password for salif130: 
Sorry, try again.
[sudo] password for salif130: 

Dernière modification par salif130n= (Le 07/09/2012, à 17:51)

Hors ligne

#17 Le 07/09/2012, à 18:13

Diahovez-Ivan

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

@ ljere n'a pas de CG:ATI Radéon HD,donc cette personne n'a pu tester le tuto.
Surtout,il y a beaucoup d"erreurs ...


Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#18 Le 07/09/2012, à 18:49

salif130n=

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

euh cool alors je fais quoi ?

Dernière modification par salif130n= (Le 07/09/2012, à 18:49)

Hors ligne

#19 Le 07/09/2012, à 18:55

Diahovez-Ivan

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

Installer la 3D sur mon premier tuto #1.


Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#20 Le 07/09/2012, à 19:15

salif130n=

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

d'accord ,       est ce que je dois  etre en mode route  pour le faire et    tu peut m'expliquer   sa :                                                                              &=c"est du bash dans un terminal (non root ) pas de sudo.
#=c"est du bash dans un terminal  (root ) pas de sudo.
 

je suis linuxien  il y a a peine deux semaine ..... big_smile

Hors ligne

#21 Le 07/09/2012, à 19:38

Diahovez-Ivan

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

Non,mon tuto est installé sur un de mes de HD,il suffit de faire un copier,coller dans un terminal ...
Bon,il est vrai qu'il n'est pas commenté,je vais le faire et aute  ...
... smile


Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#22 Le 07/09/2012, à 20:16

salif130n=

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

donc j'ai les commande de ton  premier tuto  sa donne sa :

salif130@salif130-Satellite-L840D:~$ sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* 
[sudo] password for salif130: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note : sélection de xorg-driver-fglrx pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-kernel-source pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-amdcccle-updates pour l'expression rationnelle « fglrx_* »
Note : sélection de xorg-driver-fglrx-dev pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-driver-dev pour l'expression rationnelle « fglrx_* »
Note : sélection de xfree86-driver-fglrx pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-updates pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-control-qt2 pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-updates-dev pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-dev pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-glx pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-modaliases pour l'expression rationnelle « fglrx_* »
Note : sélection de xfree86-driver-fglrx-dev pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-amdcccle pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-driver pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-control pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-amdcccle-updates pour l'expression rationnelle « fglrx-amdcccle* »
Note : sélection de fglrx-amdcccle pour l'expression rationnelle « fglrx-amdcccle* »
Note : sélection de xorg-driver-fglrx-dev pour l'expression rationnelle « fglrx-dev* »
Note : sélection de fglrx-dev pour l'expression rationnelle « fglrx-dev* »
Note : sélection de xfree86-driver-fglrx-dev pour l'expression rationnelle « fglrx-dev* »
Le paquet fglrx n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-amdcccle n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-amdcccle-updates n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-dev n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-updates n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-updates-dev n'est pas installé, et ne peut donc être supprimé
0 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.
salif130@salif130-Satellite-L840D:~$ wget [url]http://www2.ati.com/drivers/linux/amd-driver-installer-12-3-x86.x86_64.run[/url]
[url]http://www2.ati.com/drivers/linux/amd-driver-installer-12-3-x86.x86_64.run[/url]: Schéma manquant.
salif130@salif130-Satellite-L840D:~$  chmod +x amd-driver-installer-12-3-x86.x86_64.run
chmod: impossible d'accéder à «amd-driver-installer-12-3-x86.x86_64.run»: Aucun fichier ou dossier de ce type
salif130@salif130-Satellite-L840D:~$ ./amd-driver-installer-12-3-x86.x86_64.run
bash: ./amd-driver-installer-12-3-x86.x86_64.run: Aucun fichier ou dossier de ce type
salif130@salif130-Satellite-L840D:~$ sudo aticonfig –initial -f
sudo: aticonfig: command not found
salif130@salif130-Satellite-L840D:~$ 

Dernière modification par salif130n= (Le 09/09/2012, à 04:08)

Hors ligne

#23 Le 10/09/2012, à 17:59

Diahovez-Ivan

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

Salut,
Il faut mettre votre dans votre driver (amd-driver-installer-12-3-x86.x86_64.run)  dans votre HOME ...

Dernière modification par Diahovez-Ivan (Le 10/09/2012, à 18:02)


Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#24 Le 10/09/2012, à 18:04

Diahovez-Ivan

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

 sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* 

Pas important.


Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#25 Le 10/09/2012, à 20:47

ljere

Re : Pour Driver Propriétaire Ati Radeon HD 6xxxm ou plus.

@Diahovez-Ivan j'ai bien une carte ati sur mon portable et mon tuto a déjà servi pour dépanner d'autre membre donc si tu vois une erreur merci de me le signaler

@salif130n=

[sudo] password for salif130: 

signifie que tu dois mettre ton mot de passe il ne s'affiche pas c'est normal


athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openboxubuntu 14.10 64 bit
Mon Blog et Une découverte

Hors ligne

Haut de page ↑