Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 20/10/2005, à 10:35

Umaro

Jools, problèmes de dépendancecs

Bonjour!

Voilà mon problème du jour (a problem a day sends windows away...:rolleyes:)

J'essaye d'installer Jools, mais celui-ci dépend de pygame...

umaro@ubuntu:~$ sudo dpkg -i /home/umaro/Desktop/jools_0.20-1_all.deb Sélection du paquet jools précédemment désélectionné.
(Lecture de la base de données... 90311 fichiers et répertoires déjà installés.)Dépaquetage de jools (à partir de .../Desktop/jools_0.20-1_all.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de jools :
 jools dépend de pygame (>= 1.4) ; cependant :
  Paquet pygame n'est pas encore configuré.
dpkg : erreur de traitement de jools (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 jools

Et c'est là que mon enfer commence. J'ai fait le tour de synaptic, je suis passé par packages.ubuntu.com pour avoir la conscience tranquille, mais non. Tous les paquets ubuntiens de pygame sont installés: python-pygame, python2.3-pygame et python2.4-pygame,

Quitte à inspecter la chose, j'ai donc été visiter les dépôts Debian "pur"... Où j'ai effectivement trouvé, ô joie! un pygame tout court...

Que j'ai donc - après tout ça ne mange pas de pain - essayé d'installer.

Horreur...

umaro@ubuntu:~$ sudo dpkg -i /home/umaro/Desktop/pygame_1.4-1_i386.deb
Sélection du paquet pygame précédemment désélectionné.
(Lecture de la base de données... 90205 fichiers et répertoires déjà installés.)Dépaquetage de pygame (à partir de .../Desktop/pygame_1.4-1_i386.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de pygame :
 pygame dépend de python (<< 2.2) ; cependant :
  La version de python sur le système est 2.4.2-0ubuntu2.
 pygame dépend de libsmpeg0 (>= 0.4.4-7) ; cependant :
  Paquet libsmpeg0 n'est pas installé.
dpkg : erreur de traitement de pygame (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 pygame

(note: est-il besoin de préciser que j'ai iinstallé Python 2.1 AVANT d'avoir cette commande? lol)

SOIT! Je m'en vais télécharger un package libsmpeg0... roll

C'était compter sans Murphy... Ma facee beurrée est encore tombée à terre.:lol:

umaro@ubuntu:~$ sudo dpkg -i /home/umaro/Desktop/libsmpeg0_0.4.4-8_i386.deb
dpkg : concernant .../libsmpeg0_0.4.4-8_i386.deb contenant libsmpeg0 :
 libsmpeg0c2 entre en conflit avec libsmpeg0
  libsmpeg0 (version 0.4.4-8) doit être installé.
dpkg : erreur de traitement de /home/umaro/Desktop/libsmpeg0_0.4.4-8_i386.deb (--install) :
 paquets en conflit - libsmpeg0 non installé
Des erreurs ont été rencontrées pendant l'exécution :
 /home/umaro/Desktop/libsmpeg0_0.4.4-8_i386.deb

Et là je me dis que je viens d'entrer dans la quatrième dimension! Pour installer libsmpeg0_4.4-8, il faut que j'installe libsmpeg0.4.4-8 ? lol

J'ai bien peur de ne pas tout comprendre...


En un mot: euh... help? lol

Umaro qui s'éclate sous Ubuntu (et les neurones en même temps)


- Microsoft is not the the answer; Microsoft is the question. NO! is the answer.

Hors ligne

#2 Le 20/10/2005, à 10:53

sbrunner

Re : Jools, problèmes de dépendancecs

L'instalation d'un paquet debian est une mauvaise idée sad il vat mieux le recompiler cool

CU
Stéph

Hors ligne

Haut de page ↑