Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 05/10/2012, à 21:25

hlou

[Résolu]Je ne sais pas installer une ancienne version de flash

Ayant des soucis avec flash, j'ai cherché sur le forum et il semblerait que la solution pourrait être d'installer une version antérieure.

J'ai suivi les diverses manips proposées, mais ça ne marche pas, une fois on me dit que mon dossier crée n'est pas le bon, une autre que je n'ai pas l'autorisation , essayé de l'ouvrir avec synaptic....
Je n'en peux plus, ça fait plusieurs heures que j'y suis et je ne vois pas quoi faire!!!!
Concrètement là, j'ai téléchargé une ancienne version  que j'ai décompressé dans le dossier téléchargement puisque je ne peux pas le mettre créer de dossier dans le dossier usr/lib pour l'y mettre malgré que je sois en root.

Je ne sais pas quoi faire de tout ça . Il y a un dossier usr et un fichier so.

Pouvez vous m'aider? Il y a sans doute une manip très simple, mais je ne la trouve pas?!!

Dernière modification par hlou (Le 06/10/2012, à 20:27)

Hors ligne

#2 Le 05/10/2012, à 22:43

bishop

Re : [Résolu]Je ne sais pas installer une ancienne version de flash


Mon blog L'effet Papy Ion - | - Éditeur BBCode - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Precise 12.04

Hors ligne

#3 Le 05/10/2012, à 23:02

hlou

Re : [Résolu]Je ne sais pas installer une ancienne version de flash

herve@herve-Aspire-7730G:~/Flash$ 

Voila ce que ça me met, j'avais déjà essayé cette manip! Je ne sais pas quoi faire après

Hors ligne

#4 Le 06/10/2012, à 00:46

bishop

Re : [Résolu]Je ne sais pas installer une ancienne version de flash

hlou !
Supprime le dossier Flash qui se trouve dans  ton répertoire personnel.
Désinstalle la ou les différentes versions de Flash installées sur ta machine.

Quand c'est fait tu copies un des lignes du poste http://forum.ubuntu-fr.org/viewtopic.ph … 1#p8958351 qui correspond à ton architecture et au navigateur que tu utilises et tu la colles dans un Terminal.

Par exemple :
Pour Firefox sur une architecture 32 bits.

cd && mkdir Flash && cd Flash && wget -q http://fpdownload.macromedia.com/get/flashplayer/pdc/11.1.102.63/install_flash_player_11_linux.i386.tar.gz && tar xvfz install_flash_player_11_linux.i386.tar.gz && sudo cp libflashplayer.so /usr/lib/firefox/plugins

Tu copies/colles l'intégralité de cette ligne dans un Terminal, tu appuies sur Entrée et tu entres ton mot de passe quand il est requis.

Dernière modification par bishop (Le 06/10/2012, à 00:47)


Mon blog L'effet Papy Ion - | - Éditeur BBCode - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Precise 12.04

Hors ligne

#5 Le 06/10/2012, à 07:50

hlou

Re : [Résolu]Je ne sais pas installer une ancienne version de flash

Mais c'est exactement ce que j'ai fais et refait, mais ça ne marche pas et ça me donne cette réponse.
Ca fait plusieurs heures que j'y suis, j'ai lu différents posts et ça fait toujours pareil!

Hors ligne

#6 Le 06/10/2012, à 09:49

hlou

Re : [Résolu]Je ne sais pas installer une ancienne version de flash

Encore une fois, je viens de réessayer, en supprimant en plus tous les plugins de firefox, et voila ce que ça me donne!
Toujours pareil, je n'en peux plus.

herve@herve-Aspire-7730G:~$ cd && mkdir Flash && cd Flash && wget -q http://fpdownload.macromedia.com/get/flashplayer/pdc/11.1.102.63/install_flash_player_11_linux.i386.tar.gz && tar xvfz install_flash_player_11_linux.i386.tar.gz && sudo cp libflashplayer.so /usr/lib/firefox/plugins
herve@herve-Aspire-7730G:~/Flash$ 

Et au passage, il m'a recrée un dossier Flash, qui est vide dans mon dossier personnel!

Hors ligne

#7 Le 06/10/2012, à 10:31

michel_04

Re : [Résolu]Je ne sais pas installer une ancienne version de flash

Bonjour,

Si tu veux essayer : http://forum.ubuntu-fr.org/viewtopic.ph … #p10940481

M6Replay, WPReplay, Youtube, DailyMotion, etc..., ça fonctionne.

A+

Dernière modification par michel_04 (Le 06/10/2012, à 10:33)

En ligne

#8 Le 06/10/2012, à 10:43

hlou

Re : [Résolu]Je ne sais pas installer une ancienne version de flash

Dans le terminal  (une ligne après l'autre) :

sudo killall -9 firefox
sudo apt-get remove -y --purge adobe-flashplugin browser-plugin-gnash flashplugin-installer flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper  
sudo rm -f /usr/lib/mozilla/plugins/*flash*  
sudo rm -f ~/.mozilla/plugins/*flash*  
sudo rm -f /usr/lib/firefox/plugins/*flash*  
sudo rm -f /usr/lib/firefox-addons/plugins/*flash*  
sudo rm -f /usr/lib/nspluginwrapper 

C'est ça que tu me proposes de faire, si je comprends bien pour etre certain qu'il n'y ait plus de traces de flash sur mon système?
Si j'ai bien compris, peux tu me dire si ça ne risque pas de me créer des bugs ailleurs?

Hors ligne

#9 Le 06/10/2012, à 10:47

michel_04

Re : [Résolu]Je ne sais pas installer une ancienne version de flash

Re,

hlou a écrit :

C'est ça que tu me proposes de faire, si je comprends bien pour etre certain qu'il n'y ait plus de traces de flash sur mon système?
Si j'ai bien compris, peux tu me dire si ça ne risque pas de me créer des bugs ailleurs?

Si tu suis bien tout ce qui est indiqué dans mon message, du début à la fin, aucun souci.


A+

En ligne

#10 Le 06/10/2012, à 11:03

compte supprimé

Re : [Résolu]Je ne sais pas installer une ancienne version de flash

Le plus simple, c'est effectivement de désinstaller flashplayer, gnash etc.
Pour être sûr, tu ouvres nautilus (ton gestionnaire de fichier) en root :

gksudo nautilus

Avec ça, tu va voir ce qu'il y a dans /usr/lib/mozilla/plugins. Si tu y trouves encore quelque chose qui se nomme flsah_n'importe_quoi, tu le vires (tu l'effaces).
Ensuite tu déplaces là-dedans, toujours avec ton gestionnaire de fichier en root, ton fichier libflashplayer.so, celui que tu as eu en décompressant l'archive d'Adobe.

C'est tout ! Tu fermes firefox et tu le relances. Outils->Gestionnaires de modules->Plugins et là-dedans tu verras ton Shockwave Flash... C'est lui, le plugin flashplayer...

#11 Le 06/10/2012, à 20:26

hlou

Re : [Résolu]Je ne sais pas installer une ancienne version de flash

Super Faustus! Ca marche nickel et en plus tu m'as donné deux ou trois petits trucs qui me serviront pour la suite.

Merci aussi aux autres de m'avoir aidé

Hors ligne

#12 Le 07/10/2012, à 13:25

compte supprimé

Re : [Résolu]Je ne sais pas installer une ancienne version de flash

hlou a écrit :

Super Faustus! Ca marche nickel et en plus tu m'as donné deux ou trois petits trucs qui me serviront pour la suite.

Merci aussi aux autres de m'avoir aidé

Attention quand même quand tu bidouilles dans le système... Prends l'habitude de faire une copie avant d'effacer quelque chose ou de le modifier. Dans le cas de flashplayer on s'en fout un peu : ce n'est pas vital (du point de vue du système) et on peut le réinstaller de manière "officielle" (via flashplugin-installer, dans les dépôts) ou même via la version la plus récente trouvée chez adobe... Donc ce n'est pas une manoeuvre "dangereuse"...
Mais si tu touches par exemple à /etc/fstab, ça pourrait ne plus démarrer. L'idée, c'est évidemment de faire une copie du fichier, sudo cp /etc/fstab /etc/fstab.original en terminal ou une copie via nautilus. S'il y a un problème après bidouillage, tu démarres sur un liveCD et tu remets ton fstab.original à la place du fstab bidouillé et tout devrait rentrer dans l'ordre...

Haut de page ↑