Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 07/10/2012, à 03:01

TAD

installation de dolibar sur Ubuntu server

Bonsoir
je voudrai savoir si klk a déjà eu à installer Dolibarr sur Ubuntu serveur si oui kel est la procédure SVP j'ai parcouru plusieurs doc mais sans suite favorable merci

Hors ligne

#2 Le 07/10/2012, à 03:11

xavier4811

Re : installation de dolibar sur Ubuntu server

Bonsoir,

Y 'a un paquet deb disponible pour se simplifier la vie ICI

Voir leur site pour plus d'infos : http://www.dolibarr.org/downloads
Faut juste vérifier si un serveur LAMP est bien installé avant ou comme dépendance.

Hors ligne

#3 Le 07/10/2012, à 09:16

TAD

Re : installation de dolibar sur Ubuntu server

j'y est déjà fais un tour mais sans suite favorable je précise encore k j suis sur Ubuntu server donc travaille en ligne de commande et suis pas trop pro mais je veux aprandre et en passant j'ai déjà installe LAMP, webmin et même Phpmyadmin

Hors ligne

#4 Le 07/10/2012, à 12:20

xavier4811

Re : installation de dolibar sur Ubuntu server

Sur une fresh install,sans avoir installé les dépendances préalablement.

xavier@zeus:~$ ssh xavier@172.16.0.4
The authenticity of host '172.16.0.4 (172.16.0.4)' can't be established.
ECDSA key fingerprint is xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '172.16.0.4' (ECDSA) to the list of known hosts.
xavier@172.16.0.4's password: 
Welcome to Ubuntu 12.04.1 LTS (GNU/Linux 3.2.0-31-generic x86_64)

 * Documentation:  https://help.ubuntu.com/
Last login: Sun Oct  7 11:50:10 2012 from 172.16.0.1
$ wget http://downloads.sourceforge.net/project/dolibarr/Dolibarr%20installer%20for%20Debian-Ubuntu%20%28DoliDeb%29/3.2.2/dolibarr_3.2.2%2Bnmu1_all.deb
--2012-10-07 11:50:49--  http://downloads.sourceforge.net/project/dolibarr/Dolibarr%20installer%20for%20Debian-Ubuntu%20%28DoliDeb%29/3.2.2/dolibarr_3.2.2%2Bnmu1_all.deb
Résolution de downloads.sourceforge.net (downloads.sourceforge.net)... 216.34.181.59
Connexion vers downloads.sourceforge.net (downloads.sourceforge.net)|216.34.181.59|:80... connecté.
requête HTTP transmise, en attente de la réponse... 302 Found
Emplacement: http://freefr.dl.sourceforge.net/project/dolibarr/Dolibarr%20installer%20for%20Debian-Ubuntu%20%28DoliDeb%29/3.2.2/dolibarr_3.2.2%2Bnmu1_all.deb [suivant]
--2012-10-07 11:51:04--  http://freefr.dl.sourceforge.net/project/dolibarr/Dolibarr%20installer%20for%20Debian-Ubuntu%20%28DoliDeb%29/3.2.2/dolibarr_3.2.2%2Bnmu1_all.deb
Résolution de freefr.dl.sourceforge.net (freefr.dl.sourceforge.net)... 158.255.96.7
Connexion vers freefr.dl.sourceforge.net (freefr.dl.sourceforge.net)|158.255.96.7|:80... connecté.
requête HTTP transmise, en attente de la réponse... 200 OK
Longueur: 11314716 (11M) [application/octet-stream]
Sauvegarde en : «dolibarr_3.2.2+nmu1_all.deb»

100%[=====================================================================================================================>] 11 314 716  1,16M/s   ds 9,3s    

2012-10-07 11:51:24 (1,16 MB/s) - «dolibarr_3.2.2+nmu1_all.deb» sauvegardé [11314716/11314716]

$ sudo dpkg -i dolibarr_3.2.2+nmu1_all.deb
[sudo] password for xavier: 
Sélection du paquet dolibarr précédemment désélectionné.
(Lecture de la base de données... 48438 fichiers et répertoires déjà installés.)
Dépaquetage de dolibarr (à partir de dolibarr_3.2.2+nmu1_all.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de dolibarr :
 dolibarr dépend de libapache2-mod-php5 | libapache2-mod-php5filter | php5-cgi | php5-fpm | php5 ; cependant :
  Le paquet libapache2-mod-php5 n'est pas installé.
  Le paquet libapache2-mod-php5filter n'est pas installé.
  Le paquet php5-cgi n'est pas installé.
  Le paquet php5-fpm n'est pas installé.
  Le paquet php5 n'est pas installé.
 dolibarr dépend de php5-mysql | php5-mysqli ; cependant :
  Le paquet php5-mysql n'est pas installé.
  Le paquet php5-mysqli n'est pas installé.
......
dpkg : erreur de traitement de dolibarr (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 dolibarr
$ sudo apt-get -y -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés : 
  apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common autoconf automake autotools-dev binutils ckeditor cpp cpp-4.6 fontconfig-config gcc
  gcc-4.6 javascript-common libapache2-mod-php5 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libc-dev-bin libc6-dev libdbd-mysql-perl
  libdbi-perl libfile-basedir-perl libfile-desktopentry-perl libfile-mimeinfo-perl libfontconfig1 libfontenc1 libgd2-xpm libgl1-mesa-dri libgl1-mesa-glx
  libglapi-mesa libgmp10 libgomp1 libhtml-template-perl libice6 libjpeg-turbo8 libjpeg8 libjs-jquery libjs-jquery-ui libllvm3.0 libltdl-dev libltdl7 libmpc2
  libmpfr4 libmysqlclient18 libnet-daemon-perl libnusoap-php libphp-adodb libphp-pclzip libplrpc-perl libquadmath0 libsm6 libssl-dev libssl-doc libt1-5
  libtool libx11-xcb1 libxaw7 libxcb-glx0 libxcb-shape0 libxcomposite1 libxcursor1 libxdamage1 libxfixes3 libxft2 libxi6 libxinerama1 libxmu6 libxpm4
  libxrandr2 libxrender1 libxt6 libxtst6 libxv1 libxxf86dga1 libxxf86vm1 linux-libc-dev m4 manpages-dev mysql-client-5.5 mysql-client-core-5.5 mysql-common
  mysql-server mysql-server-5.5 mysql-server-core-5.5 php-fpdf php-mail-mime php-mail-mimedecode php-pear php5 php5-cli php5-common php5-curl php5-dev
  php5-gd php5-geoip php5-ldap php5-mysql shared-mime-info shtool ssl-cert ttf-dejavu-core wwwconfig-common x11-common x11-utils x11-xserver-utils xdg-utils
  zlib1g-dev
Paquets suggérés :
  www-browser apache2-doc apache2-suexec apache2-suexec-custom autoconf2.13 autoconf-archive gnu-standards autoconf-doc gettext binutils-doc cpp-doc
  gcc-4.6-locales gcc-multilib make automake1.9 flex bison gdb gcc-doc gcc-4.6-multilib libmudflap0-4.6-dev gcc-4.6-doc libgcc1-dbg libgomp1-dbg
  libquadmath0-dbg libmudflap0-dbg binutils-gold apache2 httpd glibc-doc libgd-tools libglide3 libipc-sharedcache-perl libjs-jquery-ui-docs libtool-doc
  php5-adodb automaken gfortran fortran95-compiler gcj libterm-readkey-perl tinyca mailx ttf2pt1 php5-suhosin openssl-blacklist mysql-client
  postgresql-client mesa-utils nickle cairo-5c xorg-docs-core gvfs-bin
Les NOUVEAUX paquets suivants seront installés :
  apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common autoconf automake autotools-dev binutils ckeditor cpp cpp-4.6 fontconfig-config gcc
  gcc-4.6 javascript-common libapache2-mod-php5 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libc-dev-bin libc6-dev libdbd-mysql-perl
  libdbi-perl libfile-basedir-perl libfile-desktopentry-perl libfile-mimeinfo-perl libfontconfig1 libfontenc1 libgd2-xpm libgl1-mesa-dri libgl1-mesa-glx
  libglapi-mesa libgmp10 libgomp1 libhtml-template-perl libice6 libjpeg-turbo8 libjpeg8 libjs-jquery libjs-jquery-ui libllvm3.0 libltdl-dev libltdl7 libmpc2
  libmpfr4 libmysqlclient18 libnet-daemon-perl libnusoap-php libphp-adodb libphp-pclzip libplrpc-perl libquadmath0 libsm6 libssl-dev libssl-doc libt1-5
  libtool libx11-xcb1 libxaw7 libxcb-glx0 libxcb-shape0 libxcomposite1 libxcursor1 libxdamage1 libxfixes3 libxft2 libxi6 libxinerama1 libxmu6 libxpm4
  libxrandr2 libxrender1 libxt6 libxtst6 libxv1 libxxf86dga1 libxxf86vm1 linux-libc-dev m4 manpages-dev mysql-client-5.5 mysql-client-core-5.5 mysql-common
  mysql-server mysql-server-5.5 mysql-server-core-5.5 php-fpdf php-mail-mime php-mail-mimedecode php-pear php5 php5-cli php5-common php5-curl php5-dev
  php5-gd php5-geoip php5-ldap php5-mysql shared-mime-info shtool ssl-cert ttf-dejavu-core wwwconfig-common x11-common x11-utils x11-xserver-utils xdg-utils
  zlib1g-dev
0 mis à jour, 110 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 79,4 Mo dans les archives.
Après cette opération, 259 Mo d'espace disque supplémentaires seront utilisés.
Réception de : 1 http://fr.archive.ubuntu.com/ubuntu/ precise/main libapr1 amd64 1.4.6-1 [89,6 kB]
......
Réception de : 110 http://fr.archive.ubuntu.com/ubuntu/ precise/main x11-xserver-utils amd64 7.6+3 [182 kB]                                                   
79,4 Mo réceptionnés en 1min 3s (1 247 ko/s)                                                                                                                  
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
Sélection du paquet libapr1 précédemment désélectionné.
(Lecture de la base de données... 53695 fichiers et répertoires déjà installés.)
Dépaquetage de libapr1 (à partir de .../libapr1_1.4.6-1_amd64.deb) ...
......
mysql start/running, process 8819
Paramétrage de mysql-server (5.5.24-0ubuntu0.12.04.1) ...
Paramétrage de dolibarr (3.2.2+nmu1) ...
Run the dolibarr config script
Ask for web server to setup
Run the dolibarr postinst script
Mysql superuser found to use is debian-sys-maint
Create empty file /etc/dolibarr/conf.php
Complete config of server apache2
Web user.group used is www-data.www-data
Complete config of server lighttpd
Web user.group used is www-data.www-data
Add link for Apache config file
Restart web server using invoke-rc.d
 * Reloading web server config apache2                                                                                                                         apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
                                                                                                                                                        [ OK ]
Lighttpd not installed, skipping
----------
Call Dolibarr page http://localhost/dolibarr/ to complete the setup and use Dolibarr.
----------
Paramétrage de libglapi-mesa (8.0.3+8.0.2-0ubuntu3.2) ...
......
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place

Y a plus qu' a finir l'installation sur ton navigateur

zr61t51m_mini.png
ux7mi8i8_mini.png

Hors ligne

Haut de page ↑