Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 12/10/2012, à 10:45

golgot200

polices de caractère

Bonjour,

Quand je personnalise ma police de caractère,de temps en temps elle se remet par défault . C'est pas une histoire de cache ?
Mais je doute car j'utilise bien des polices du système. j'ai lancé "sudo fc-cache -f -v" mais bon rien y fait.
J'ai juste en fin de résultat:

.....
/home/patrick/.fonts: skipping, no such directory
/var/cache/fontconfig: cleaning cache directory
/home/patrick/.fontconfig: cleaning cache directory
/home/patrick/.fontconfig: invalid cache file: a2520612f0a1a7ace89c8c157c20cc70-le64.cache-3
fc-cache: succeeded

J'ai viré le contenu du dossier .fontconfig tout les fichiers et relancé la commande est là :
...
.....fontconfig: cleaning cache directory
fc-cache: succeeded

Plus de : invalid cache




Merci par avance.

Dernière modification par golgot200 (Le 12/10/2012, à 10:53)


"L’ultime question … L’intelligence a besoin de la Bêtise pour s’affirmer, La Beauté a besoin de la Laideur pour resplendir, Le Courage naît dans la Peur, Les Forts impressionnent au milieu des Faibles, Mais au final,…Qui a donc besoin d’autant de connards ?"

Hors ligne

#2 Le 12/10/2012, à 18:23

ft

Re : polices de caractère

J'ai eu le même bug sous Precise et sur des versions antérieures.
Je l'ai eu aussi *une* fois sous Quantal.
Ce qui est déroutant c'est qu'il est très rare et aléatoire. Un plantage mal maîtrisé des systemsettings ?


Thinkpad T440s, Ubuntu Gnome 14.04

Hors ligne

#3 Le 13/10/2012, à 03:07

Ironwind25

Re : polices de caractère

Salut golgot200

Et bien pour tout te dire je ne saisie pas bien le sens du bug!Est ce que tu veut dire que les police tombent en mode aléatoire tout seul et n'applique pas celle que tu as sélectionné?
Pour moi jusqu’à présent je n ai pas eu ce bug!Mais.......

-f:Régénérer les fichiers du cache, même si elles semblent être à jour(OK)
-v:Afficher les informations de version(OK)

Ce peut t-il que si ton problème persiste encore une fois que avec un -s en l'appliquant au système seulement que sa résoudrais le problème définitivement?

-s:Scanner les répertoires de polices pour l'ensemble du système, et non pas les polices dans le répertoire personnel de l'utilisateur.

Mais avec ce que tu as dit on dirait que ça décrit la manœuvre mais toi tu la fait manuellement!
Sa devrais faire l’affaire!

Cordialement!


Where there is a shell,There is a way!
Quand la vie apporte des questions, Google donne les réponses.
Pc No Name sous Kubuntu 12.04 lts 64 bits intel 3.07 ghz,24 gigs de ram!
Portable Asus k72j Sous Ubuntu 12.04 lts 64 bits intel 2.56 ghz,4 gigs de ram!

Hors ligne

#4 Le 13/10/2012, à 09:47

bruno

Re : polices de caractère

C'est un bug. J'ai le même souci depuis plusieurs versions de Kubuntu.
Je n'aime pas la Police Ubuntu (police par défaut) que je trouve peu lisible à l'écran et je modifie dons systématiquement mes réglages pour utiliser "DejaVu sans" partout.
De temps en temps ce réglage est modifié et la police Ubuntu revient. Je n'ai pas réussi (ni vraiment cherché) à trouver d'où venait le problème. Cela se produit lors de certaines mises à jour ou lors de certaines modifications dans la configuration du système.

EDIT :

Je viens de refaire un test.
J'ai réglés toutes les polices sur "sans-serif" (c'est en fait DejaVu sans)
Je regarde mon fichier ~/.kde/share/config/kdeglobals et j'ai bien :

[Directories-default]
prefixes=/usr/share/kubuntu-default-settings/kde4-profile/default/

[Emoticons]
emoticonsTheme=Oxygen

[General]
BrowserApplication[$e]=!rekonq
ColorScheme=Modèle actuel
TerminalApplication[$e]=yakuake
XftAntialias=true
XftHintStyle=hintfull
XftSubPixel=none
desktopFont=Sans Serif,9,-1,5,50,0,0,0,0,0
fixed=Monospace,9,-1,5,50,0,0,0,0,0
font=Sans Serif,9,-1,5,50,0,0,0,0,0
menuFont=Sans Serif,9,-1,5,50,0,0,0,0,0
shadeSortColumn=true
smallestReadableFont=Sans Serif,8,-1,5,50,0,0,0,0,0
taskbarFont=Sans Serif,9,-1,5,50,0,0,0,0,0
toolBarFont=Sans Serif,8,-1,5,50,0,0,0,0,0
widgetStyle=oxygen

- je vais maintenant simplement ouvrir les régalages de l'écran de connexion (KDM) que lje referme aussitôt
- je regarde à nouveau  ~/.kde/share/config/kdeglobals  et surprise :

[Directories-default]
prefixes=
prefixes=/usr/share/kubuntu-default-settings/kde4-profile/default/

[Emoticons]
emoticonsTheme=Oxygen
emoticonsTheme=Oxygen

[General]
BrowserApplication[$e]=!rekonq
BrowserApplication[$e]=!rekonq
ColorScheme=Modèle actuel
TerminalApplication[$e]=yakuake
XftAntialias=true
XftHintStyle=hintfull
XftHintStyle=hintmedium
XftSubPixel=none
desktopFont=Sans Serif,9,-1,5,50,0,0,0,0,0
desktopFont=Ubuntu,9,-1,5,50,0,0,0,0,0
fixed=Monospace,9,-1,5,50,0,0,0,0,0
font=Sans Serif,9,-1,5,50,0,0,0,0,0
font=Ubuntu,9,-1,5,50,0,0,0,0,0
menuFont=Sans Serif,9,-1,5,50,0,0,0,0,0
menuFont=Ubuntu,9,-1,5,50,0,0,0,0,0
shadeSortColumn=true
smallestReadableFont=Sans Serif,8,-1,5,50,0,0,0,0,0
smallestReadableFont=Ubuntu,8,-1,5,50,0,0,0,0,0
taskbarFont=Sans Serif,9,-1,5,50,0,0,0,0,0
taskbarFont=Ubuntu,9,-1,5,50,0,0,0,0,0
toolBarFont=Sans Serif,8,-1,5,50,0,0,0,0,0
toolBarFont=Ubuntu,8,-1,5,50,0,0,0,0,0
widgetStyle=oxygen

Admirez les doublons ! Il semble que le contenu du fichier /usr/share/kubuntu-default-settings/kde4-profile/default/kdeglobals ait été fusionné avec le mien et je me retrouve de nouveau avec la Police Ubuntu ! WTF

Solution temporaire de contournement :

sudo rm -i /usr/share/kubuntu-default-settings/kde4-profile/default/share/config/kdeglobals

Dernière modification par bruno (Le 13/10/2012, à 10:03)

Hors ligne

#5 Le 13/10/2012, à 10:41

golgot200

Re : polices de caractère

Bonjour à vous,
Et bien, celle là, elle est pas mal effectivement, un mixe de 2 configurations dans un même fichier !!!
Et en le passant, une fois sa configuration remise, en lecture seule ? On éviterait la suppression.
En tout cas merci à vous de m'aider ...


"L’ultime question … L’intelligence a besoin de la Bêtise pour s’affirmer, La Beauté a besoin de la Laideur pour resplendir, Le Courage naît dans la Peur, Les Forts impressionnent au milieu des Faibles, Mais au final,…Qui a donc besoin d’autant de connards ?"

Hors ligne

#6 Le 13/10/2012, à 11:06

bruno

Re : polices de caractère

J'ai trouvé ce rapport de bogue :

https://bugs.kde.org/show_bug.cgi?id=254430

mais je pense que ce n'est pas un bogue de KDE mais un bogue dans les paquets Ubuntu (probablement dans kubuntu-default-settings)

et le bogue sur Launchpad :

https://bugs.launchpad.net/ubuntu/+sour … bug/766145

Dernière modification par bruno (Le 13/10/2012, à 11:10)

Hors ligne

#7 Le 13/10/2012, à 11:21

golgot200

Re : polices de caractère

Et ben, un bug connu depuis pas mal de temps !!!
Merci pour ta recherche.

suite :
http://forum.ubuntu-fr.org/viewtopic.php?id=1099271

Dernière modification par golgot200 (Le 09/11/2012, à 15:04)


"L’ultime question … L’intelligence a besoin de la Bêtise pour s’affirmer, La Beauté a besoin de la Laideur pour resplendir, Le Courage naît dans la Peur, Les Forts impressionnent au milieu des Faibles, Mais au final,…Qui a donc besoin d’autant de connards ?"

Hors ligne

Haut de page ↑