Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 15/05/2012, à 14:53

jb81

[RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Bonjour,

J'ai mis à jour Ubuntu de oneiric vers precise, et depuis ma carte réseau (un peu ancienne) n'est plus détectée ("périphérique non prêt" dans l'indicateur réseau à côté de la date).

J'ai cependant une astuce un peu fastidieuse qui me permet de me connecter : choisir le mode de dépannage dans le menu Grub, puis l'option "network" ("activer la prise en charge du réseau") puis "resume" ("reprendre le démarrage normal"). Là, tout est normal.

Cette discussion laisse entendre que ma carte réseau pourrait être trop vieille et qu'il faudrait patcher le noyau, mais si elle est reconnue avec mon astuce, c'est qu'il y a autre chose non ?

Si quelqu'un peut m'aider... ce serait chouette !

lspci (quand je suis connecté) donne :

00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(AS)

Merci et à +

Dernière modification par jb81 (Le 22/10/2012, à 09:55)

Hors ligne

#2 Le 15/05/2012, à 17:19

inbox

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Salut,

Je n'ai pas le temps d'approfondir, pour aujourd'hui, mais il semble qu'il y ai une piste ici.

Pour faire avancer les choses, donne le contenu du fichier /etc/network/interfaces.

A+

[EDIT] Au cas ou, le lien vers le sujet d'origine.

Dernière modification par inbox (Le 15/05/2012, à 17:20)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#3 Le 15/05/2012, à 17:42

Korak

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Bonjour,

jb81 a écrit :

J'ai cependant une astuce un peu fastidieuse qui me permet de me connecter : choisir le mode de dépannage dans le menu Grub, puis l'option "network" ("activer la prise en charge du réseau") puis "resume" ("reprendre le démarrage normal"). Là, tout est normal.

Fais ce que tu expliques ci-dessus puis lance le gestionnaire de mise-à-jour et fais toutes les mises-à-jour proposée. Puis après la fin des mises-à-jour, redémarre le PC normalement.

Avec un peu de chance, ça va régler ton problème.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

En ligne

#4 Le 15/05/2012, à 18:13

jb81

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Merci pour vos réponses !

Korak a écrit :

Fais ce que tu expliques ci-dessus puis lance le gestionnaire de mise-à-jour et fais toutes les mises-à-jour proposée. Puis après la fin des mises-à-jour, redémarre le PC normalement.

Avec un peu de chance, ça va régler ton problème.

C'est ce que je fais chaque fois que des mises à jour sont disponibles... pas de chance pour l'instant smile

Merci inbox pour tes pistes que je vais creuser.

inbox a écrit :

Pour faire avancer les choses, donne le contenu du fichier /etc/network/interfaces.

cat /etc/network/interfaces
auto lo
iface lo inet loopback

à+

Hors ligne

#5 Le 15/05/2012, à 22:11

jb81

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Bonsoir,

J'ai essayé d'ajouter comme indiqué ici les lignes

auto eth0
iface eth0 inet dhcp

dans /etc/network/interfaces puis de redémarrer mais ça n'a pas fait détecter ma carte réseau, au contraire en redémarrant avec mon astuce (via Grub et les options "network" et "resume" dans le mode de dépannage) je n'avais plus de connexion ; j'ai enlevé ces deux lignes et relancé network-manager, et ça m'a connecté.

Puis j'ai essayé selon ce message, en démarrant sans l'astuce (donc déconnecté) :

/sbin/lsmod | grep ne2k-pci

aucune réponse (avec ou sans /sbin)

/sbin/modprobe ne2k-pci

aucune réponse (avec ou sans /sbin ou sudo)

/sbin/lsmod | grep ne2k-pci

toujours aucune réponse

cat /proc/pci
cat: /proc/pci: Aucun fichier ou dossier de ce type

J'ai aussi essayé :

sudo modprobe r8168
FATAL: Module r8168 not found.

Il y a sûrement une solution !

Bonne nuit

Hors ligne

#6 Le 16/05/2012, à 09:30

inbox

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Dans ce cas, donne le retour de :

sudo lshw -class network
lsmod | grep ne2k
ifconfig
sudo rfkill list
lspci -nn | grep -i net
nm-tool

Dernière modification par inbox (Le 16/05/2012, à 09:32)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#7 Le 20/05/2012, à 14:59

jb81

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Désolé pour le délai de réponse, je n'ai pas beaucoup de temps devant l'écran ces jours-ci...

Merci pour tes indications income, je me laisse guider.

Voilà les retours des commandes demandées, en démarrant normalement c'est-à-dire sans connexion :

amikaro@ordi-jb:~$ sudo lshw -class network
[sudo] password for amikaro: 
  *-network               
       description: Ethernet interface
       produit: RTL-8029(AS)
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: b
       information bus: pci@0000:00:0b.0
       nom logique: eth0
       version: 00
       numéro de série: 00:00:b4:ba:91:ae
       bits: 32 bits
       horloge: 33MHz
       fonctionnalités: ethernet physical
       configuration: broadcast=yes driver=ne2k-pci driverversion=1.03 latency=0 multicast=yes
       ressources: irq:10 portE/S:8800(taille=32)
amikaro@ordi-jb:~$ lsmod | grep ne2k
ne2k_pci               13389  0 
8390                   18400  1 ne2k_pci
amikaro@ordi-jb:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:00:b4:ba:91:ae  
          adr inet6: fe80::200:b4ff:feba:91ae/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:10 erreurs:0 :0 overruns:0 frame:0
          TX packets:25 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:1354 (1.3 KB) Octets transmis:4551 (4.5 KB)
          Interruption:10 Adresse de base:0x8800 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:500 erreurs:0 :0 overruns:0 frame:0
          TX packets:500 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:40464 (40.4 KB) Octets transmis:40464 (40.4 KB)
amikaro@ordi-jb:~$ sudo rfkill list
amikaro@ordi-jb:~$ lspci -nn | grep -i net
00:0b.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8029(AS) [10ec:8029]
amikaro@ordi-jb:~$ nm-tool

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            ne2k-pci
  State:             unavailable
  Default:           no
  HW Address:        00:00:B4:BA:91:AE

  Capabilities:

  Wired Properties
    Carrier:         off

À toutes fins utiles je donne aussi le retour des commandes en démarrant avec l'astuce (c'est-à-dire avec connexion) :

amikaro@ordi-jb:~$ sudo lshw -class network
[sudo] password for amikaro:
  *-network               
       description: Ethernet interface
       produit: RTL-8029(AS)
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: b
       information bus: pci@0000:00:0b.0
       nom logique: eth0
       version: 00
       numéro de série: 00:00:b4:ba:91:ae
       bits: 32 bits
       horloge: 33MHz
       fonctionnalités: ethernet physical
       configuration: broadcast=yes driver=ne2k-pci driverversion=1.03 ip=192.168.0.11 latency=0 multicast=yes
       ressources: irq:10 portE/S:8800(taille=32)

amikaro@ordi-jb:~$ lsmod | grep ne2k
ne2k_pci               13389  0
8390                   18400  1 ne2k_pci

amikaro@ordi-jb:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:00:b4:ba:91:ae 
          inet adr:192.168.0.10  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::200:b4ff:feba:91ae/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:42694 erreurs:0 :0 overruns:0 frame:0
          TX packets:26983 errors:0 dropped:0 overruns:0 carrier:0
          collisions:19 lg file transmission:1000
          Octets reçus:58321640 (58.3 MB) Octets transmis:2666819 (2.6 MB)
          Interruption:10 Adresse de base:0x8800

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:4 erreurs:0 :0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          Octets reçus:240 (240.0 B) Octets transmis:240 (240.0 B)

amikaro@ordi-jb:~$ sudo rfkill list

amikaro@ordi-jb:~$ lspci -nn | grep -i net
00:0b.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8029(AS) [10ec:8029]

amikaro@ordi-jb:~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0  [Freebox] ------------------------------------------------------
  Type:              Wired
  Driver:            ne2k-pci
  State:             connected
  Default:           yes
  HW Address:        00:00:B4:BA:91:AE

  Capabilities:

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.0.10
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.254

    DNS:             212.27.40.241
    DNS:             212.27.40.240

à bientôt

Dernière modification par jb81 (Le 20/05/2012, à 20:45)

Hors ligne

#8 Le 20/05/2012, à 16:01

inbox

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

A priori, ta carte réseau est reconnue correctement. Tu es donc connecté à ta box.

Donne le retour de :

ping -c 3 212.27.40.241
ping -c 3 173.194.67.105
ping -c 3 www.google.com

Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#9 Le 20/05/2012, à 20:43

jb81

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Voilà :

amikaro@ordi-jb:~$ ping -c 3 212.27.40.241
connect: Network is unreachable
amikaro@ordi-jb:~$ ping -c 3 173.194.67.105
connect: Network is unreachable
amikaro@ordi-jb:~$ ping -c 3 www.google.com
ping: unknown host www.google.com
inbox a écrit :

A priori, ta carte réseau est reconnue correctement. Tu es donc connecté à ta box.

J'ai juste un doute sur le fait que tu aies lu les bons retours, j'enlève leur balise "code" dans mon message précédent pour être plus clair.

Hors ligne

#10 Le 21/05/2012, à 13:14

inbox

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Donne le retour de :

sudo service network-manager restart
ifconfig

Dernière modification par inbox (Le 21/05/2012, à 13:47)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#11 Le 22/05/2012, à 17:26

jb81

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Voilà :

amikaro@ordi-jb:~$ sudo service network-manager restart
[sudo] password for amikaro: 
network-manager stop/waiting
network-manager start/running, process 2083
amikaro@ordi-jb:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:00:b4:ba:91:ae  
          adr inet6: fe80::200:b4ff:feba:91ae/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:15 erreurs:0 :0 overruns:0 frame:0
          TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:3722 (3.7 KB) Octets transmis:8890 (8.8 KB)
          Interruption:10 Adresse de base:0x8800 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:1588 erreurs:0 :0 overruns:0 frame:0
          TX packets:1588 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:130128 (130.1 KB) Octets transmis:130128 (130.1 KB)

Hors ligne

#12 Le 24/05/2012, à 21:21

jb81

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

up smile

Hors ligne

#13 Le 13/07/2012, à 21:34

Dunjee

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Bonjour,

même soucis, suite à la mise à jour vers ubuntu 12.04. Je récupère le réseau en faisant un

sudo  NetworkManager

Le pb est qu'au démarage je reste bloqué  2 min pendant que le système tente vainement de se connecter.

J'ai écumé les forums mais je n'ai pas trouvé de solutions à mon problème.

Dernière modification par Dunjee (Le 13/07/2012, à 21:36)

Hors ligne

#14 Le 14/07/2012, à 00:14

Dunjee

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

J'ai finalement résolu ce problème pour ma configuration :
Dans une version précédente d'Ubuntu j’avais cherché à activer le réveil du PC à distance (WakeOnLan) en ajoutant des lignes supplémentaires dans le fichier de configuration de l'interface réseau  "/etc/network/interfaces". Mais l'outil "ethtool" qui était invoqué a disparu de la nouvelle distribution.
Avec cette erreur, la nouvelle procédure de boot ("Upstart" qui remplace désormais la (très) ancienne procédure "init") comprend que l'initialisation des interfaces ne se fait pas. Elle déclenche une mesure de protection en activant un script "/etc/init/wait-for-state.conf" qui dit d'attendre pendant 2 minutes...
Bref ne gardant que les lignes suivantes dans /etc/network/interfaces :

auto lo
iface lo inet loopback

Tout rentre dans l'ordre. Et je peux enfin apprécier le boot plutôt rapide de ubuntu 12.04.

Hors ligne

#15 Le 13/10/2012, à 10:25

boubountu

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Petite contribution

J'ai eu le même problème après une mise à jour (il me semble) de Ubuntu 10.04 64 bits : ma carte réseau ne fonctionnait plus.
La solution a été de supprimer l'adressage ipv6 qui avait été attribué automatiquement à mon interface réseau avec la commande:

sudo ifconfig [interface] del [adresse ipv6]

En remplaçant

  • [interface] par le nom de l'interface réseau concernée

  • [adresse ipv6] par l'adresse IP au format ipv6, visible avec la commande "ifconfig" à la ligne "adr inet6"

Ce qui donnait par exemple, dans mon cas:

sudo ifconfig eth0 del fe80::be5f:f4ff:fe0c:7502/64

Cet adresse m'avait été configuré automatiquement. Il y a de fortes chances que cela se soit produit après une mise à jour de Ubuntu.
Cependant j'ai un léger doute car j'ai entre temps changé de box : je suis passé de la box orange à la box OVH (Thomson Technicolor TG788vn).
Mais bon, sI ça peut aider.


PC fixe : ASROCK P5B-DE + Core 2 Duo  : Lucid Lynx (10.04) / Trusty Tahr (14.04) / Mint Qiana (17) / Windows 7

Pc portable : Asus Pro P53SJ-S043X : Precise Pangolin (12.04) / Gnome Shell Remix (12.04) / Windows 7

Hors ligne

#16 Le 22/10/2012, à 09:54

jb81

Re : [RÉSOLU] [12.04] Carte réseau non détectée après mise à jour

Merci boubountu pour l'astuce,

Cependant je ne l'ai pas essayée car j'ai résolu mon problème en passant à la version 12.10 (et Lubuntu), qui détecte correctement ma carte réseau.

Hors ligne

Haut de page ↑