Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 03/09/2012, à 03:27

drefhill

gestion d'énergie Lubuntu

Bonjour
Je ne trouve pas le gestionnaire d'énergie, je ne sais pas si je l'ai enlevé ou quoi...
C'est quoi et il est ou ? Il n'est pas en bas à droite à coté de l'heure et je ne trouve rien dans le menus.
Quand je branche mon PC sur secteur la luminiosité baisse et si je laisse sur baterie la luminiosité monte j'aimerais donc remetre correctement l'inverse.

Merci


Linux Mint 13 32bits    sur   HP mini 2140                                               
Puce graphique Mobile Intel GMA 950          Chipset Mobile Intel 945GSE Express        CPU intel Atom N270 32bits
Disque dur SEAGATE 2,5'' 250 go + 4 go ssd 32 mo 7200 tr/min - hybride/sata ii - momentus xt
LinuxMint 13 64bits + Cinnamon

Hors ligne

#2 Le 03/09/2012, à 10:42

Pierrot86

Re : gestion d'énergie Lubuntu

Depuis Lubuntu 12.04, tu peux le trouver dans le menu Préférences. Pour la version 11.10, il faut lancer xfce4-power-manager-settings (je ne sais plus si c'est également le cas pour les versions antérieures).

Hors ligne

#3 Le 15/10/2012, à 21:08

cracolinux

Re : gestion d'énergie Lubuntu

Coucou, léger déterrage pour enrichir (j'espère) ce fil au nom bien choisi

J'ai du mal à comprendre plusieurs petites choses dans la gestion d’énergie de Lubuntu.
J'utilise Lubuntu 11.10

1/
Semblerait, du moins chez moi, que xfce4-power-manager et xscreensaver (onglet avancé de xscreensaver (préférences/économiseur d'écran)) fassent doublons concernant la gestion d'energie, non ?
Lequel des deux à le dernier mot ?

2/
En essayant de désactiver xfce4-power-manager par l'intermédiaire de préférences/paramètre de la session  mini_121015092108323841.png et après avoir redémarré, je m'aperçois que xfce4-power-manager est quand même lancé au démarrage... c'est pas un peu bizarre ?

3/
Un peu HS mais ça me fait me poser la question suivante : comment activer et désactiver le lancement au démarrage des serveurs/démons d'un système sous Lubuntu ?

Des idées ?

Dernière modification par cracolinux (Le 15/10/2012, à 21:09)


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#4 Le 15/10/2012, à 23:26

afilmore

Re : gestion d'énergie Lubuntu

cracolinux a écrit :

1/
Semblerait, du moins chez moi, que xfce4-power-manager et xscreensaver (onglet avancé de xscreensaver (préférences/économiseur d'écran)) fassent doublons concernant la gestion d'energie, non ?
Lequel des deux à le dernier mot ?

D'après ce que je comprends il n'y a que la mise en veille de l'écran qui fasse doublon ?

1350333278.png

cracolinux a écrit :

2/
En essayant de désactiver xfce4-power-manager par l'intermédiaire de préférences/paramètre de la session  http://nsa31.casimages.com/img/2012/10/15/mini_121015092108323841.png et après avoir redémarré, je m'aperçois que xfce4-power-manager est quand même lancé au démarrage... c'est pas un peu bizarre ?

Paramètre de Session, c'est un peu buggé, il affiche comme desactivés des services qui sont activés. tongue

cracolinux a écrit :

3/
Un peu HS mais ça me fait me poser la question suivante : comment activer et désactiver le lancement au démarrage des serveurs/démons d'un système sous Lubuntu ?

Les services et programmes sont lancés de plusieurs façon différentes.

Ça marche comme ça :

kernel
	
	init PID 1
	/etc/int/lightdm.conf
		
		lightdm
		/etc/lightdm/lightdm.conf
		/usr/share/xsessions
			
			Lubuntu.desktop
			/usr/bin/startlubuntu
			
				/usr/bin/lxsession -s Lubuntu -e LXDE
				~/.config/autostart
				/etc/xdg/autostart
				/etc/xdg/lxsession/Lubuntu/autostart

					explorateur de fichier
					panel
					etc...

D’abord le noyau s’exécute, il lance "init" qui est le processus n°1 du système, sur Ubuntu c'est Upstart, sur d'autres systèmes sera System V init ou System D... heu non... je voulais dire systemd pardon. tongue

Ensuite tu as Lightdm qui te permet de lancer une session utilisateur en graphique, dans notre cas ça va exécuter le fichier "Lubuntu.desktop" qui va lancer le script "/usr/bin/startubuntu", qui va lui... c'est compliqué tongue qui va lui lancer "lxsession" qui est le programme qui lance les applications en mode utilisateur, le bureau, le panel, des services utilisateurs etc...

LxSession va executer les programmes qu'il trouve dans ~/.config/autostart, dans /etc/xdg/autostart et également dans le fichier "/etc/xdg/lxsession/Lubuntu/autostart".

Si tu tape "pstree" dans un terminal tu verras la hiérarchie des processus :

     ├─lightdm─┬─Xorg 
     │         ├─lightdm─┬─lxsession─┬─cairo-compmgr───{cairo-compmgr} 
     │         │         │           ├─lxdesktop─┬─bash───pstree 
     │         │         │           │           ├─gnome-pty-helpe 
     │         │         │           │           └─3*[{lxdesktop}] 
     │         │         │           ├─openbox 
     │         │         │           ├─polkit-gnome-au───{polkit-gnome-au} 
     │         │         │           ├─spanel───2*[{spanel}] 
     │         │         │           ├─ssh-agent 
     │         │         │           ├─xscreensaver 
     │         │         │           └─2*[{lxsession}] 
     │         │         └─{lightdm} 
     │         └─2*[{lightdm}] 

En résumé, les services système sont exécutés par Upstart, les services utilisateur par LxSession.

Ce qui nous intéresse surtout c'est ce que lance LxSession. tongue

Pour savoir quel sont les services qui s'exécutent vraiment :

hotnuma@inspiron:~$ cd /etc/xdg/autostart
hotnuma@inspiron:/etc/xdg/autostart$ grep -Lr LXDE
gnome-keyring-gpg.desktop
pulseaudio.desktop
gnome-keyring-pkcs11.desktop
update-notifier.desktop.dpkg-dist
gnome-keyring-ssh.desktop
nm-applet.desktop
gnome-settings-daemon.desktop
gnome-keyring-secrets.desktop
hotnuma@inspiron:/etc/xdg/autostart$ cd ~/.config/autostart/
hotnuma@inspiron:~/.config/autostart$ grep -Lr LXDE
indicator-multiload.desktop
hotnuma@inspiron:~/.config/autostart$ cat /etc/xdg/lxsession/Lubuntu/autostart 
@xscreensaver -no-splash
@xfce4-power-manager
@lxdesktop --desktop
@/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
volumeicon
spanel
cairo-compmgr

Voila ce que ça donne dans mon cas, je précise que c'est pas une installation standard, donc tu auras des résultats différents sur ton système. tongue
Et donc là on voit que la commande qui exécute xfce4-power-manager est dans le fichier "/etc/xdg/lxsession/Lubuntu/autostart".

Si tu veux le désactiver il faut ouvrir le fichier en root et supprimer la ligne en question.

D'abord tu fais une copie du fichier tongue

hotnuma@inspiron:~$ sudo cp /etc/xdg/lxsession/Lubuntu/autostart /etc/xdg/lxsession/Lubuntu/autostart.bak

Tu vérifie :

hotnuma@inspiron:~$ ls /etc/xdg/lxsession/Lubuntu
autostart  autostart.bak  desktop.conf

T'ouvre le fichier en root :

hotnuma@inspiron:~$ sudo leafpad /etc/xdg/lxsession/Lubuntu/autostart

Tu peux modifier le contenu.
AVEC PRUDENCE big_smile

En cas de soucis tu pourra récupérer le fichier d'origine (autostart.bak)

Voili. tongue

Hors ligne

Haut de page ↑