Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 16/10/2012, à 15:31

laurentv88

Monter le répertoire /HOME se trouvant sur un AD

Bonjour à tous,

Le contexte
Je travail actuellement sur l'intégration de machine Linux Ubuntu 12.04 LTS sur un domaine Active Directory sous Windows 2008 R2.
J'ai bien réussi à intégrer mes machines Ubuntu 12.04 sur l'AD 2008, mes utilisateurs s'authentifie correctement sur l'AD à l'ouverture de session.
Logiciels utilisé : Samba - Winbind - Kerberos - NTP

Pour le montage des partages, j'ai installé : libpam-mount

Tout fonctionne quand je monte le partage par exemple sur /media
Mon fichier de config : /etc/security/pam_mount.conf.xml

<volume fstype="cifs" server="serveurdepartage" path="%(USER)$" mountpoint="/media/%(USER)" user="*" />

Je peux créer et supprimer des fichiers sans problèmes.

Mon problème
Je bloque actuellement sur le montage du /HOME pour les utilisateurs (genre de profil itinérant)
Mon fichier de config : /etc/security/pam_mount.conf.xml

<volume fstype="cifs" server="serveurdepartage" path="%(USER)$" mountpoint="/home/%(USER)" user="*" options="rw,auto,iocharset=utf8" />

Lorsque j'ouvre la session, je me retrouve sur le bureau vide, aucun menu, pas de lanceur d'application.
j'ai bien quelques fichiers qui se retrouve dans le répertoire utilisateur du serveur 2008 : Bureau, Documents, Videos,...

Je ne vois pas d'où vient le problème.

Merci d'avance, si quelqu'un peut m'apporter un peu d'aide.

----------------------
Cordialement
Laurent

Hors ligne

#2 Le 16/10/2012, à 22:55

Maisondouf

Re : Monter le répertoire /HOME se trouvant sur un AD

Pour ce qui est du bureau vide, de l'absence de menu, il n'y a rien d'anormal.
Ta commande a fait exactement ce que tu lui as demandé.
Elle a remplacé le répertoire '/home/<user>' par le contenu du répertoire de l'AD, donc il n'y a plus aucun accès aux sous-répertoires '/home/<user>/.gnome', '/home/<user>/.conf', '/home/<user>/.gconf', etc, etc....

Il faut que tu crées un sous-répertoire dans chaque 'homedir' (par exemple '/home/<user>/AD' ) et que tu t'en serves comme point de montage pour le répertoire provenant de l'active serveur.


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 17/10/2012, à 00:03

laurentv88

Re : Monter le répertoire /HOME se trouvant sur un AD

en faite normalement avec la commande

session required        pam_mkhomedir.so

que j'ai mis dans le fichier  /etc/pam.d/common-session
ça créer l’arborescence automatiquement si elle est manquante, en local ça le fait bien, mais pas avec le montage réseau (enfin ça le fait pas bien puisqu'il y'a quelques répertoires et fichiers créés quand même)

Hors ligne

#4 Le 18/10/2012, à 08:41

laurentv88

Re : Monter le répertoire /HOME se trouvant sur un AD

J'ai finalement monté le partage dans le répertoire Documents sur le profil local

<volume fstype="cifs" server="hades" path="%(USER)$" mountpoint="~/Documents" user="*" options="rw,auto,iocharset=utf8" />

Hors ligne

Haut de page ↑