Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 10/10/2012, à 20:39

gawindx

[Résolu] Gwibber et compte Facebook

Bonjour à tous,

Suite à une longue absence du monde linuxien, j'ai récemment réinstallé Ubuntu et j'ai pu constater de nombreux changements(dans le bon sens).

Je rencontre par contre un souci avec Gwibber et Facebook, je m'explique :
Lors de la première installation, j'ai déclaré mon compte twitter sans aucun problème, ainsi que mon compte facebook. Jusque là ça marchait très bien.
Comme je suis assez fan des modifications visuelles, j'ai un peu trop joué avec compiz et j'ai réussi à planter ma session.
J'ai réussi à la récupérer en renommant mon répertoire et en me reconnectant puis j'ai recopié mes documents dans mon nouveau répertoire (j'en déduis que j'avais du corrompre un fichier mais je ne sais pas lequel).

Depuis cette opération, gwibber ne fonctionne plus correctement, c'est à dire que je peux correctement créer mon compte twitter mais plus moyen de créer un compte facebook (ni le mien, ni celui de ma femme).

J'ai essayé de nombreuses choses : downgrade de version, suppression de tous les fichiers (merci locate gwibber), lancer le service gwibber avec l'option -do, j'ai également trouvé des info par rapport au fichier hosts et d'autres encore mais rien n'y fait.

Je suis sous Ubuntu 12.04.1 amd64.

Si l'un de vous à une idée ou une info, je suis preneur.

Dernière modification par gawindx (Le 21/10/2012, à 12:31)

Hors ligne

#2 Le 12/10/2012, à 01:57

Coeur Noir

Re : [Résolu] Gwibber et compte Facebook

Mmmm je remarque depuis quelques jours que mon "fil" facebook ne se met plus à jour dans gwibber - pas de modif's de mon système ces derniers temps (12.04.1) r. à s. se peut-il que le problème vienne de FB ?

Modifier le fichiers hosts et effacer %gconf.xml n'a rien amélioré non plus...

Bug "proche" déclaré là → https://bugs.launchpad.net/gwibber/+bug/1058672

Dernière modification par Coeur Noir (Le 12/10/2012, à 02:07)

Hors ligne

#3 Le 12/10/2012, à 08:53

gawindx

Re : [Résolu] Gwibber et compte Facebook

Je confirme la ressemblance des symptômes que je rencontre avec ceux décrit :
Lorsque je termine la création du compte, le compte n'apparait pas dans la liste, j'obtient le message "succes" et c'est tout, pas de message spécifique.

Je me pose également la question de savoir si le problème ne vient pas de facebook (apparition de la fonction journal sur le mur, ils auraient modifier l'API???? ou alors gwibber ne gérerait pas cette fonction??) , mais le compte devrait quand même être crée dans gwibber.

Hors ligne

#4 Le 21/10/2012, à 12:30

gawindx

Re : [Résolu] Gwibber et compte Facebook

Suite à la mise à jour vers Ubuntu 12.10, Gwibber fonctionne de nouveau correctement.

Je passe en résolu.

Hors ligne

#5 Le 25/02/2013, à 14:39

Blue Djoe

Re : [Résolu] Gwibber et compte Facebook

Pour celles et ceux qui auraient un souci avec Facebook et Gwibber dans la 12.04 j'ai trouvé ce tutoriel et il fonctionne : http://www.webupd8.org/2013/01/fix-face … ibber.html


PC : eMachine G520, Xubuntu 12.04

Un crayon, une feuille... le bonheur quoi :)
Blue Djoe

Hors ligne

#6 Le 05/03/2013, à 08:07

gawindx

Re : [Résolu] Gwibber et compte Facebook

Bonjour et merci,

Effectivement, la mise à jour en 12.10 n'avait résolu que temporairement le problème.
Par manque de temps j'avais abandonné.
Blue Djoe, ta solution a parfaitement fonctionnée

Merci.

Hors ligne

#7 Le 31/03/2013, à 18:54

manup31

Re : [Résolu] Gwibber et compte Facebook

Blue Djoe a écrit :

Pour celles et ceux qui auraient un souci avec Facebook et Gwibber dans la 12.04 j'ai trouvé ce tutoriel et il fonctionne : http://www.webupd8.org/2013/01/fix-face … ibber.html

J'ai eu beau suivre à la lettre le workaround mentionné dans ce lien, rien à faire pour "connecter" un compte FB avec Gwibber sur une 12.04.

D'ailleurs, en passant, le "tuto" indique de trouver

      m["privacy"]["description"] = data["privacy"]["description"]

et de le remplacer par

      if data["privacy"].has_key("description"):
        m["privacy"]["description"] = data["privacy"]["description"]
      else:
        m["privacy"]["description"] = "Unknown"

Or ces lignes existent déjà et la seule différence trouvée est "Unknown" à la place de ""

D'ailleurs, son screenshot ne montre pas un remplacement de la ligne trouvée par les 4, sans quoi on aurait, en remplacement la ligne trouvée par les 4 citées :

      if data["privacy"].has_key("description"):
      if data["privacy"].has_key("description"):
        m["privacy"]["description"] = data["privacy"]["description"]
      else:
        m["privacy"]["description"] = "Unknown"
      else:
        m["privacy"]["description"] = ""

Ce qui n'aurait pas de sens et ne fonctionnerait sans doute pas. hmm


manu'

Hors ligne

Haut de page ↑