Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 06/10/2012, à 22:06

R2D2Que

Partage de fichiers (Mot de passe refusé)

Bonjour

Je cherche à savoir comment avoir la liste des mots de passe pour le partage des fichiers entre deux PC sous Ubuntu. Parce que si je veut accédé à un répertoire de l'autre PC le mot de passe demandé est toujours refusé.

De plus je n'ai pas l'onglet Partage dans Nautilus pour tous mes répertoires.

Mes recherches ne sont pas fructueuses

Dernière modification par R2D2Que (Le 06/10/2012, à 22:10)

Hors ligne

#2 Le 07/10/2012, à 01:47

Maisondouf

Re : Partage de fichiers (Mot de passe refusé)

Déjà, si tes partages demande un mot de passe, c'est qu'en les créant tu n'as pas autorisé l'accès public.
77845c025ef69000e0fd18ed6a32b.png
Il faut bien cocher la dernière ligne pour un accès public en lecture et éventuellement celle juste au dessus si tu veux autoriser l'écriture.


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 08/10/2012, à 03:28

R2D2Que

Re : Partage de fichiers (Mot de passe refusé)

Bonjour
Merci de me répondre. Mais voilà je n'ai plus accès à cette fenêtre de partage. Pour tous mes dossiers quelqu'ils soit je n'ai accès qu'à Général et permission .
J'ai la version ubuntu 11.10. c'est après une mise-à-jour que j'ai perdu celle-ci.

Hors ligne

#4 Le 10/10/2012, à 14:12

ladyviolet

Re : Partage de fichiers (Mot de passe refusé)

Bonjour,

J'ai 2 problèmes. Malgré une lecture plutôt attentive des aides je ne parviens pas à me dépanner. J'envoie ce message d'un ordinateur fixe. Mes problèmes concernent un ordinateur portable acheté en février. Partition Ubuntu-Windows a été faite lors d'un événement Le jour du libre en mai, je crois. On m'a installé la version 12.04.1 LTS.
1er problème : à la suite d'une interruption sans doute jugée brutale par le système, sous Windows qui tentait de se mettre à jour, je n'ai plus eu accès à Windows, du tout. Une tentative de commencer en accès erreur (désolée, je n'ai peut-être pas les termes exacts) n'a pas résolu le problème. J'ai montré l'ordinateur à un réparateur qui ne connaît pas Ubuntu qui m'a simplement suggéré de réinstaller Windows.  Ce que je n'ai pas encore fait. Ensuite j'ai voulu faciliter l'accès à cet ordinateur, sous Ubuntu uniquement dorénavant, en supprimant le mot de passe. Maintenant je peux toujours utiliser mon ordinateur mais je ne peux pas avoir accès au Gestionnaire des mises à jour, le système d'authentification étant toujours en échec.

J'ai lu par ailleurs des solutions possibles, mais les termes ou les ordres ne font pas sens pour moi. Si quelqu'un peut m'aider, pouvez-vous faire en sorte que les instructions ne soient pas trop complexes ?

Merci beaucoup.

Hors ligne

#5 Le 11/10/2012, à 22:38

patrick L

Re : Partage de fichiers (Mot de passe refusé)

lorsque vous bootez,  vous devez avoir un menu qui s'affiche indiquant ubuntu et windows. lorsque vous lancez windows l'erreur se produit quand ?

et le message d'erreur windows ? ca serait bien de le dire.

Dernière modification par patrick L (Le 11/10/2012, à 22:39)

Hors ligne

#6 Le 12/10/2012, à 00:19

Maisondouf

Re : Partage de fichiers (Mot de passe refusé)

C'est quoi le sujet du post, les accès réseau ou les lanceurs d'OS ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#7 Le 12/10/2012, à 13:46

ladyviolet

Re : Partage de fichiers (Mot de passe refusé)

Je ne savais pas (je suis vraisemblablement ignare ou aveugle) où poster ma demande. J'ai cru bien faire en le mettant à la suite d'une demande de mot de passe, car c'est un de mes 2 problèmes. Il semble que ce soit bien (l'autre prolème) une difficulté de lancement de l'OS, je n'ai plus du tout accès à Windows. Et je voudrais avoir cet accès parce que je veux brancher une imprimante-scanner et que ça ne marchait pas avec Ubuntu. Est-ce plus clair ? Merci.

Hors ligne

#8 Le 12/10/2012, à 13:55

ladyviolet

Re : Partage de fichiers (Mot de passe refusé)

Message qui apparaît quand je veux lancer Windows: Error mounting: mount exited with exit code 14 : Windows is hibernated, refused to mount.
Failed to mount '/dev/sda3': operation not permitted.

Hors ligne

#9 Le 12/10/2012, à 18:02

patrick L

Re : Partage de fichiers (Mot de passe refusé)

http://support.moonpoint.com/os/unix/li … il_sys.php

le principe du systeme... 

- booter sur un live cd... 
- ensuite faut monter la partition de windows, la partition systeme !!!! attention !!!!  en mode rw.  et dans un dossier linux /mnt/hdd
- ensuite le fichier mtab permet de vérifier que la partition sda1 est bien en mode écriture.
- ensuite  faut éditer en hexa le fichier /mnt/hdd/hiberfile.sys et supprimer les lettres w a k e 

donc editer un fichier systeme en binaire... pour dire à windows qu'il est plus en hibernation.  donc mieux vaut que ce soit un qui connaisse l'informatique par chez vous.

Dernière modification par patrick L (Le 12/10/2012, à 18:24)

Hors ligne

#10 Le 14/10/2012, à 15:58

ladyviolet

Re : Partage de fichiers (Mot de passe refusé)

Merci pour la réponse : comme je le craignais c'est bien trop complexe pour moi., paresse intellectuelle ou problème de vocabulaire : je ne comprends pas. Je n'ai personne autour de moi qui s'y connaisse en Ubuntu, je vais devoir attendre un samedi sur Paris...

Hors ligne

#11 Le 17/10/2012, à 23:15

R2D2Que

Re : Partage de fichiers (Mot de passe refusé)

Bon je reviens sur le sujet de départ: soit le mot de passe pour le partage de fichiers non celui du système. J'ai fait plusieurs recherche sans succès. Je n'ai pas l'onglet Partage quand je demande les propriété d'un répertoire. Et ce sur deux ordinateurs différents. soit un de bureau avec Ubuntu 11.10 et un portable avec Ubuntu 12.04. Ils sont en réseau filaire derrière un routeur. Je peut accéder à l'imprimante branchée avec un connecteur LPT sur le routeur.

Avant août dernier et une mise à jour mes ordinateurs partageais facilement les documents sans samba, Maintenant impossible. De plus j'ai essayé d'installer samba mais des messages d'erreurs arrête l'installation et c'est pareil sur les deux PC.
Alors si quelqu'un peut me guider. Merci

Hors ligne

#12 Le 22/10/2012, à 15:14

patrick L

Re : Partage de fichiers (Mot de passe refusé)

moi sous samba je mets le fichier /etc/samba/smb.conf   en security user et  dans [global]  je mets le nom de mon groupe de travail dans

workgroup = groupe 
security  = user 

et  je mets le partage

[patrickDocs]
path = "/home/patrick/Documents"
read only = yes
valid users= patrick,  maman, lasoeur 
write list = patrick 

ensuite je crée les users si nécessaire

sudo useradd maman -s /sbin/false -d /dev/null -g sambausers 
sudo smbpasswd -a maman 

et pareil pour lasoeur

et pour lancer les choses

sudo testparm
sudo service smbd  restart.

et là ca marche chez moi...

Dernière modification par patrick L (Le 22/10/2012, à 15:15)

Hors ligne

#13 Le 24/10/2012, à 16:54

R2D2Que

Re : Partage de fichiers (Mot de passe refusé)

Bonjour
Merci de me répond Patrick L.
J'ai en grande partie réussi à utiliser Samba qui posait des problème d'installations sur le deux PC. Maintenant quand je fait

 sudo useradd roch -s /sbin/false -d /dev/null -g sambausers
[sudo] password for roch: 
useradd : le groupe « sambausers » n'existe pas

Comme il me demande le nom de groupe je met WORKGROUP à la place de sambausers c'est la même chose.
Maintenant j'ai imprimé quelques pages d'installation pour samba de la documentation pour mieux comprendre.
Merci

Hors ligne

#14 Le 25/10/2012, à 21:11

patrick L

Re : Partage de fichiers (Mot de passe refusé)

faut ajouter le groupe sambausers

sudo groupadd sambausers

et aussi de faire attention à ce que le groupe sambausers soit dans le /etc/samba/smb.conf

j'explique comment les choses se passent...

vous avez le groupe de travail avec les ordinateurs windows  et linux...  ce groupe de travail est workgroup dans le smb.conf...  par defaut le nom de ce groupe de travail et WORKGROUP.  A changer de préférence. sinon le pirate rentre là dedans et s'amuse !! ou aussi j'ai tendance à virer tout ce qui est par défaut...   

alors ce groupe de travail (les ordis du réseau) c'est dans le fichier smb.conf ligne workgroup = COLLAIGES   (volontaire la fote d'orethot) le pirate a qu'à chercher.

ensuite dans ce groupe de travail peut etre que tout le monde ne doit pas se connecter dans le groupe COLLAIGES.  par exemple le stagiaire c'est pas bon qu'il aille  modifier des trucs dans votre home.

donc la commande ca ajoute un utilisateur samba dans le groupe d'users de linux pour avoir le droit de se connecter à samba pour aller voir sur votre ordi.     

ensuite la ligne [sudo] password for roch me fait penser que vous etes dejà inscrit comme user... la commande useradd ajoute un user, pas utile de créer un utilisateur qui existe dejà  = vous meme.   

donc la commande pour l'utilisateur roch (qui existe) et

sudo groupadd sambausers # creation de sambausers  
sudo adduser roch sambausers # ajout de l'user roch dans sambausers
sudo smbpasswd -a roch  # ajout du mot de passe de roch pour se connecter en samba. 

les # indiquent des commentaires.  sambausers c'est un groupe d'utilisateurs samba..   
ensuite la commande useradd  -s ... -d .... -g sambausers  crée un utilisateur samba sans shell et sans dossier home de créé.  l'utilisateur va exister comme ayant acces à des partages  mais sans avoir autre acces que les partages pour lesquels on a configuré des droits.

si vous voulez que votre soeur se connecte mais sans prendre de risque...   

sudo useradd masoeur -s /bin/false -d /dev/null -g sambausers 
sudo smbpasswd -a masoeur 

ensuite à la fin du smb.conf vous mettez votre partage.

[nomPartage]
path=/home/roch/dossier
read only = yes # par defaut on se contente de lire 
valid users= roch, masoeur
write list = roch 

<echap> :wq pour sortir de vim

et ensuite

sudo /etc/init.d/smbd restart

attention à copier le fichier smb.conf avant toute manif... c'est tres facile de le planter  le samba..

sudo cp /etc/samba/smb.conf  /etc/samba/smb.conf.save`date +%Y%m%d` 

la commande copie de secours  le smb.conf dans smb.conf.save20121025  indiquant la date de la sauvegarde. pratique si on a plusieures copies successives.

et aussi de mettre des mots de passes sambapasswd différents du votre... sinon le pirate ira tout de suite essayer son mot de passe samba pour se connecter sur votre compte user.  et faire plein de bêtises...  une pas sympa est déjà de vous changer votre mot de passe qui est le meme que samba..   et pour accéder à root ... on rentre  son mot de passe utilisateur.


aussi y a un outil de test de la config de samba. ca évite de tout planter.
faut rentrer testparm ca affiche les erreurs dans le fichier.

Dernière modification par patrick L (Le 25/10/2012, à 21:20)

Hors ligne

#15 Le 25/10/2012, à 22:29

Maisondouf

Re : Partage de fichiers (Mot de passe refusé)

@patrick L: Je ne dit qu'une chose : Bravo!
Un petit plus quand même, d'après cette doc, le RID du groupe sambausers doit être 513

Doc Samba a écrit :

Créer un groupe sambausers:

Ce groupe doit être créé avec le RID 513 pour être en conformité avec la terminologie Windows.

#groupadd -g 513 sambausers

Je ne sais pas si ça a une réelle importance, mais c'est documenté ainsi....

Dernière modification par Maisondouf (Le 25/10/2012, à 22:30)


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#16 Le 26/10/2012, à 12:05

patrick L

Re : Partage de fichiers (Mot de passe refusé)

merci...

j'ai lu votre doc, et merci du lien.  le groupe sambausers  c'est pour mettre dans les valid users....   



[partage]
path = /home/roch/partage
read only = yes
valid users = @sambausers
write list = @sambawrite

Dernière modification par patrick L (Le 26/10/2012, à 12:51)

Hors ligne

#17 Le 26/10/2012, à 21:39

R2D2Que

Re : Partage de fichiers (Mot de passe refusé)

Bonjour
Merci de votre aide
Patrick L. Je me demande si j'utilise le même nom soit roch dans mes pc si il y a risque de confusion. Je suis le seul à utiliser mon réseau composé de trois pc. Deux de bureau côte à côte et un portable. note :  le vieux vieux pc sous Windows 98 est très coopératif et les deux ubuntu y ont accès facilement.

Wholes
lorsque je fais

nautilus-connec-server
Commande 'nautilus-connec-server' non trouvée, vouliez-vous dire :
 La commande 'nautilus-connect-server' du paquet 'nautilus' (main)
nautilus-connec-server : commande introuvable

De même avec sudo

sudo nautilus-connec-server
[sudo] password for roch: 
sudo: nautilus-connec-server: command not found

Par contre la commande nautilus ssh//roch@192.xxx.xxx.xxx/  fonctionne bien
De même dans nautilus Fichier/se connecter à un serveur donne le même résultat.
Mais je me demande si la sécurité est présente car la première fois j'ai entré un mot de passe mais maintenant je rentre seulement l'adresse ip.
Je vais encore travailler mon réseau en relisant vos conseils.
Merci

Hors ligne

#18 Le 27/10/2012, à 00:07

patrick L

Re : Partage de fichiers (Mot de passe refusé)

vous avez tapé connec au lieu de connect linux aime pas ca

nautilus-connect-server   sinon ssh va se paumer dans les utilisateurs... sudo ca vous met en root donc nautilus va gérer l'utilisateur root. pas vous...

mais avant faut faire un :

ssh-keygen -t rsa
ssh-copy-id -i ~/.ssh/id_rsa.pub roch@192.168.2.102

ca vous demande votre mot de passe roch sur le serveur...  là vous etes sur le client...
c'est là que c'est important d'avoir mis password_authentification = yes
sinon ca vous fera une erreur et faut rentrer une gaitée


ssh roch@192.168.2.102 "echo $(cat ~/.ssh/id_rsa.pub) >> .ssh/authorized_keys" 

je sais même pas comment on fait pour que ca marche cette commande et d'ailleurs ca marche pas. la raison est que pour se connecter à roch@serveur   on doit avoir une clef publique dans le fichier, clef qui n'existe pas car la clef n'est pas encore dans le fichier authorized_keys. ca tourne en rond. donc faut que les connections via mot de passe normal soient autorisées. 

ensuite apres la saisie du mot de passe ca vous envoie des gaitées et ensuite la clef est mise en dans la liste des autorisées.  simple et fiable !!!


ensuite sur le client (faut jamais retourner au serveur...  penser que vous etes à 200 bornes)

ssh roch@192.168.2.102  et là on vous demande la passphrase.

possible de pas en mettre mais si on vous vole votre ordi le voleur a accès à votre ordinateur et votre réseau tant qu'à faire...


sur votre question de mettre deux ordis compte roch c'est pas un probleme vous avez roch@ordi1 d'un coté et roch@ordi2 de l'autre coté. avec linux c'est pas je te charge des trucs et ca marche au premier coup.. faut comprendre le principe et ensuite on mets en place. moi je suis dans l'informatique et linux j'ai installé la 10.10 et ensuite je commence à comprendre des bases.   c'est pas si difficile mais faut bien comprendre avant de taper des choses.
alors l


le ssh c'est une connexion que l'on appelle asymétrique...  au départ mais le plus simple c'est de voir comment marche en symétrique.  en symetrique la clef est partagé entre deux personnes.

on a une clef en wifi qui peut etre ce que l'on veut "demain les puces sont en vacances"   et alors faut que j'envoie la clef au destinataire...  mais attention le pirate peut intercepter et alors ca sert à rien.   alors faut avoir un moyen de la chiffrer pour envoyer la clef et là le pirate va faire grise mine.

alors on fait en asymétrique...    la première fois que l'on se connecte au serveur on dit "je veux ta clef publique" le serveur envoie sa clef publique... elle est publique et connue de tous... le pirate peut la lire pas de soucis.  je recois cette clef du serveur alors j'envoie ma clef publique à moi,  comme j'ai la clef du serveur je la chiffre et le pirate sait pas qui appelle en fait.  le serveur va lire si la clef publique est dans le fichier authorized_keys  et elle est dedans.

alors le serveur envoie la clef symétrique pour la suite...   ensuite c'est la même clef quand le serveur envoie des données et le client qui envoie des commandes.

Dernière modification par patrick L (Le 27/10/2012, à 00:32)

Hors ligne

#19 Le 28/10/2012, à 01:31

R2D2Que

Re : Partage de fichiers (Mot de passe refusé)

Bonsoir
Je vais bien lire ce que vous dites pour essayer de bien comprendre et faire attention à ce que je tape sur mes clavier des pc car je ne suis pas un informaticien.
Et je vous donnerez les résultats.
Merci encore

Dernière modification par R2D2Que (Le 28/10/2012, à 01:35)

Hors ligne

#20 Le 28/10/2012, à 19:17

R2D2Que

Re : Partage de fichiers (Mot de passe refusé)

bonjour
Si j'utilise ubuntu depuis la version 8.04, c'est le fait que j'ai un portable (usagé 2004) depuis peu que je m'intéresse plus au réseau et au partage de fichiers.
De plus j'ai essayé la version 12.10 pour voir si il y aurait une si cela serait plus simple. Mais je ne voie que des changements cosmétique!
Merci encore pour ce dernier conseil.

Hors ligne

#21 Le 29/10/2012, à 00:07

patrick L

Re : Partage de fichiers (Mot de passe refusé)

moi je pense que "keygen" c'est quand même mieux car plus sécurisé...   surtout sur les échanges de fichiers... c'est plus sécurisé.

l'avantage de keygen  c'est que ton client puisse se connecter sur plein d'ordinateurs le tien, celui de la famille  à paris, etc.  c'est mieux de sécuriser quand même. sans faire dans la parano non plus mais des fois on envoie des informations personnelles comme sa région. comme son adresse pour un rendez vous et on voit des abus pour les anniversaires qui font venir des milliers d'amis de la personne.   c'est aussi parce que les mails peuvent etre espionnés facilement.


les clefs rsa permettent de taper du courrier avec son adresse sans risque (ou presque) et de rentrer des données personnelles.  on peut prendre un email poubelle et mettre dans le message le email de réponse pour la réponse.

Hors ligne

#22 Le 29/10/2012, à 19:21

patrick L

Re : Partage de fichiers (Mot de passe refusé)

moi ce que je trouve bien c'est de ne plus avoir de soucis lorsque un compte change de mot de passe.  je trouve pas très difficile de lancer deux commandes.   Il fait des essais entre deux ordis. mais le but sera sûrement qu'un jour il se retrouve à l'extérieur pour envoyer des messages sur le bureau d'un user chez lui....

Dernière modification par patrick L (Le 29/10/2012, à 19:47)

Hors ligne

#23 Le 05/11/2012, à 09:04

ubunpac

Re : Partage de fichiers (Mot de passe refusé)

R2D2Que a écrit :

Merci de me répondre. Mais voilà je n'ai plus accès à cette fenêtre de partage. Pour tous mes dossiers quelqu'ils soit je n'ai accès qu'à Général et permission .
J'ai la version ubuntu 11.10. c'est après une mise-à-jour que j'ai perdu celle-ci.

Je ne sais pas si cela peux résoudre le problème d'accès à la fenêtre "Partage de dossier" comme mis au post #2, mais pour moi, il a fallu installer le paquet "libapache2-mod-dnssd" et ces dépendances :

sudo apt-get install libapache2-mod-dnssd

Après cela, j'avais accès à la fenêtre "Partage de dossier" (Clic-droit sur le dossier à partager, puis "Options de partage") et pouvais ainsi cocher les cases désirées.

Dernière modification par ubunpac (Le 05/11/2012, à 09:08)


°Software is like sex, it's better when it's free. (Linus Torvalds)
°Commencez par changer en vous ce que vous voulez changer autour de vous. (Gandhi)
°Le savoir n'est bon que s'il est partagé. (???)

Hors ligne

Haut de page ↑