Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 25/10/2012, à 20:41

adjoint

Une erreur est survenue lors du montage

Bonjour les amis,

Je viens de passer à la version 12.10 de Xubuntu et j'ai un problème (que je n'ai jamais eu) lors du démarrage de Xubuntu.

J'ai le message suivant :

Une erreur est survenue lors du montage du disque /media/Disque Externe

J'ai regardé un peu sur le net, et tapé :

cat /etc/fstab

qui me renvoi

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc	/proc	proc	nodev,noexec,nosuid	0	0
#Entry for /dev/sdb1 :
UUID=7a7901d3-ddfd-4ef5-8213-0a2b971f4403	/	ext4	errors=remount-ro	0	1
#Entry for /dev/sdc1 :
UUID=049C54979C548558	/media/Disque\040Externe	ntfs-3g	defaults,uid=1000,nodev,locale=fr_FR.UTF-8	0	0
#Entry for /dev/sdb5 :
UUID=55bd40e9-6a14-4869-9a86-41d5504578ec	none	swap	sw	0	0

Le fstab me parait bon, la vérification du disque (pass = 0) est désactivé sur "Disque Externe". Le problème n'est gênant qu'au démarrage. Le "Disque Externe" est monté ensuite et le pc fonctionne normalement.
J'ai peut être trouvé des pistes vers grub mais j'avoue ne pas bien comprendre le problème.

Si quelqu'un peut m'aider, je suis preneur.

Merci par avance smile

Hors ligne

#2 Le 25/10/2012, à 23:09

Maisondouf

Re : Une erreur est survenue lors du montage

Est ce que l'UUID est bon ?
Liste de UUID:

sudo blkid

Puis je ne sais pas trop si 'ntfs-3g' existe encore ou si il y a pas une nouvelle appellation..

EDIT : c'est 'ntfs' tout court maintenant.
Sur le PC du dev :

# add Vbox disk
UUID=2817E8AA5D32259F /media/Perso ntfs defaults 0 0

Dernière modification par Maisondouf (Le 25/10/2012, à 23:13)


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 26/10/2012, à 07:27

adjoint

Re : Une erreur est survenue lors du montage

Merci pour ton aide Maisondouf.

J'ai déjà vérifié les UUID et ils sont bon.

Par contre, en effet je me suis posé la question pour ntfs-3g. Je testerais ce soir en mettant uniquement ntfs.

Dernière modification par adjoint (Le 26/10/2012, à 07:27)

Hors ligne

#4 Le 26/10/2012, à 08:24

Keiser

Re : Une erreur est survenue lors du montage

Salut,

oui, c'est bien ntfs, du moins chez moi c'est ça.
Un autre soucis, je pense que tu t'es planté de "/" smile :

Entry for /dev/sdc1 :
UUID=049C54979C548558	/media/Disque\040Externe	ntfs-3g	defaults,uid=1000,nodev,locale=fr_FR.UTF-8	0	0

devrait être plutôt :

Entry for /dev/sdc1 :
UUID=049C54979C548558	/media/Disque/040Externe	ntfs-3g	defaults,uid=1000,nodev,locale=fr_FR.UTF-8	0	0

le

defaults,uid=1000,nodev,locale=fr_FR.UTF-8

me parait un peu compliqué, chez moi ça ferait juste :

Entry for /dev/sdc1 :
UUID=049C54979C548558	/media/Disque/040Externe	ntfs	relatime	0	0

Ca devrait être bon, à condition bien sûr d'avoir un bon UUID, et d'accorder les droits qui vont bien à /media/Disque/040Externe :

Sudo chmod 777 /media/Disque/040Externe

J'espère que ça ira.

Hors ligne

#5 Le 26/10/2012, à 13:00

adjoint

Re : Une erreur est survenue lors du montage

Merci de ta réponse Keiser.

Pour l'espace dans le nom du fichier, dans la doc il dise

 Pour Fstab : l'espace doit être remplacé par \040 

source : http://doc.ubuntu-fr.org/mount_fstab

Cela marché jusqu'à la 12.04 sans problème.

Par contre, je vais essayer ce soir le "ntfs". J'utilisais ntfs-3g car il permettait la lecture, l'écriture et la gestion de la corbeille linux. Mais le passage à la 12.10 a peut être supprimé l'utilisation de "ntfs-3g".

Hors ligne

#6 Le 26/10/2012, à 14:01

Keiser

Re : Une erreur est survenue lors du montage

Ah ok, c'est parce que tu as un espace entre "disque" et "externe", je savais pas tongue qu'il fallait ça, j'ai rien dit alors...
(bizarre d'ailleurs que tu ais besoin d'éditer le fstab pour un disque externe, il est pas reconnue sinon ? Question conne mais si tu fais sans cette ligne dans ton fstab, il se passe quoi ?)

Hors ligne

#7 Le 26/10/2012, à 15:46

The Uploader

Re : Une erreur est survenue lors du montage

Ça ne se monte pas automatiquement au démarrage, sans cette ligne.

Sinon j'viens de tester (j'ai aussi des partitions NTFS), c'est bien 'ntfs' court qu'il faut mettre pour le type. Mais ça ne semble pas être le pilote ntfs-3g..

edit : Ça fonctionne aussi si je met 'ntfs-3g' pour le type ! >_<

Sous ma Archlinux, ntfs-3g est dans un paquet spécifique. Il ne fait pas partie du noyau linux (qui lit /etc/fstab), et il est installé. Peut-être te manque-t-il le paquet contenant ntfs-3g, pour que ça marche au niveau de /etc/fstab ?

Au pire, tu peux peut-être passer par /etc/rc.local (c'est un script qui est exécuté avec les droits root par Ubuntu à chaque démarrage) :

mount <partition> <point de montage> -t ntfs-3g

(*)

M'enfin ça a l'air de fonctionner avec le pilote 'ntfs'  du kernel aussi. Je peux supprimer des fichiers, en créer...

En fait, je ne vois pas de différence entre les deux, mais je préfère tout de même 'ntfs-3g'.

(*) Tout ce que j'ai vu de particulier, c'est que s'il manque l'argument 'nodev', les fichiers supprimés ne passent pas par la corbeille (donc à mon avis il vaut mieux passer par /etc/fstab) !
Donc cette ligne me paraît la bonne :

UUID=049C54979C548558	/media/Disque\040Externe	ntfs-3g	defaults,uid=1000,nodev,locale=fr_FR.UTF-8	0	0

(quand j'ai testé, je n'ai pas eu besoin de faire "sudo chmod 777 /media/Disque/040Externe")

Dernière modification par The Uploader (Le 26/10/2012, à 16:22)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE 4
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#8 Le 26/10/2012, à 17:29

adjoint

Re : Une erreur est survenue lors du montage

Merci The Uploader.

Après une recherche plus approfondie, il semblerait que le problème vienne de l'espace.
Ce bug a été signalé pour la version 12.10 : https://bugs.launchpad.net/ubuntu/+sour … ug/1059726

Hors ligne

#9 Le 26/10/2012, à 17:47

The Uploader

Re : Une erreur est survenue lors du montage

Il suffit de l'enlever, non ?


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE 4
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#10 Le 26/10/2012, à 17:50

adjoint

Re : Une erreur est survenue lors du montage

En effet sans l'espace, cela fonctionne normalement. Mais je suis une tête de noeud, et je veux que l'informatique s'adapte à ce que je veux. Du coup je vais attendre le correctif lol.

Hors ligne

Haut de page ↑